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What's New in Autodesk
Maya

Welcome to What'’s New in Autodesk® Maya® 2013.

Image created by Jean-Marc Belloncik

Maya 2013 delivers new toolsets for dynamic simulation, rendering, and animation;
implements an Open data initiative to facilitate non-linear workflows; and provides solutions
to create and maintain open pipelines.

Enhancements to the Maya Nucleus framework, including the addition of a new Maya nHair
module, combined with the new open source AMD Bullet Physics engine, help you create
complex and realistic simulations.

With the high-performance and high-quality Viewport 2.0, new features have been added to
expand the level of support, so artists can efficiently evaluate their work in a higher fidelity
interactive environment.



Improvements to rigging tools, the ability to match Trax clips, enhancements to the Graph
Editor, and a new Heat Map Skinning method offer an enhanced animation experience.

Additionally, improvements to file referencing workflows and the support of Alembic and
Animation Transfer Object Model (ATOM) file formats make Maya 2013 easier to integrate
into open pipelines.

General

Alembic files provide artists with a fast workflow for
passing complex scene data between various areas of
a production pipeline. The new Pipeline Cache tools
let you save and load scene files as Alembic-based cache
files, which provide performance improvements includ-
ing accelerated loading of large scenes, faster play back
of complex character animations, and real-time play
back of geometry data with topology changes.

In addition, new single-step workflows let you send
scene data between Maya and 3ds Max.

See What's New in General (page 7).

Basics

The new Node Editor lets you view, modify and create
node connections using an editable schematic that
displays nodes and the connections between their at-
tributes. This interactive tool lets you build and edit
networks of nodes using a simple click-and-drag
method.

You can customize the Attribute Editor layout by
creating custom views and attribute controls for node
types and specific nodes. Customized XML-based
templates are loaded by selecting new options in the
Attribute Editor Show menu.

See What's New in Basics (page 11).
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File Referencing

Modeling

New File reference options in the Qutliner make it
easier to manage your file references outside of the
Reference Editor. These options include new Refer-
ence menu items and a Reference Node display op-
tion that lets you locate and identify the loaded and
unloaded file references in your scene.

Similarly, other new features and options improve a
number of file referencing workflows. Now you can
edit animation curves in referenced files, perform ref-
erencing operations on multiple references, view the
contents of unloaded references in your scene, and
include files associated with unloaded references in
the scene archive.

See What's New in File Referencing (page 13).

The Extrude Tool now has Thickness, Offset and
Divisions values to allow for greater precision. Other
tool improvements include the addition of a back-
ground colour for improved readability and the ability
to use Ctrl and Shift to more quickly adjust values.

The new Brush strength slider in the Sculpt Geo-
metry Tool lets you adjust the amount of pinching
that is applied while sculpting.

See What's New in Modeling (page 29).
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Animation

When blending between clips of animation in the
Trax Editor, new clip matching manipulators and
options let you define an offset to properly align the
clips in an animation sequence. Updated Trax Editor
options include clip Offset settings for absolute or
relative offsets and Rotation Blend settings with
simpler Euler and Quaternion options.

Maya's new ATOM file type gives animators a fast
workflow for repurposing existing animation as new
characters are created. The .atom file type and its asso-
ciated import/export options let you save specific poses
or animation sequences, then easily reload them onto
other objects.

In addition, the new Retime Tool lets you directly
adjust the timing of key movements in your anima-
tions. A new type of timing manipulator is available
in the Graph Editor that lets you shift or warp anim-
ation. Similar animation retiming tools are available
in other Autodesk applications. Other changes to the
Graph Editor include updates to the View menu
and toolbar icons.

See What's New in Animation (page 17).

Rigging

The new Heat Map binding method uses a heat diffu-
sion technique to distribute weights, and gives you
better results than the existing binding methods.

Updates to the HumanlIK character setup tools increase
usability and streamline common character setup
workflows: a unified interface lets you perform multiple
tasks in a single window; character layouts can be
customized to fit specific requirements; and HumanIK
animation is easily retargeted to and from a custom
rigged character.
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Dynamics and nDynamics

Additionally, new properties and options give you
improved control over roll bone behavior and anima-
tion rigs.

See What's New in Rigging (page 23).

The nHair hair generation system is the newest addi-
tion to the Nucleus dynamic simulation framework.
With the ability to self-collide and interact with other
Nucleus objects, nHair has many advantages over the
previous hair system. Improvements include faster
performance with a large number of follicles, better
collision accuracy and control, the ability to create
nConstraints, and nCaching for saving and playing
back hair simulations.

Maya now includes the MayaBullet physics simulation
plug-in. Built from the Bullet physics library, the plug-
in lets you use the Bullet physics engine to create large-
scale, highly-realistic dynamic and kinematic simula-
tions. MayaBullet simulations can include interacting
soft body and rigid body objects, as well as constrained
collision objects, all contained in a single dynamic
system within Maya.

See What's New in Dynamics and nDynamics (page
31).
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Rendering and Render Setup

New Viewport 2.0 features include support for image
planes and animation and rigging features such as
HumanlK, joints, motion paths, ghosting and playblast.
New polygons, NURBS and dynamics features have
been added. Improvements in tumble and animation
performance of large scenes are also included.

The new Mandelbrot node allows you to texture your
model with the Mandelbrot set. You can create a 2D
version of this node (Mandelbrot), a 3D version of this
node (Mandelbrot 3D), or shade a fluidShape node
using the built-in Mandelbrot texture.

Image created by Duncan Brinsmead

A new simplified workflow lets you automatically bake
a substance texture to disk to render it with mental ray
for Maya, IPR, or other 3rd party renderers. Several new
substance textures have also been added.

See What's New in Rendering and Render Setup (page
33).
Documentation

Read about improvements to the search function in the Maya Help and the ability to share
help topics by email directly from your web browser.

See What's New in Documentation (page 37).

MEL and Python

Read about commands that have been added, changed, and removed for this release.

See What's New in MEL and Python (page 39).

API

You can now easily create a distributable deployment of your plug-in. This way, making
changes to the plug-in is simple even across multiple Maya versions and platforms.
Additionally, a new module file syntax allows multiple versions of a plug-in to be supported.

See What's New in API (page 45).
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What's New in General

Pipeline caching

Interoperability with 3ds Max

New Pipeline Cache tools let you load, save, and play
back Maya scenes as Alembic cache files. The Alembic
file format is an open-source format developed for ex-
changing complex 3D geometry data. Alembic files are
highly portable and application-independent so they
can be shared, processed, and played back by many
content creation applications.

Alembic caches provide several performance improve-
ments, including accelerated scene loading of large
scenes, faster playback of complex character animation,
and real-time play back of geometry data with topology
changes. Alembic files also let you share large scenes
between various areas of a production pipeline without
the large memory overhead of fully editable scene files.

Options in a new Pipeline Caching menu let you
configure settings for loading and saving Alembic files.

Transfer data between Maya and 3ds Max using the new
Send to 3ds Max command in the File menu. You
can send various forms of data, including geometry,
animation, materials, and textures, to 3ds Max. You
must have matching versions of Maya 2013, 3ds Max
2013 and FBX 2013 to use this command.



Run Maya with a Simplified Chinese interface

Maya is now available with a Simplified Chinese inter-
face. For instructions on how to run Maya with a
Simplified Chinese interface on different operating
systems, see Run Maya with a Japanese or Simplified
Chinese interface.

Check for updates including Service Packs and Hotfixes
using the new Autodesk Maya Update Manager (Help
> Check for Updates).

This window lists updates that are available for your
version of Maya, and lets you check for updates using
download codes.

New Bonus Tools

The new Attribute Editor Template Builder tool helps you build custom Attribute
Editor templates. You can download Bonus Tools from the Autodesk website by selecting
Help > Download Bonus Tools in Maya.

New suites specific environment variables

Several new suites specific environment variables let you run Maya off a network when it
is used as part of the Autodesk Entertainment Creation Suites. See Suites specific environment
variables.
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Autodesk MatchMover scripting support
Autodesk MatchMover now includes Python scripting support. Use MatchMover's Script

Editor and Script Manager to create and load scripts that process input and output data
as well as launch interface commands.

Autodesk Composite QuickTime™ movie support
You can now select the QuickTime movie (.mov) file format as a Render output for your

Composite projects. By default, QuickTime uses the H.264 codec. You can select resolutions
up to 1080P.
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What's New in Basics

Node Editor

Attribute Editor updates

The Node Editor presents an editable schematic of the
dependency graph, displaying nodes and the connec-
tions between their attributes. It allows you to view,
modify and create new node connections. You can ac-
cess the Node Editor from the Windows menu. (
Window > Node Editor).

You can graph the network of nodes of your choice,
and build networks by using the Tab key and dragging
lines from one node to another. Using this method,
you can easily edit existing networks. All attribute ports
and connection lines are represented by different colors
so that connections can be easily read. In addition, you
can create bookmarks to return to previous graph lay-
outs for easy navigation.

Now you can customize the Attribute Editor window in several different ways:

Custom Attribute Editor templates

You can edit the way attributes are displayed in the Attribute Editor by creating XML-based
template files for specific nodes and node types.

A template can have one or more views associated with it. Each view describes a particular
display layout and can be used to tailor the interface for different purposes. After applying
your custom template, you can access your views from the Show menu in the Attribute

Editor.

Custom callbacks

n



You can use MEL or Python based callbacks to link an attribute to a control or a complex
script. Using the <description language ="cb"> tag in your custom Attribute Editor
template lets you specify a callback command and links your callback to an attribute.

Use node type filtering to improve Attribute Editor performance

When making a selection in Maya, having the Attribute Editor open may cause
performance delays if too many nodes related to the selection are displayed as tabs. To avoid
a slowdown, you can use node type filtering to customize which related nodes are displayed
in the Attribute Editor.

Creating attributes using attribute patterns

You can create dynamic or extension attributes using attribute patterns. An attribute pattern
is a description of the dynamic or extension attributes that can be added to any specific
node, or node type. Using this feature, you no longer need to create each attribute using
individual addAttr or addExtension commands.

This feature is supported by the pyJsonAttrPatternFactory.py plug-in.

Editing the file path in the file browser

You can now edit the file path in the Look in field of the file browser and use its auto
completion functionality.
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What's New in File Refer-
encing

File referencing options in the Outliner

Reference node display

A new Reference Node display option in the Out-
liner makes it easier to locate and identify all the
loaded and unloaded file references in your scene. You
can access the option in the Outliner by selecting
Display > Reference Nodes. The Reference Nodes
display option is on by default.

Create and manage file references

New Reference menu items in the Outliner let you
create and manage file references without opening the

r

I
Reference Editor. In the Outliner, - -click a ref-
erence node or referenced object to access file referen-
cing commands.

Allow Referenced Animation Curves to be Edited

You can now edit animation curves from referenced
files. These changes are managed by the reference node
like other reference edits. You can modify an animation
curve, such as changing tangent types or editing key-
frames, then export the updates as reference edits to an
offline file.
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To edit animation curves in referenced files, you must
turn on Allow Referenced Animation Curves to
be Edited in the Referenced Animation Curves
section of the Animation Preferences.

File referencing improvements

Maya 2013 includes a number of new file referencing features and options that improve file
referencing workflows.

Updated reference node Attribute Editor

An updated reference node Attribute Editor displays information about reference nodes,
such as file path, namespace, and sharing details.

Operations on multiple references

Using the file referencing options in the Outliner, you can now perform referencing
operations on multiple references including the following:
m  Loading, unloading and reloading

m  Importing
m  Locking and unlocking

Preview unloaded content

A new Preview unloaded content option lets you view the hierarchy of the unloaded
references in your scene without loading the reference in the scene.

Archiving unloaded references

An option has been added to scene archiving that lets you include files associated with
unloaded references in the scene archive.

Namespace updates and improvements

Merge into selected namespace

A new Merge into selected namespace option lets you choose to merge referenced or
imported object namespaces with a namespace that exists in the parent scene. When
duplicate namespaces occur, the namespaces are merged and duplicate object names are
incrementally suffixed with a number.
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This new option lets you keep duplicate namespaces and avoids an accumulation of new
namespaces each time your referenced or imported objects have the same name.

You can access the Merge into selected namespace option in the Reference Options,
Import Options, and Assign Offline File Options windows.

New MEL Commands

Namespace MEL commands have been updated to allow easier manipulation of namespaces.

These new command updates include:

The namespaceInfo command has several new flags for querying information about a
namespace. New flags allow for namespace names to be returned in various formats:
baseName, absoluteName, and fullName. The isRootNamespace ﬂag determines whether
the namespace is the root namespace.

The namespace and file commands have new operations for namespace management:
mergeNamespaceWithParent and mergeNamespaceWithRoot. The namespace command
also has a new collapseancestor option.

For referenceQuery, the flags -namespace and -parentNamespace query the full
namespace path of a referenced node, file, or its parentNamespace.

The 1s command has additional functionality related to namespaces. The -showNamespace
flag returns object/namespace pairs. The -absoluteName flag can be used with 1s
-showNamespace, to return the absolute namespace names regardless of current namespace
or relative namespace state. For example: 1s -showNamespace -absoluteName.

You can now rename and create nodes using absolute namespace paths. For example:
:nsl:ns2:mySphere.

What's New in File Referencing | 15
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What's Newin Animation

Live character streaming

The options in the new Live Connection window (

- > Edit > Live Connection or File > Send to
MotionBuilder > Live Connection) are an extension
of the Send to commands that were introduced in
Maya 2012. Now you can send your HumanlIK defined
character to MotionBuilder and establish a live stream-
ing connection.

This new workflow lets you drive your skeleton or

Custom rig with motion capture data, so you can pre-
visualize your retargeting result before baking the final
animation from MotionBuilder into your Maya scene.

NOTE Sl This feature is only available if Maya is used

as part of the Autodesk Entertainment Creation Suites.

Improved import and export with ATOM file format

Documents library You can now share and reuse animation more efficiently
using Maya's ATOM (Animation Transfer Object Model).
The .atom file type and its associated import/export
options let you save specific poses or animation se-
vy —— quences, then easily reload them onto other objects.

ATOM options let you set precisely which animation
to reuse and how you want to import and export it.
After exporting, you can import animation based on
the character hierarchy, name matching, or using a
template file as a filter.

17



NOTE The .anim file format, animlmportExport.mll plug-
in, and its related options remain available from the File
> Export Selection and File > Export All menu items.

Nonlinear animation improvements

Clip matching

When manipulating clips of animation in the Trax
Editor, new clip matching tools let you define an
offset object to better align the movements in your
animation sequence.

More easily set relative or absolute clip offsets

Updated clip Offset settings are now included in the

Create Clip Options (Animate > Create Clip > 0 )
and in the Trax Editor context-sensitive menu, letting
you more easily view and set whether channels have
an absolute or relative offset from the previous clip.
See also Offset clip channels.

NOTE Absolute is now the default Offset option for
new clips and imported clips.

Other updates

The Rotation Blend setting in the Blend Clip Op-

tions (Create > Blend > O ) has been updated with
simpler Euler and Quaternion options. Quaternion
is now the default Rotation Blend setting when you
create a blend between animation clips. See Trax menu
bar for updated information.
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Retime animation

Converting CAT to HumanlIK

Other Graph Editor updates

In the Graph Editor, the Retime Tool n lets you
directly adjust the timing of key movements in your
animations. This tool provides a new type of timing
manipulator in the graph view, letting you shift key
moments in time, or warp entire sequences to make
them occur faster or slower.

For animators working in a pipeline with multiple
Autodesk applications, similar animation retiming
tools are available in 3ds Max, Softimage, and Motion-
Builder.

The new Send to commands in Maya and 3ds Max
let you convert a CAT bipedal character into a Maya
compatible HumanlIK character. This direct connection
lets you transfer your character structure, definition,
and animation from 3ds Max into an FK representation
on a HumanlIK skeleton in Maya. Any changes or new
animation that you create in Maya can be updated on
your original CAT character, so you can continue to
animate in the context of your 3ds Max scene.

NOTE i This feature is only available if Maya is used

as part of the Autodesk Entertainment Creation Suites.

m  Updated Buffer Curve options Graph Editor Curves menu
now let you create a snapshot of referenced curves. See Edit
animation curves in referenced files.

m  The Add Key Tool (originally available in the Graph Editor
toolbar) is now only available from the Keys menu. The ori-

o
ginal Add Key icon now represents the Insert Keys Tool.
See also Add keys to a curve.
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m View framing options (Frame All, Frame Selection, Frame
Playback Range) are now grouped in a View > Frame
menu.

Stepped Tangent preview mode

The new Stepped Tangent preview playback mode lets you temporarily set all keys to
display with Stepped tangents, switching easily from Spline to Stepped and back. Play your
animation in this mode to get a quick view of object positions as they hit each keyframe.

To turn the playback mode on and off, right-click the Time Slider and toggle the Enable
Stepped Preview option.

NOTE The original tangents are preserved and restored when you turn Enable Stepped Preview
off.

Keyframe and Tangent marking menu updates

The marking menus available for editing keyframes and tangents have been updated to
allow manipulation of motion trails, keys, and tangents directly in the scene view. To access

the updated marking menus, press M +S+ € , then select the Keys or Tangents
menu for more options. For example, the Keys menu contains options to let you copy and
paste keys on a motion trail, while the Tangents menu lets you quickly change the tangent
type for a selected key.

i ' i
NOTE The Tangents menu available from M +S+ replaces the former M +S+

marking menu.

Camera Sequencer improvements

You can now create an ubercam for camera shots that are keyed with weighted curves. In
addition, sequences with gaps between camera shots are now handled correctly. See Create
a single camera for all shots in a sequence.

Improved baking options
New options in the Character ControlsBake menu let you bake animation to a HumanIK

skeleton, Control rig, or Custom rig. The Bake menu updates dynamically to display options
that reflect the current character's state.
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New Playblast features

Maya now supports H.264 Quicktime output on Windows 64-bit. In addition, audio and
multi-track audio are supported.
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What's New in Rigging

Updates to the character setup tools

¥ Mapping Controls

Unified Character Controls

The new Character Controls let you perform multiple
character setup tasks in a single window.

As you set up your character, the previously independ-
ent HumanlIK tools appear as tabs in the consolidated
Character Controls, simplifying the character set up
process.

The Skeleton, Definition, Controls, and Custom
Rig tabs appear as you select options from the Start
pane, Source menu, or Character Controls menu
button.

Start pane

Begin the character setup process using the Start pane
in the Character Controls window. Whether you are
creating a new HumanlIK skeleton from scratch, defining
an existing skeleton, or adding a Control rig or Custom
rig mapping to your character, this pane is designed to
guide you through the setup process.

Source management

The new Source menu provides feedback about the type
of source driving your character. The Source menu is
available in the Character Controls window at all
times, regardless of the HumanlIK tool that is active.
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This menu updates dynamically as you work to reflect
changes to the character state. You can also set your
character's source type by manually selecting an option
from the drop-down menu.

Custom Rig Mapping

The new Custom Rig tool gives you a visual interface
for mapping your non-HumanlIK rigs.

Designed to streamline the mapping and retargeting
process, this tool lets you map and retarget bipedal
HumanlIK character animation to and from a Custom
rigged character. You can define your rig using the fa-
miliar click-and-assign workflow.

Other controls let you save and load mapping tem-
plates and adjust the offsets between a Custom rig and
the character's skeleton joints.

Customizable character layout

You can now customize the character layout in the
Character Controls to fit your character.

The layouts for the Controls and Custom Rig tabs
are available as user-editable XML files, located in the
new CharacterControls directory. Editing these files
lets you create custom layouts. For example, you can
replace the background image or change the position,
quantity, color, and size of cells.

24 | Chapter 6 What's New in Rigging



Heat Map binding

In the Smooth Bind Options window, the Bind
Method options now include a Heat Map method.

This method uses a heat diffusion technique to distrib-
ute weights, and generally gives better default results
than the existing Closest Hierarchy and Closest
Distance binding methods.

Heat Map binding sets initial weights based on each
influence object inside the mesh acting as a heat
source, emitting weight values onto the surrounding
mesh. Higher (hotter) weight values occur closest to
the object, and dissipate to lower (cooler) values as you
move away from the object.

Paint weights for nonlinear deformers

You can now paint weights for the Bend, Flare, Sine,
Squash, Twist, and Wave deformers. Select the new
Edit Deformer > Paint Nonlinear Weights Tool
menu item to use a Maya Artisan brush and paint point
weights on your deformed geometry.
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Improved controls for roll bone behavior

~  Roll & Pitch Updated Roll properties for the HumanlIK skeleton

definition are now available in the Attribute Editor
to give you improved control over roll bone behavior
as you rotate character limbs. See Define roll bone be-
havior.

Improved Control Rig manipulation
Stance pose on body parts

Now you can force a stance pose ( > Edit > Con-
trols > Stance Pose) on selected body parts. This
functionality is useful during pose-to-pose character
animation when only specific body parts need to be
reset to create a new pose.

Continuous rig align

When manipulating your character in Full Body or
Body Part mode, the IK and FK effectors of your
character's Control rig now appear synchronized. By
default, the IK and FK solutions visually merge to show
the final solving of the character's skeleton.

This feature replaces the Align Rig After Time
Change option.

Move Weights improvements
When moving weights (using the Move Weights button in the Paint Skin Weights

Tool or Skin > Edit Smooth Skin > Move Weights To Influences), the first selected
influence now acts as the source influence and all other selected influences act as targets.
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If an influence is locked in the Paint Skin Weights Tool, it will not receive weights when
you move weights from neighboring influences.
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What's New in Modeling

Extrude tool improvements

The following improvements have been made to the extrude tool. Select Edit Mesh > Extrude
for the tool.

m  Allows for more precision with the Thickness, Offset and Divisions values.

m  Uses the same precision settings as the Channel Box. Select Edit > Settings >
Change Precision to set.

m Sliders have been removed so you are no longer limited to a maximum or minimum value.
m  Background color added for improved readability.

m  Respects the use of Ctrl and Shift to adjust the speed of changing the values.

Sculpt Geometry Tool improvements

The following improvements have been made to the Sculpt Geometry Tool (Edit NURBS >

Sculpt Geometry Tool > O or Mesh > Sculpt Geometry Tool > O )-

m  The new Brush strength slider lets you achieve more pronounced pinching while
sculpting your NURBS and polygon surfaces.

m  The Pinch brush algorithm has been improved to provide smoother results.
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What's New in Dynamics

and nDynamics

nHair

Head geometry courtesy of Hiroki Kawasaki

The nHair hair generation system has been added to
the Nucleus dynamic simulation framework. As part of
a Nucleus system, dynamic nHair curves can self-collide
and interact with other Nucleus objects, including
nParticle, nCloth, and passive collision objects.

nHair has many advantages over the previous hair sys-

tem including:

m  Performance improvements especially for hair systems with a
large number of follicles.

m  Nucleus-based solving for collisions and self-collisions that
provide better collision accuracy and control.

m nConstraints that let you create constraints between Nucleus
object components.

m  nCaching for saving and playing back hair simulations.

You can create and modify nHair systems from the
nHair menu located in the nDynamics menu set.
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MayaBullet physics simulation plug-in

Maya now includes the MayaBullet physics simulation
plug-in. Built from the Bullet physics library, the plug-
in lets you use the Bullet physics engine to create large-
scale, highly-realistic dynamic and kinematic simula-
tions. MayaBullet simulations can include interacting
soft body and rigid body objects, as well as constrained
collision objects, all contained in a single dynamic
system within Maya.

MayaBullet automatically installs with Maya on Win-
dows 64-bit, Mac OS, and Linux systems. MayaBullet
is not available for Windows 32-bit systems.

For documentation on MayaBullet, see ht-
tp://www.autodesk.com/mayabullet-docs.

Fluid nCaching improvements

The Create Fluid Cache Options window now includes a One file per geometry
option, which lets you can select multiple fluid objects in your scene and create individual
fluid nCache files for each object.

nParticle

A new Post Cache Ramp Evaluation attribute lets you determine how ramp attribute
data is evaluated. When on, the ramp output is re-evaluated using the cached input attribute
rather than the cached data. This attribute is off by default.

Particle count heads-up display

A new Particle Count heads-up display option lets you display the total number of particles
and the number of selected particles (including nParticles and classic particles).

To turn on Particle Count, select Display > Heads Up Display > Particle Count.
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What's New in Rendering
and Render Setup

New Viewport 2.0 features

New render passes added

Viewport 2.0 now supports animation and rigging fea-
tures such as HumanlK, joints, motion paths, ghosting
and playblast. Image plane support is also included as
well as a new depth peeling transparency algorithm. In
addition, support for several other shaders and tools,
and polygons, NURBS and dynamics features have been
added.

Furthermore, Viewport 2.0 now includes widespread
improvements in tumble performance of large scenes
and in animation performance with large or complic-
ated scenes.

Two new multi-render passes have been added: UV pass
and world position pass.

A UV pass converts UV values to R/G values and creates
a rasterized version of UV space. Using a UV pass, you
can replace textures in 3D renderings as a post-process
without the need to track new textures in place.

A world position pass converts position (x,y,z) values
to R,G,B values. Use the world position pass for relight-
ing workflows in compositing.

NOTE You must save to the openEXR file format when
rendering the UV pass and world position pass.
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Mandelbrot 2D and 3D textures

The new Mandelbrot node allows you to texture your
model with the Mandelbrot set. You can create a 2D
version of this node (Mandelbrot), a 3D version of this
node (Mandelbrot 3D), or shade a fluidShape node
using the built-in Mandelbrot texture.

The Mandelbrot set is a set of mathematical points in
the complex plane, the boundary of which is an inter-
esting fractal shape. Through this node, you can select
the Mandelbrot Set, the Julia set, the Mandelbox set
and other hybrid evaluations. Using this node, you
can add interesting effects to your Mandelbrot set
fractal, such as circles, leaves, points, checker patterns,
and Pickover stalks.

Image created by Duncan Brinsmead

Choose among different shading methods and custom-
ize the range of the color values used to represent your
Mandelbrot set points.

New substance textures and functionality

You can now automatically bake a substance texture
to disk to render it with mental ray for Maya, IPR, or
other 3rd party renderers.

The following new substance textures have also been
added:
m  Clouds_2_Animated

m  |mpact_01
m  Make_It_Tile

m  metal_plate_009
= Plasma_Animated
m  Space_Ship

m  Sunshine

m  Water_Drips

m  Waves

m  Windscreen_Glass_01
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In particular, the new Make_It_Tile substance texture
allows you to easily and seamlessly tile a file texture.
New callbacks command added

The new callbacks command allows you to extend the Maya Ul with your own components.
Use this command to add your own callbacks to standard Maya hooks without the need to
overwrite Maya MEL files. Currently, Maya hooks are provided for the Hypershade, the
Create Render Node dialog, and Attribute Editor templates.

See the callbacks command documentation for more information about this command.

Free image planes
You can now create a free image plane. A free image plane is an image plane that is not

attached to the camera; one that you can select and transform in your scene. Select Create
> Free Image Plane to create one.

mental ray rendering support for GPU cached Alembic files

mental ray supports the rendering of GPU cached Alembic files, including baked diffuse
color information if the GPU cache was used to create the Alembic file.

New mental ray BSDF shaders
Built in BSDF (bidirectional scattering distribution function) shaders from NVIDIA mental
images are now exposed in Maya. You can find them by selecting Window > Rendering

Editors > Hypershade > mental ray > Materials. For more information about these
shaders, please see the mental ray shader documentation.

mental ray version 3.10

Maya now uses mental ray version 3.10.
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What's New in Document-
ation

Improved search in the Maya Help

The Maya Help now includes an improved search that
queries a wider variety of sources with greater efficiency
than ever before.

Matches from the Maya Help documentation and other
websites, like the Autodesk YouTube channels and for-
ums, are included in your search results. Each match
includes an excerpt of text, the name of its source, and
the date it was last updated, so you can quickly navigate
your results.

NOTE If you search with the locally installed Help, you do
not get results from online sources.

Updated Navigation Buttons

Clicking the new Share button lets you send a link to the currently viewed topic. This button
launches your default email application and places the link in the body of a new email message.
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What's New in MEL and
Python

New commands

The following commands have been added:
m applyAttrPattern

m baseTemplate

m baseView

m callbacks

m clipMatching

m createAttrPatterns
m  deleteAttrPattern

m getModulePath

m imagePlane

m listAttrPatterns

= maxfloat

= maxint

= minfloat

= minint

= nodeEditor

m retimeKeyCtx

m saveViewportSettings
m stringArrayRemove
m suitePrefs

m timeWarp
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Obsolete commands

The following command has been removed:
m projFileViewer

Changed commands

The following commands have been changed:

Command Changes

about Flag added: installedVersion
Flag added: liveUpdate
Flag added: preferences

animDisplay Flag added: refAnimCurvesEditable
artPuttyCtx Flag added: brushStrength
attrCompatibility Flag added: pluginNode

attributeQuery Flag added: affectsAppearance
Flag added: affectsWorldspace
Flag added: attributeType
Flag added: cachedInternally
Flag added: categories
Flag added: channelBox
Flag added: indeterminant
Flag added: renderSource
Flag added: usedAsFilename
Flag added: usesMultiBuilder
Flag added: worldspace

bakeResults Argument type changed for minimizeRotation from "string" to "boolean"
bakeSimulation Argument type changed for minimizeRotation from "string" to "boolean"
bufferCurve Flag added: query

Flag added: useReferencedCurve
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Command

character

clip

cmdScrollFieldEx-
ecuter

confirmDialog

containerTem-
plate

convertSolidTx

copyKey

curve

dginfo

editorTemplate

exportEdits

file

floatFieldGrp

Changes

Flag added:
Flag added:

Flag added:
Flag added:

Flag added:

Flag added:

Flag added:
Flag added:
Flag added:
Flag added:

Flag added:

Flag added:

Flag added:

Flag added:

Flag added:
Flag added:

Flag added:
Flag added:

Flag added:
Flag added:
Flag added:
Flag added:
Flag added:

Flag added:

addOffsetObject
removeOffsetObject

rotationOffset
translationOffset

autoCloseBraces

annotation

allKeyable
attribute
fromSelection
useHierarchy

pixelFormat

animLayer

bezier

size

queryName
removeControl

includeConstraints
includeSetDrivenKeys

add

loadReferencePreview
mergeNamespaceWithParent
mergeNamespaceWithRoot
preview

step
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Command

KkeyingGroup

Is

menultem

modelEditor

movielnfo

namespace

namespacelnfo

ogs

outlinerEditor

pasteKey

Changes

Flag added:

Flag added:
Flag added:
Flag added:
Flag added:

Flag added:

Flag added:
Flag added:
Flag added:

Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:

Flag added:
Flag added:
Flag added:

Flag added:
Flag added:

Flag added:

Flag added:
Flag added:

Flag added:

minimizeRotation

absoluteName
excludeType
modified

showNamespace

optionBoxlcon

clipGhosts
imagePlane
motionTrails

counter
dropFrame
frameDuration
movieTexture
negTimesOK
numFrames
quickTime
timeCode
timeCodeTrack
timeScale
twentyFourHourMax

deleteNamespaceContent
mergeNamespaceWithParent
mergeNamespaceWithRoot

baseName
fullName

rebakeTextures

showReferenceMembers
showReferenceNodes

animLayer
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Command Changes

Flag added: matchByName
playbackOptions Flag added: blockingAnim

polyListCompon-  Flag added: vertexFaceAllEdges
entConversion

radioButtonGrp Flag added: annotation1
Flag added: annotation2
Flag added: annotation3
Flag added: annotation4
Flag added: labelAnnotation

referenceQuery Flag added: isPreviewOnly
Flag added: namespace

relationship Flag added: relationshipData

scriptTable Flag added: cellBackgroundColorCommand
Flag added: cellForegroundColorCommand
Flag added: cellindex
Flag added: cellValue
Flag added: editable
Flag added: excludingHeaders
Flag added: multiEditEnabled
Flag added: rowHeight
Flag added: selectedCells
Flag added: selectedColumns
Flag added: selectedRows
Flag added: selectionBehavior
Flag added: selectionMode
Flag added: useDoubleClickEdit

selectPriority Flag added: byName
selectType Flag added: byName
setAttr Flag added: capacityHint
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Command

shot

skinCluster

stereoCameraView

textFieldButton-
Grp

textFieldGrp

treeView

Changes

Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:
Flag added:

Flag added:
Flag added:

Flag added:
Flag added:
Flag added:

Flag added:

Flag added:

Flag added:
Flag added:

createCustomAnim
customAnim
deleteCustomAnim
flag10

flag11

flag12

flag1

flag2

flag3

flag4

flag5

flagé6

flag7

flag8

flag9
hasCameraSet
hasStereoCamera
transitioninLength
transitionInType
transitionOutLength
transitionOutType

bindMethod
heatmapFalloff

cameraSet
imagePlane
motionTrails

textChangedCommand

textChangedCommand

buttonErase
ignoreButtonClick
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What's New in API

imagePlane node changes

The imagePlane node, which was previously a dependency node, is now a shape node (in
other words, a DAG node). This may require changes to your scripts and plug-ins.

If you have been using MFnDependencyNode to create imagePlane nodes, you must change
your code to use MFnDagNode instead. Similarly, if you were using MDGModifier to create
or delete imagePlane nodes, then you must use MDagModifier instead.

Scripts and plug-ins which delete imagePlane nodes may now have to do additional work to
clean up the parent transforms.

In addition, to avoid conflicts with some of the standard DAG node attributes, the following
imagePlane attributes have been renamed:

previous name new name
center (c) imageCenter (ic)
centerX (cx) imageCenterX (icx)
centerY (cy) imageCenterY (icy)
centerZ (cz) imageCenterZ (icz)

Scripts and plug-ins that refer to the child attributes by their previous names no longer work.

Scripts and plug-ins that refer to the parent attribute by its previous name (center) appear to
work but now return the center of the node's bounding box, and not the center of the image
plane, which may be different.
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Module support for plug-ins

You can now easily create a distributable deployment of your plug-in. The site administrator
can setup a plug-in as a folder on a network, along with a module description file. Each
user's machine should point to the module description file through the
MAYA_MODULE_PATH environment variable. This way, making changes to the plug-in is
simple even across multiple Maya versions and platforms.

Multiple versions of a plug-in are now supported, where the version used is determined by
a combination of the current operating system, the version of Maya, and the language
setting (locale). The details of the new module file syntax are outlined in the following
section.
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