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1 Introduction
In Maya 5.0.1 we corrected some issues in the Maya 5 software that were 
reported by our customers. While this release is primarily to address 
issues that were discovered soon after release, there are a few extensions 
to existing features that we want to bring to your attention, in particular:

• the pre-lighting workflow with the mental ray renderer and

• changes to the UV texture placement workflow.

To learn about the changes we’ve made, read the following:

• Chapter 2, “What’s fixed and improved”

• Chapter 3, “Release notes”

For more information about using Maya, see the Maya 5 online help 
(Help > Contents and Search), including the Maya 5 Release Notes.
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2 What’s fixed and 
improved
The following lists the software limitations that were fixed for Maya 5.0.1. 

• “General UI and miscellaneous”

• “Improvements to file referencing”

• “Modeling”

• “Animation and Character Setup”

• “Dynamics”

• “Fluid Effects”

• “mental ray renderer”

• “Baking in mental ray”

• “Hardware renderer”

• “Vector renderer”

• “Artisan”

• “Paint Effects”

• “3D Paint”

• “Fur”

• “DWG/DXF”

• “IGES”

• “MEL”

• “API”

• “Documentation”

General UI and miscellaneous

The following lists general UI and miscellaneous limitations that were 
improved or fixed for Maya 5.0.1.

Importing multiple files with the same shaders

When importing multiple files with the same shaders, the shaders get 
duplicated. To prevent duplication, turn on Remove Duplicate 
Networks in the File Import Options. 

(Linux) Maya corrupted when shelves loaded

When loading shelves in Maya for Linux, the Maya interface may 
become corrupted. This has been fixed. 
Maya 5.0.1 Release Notes
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2 | What’s fixed and improved 
 > Instanced geometry
Instanced geometry

In Maya 5.0 in some cases instanced geometry had a bad DAG path, 
when written out to ASCII files. This has been fixed. 

Underworld nodes

Occasionally when creating underworld objects in complex situations, 
they were not visible in the Attribute Editor. This has been fixed. 

Objects disappearing from Outliner and Attribute 
Editor 

After baking a simulation, objects may have disappeared from the 
Outliner or Attribute Editor. This is now fixed. 

(Linux) wrl2ma not loading

A wrapper script was created to ensure proper library loading before 
running wrl2ma.bin. 

Hypergraph performance

Performance regression in Hypergraph has been fixed. 

Improved memory management when loading Maya 
ASCII (.ma) scenes with many objects

We’ve improved memory management when loading Maya ASCII 
(.ma) scenes with many objects. 

Zero-size swatch files

Maya would crash with a zero-size swatch file. This has been fixed. 

Improvements to file referencing

The following lists the many improvements made to file referencing for 
Maya v5.

• Ability to unload a reference that contains compound connections

• Ability to load and unload references at an arbitrary depth 
without unloading nested references

• Performance improvements to unloading and reloading 
references

• New parentNamespace and flushReference flags added to the 
file command
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2 | What’s fixed and improved

 > Modeling
Modeling

The following lists modeling limitations that were improved or fixed for 
Maya 5.0.1.

Improvements to Texture Editor

We’ve added an alternative display option in the UV Texture Editor to 
provide a workaround for some resolution and cropping limitations 
in the texture display. For details, see C, “UV Texture Editor.”

Option to bake using “sample plane”

In order to create an image map for layered shaders or other non 
directly supported shading networks properly without having the 
image cropped based on an object’s UVs, we’ve added the Bake Using 
Virtual Plane option to the Convert to File Texture Options window 
(Hypershade > Edit > Convert to File Texture > ). This bakes out a 
sample image using a virtual plane with UVs from 0,0 to 1,1 square. 

CV/EP/Pencil Curve Tool Settings window controls 
missing

In Maya 5.0 if you set Open Tool Settings to In Separate Window in 
the Preferences window, the window controls (options) would not 
appear for the following tools: CP Curve Tool, EP Curve Tool, and 
Pencil Curve Tool. However this problem did not exist when Open 
Tool Settings was set to In Main Maya Window. This is now fixed. 

Projection texture on polygons breaks display

In Maya 5.0 if you applied a texture as a projection on to a polygon 
the display may have become broken. This has been fixed. 

Problem using Bonus Tools 

In Maya 5.0 if you may have experienced problems if you used Bonus 
Tools > Select Components > Select Poly Projection Node Faces. This 
has been fixed. 

Animation and Character Setup

The following animation and character setup limitations were fixed for 
Maya 5.0.1.
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2 | What’s fixed and improved 
 > Spline IK twist controls
Spline IK twist controls

We’ve enhanced Maya's spline IK handle to allow better control over 
twisting along the joint chain. For details, see A, “Advanced Spline IK 
twist controls.” 

Enable IKFK now off by default

Enable IKFK Control was introduced in Maya 5.0 and it was set to 
“on” by default. To preserve some character IK-rig behaviors from 
Maya 4.5 to Maya 5.0.1, the menu option Enable IKFK Control has 
been set to “off” by default for 5.0.1. 

If you try to run Maya 5.0 after upgrading to and running Maya 5.0.1, 
Maya 5.0 will not understand the newer version of the preferences, 
and will create default UI prefs. If you think you may be running both 
Maya 5.0 and 5.0.1 and have custom preferences, window positions, 
etc., you may want to create a back-up copy of your 5.0 prefs folder. If 
you are using Maya 5.0.1 exclusively, this is not applicable. 

IK handle creating causing unwanted rotations

The problem where adding an ik handle sometimes caused the joints 
to rotate randomly has been fixed. 

(Linux) Animation curves

Selection of animation curves in the Graph Editor now works as 
expected on Linux. 

Random crash on file open

Crashes occurred in some cases where the Hypergraph had been open 
in the previous session with the file. This has been fixed. 

Can't bake animation to vertices on heavy geometry 

Since Maya 4.5 baking animation to vertices could crash if the 
geometry was heavy. This has been fixed in Maya 5.0.1.

Rotation flipping on constraints 

A change in Maya 5.0 from Maya 4.5 resulted in rotation flipping on 
some constraints, in cases where not all the rotation channels were 
controlled by the rotation constraint. This has been fixed in Maya 
5.0.1. 
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2 | What’s fixed and improved

 > (Mac OS X) Launching fcheck from a playblast
(Mac OS X) Launching fcheck from a playblast

On Macintosh machines, when fcheck is the designated program to 
use for a playblast, fcheck is now launched successfully. 

Crash upon new file after baking animation

Maya may crash when creating a new file after baking animation. This 
has been fixed. 

Crash when loading file

In Maya 5.0 a crash may occur when loading files containing character 
nodes for which no clips are defined. This has been fixed in Maya 
5.0.1. 

Constrained camera attributes are editable

Changes to Maya 5.0 caused constrained camera attributes to be 
editable. This has been fixed. 

lookAt nodes

In Maya 5.0, “lookAt” nodes could occasionally be incorrectly deleted 
when deleting other related nodes from a Maya scene. In Maya 5.0.1, 
they persist appropriately. 

Two-node camera problems

Problems with two-node cameras in Maya 5.0 have been fixed in 
Maya 5.0.1. 

(IRIX, Linux) Alternate Expression Editor 

You may have experienced problems using the alternate Expression 
Editor in Maya on IRIX and Linux. This is now fixed. 

Maya hangs when adding attributes to a Character 
Set

Maya would hang under some conditions when adding attributes to a 
Character Set. This problem occurred if an attribute being added to 
the Character Set was one for which there was blending between 
keyframed animation and a constraint. This has been fixed.
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2 | What’s fixed and improved 
 > Keyframes missing on file reload
Keyframes missing on file reload

When combining keyframed animation and constraints on IK handles, 
you could encounter a situation where everything seemed to work 
fine until you saved your scene. The next time you loaded the scene, 
the keyframes would be missing. This has been fixed. 

Dynamics

The following dynamics limitations were fixed for Maya 5.0.1.

Maya 4.5 Linux Particle Disk caching

In Maya 4.5 for Linux Particle Disk cashing did not work. This was 
fixed in Maya 5.0. 

Particle Expression Corruption on scene save 

You may have experienced corruption of particle expressions in Maya 
5.0. This occurred in expressions that contained newline characters. 
This has been fixed. 
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2 | What’s fixed and improved

 > Fluid Effects
Fluid Effects

The following Fluid Effects limitations were fixed for Maya 5.0.1.

Fluids caching

We’ve enhanced fluids caching for Maya 5.0.1. For details, see B, 
“Fluids caching.” 

(Windows) Creation of cache on instanced fluid 

You may have experienced problems with the creation of cache on 
instanced fluids on Windows. This has been fixed. 

Incorrect fluids cache info created

Occasionally when saving a new version of a file already containing 
cached fluids, the info in the fluid cache node will be written 
incorrectly. Maya was incorrectly prepending fluid cache file names 
with a “.” prefix. This has been fixed. 

Surface locators incorrect

In Maya 5.0 if ponds were scaled or transformed the positioning of 
buoys and locators on the pond surface may not have been correct. 
This has been fixed. 

Turbulence speed on fluid emitters 

You may have experienced problems with turbulence speed on 
emitters. This has been fixed. 

mental ray renderer

The following mental ray rendering limitations were fixed for Maya 5.0.1.

Loading/unloading mental ray plug-in

In Maya 5.0 you may have experienced a crash while loading or 
unloading the mental ray plug-in. This has been fixed. 

Network rendering with mental ray

• Previously, Maya may have crashed when mental ray network 
rendering was used. It happened when mental ray couldn’t connect to 
the slave host or when the mental ray server emitted errors to the 
master. This particular issue has been corrected, but slave errors 
during rendering still affect the Maya master rendering. 
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2 | What’s fixed and improved 
 > (Mac OS X) Network rendering with mental ray
• In Maya 5.0 you may have experienced crashes when network 
rendering with more then 3 machines. In Maya 5.0.1 the mental ray 
for Maya renderer is based on the mental ray standalone core version 
3.2.6. This version fixes a number of limitations, including this one. 

(Mac OS X) Network rendering with mental ray

Network rendering with mental ray for Maya will be set up for the 
user who installed Maya. Other users should do the following setup 
(only once) to run network rendering. 

To install settings for a new user, that user should type in a shell 
(Terminal window):

    sh /Applications/AliasWavefront/maya5.0/bin/setup_defaults.sh install 

To remove settings for a user, that user should type in a shell 
(Terminal window):

    sh /Applications/AliasWavefront/maya5.0/bin/setup_defaults.sh remove

(Mac OS X) mental ray batch rendering 

Render > Show Batch Render and Render > Cancel Batch Render now 
work properly on Mac OS X. 

(Linux) Maya -batch -preframe export (.mi) results in 
fatal error

In the previous version of Maya you may have experienced a fatal 
error when batch rendering per frame on Linux. This has now been 
fixed.

(Windows, IRIX, and Linux) Render layers

In Maya 5.0 render layers were not respected by the mental ray 
renderer. This has been fixed. 

MayatomrJob -startFrameCallback

Now the script specified by the “MayatomrJob -startFrameCallback” 
command is executed after the frame number is set. 
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2 | What’s fixed and improved

 > Error: No object matches name: mentalrayGlobals.outputPath
Error: No object matches name: 
mentalrayGlobals.outputPath

We have fixed mental ray so you won’t get an error message like this: 

// Error: file: /Applications/AliasWavefront/maya5.0/ApplicationSupport/
scripts/others/mentalrayUI.mel line 1715: No object matches 
name:mentalrayGlobals.outputPath // 

Render menu

If you added custom menu items or a submenu to the Maya Render 
menu, after you load the mental ray plug-in, your custom items will 
now appear correctly. 

Subdivision surfaces

mental ray now renders subdivision surfaces as expected. 

Pre Render MEL and Post Render MEL

• The mental ray tab of the Render Global Settings window now takes 
the values for Pre Render MEL and Post Render MEL and passes them 
on to mental ray correctly. 

• Pre Render MEL and Post Render MEL now work correctly in mental 
ray batch render mode. 

• The Pre Render MEL and Post Render MEL text fields used to have 
problems handling MEL scripts with quotation marks in them, such as 
printery”); this is now fixed. These text fields can pass MEL scripts 
with quotation marks on to mental ray correctly. 

Motion Blur Shadows

In the mental ray tab of the Render Global Settings window (Window 
> Rendering Editors > Render Globals) Motion Blur Shadows are now 
turned on when Shadow Maps are turned on. 

Turning Receive Shadows off in mental ray

The mental ray renderer’s Receive Shadows flag is now respected by 
the renderer. 

Lightmap shader performance

The performance of the mental ray lightmap shader has improved. 
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2 | What’s fixed and improved 
 > Shadowmaps and volumes
Shadowmaps and volumes

When using shadowmaps with volumes and mental ray you should 
override (increase) the volume samples settings on the volume shape. 
You may also need to enable depth jittering and tune up mental ray 
shadow map settings on light sources, such as Softness and Samples. 

Connections to U and V coordinate attributes

Previously, creating connections to a U or V coordinate attribute in a 
texture node would cause mental ray to crash. A node cycle detection 
has been implemented to avoid endless loops and crashes when 
translating such DG graphs. The performance impact grows with the 
depth of the visited shading graph. The cycle detection is enabled by 
default, but can be disabled by adding a dynamic attribute 
nodeCycleCheck (boolean) to the render globals node. 

Light linking and lighting for particle instanced 
geometry

Due to limitations in the Maya API, particle instanced geometry was 
previously only illuminated by the default light. This situation has 
been improved in that shading groups containing particle instanced 
geometry are excluded from light linking. Particle instances are now 
illuminated by all lights if the material used for the particle instances 
is not used elsewhere in the scene and the original instanced object is 
hidden. 

Animated displacement maps

Animated displacement is now rendered properly for all types of 
displacement approximations. This includes detecting animated 
displacement shaders and marking objects with such shaders attached 
as “dirty.” 

HDR images

HDR images now behave as expected. 

Animated energy values

Previously animated energy values on light sources were not 
recognized and didn't change in subsequent frames of an animation. 
This has been fixed. 
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2 | What’s fixed and improved

 > Software particle cloud caused Maya to crash during mental ray render
Software particle cloud caused Maya to crash during 
mental ray render 

In the previous version of Maya there was a hard-coded limit on the 
number of particles that any ray could intersect. If the number of 
particles in a ray's path exceeded that limit, a crash occurred. In Maya 
5.0.1, there is no longer a hard-coded limit. 

Color blending tab index off by 1

In Maya 5.0 the Color Blending tab inside the Vertices bake set option 
was off by 1. Subtract appears to be Add, Multiply is Subtract, etc. 
This has now been fixed in Maya 5.0.1. 

Mental Ray fatal error: out of array bounds in 
mayabase 

Mayabase had an access violation error in some cases when the noise 
function was used. This has been fixed. 

Imageplane

Imageplane now moves with the camera if the camera is animated. 

Baking in mental ray

The following baking in mental ray limitations were fixed for Maya 5.0.1.

mental ray baking hierarchies of geometry

When baking hierarchies of geometry, mental ray now behaves as 
expected. 

Vertex/Texture baking using mental ray

When temporary objects sets are created during mental ray baking 
operations (for example: selObjFaceSet, selObjFaceSet1), they are now 
removed automatically. Previously they had to be manually deleted 
or cleaned up using File > Optimize Scene. 

Light linking

Baking now respects light linking. 

Baking and shadow results

Baking with mental ray now produces expected shadow results. 
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2 | What’s fixed and improved 
 > Min/Max clamping of Batch Bake Pre-light
Min/Max clamping of Batch Bake Pre-light

Min/Max clamping of Batch Bake Pre-light now behaves as expected. 

Overbake algorithm improved

Pre-light to texture has an improved overbaking algorithm. Edges 
along UV borders are less noticeable. 

Bake to color per vertex

Baking objects with per face material no longer crashes. 

Batch bake and per-face material assignment

“per-face material” and “bake to one map” is now supported by 
baking. To generate one texture per mesh with per-face material 
assignment, assign a texture bakeset to the object and turn on Bake To 
One Map in the Baking Attribute Editor. 

Alpha Mode for Bake Alpha

When you turn on Bake Alpha in the Baking Attribute Editor, the 
Alpha Mode, specifically Pass Through, now behaves as expected. 

Hardware renderer

The following lists the Hardware rendering limitations that were fixed for 
Maya 5.0.1.

2D Texture Placement

Placement has been fixed so various options, including WrapU and 
WrapV, provide the correct result. Also, problems related to rendering 
surfaces that do not have complete texture space coverage (i.e., 0,0 -> 
1,1) have now been fixed. 

Note Files may take longer to hardware render compared to Maya 5.0 
because some texture placement configurations cause the 
renderer to bake the associated file texture. This may also result 
in a decrease in image quality if the file texture’s resolution is 
larger than the color texture resolution in Render Global 
Settings. You are encouraged to use render diagnostics to 
identify those file textures that will be baked and, if possible, 
adjust the placement parameters to avoid the baking process. 
Maya 5.0.1 Release Notes 

24



2 | What’s fixed and improved

 > Specular, incandescence and environment map reflection
Specular, incandescence and environment map 
reflection 

The calculation for this now matches software rendering more closely. 
In software rendering, the transparency of a surface does not affect the 
specular highlight intensity, incandescence and environment map 
reflection. The Hardware renderer now behaves similarly. 

Render layers

Multiple cameras or render layers will now render correctly. In Maya 
5.0, only the first camera or first render layer would render. 

Vector renderer

The following lists the Vector rendering limitations that were fixed for 
Maya 5.0.1.

When Highlights are on

When Highlights are on, making changes to your scene (for example, 
changing the Highlight Level value, adding a new object to your 
scene, adding a glow to a light) no longer causes surface fills to 
become lighter (if the surface material shininess is greater than 0). 

Error during rendering a camera which is constrained 
to two locators

Vector renderer now handles cameras constrained with locators. 

Shadows gray instead of black

Shadows no longer appear gray instead of black. They behave as 
expected. 

Artisan

The following Artisan limitations were fixed for Maya 5.0.1.

Paint Vertex Color Tool

After exporting color per vertex maps multiple times from the Paint 
Vertex Color Tool, Maya may crash. This has been fixed. 
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2 | What’s fixed and improved 
 > Paint Skin Weights Tool
Paint Skin Weights Tool

The list of joints in the Influence section of the Paint Skin Weights 
Influence Tool settings window used to update incorrectly for 
operation selection, brush size changes, etc. This has been fixed. Now 
the list updates only when it is necessary. 

Paint Effects

The following Paint Effects limitations were fixed for Maya 5.0.1.

Paint Effects to Polygons

In Maya 5.0 Paint Effects to Polygons may have failed to create a 
shader for some brush settings. This has been fixed. 

3D Paint

The following3D Paint limitations were fixed for Maya 5.0.1.

Polygon or Subd with multiple shaders assigned to 
multiple faces

Create a polygon or subdivision surface with multiple shaders 
assigned to different faces. Then delete one of the shaders and start 
the 3D Paint Tool. Maya crashes. This has been fixed. 

Fur

The following Fur limitations were fixed for Maya 5.0.1.

Rendering with Fur shading

In Maya 5.0, the fur render could fail after adding a light with fur 
shading until a new session of Maya was started. This is now fixed. 

Reading Equalizer Maps with referenced files

Reading Equalizer Maps used to fail when a scene was referenced 
with Use Namespaces turned on or when name clashes were resolved 
using a string. This is now fixed. 

Batch rendering when file with Fur is referenced

Batch Render now renders fur when the file with fur is referenced. In 
the previous version of Maya this did not render when Batch Render 
was invoked from the Maya application window (not the command 
line). 
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2 | What’s fixed and improved

 > Equalizer Maps
Equalizer Maps

In the previous version of Maya if the Equalizer map was created 
using Read Equalizer Map in the Fur Globals window and batch 
rendered, Fur would not show up in the output. This has been fixed. 

Rendering Fur through the entire range of frames

In Maya 5.0 Fur may not always render on the surface through the 
entire range of frames. Memory improvements to Fur in Maya 5.0.1 
have fixed this. 

Spotlights and Auto Shading

In Maya 5.0, we changed the default behavior for spotlights so that fur 
growing on the side of an object away from the light would not be lit. 
However, this behavior prevents Auto Shading parameters such as 
Back Shade Darkness and Back Shade Factor from being used. 
Consequently, we have now made this behavior optional. A new 
option in Fur > Fur Globals > Fur Render Options > Advanced 
Options, called Auto Back Shade Spotlights, controls whether or not 
fur growing on the side of objects away from spotlights is 
automatically excluded from the lighting effect, regardless of any Fur 
Shading applied to the light. The default is now off, which is 
equivalent to the behavior in Maya 4.5 and earlier. 

DWG/DXF

The following lists DWG/DXF limitations that were improved or fixed for 
Maya 5.0.1.

(IRIX, Linux) DWG/DXF Options box

(IRIX, Linux) When you import a DWG/DXF file, the Options box can 
now be opened. 

Extrusions fully supported

All extrusions in AutoCAD are mapped to Maya correctly. 

Invisible edges supported

Invisible edges within AutoCAD Polymeshes are now supported. 

Traces supported

Traces within AutoCAD are mapped to Maya correctly. 
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2 | What’s fixed and improved 
 > Instances supported
Instances supported

Maya Instances are supported. 

Block references support

Block references are now supported. 

Shader assignments + xform

Shader/Layer assignments are now more robust. 

IGES

The following IGES limitations were fixed for Maya 5.0.1.

Rendering IGES imported models

Now after importing via IGES, the geometry is assigned a default 
shader. 

Catia IGES files

Catia v5 and v4 IGES files no longer cause Maya to crash on import. 

MEL

The following lists MEL limitations that were improved or fixed for Maya 
5.0.1.

Path containing “/” and “\” slashes

In certain circumstances we would create a path containing both a “/” 
and a “\”. We’ve fixed this so it’s consistent. 

String quoting broken in batch mode 

In Maya 5.0 you may have experienced problems if you used the 
command maya -batch -prompt followed by a long string (>256 
characters). This is now fixed. 

file command having trouble with like named 
referenced files 

The mel command “file” was unable to distinguish between two 
referenced files with the same name, but different paths. This has been 
fixed. 
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2 | What’s fixed and improved

 > Cannot source script in current working dir
Cannot source script in current working dir

If you launched Maya from a directory that's not in 
MAYA_SCRIPT_PATH and you tried to source a MEL script that's in 
there, Maya 5.0 would not source the script. This is now fixed. 

API

The following lists API limitations that were improved or fixed for Maya 
5.0.1.

• A memory problem when calling the 
addPlugToManipConversionCallback() or 
addManipToPlugConversionCallback() of the MPxManipContainer 
class has been fixed. 

• The MLibrary::initialize() method will not cause an exception if called 
more than once. 

• The MPxDeformerNode class now works on Mac OS X. 

• The MPxTransform::resetTransformation() method now respects 
attribute locking. 

• A problem retrieving the local transformation matrix using the 
MFnTransform class on an MPxTransform node has now been fixed. 

Documentation

The following lists documentation limitations that were improved or fixed 
for Maya 5.0.1.

Docs server on Mac not working between logins

There was a problem where the online help was not available after a 
logout on Mac. The problem arose because of the default permissions 
on a log file that was being created by the docs server. The docs server 
startup script now creates the logfile with global write permissions. 
This is fixed in the CD-ROM version only; the download version will 
not update the docs server. 

Online help on Mac/Linux 5.0 on Mozilla-based 
browsers

The table of contents on the left side of the online help sometimes 
would not work as an expanding hierarchy (instead, the different 
levels would load as separate pages). This was caused by the limit on 
how long the page would wait for the new level to load being set too 
low. This is now fixed if you installed 5.0.1 from a CD-ROM. If you 
install 5.0.1 from the download, you must do the following to fix this:
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 > Selecting the location of Japanese manual
1 Go to where Maya is installed.

2 Open docs/Documents/Maya5.0/en_US/style.

3 Open the toc.js file in a text editor.

4 Find the line that begins “if (count”.

5 Change number after the less-than sign (<) to 20. This number controls 
how long the page will try to load the next level in the hierarchy 
before falling back to loading the page directly.

The expanding hierarchy only works on modern browsers. Older 
browsers such as Netscape 4.x and OmniWeb 4 will always show 
separate pages. 

Selecting the location of Japanese manual

For Maya 5.0.1 the ja_JP docs installer (as well as the doc server 
installer that will ship on the CD-ROM) will permit the user to select 
the install location.  The install will default to sane values (usually 
relative to the Maya install path). 
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3 Release notes
In this chapter we list new release notes or additional information you 
should know about using Maya 5.0.1. 

• “(Linux) Maya 5.0.1 may not run”

• “(Linux) Maya may crash when unloading plug-ins”

• “(Mac OS X) File type and launching fcheck”

• “(Win XP) Installing Maya 5.0.1”

• “Camera film back display options”

• “(Linux) Wacom stylus and tablet”

• “Dynamic compound attribute”

• “Referenced Fluids, Particles, and Jiggle deformers will not cache if 
Use Namespaces is turned on”

• “Attributes driven by keyframes and constraints may behave 
unexpectedly”

• “Paint Effects Mesh brushes”

• “Fur shadows and Dmap Auto Focus”

• “General rendering”

• “Hardware renderer”

• “mental ray renderer”

• “Baking in mental ray”

• “API”

• “Online Help”

(Linux) Maya 5.0.1 may not run

Maya 5.0.1 for the Linux platform will not run. This version of Maya is 
dependent on the shared library named libfam.so. This is the File 
Alteration Monitor (FAM) library.

Workaround

Install the runtime FAM rpm from the Red Hat 7.2/7.3/8.0 CD.

(Linux) Maya may crash when unloading 
plug-ins

Plug-ins compiled on Red Hat 7.3 with gcc 3.2.2 may not unload 
properly when running on later versions of Red Hat (8.0/9.0).
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 > (Mac OS X) File type and launching fcheck
Workaround

Compile plug-ins with the -Wl, -Bsymbolic linker option.

(Mac OS X) File type and launching fcheck

Importing certain file formats—such as obj, iges, and dwg—when the 
file type option of the import command is set to "best guess" may 
cause fcheck to launch instead of importing the file.

Workaround

If this happens, set the file type to the format of the file you are 
importing.

(Win XP) Installing Maya 5.0.1

Maya 5.0.1 won't install to a path containing a mapped drive.

Workaround 

Specify the full directory path (not the mapped path) when installing 
Maya 5.0.1. Alternatively, install to the default location. 

Camera film back display options

We’ve provided options to display in the viewport the film pivot and 
film origin for a camera. Turn these on to see where the filmback pivot 
and filmback origin are located in the viewport (the origin of the 
filmback prior to translating or offsetting the filmback). Turn these on 
and off using either the Camera Attribute Editor > Display Options 
section or using the panel’s View > Camera Settings > Film Origin, 
and Film Pivot menu items. By default, these options are turned off. 

(Linux) Wacom stylus and tablet

When you paint strokes in Paint Effects on Linux, your Wacom stylus 
and tablet may have no pressure sensitivity. Select an Artisan tool (for 
example, the Paint Selection Tool) and open the Tool Settings editor. 
Expand the Stylus Pressure section. If the Stylus Pressure options are 
disabled, Maya cannot find your Wacom tablet. Your tablet may be 
installed under the generic name “tablet.” 

Workaround

To fix this, go to the Wacom web site (www.wacom.com) and read the 
product support information for Linux.
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 > Dynamic compound attribute
Dynamic compound attribute

If you add a dynamic compound attribute to a node with other 
dynamic attributes, and then delete the compound attribute, you will 
not be able to recreate another dynamic attribute with the same name. 

Workaround

Do one of the following:

• Save your scene and reload it. 

• Duplicate the object, delete the original, and rename the duplicate 
to match the original.

Referenced Fluids, Particles, and Jiggle 
deformers will not cache if Use Namespaces 
is turned on

You can not cache Fluids, Particles, or Jiggle objects if they are 
referenced using the Use Namespaces option, due to the colon this 
writes into the cache name.

Workaround

Use another method to resolve name clashes when referencing Fluids, 
Particles, and Jiggle deformers, such as prepending the filename (the 
default method) or a chosen string.

For example, if you create a particle system called spark1, save it in the 
file bonfire.ma, and then reference the particle system from another file, 
the system would be called bonfire:spark1 with the namespace option 
and bonfire_spark1 without the namespace option.

Attributes driven by keyframes and 
constraints may behave unexpectedly

You may encounter unexpected behavior when dealing with 
attributes that have both keyframes and constraints driving them. This 
problem arises when using such attributes in Characters Sets and clips 
in Trax.

Paint Effects Mesh brushes

The interpolation for Paint Effects triangles with Mesh brushes may 
result in distorted textures where the triangle count is low. 

Workaround

Increase the triangle density on the brush or convert the Paint Effects 
strokes to polygons to render.
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 > Fur shadows and Dmap Auto Focus
Fur shadows and Dmap Auto Focus

Fur Shadows can be incorrectly placed when Dmap Auto Focus is 
turned on. We suggest you turn off Dmap Auto Focus for all 
spotlights that have Fur Shadow Maps enabled, and instead set the 
Dmap Focus value to Cone Angle + (Penumbra * 2). 

General rendering

The following lists any new release notes or additional information you 
should know about rendering in general in Maya 5.0.1.

Frame/Animation Extension

Frame/Animation Extension is now consistent between Software, 
Vector, and Hardware rendering. All three renderers support single 
frame rendering, and single file multi-frame rendering for AVI and 
Quicktime. The mental ray renderer still has the same limitations; for 
more information, see the Maya 5.0 Release Notes in the Maya 5.0 
online help.

Using Maya Batch Renderer

When using the Maya Batch Renderer on a remote machine the User 
Account information (i.e. username) must be consistent between the 
machines to ensure that User Authentication will function correctly. 

Multiple batch file render

Only the first command gets executed when trying to launch multiple 
mayarender_with_mr, mayaexport_with_mr or mayaVectorRender 
commands in a batch script on Windows. 

Workaround

Use the call command on each line, for example: 

call mayarender_with_mr -file sceneA.mb 
call mayarender_with_mr -file sceneB.mb 
call mayarender_with_mr -file sceneC.mb 
call mayarender_with_mr -file sceneD.mb

Hardware renderer

The following lists any new release notes or additional information you 
should know about using the Hardware renderer in Maya 5.0.1.
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 > Quality Presets
Quality Presets

Existing files created in Maya 5.0 loaded into Maya 5.0.1 will render 
the same as they did before. New scenes created in Maya 5.0.1 will 
have Intermediate quality set as their default quality setting in the 
Render Global Settings window. 

New scenes have the following differences:

• There is a new attribute called enableAcceleratedMultiSampling 
that improves image quality if the video card supports hardware 
multi-sampling. It is enabled for newly-created 5.0.1 scenes. With 
the Preview quality setting, this attribute is turned off. If a 5.0 
scene is loaded into 5.0.1, this attribute takes its value from 
whatever enableEdgeAntiAliasing was set to. The 
enableEdgeAntiAliasing attribute from Maya 5.0 is now ignored 
in 5.0.1. 

• There is a new attribute called enableHighQualityLighting. 
Existing Maya 5.0 scenes and newly created 5.0.1 scenes both have 
this attribute enabled. When Preview quality preset is used, this 
attribute is turned off. 

• Low quality lighting is now an option in 5.0.1. This option can 
produce images orders of magnitude faster than before. However 
there are numerous limitations with this option due to the per 
vertex calculations being used for all lighting effects.

Pros Cons

• Render time can be 8 to 10 
times faster, due to fewer 
passes. 

• Lighting looks similar or 
better than what can be 
obtained in the 3D viewport 
or Hardware Render Buffer.

• If the surface is not highly 
tessellated, specular 
highlights and spot light 
penumbras will have 
significant image artifacts due 
to interpolation of lighting 
between vertices. 

• The lighting is clamped after 
rendering up to eight lights 
(vs. one light for high quality 
lighting) for each pass. This 
means that scenes may often 
be too dark, and adding lights 
will not help consistently.

• Shadows, bump, and 
projective light textures are 
not supported. 
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 > Texture Compression
• The default image quality preset in 5.0.1 has been changed to 
Intermediate. As a result, new 5.0.1 scenes have the color and 
bump resolution (used to bake textures before a Hardware render 
is performed) set to 256 and 512 respectively. By comparison, new 
scenes in 5.0 had default color and bump resolution settings of 128 
and 256.

Texture Compression

There is a new attribute called textureCompression. When enabled, 
hardware-assisted image texture compression is used to reduce 
texture memory usage with typically unnoticeable image artifacts. 
Newly-created 5.0.1 scenes render using hardware texture 
compression. Existing Maya 5.0 scenes loaded into 5.0.1 do not use 
texture compression, to avoid any image differences. 

Improved Hardware rendering interruptability

We’ve improved the Hardware renderer so that it is more 
“interruptable” than before. In Maya 5.0, the renderer only checked 
for interrupts for each frame of an animation. In Maya 5.0.1 it now 
checks for interrupts at several points during the translation and draw 
process. 

AVI output

An AVI output has been added in the Hardware renderer’s file 
formats on Windows.

Performance

There are new culling methods, which improve the performance of 
hardware rendering when there are many lights or many non-visible 
objects in the scene. The following culling methods are now be used: 

• camera frustum per particle systems 

• point frustum and spotlight frustum per scene object 

• radial decay (sphere of influence) per object. This only applies to 
graphic cards that fully support NV fragment programs or ARB 
fragment programs. 

• camera frustum per object culling during processing. This will 
help improve render time per frame as well as the amount of 
resources used. 
Maya 5.0.1 Release Notes 

36



3 | Release notes

 > Point light shadows
Point light shadows

Point light shadows are now supported on non Quadro FX cards 
(NV30GL).

Support for more rendering flags

The Hardware renderer now supports Cast/Receive Shadow 
rendering flags, Ignore When Rendering property of connections on 
the shading nodes, and Matte Opacity.

Support for Use Background Shader

Support for the functionality of shadow catching has been added, but 
not reflections. This is to help support compositing with live action 
backgrounds. For shadow catching, shadows from spot lights and 
directional lights are supported. Neither intensity, decay on lights, nor 
non-shadow casting lights have any affect on the alpha mask. For 
color output, only black backgrounds are supported. Image planes are 
not supported, so they will not show up for objects using this shader. 
All new rendering flags are supported for Use Background shader. 

Enable Geometry Mask

We’ve added Enable Geometry Mask in the Hardware Render Global 
Settings. When off, surfaces are hardware rendered as usual. When 
this option is turned on, opaque geometry objects are not drawn, but 
mask out particle objects, while transparent geometry do not get 
drawn. This is especially useful when compositing particles over 
geometry rendered in different passes. Geometry Mask is off by 
default.

Shadow quality

Point particles now cast round shadows versus square shadows. Also, 
there is a new option to have totally transparent areas on an object not 
cast shadows from those areas. This applies for both surface and 
particle types, such as sprites.

mental ray renderer

The following lists new release notes or additional information you 
should know about using the mental ray for Maya renderer in Maya 5.0.1.
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 > mental ray standalone
mental ray standalone

The mental ray for Maya renderer is based on the mental ray 
standalone core version 3.2.6. This version fixes a number of 
limitations, but it doesn't introduce new features. 

Floating licenses

The following limitation is related to licensing mental ray for Maya. In 
Floating License environments that have both Maya Unlimited and 
Maya Complete licenses, the mental ray for Maya plug-in may not 
load if the MAYA_LICENSE environment variable is set to 
-unlimited.

Workaround

To correct this, set this environment variable to complete and remove 
any MAYA_LICENSE setting from the Maya.env file.

mental ray online documentation

We provide two mental ray guides in the Maya 5.0 online help (Help 
> Contents and Search > Reference section). These two guides are 
mental ray reference and mental ray shader reference. These two 
documents are currently not searchable using the Search field in the 
online help. 

Default approximation change

In Maya 5.0.1, the default for displacement mapping has changed 
from fine displacement approximation to parametric approximation. 
This results in less memory used, but may produce different results 
than in Maya 5.0. To get the same results as in Maya 5.0, explicitly set 
the approximation node to fine displacement approximation. 

Shadow maps on scaled lights

mental ray does not handle shadow maps on scaled light sources very 
well. Proportional scaling for the light should be used. 

Light linking shadows

Light linking does not take shadows into account. 

Caustics and directional lights

Caustics are not created when using directional lights. Directional 
lights are not recommended for emitting photons. 
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 > Converting .hdr images to tiled .map texture
Workaround

Use a spotlight instead.

Converting .hdr images to tiled .map texture

In some cases when converting an .hdr (rgbe) image to a tiled .map 
texture to be used for rendering, artifacts may appear. To avoid this, 
first convert the .hdr image to a .tif (rgb_fp) image, then convert the 
.tif to a tiled .map (rgb_fp) image. For example: 

imf_copy -v texture.hdr texture.tif tif rgb_fp

imf_copy -v -r texture.tif texture.map map rgb_fp

Additionally, this problem does not occur if a non tiled .map texture is 
used. Use the following command:

imf_copy -v -p texture.hdr texture.map map rgb_fp

16-bit RLA texture

Maya may crash when rendering a 16-bit RLA texture with alpha in 
Maya's mental ray renderer. 

Workaround

Use any other (8-bit) image format such as .tga, .tiff, .iff, etc.

Pixel Aspect Ratio 

Pixel Aspect Ratio has been added to the mental ray Render Global 
Settings window. 

Final Gather options

Additional Final Gather options have been added to the Final Gather 
section of the mental ray Render Global Settings tab. These options 
are: 

Final Gather Filter

Final gathering uses a speckle elimination filter that prevents samples 
with extreme brightness from skewing the overall energy stored in a 
final gather hemisphere. This is done by filtering neighboring samples 
such that extreme values are discarded in the filter size. By default, 
the filter size is 1. Setting this to 0 disables speckle elimination, which 
can add speckles but will better converge towards the correct total 
image brightness for extremely low accuracy settings. Size values 
greater than 1 eliminate more speckles and soften sample contrasts. 
Sizes greater than 4 or so are not normally useful. 
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 > Semi-transparent shadows with caustics and global illumination
Final Gather Falloff Start

Final Gather Falloff Stop

Limits the length of final gather rays to a distance of stop in world 
space. If no object is found within a distance of start, the ray defaults 
to the environment color. Objects farther away than stop from the 
illuminated point will not cast light. Effectively this limits the reach of 
indirect light for final gathering (but not photons). The start parameter 
defines the beginning of a linear falloff range; objects at a distance 
between start and stop will fade towards the environment color. This 
option is useful for keeping final gather rays from pulling remote 
parts of the scene, which may not affect illumination very much, into 
the geometry cache. This allows mental ray to render with a much 
smaller memory footprint. 

Final Gather Trace Depth

If this is set to 0, it prevents final gather rays from spawning subrays. 
This means that indirect illumination computed by final gathering 
cannot pass through glass or mirrors, for example. A depth of 1 
(where the sum must not be less than the other two) would allow a 
single refraction or reflection. It is not normally necessary to choose 
any depth greater than 2 (the default). This is not compatible with 
mental ray 3.1 and earlier that use the trace depth (which defaults to 2 
2 4) for final gathering. 

Semi-transparent shadows with caustics and global 
illumination

You can now produce transparent shadows with caustics and global 
illumination. When you turn on the Enable Semi-transparent Shadows 
option (Window > Rendering Editors > Render Globals > mental ray 
> mental ray tab > Caustics and Global Illumination), shadow shaders 
with photons are used. When this option is off, no transparent 
shadows are produced when photons are used. 

Note  “Optimize_Photon_Shadows” is the dynamic attribute name for 
the Enable Semi-transparent Shadows option in the mental ray 
Render Global Settings. 

mi_Export_Shadow_Shader

This overrides the global “Optimize_Photon_Shadows” setting 
on a per-material basis. If this attribute is enabled, shadow 
shaders are used even though photons are being used. If it is 
disabled, the old behavior is reinstated for this specific material.
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 > If you experience a crash
If you experience a crash

If you experience a crash while rendering a scene using mental ray, 
try the following to prevent the crash: 

1 Put a memory limit of 800 Mb on mental ray. For a new scene in 5.0.1, 
the Physical Memory default value of 800 Mb already applies, but if 
you have an old scene, it is possible that value is still set to -1; change 
it to 800. To do so, select Window > Rendering Editors > Render 
Globals > mental ray tab > Memory and Performance > Memory 
Limits > Physical Memory and enter 800 as the value. 

2 In addition to this memory cap, turn off Scanline rendering for mental 
ray, (Window > Rendering Editors > Render Globals > mental ray tab 
> General > Scanline).

Baking in mental ray

The following lists new release notes or additional information you 
should know about baking in the mental ray for Maya renderer in Maya 
5.0.1.

Baking invisible, template, intermediate, reference 
objects

mental ray ignores bake invisible, template, intermediate, and 
reference objects. Baking components only supports poly faces. 

Bake Set menu changes

New options have been added to the Assign Existing Bake Set menu 
item in the right-click pop-up menu. These two options are: 

• initialTextureBakeSet allows access to the default initial texture 
bake set so that it may be modified

• initialVertexBakeSet allows access to the default initial vertex 
bake set so that it may be modified 

Overriding assigned bakeset attributes

You can override baking options for selected objects to test, for 
example, baking options quickly without having to reassign objects to 
bake sets to see the results. 

When you turn on the Use Bake Set Override (Lighting/Shading > 
Batch Bake (mental ray) > ), the override options can be modified. 
Selected objects you bake take the override settings instead of those of 
the bake set to which the objects are assigned. 
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Saving override presets

You can save override settings as a preset that you can later delete or 
load. To save a preset, click the Preset button, then name the Preset 
when prompted. 

Texture/Vertex bakeset presets created using the override option are 
accessible through the Presets button in the Attribute Editor for vertex 
and texture bakesets.

Texture Bake Set attributes

We’ve added two attributes for texture bake sets.

• The Bake to One Map option allows you to bake several objects 
into one lightmap file. 

• The Keep Original Shading Network option allows you to 
preserve the existing shaders on objects, but create the resulting 
lightmap file to disk. 

Vertex Bake Set attributes

We’ve made some changes to the Vertex Bake Set attributes:

• The Shared Vertices and Alpha Mode attributes have been 
removed from the Vertex Bake Set Attribute Editor. 

• Two new attributes have been added to the Vertex Color Filtering 
section of the Vertex Bake Set Attribute Editor. These attributes 
are: 

Filter Size

Set the Filter Size value to -1 to turn filtering off. Set the value to 0 or 
higher to turn it on. 

If final gathering is baked to vertices and the scene contains high 
frequency information, discontinuities in the color channel may 
become visible. This artifact becomes especially apparent if low final 
gather quality settings are used. Filtering baked vertex colors then 
yields the desired smooth look. Provide a small positive filter size as 
argument to this parameter (it is multiplied by the object's bounding 
box size to obtain the absolute size).

Note The override options are the same as those in the initial vertex 
bake set or the initial texture bake set. 
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Lower final gather quality settings require larger filter sizes to get a 
smooth look and renders are less accurate. In general, the final gather 
quality should be raised as long as rendering times are acceptable; 
then the filter size should be increased until the desired smooth look 
is obtained. A tiny filter size may suffice; it enforces that baked colors 
are shared at vertices that have identical positions and normals. The 
default is no filtering. 

Filter Normal Tolerance

The filter normal tolerance is in degrees (0 to 180). Vertices whose 
normals subtend an angle larger than this tolerance with the current 
vertex's normal are not considered for filtering. This avoids undesired 
color bleed across hard edges. The default is 0.

Vertex baking

After vertex baking, baked objects are displayed as color in shaded 
emission mode so that users can see the result of the bake. 

Baking performance

We have improved baking performance by baking multiple objects in 
one command. As a result, scene translation, photon emission and 
final gather computation is done once per baking process. Baking uses 
multiple processes if the machine has more than one CPU. 

API

The following lists new release notes or additional information you 
should know about using API in Maya 5.0.1. 

Accessing the current file name

The Maya API now supports accessing the current file name in the 
following messages:  

• pre-open

• pre-save

• pre-import

• pre-export

• pre-reference

The new methods in the MFileIO class are:

static MString beforeOpenFilename(MStatus * ReturnStatus = NULL);
static MString beforeImportFilename(MStatus * ReturnStatus = NULL);
static MString beforeSaveFilename(MStatus * ReturnStatus = NULL);
static MString beforeExportFilename(MStatus * ReturnStatus = NULL);
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static MString beforeReferenceFilename(MStatus * ReturnStatus = NULL);

A sample plug-in fileIOMsgCmd.cpp is included in the devkit that 
demonstrates this functionality.

Building a Maya plugin on Linux

Plugins may need to be compiled with the -Wl, -Bsymbolic linker 
option on Linux.

Online Help

The following lists additional information you should know about 
viewing online documentation in Maya 5.0.1. 

Help on Fur attractors and polygons

As of Maya 5.0 you can attach attractors to polygons. However in the 
online help it erroneously states that Maya’s attractors only work with 
NURBS. Specifically, the erroneous text is found under the following 
topics:

• Move attractors by connecting forces to attractor particles

• Move attractors by moving the surface they are attached to

Troubleshooting the help server

This information is also available in Maya if you select Help > If Help 
doesn’t work. 

What if I can't start the help server service on Windows unless 
I'm an Administrator?

This is a known issue with Windows. Refer to the following Microsoft 
knowledge base articles for information on how to fix this.

support.microsoft.com/?kbid=256299

support.microsoft.com/default.aspx?scid=kb;EN-US;256345

What if my browser complains that “localhost” is not found? 
What if the server seems to be running but I can't load any 
pages from it?

This can happen if your computer is behind a proxy server.

Make sure the proxy configuration for your browser knows that you 
shouldn't be going through the proxy to access “localhost”.

• On Mac OS X, open the System Preferences and click Network, 
click the Proxy tab and enter localhost in the Bypass proxy 
settings box.
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• In Netscape, select Edit > preferences and click Advanced and 
then Proxies.

• In Internet Explorer, select Tools > Internet Options, click 
Connections and then LAN Settings.

You can also try using your computer’s DNS name or IP address 
instead of localhost. In Maya, select Window > Settings/Preferences > 
Preferences and click Misc. Set Help Location to Remote and enter 
http://<your computer’s name or IP address>:4444/Maya5.0/

en_US/.

What if I can’t view help from the help server? What if the Web 
server won't start?

There are a few conditions that may prevent the help server from 
starting:

• This may happen if another network service on your machine has 
already claimed port 4444. You can make the Maya help server 
use a different port number by editing docs/port.txt under the 
main Maya folder.

• This can also happen if another copy of the Maya help server is 
still running on the port. Try opening a page from the server in a 
browser (for example http://localhost:4444/Maya5.0/en_US/) 
to see if this is the case.

• On Windows the Maya help server runs as a network service, and 
Maya uses the net start and net stop commands to control it. 
It is possible for Windows to be misconfigured to the point where 
these commands are not available on the command line. To test 
this, open a command window and type net start 
AWHelpServer. If the computer responds that the net command is 
not a command, you need to fix your system paths to include the 
directory with the net command.

• On Mac OS X, IRIX, or Linux, you may get a condition, especially 
after uninstalling and reinstalling, where an old help server is still 
running and unable to serve content. Find the server process in 
the process list (grep for java and/or vertigo) and kill it, then 
restart Maya.

How do I shut down the help server?

You can use any of the following procedures to stop the server:

• When Maya is set to use a local help server, the server should 
shut down when you quit Maya.
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• On Windows, the help server runs as a network service. Go to the 
control panel, double-click Administrative Tools, then open 
Services. Right-click the Alias Wavefront Help Server line and 
select Stop, or open a command window and type net stop 
AWHelpServer.

• On platforms other than Windows, you can shut down the server 
from the server home page. In a browser, go to http://
localhost:4444/ and click the power icon at the bottom of the 
left column.

Viewing the online help without using the help server

Please note before you begin: if you read the help outside the Maya 
help server, search is not available. For this reason you may want to 
consider using a centralized Maya help server instead of moving the 
help onto a different Web server.

The Maya help server reads the online help from inside zip files. In 
order to read the help files directly from the filesystem or from a Web 
server other than the Maya help server, you need to unzip the help 
content.

1 Under the main Maya folder, go to docs/Documents/Maya5.0/en_US. 
This folder contains the online help content.

2 Unzip all the zip files into directories with the same names. For 
example, put the contents of Painting.zip into a directory called 
Painting/

Make sure you don't accidentally create a structure like Painting/
Painting/.

3 Once you have unzipped the files you can move them to a Web server, 
or leave the files where they are if you just want to be able to read 
them directly from the file system without using a server.

4 Open Maya and choose Window > Settings/Preferences > Preferences. 
Click Misc. Under Help Location click Remote and enter the URL of 
the help’s new location (either the URL of the directory on the Web 
server or a file: URL pointing to the docs directory. For example 
file:///usr/aw/maya5.0/docs/Documents/Maya5.0/en_US).
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twist controls
About Advanced Spline IK twist controls

Spline IK handles let you pose a joint chain with a NURBS curve. When 
you manipulate the curve, the handle’s ikSplineSolver rotates the joints in 
the chain accordingly.

With the new Spline IK twist control attributes, you can constrain the local 
rotation of the joints in a chain to a fixed worldspace vector. This vector is 
the orientation of the Spline IK NURBS curve. For example, you can use 
the advanced Spline IK twist controls to stabilize a snake character, the 
spine of a biped character, or the movements of a coil spring. Also, to 
fine-tune the twist along the chain, you can add additional twist to the 
joints with the Twist Value attributes.

By aligning the joints Up axes with a fixed worldspace vector before 
applying additional twist, you can achieve a more predictable and stable 
result than was previously possible.

How do I? Use the advanced Spline IK twist controls

Example scenario

A snake character with Spline IK slithers across the forest floor. The snake 
is manipulated by translating and rotating the NURBS curve. The NURBS 
curve is driven by manipulation objects (in this example, they are locators) 
at the beginning (head) and end (tail) of the curve.

Note The Advanced Twist Control attributes are relevant only if your 
IK handle uses the ikSplineSolver.
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1 Select the snake character’s Spline IK handle.

The Spline IK handle starts at the first joint and ends at the last joint of 
the snake’s skeleton, and its NURBS curve runs through all the joints 
and bones.

2 In the Attribute Editor, go to ikHandle > IK Solver Attributes.

3 Click the Add Advanced Twist Control button.

The advanced Spline IK twist control attributes appear.

4 Set the World Up Type to Object Rotation Up (Start/End) and the Up 
Axis to Positive Y.

This constrains the start and end joint Up vectors of the snakes joints 
to the Y axes of the locators used to drive the NURBS curve.

5 Type the name of the head locator in the World Up Object field and 
the tail locator in the World Up Object 2 field.

The positive Y orientation of the locators is used to calculate the Up 
vectors of the joints in the Snake’s skeleton.

6 Select and move the head locator.

This moves all the joints and bones in the snake’s skeleton. Notice that 
the joints and bones also now respect the orientation of the 
manipulation objects.

Note The Up Axis attribute specifies what local joint axis is aligned 
with the Up Object vectors specified in the Up Vector fields.

Note You can specify a specific vector offset for the joints with the Up 
Vector and Up Vector 2 fields.
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Reference > Spline IK twist controls
Reference Spline IK twist controls

Add Advanced Twist Control Attributes

This button reveals additional attributes for the current Spline IK handle.

Enable Twist Controls

If on, Maya applies an up vector constraint to the local frame of each 
joint in the current Spline IK handle’s joint chain.

World Up Type

Specifies the type of up vector constraint that is applied to the joints in 
the Spline IK handle’s joint chain.

Scene Up Sets the scene’s up direction as the Up vector for all 
joints.

Object Up Sets the Up vector of each joint as the direction from 
the joint to the center of a specified object.

Type the object’s name in the World Up Object field.

Object Up 

(Start/End) Sets the Up vector of the first and last joints as the 
direction from the joints to the center of the 
specified start and end objects.

Type the names of the start and end joint up objects 
in the World Up Object and World Up Object 2 
fields. The results from the start and end of the 
chain are interpolated along the chain to provide up 
vectors for the middle joints.

Object Rotation 

Up Sets a particular vector in the local space of the 
specified object as the Up vector for all joints.

Type the local vectors in the Up Vector fields and 
the object name in the World Up Object field. The 
default Up Vector value is (0,1,0). This means that 
the object’s positive Y axis is used as the Up Vector.

Object Rotation 

Up (Start/End) Sets a particular vector in the local space of the 
specified objects as the Up vector for the start and 
end joints in the current chain.

Type the local vectors and object name for the start 
joint in the Up Vector and World Up Object fields, 
and type the local vectors and object name for the 
end joint in the Up Vector 2 and World Up Object 2 
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fields. The results from the start and end of the 
chain are interpolated along the chain to provide up 
vectors for the middle joints.

 Vector Sets a particular vector in worldspace as the up 
vector for all joints.

Type the worldspace up vectors in the Up Vector 
fields.

Vector (Start/

End) Sets specific vectors in worldspace as the up vectors 
for the start and end joints.

Type the start joint worldspace up vectors in the Up 
Vector fields and the end joint worldspace up 
vectors in the Up Vector 2 fields. The results from 
the start and end of the chain are interpolated along 
the chain to provide up vectors for the middle joints.

 Relative Sets the Spline IK to behave as in previous versions 
of Maya (pre-Maya 5.0.1). The up vector constraint 
is not applied to the joints in the chain.

Up Axis

Specifies which local joint axis is aligned with the worldspace up 
vector. Positive Y axis is the default. 

If you select any of the Closest axes, either the positive or negative axis 
is used at each joint, depending on which is currently closer to the 
worldspace up vector. The Closest option lets you preserve the 
orientation of joint chains whose axes flip every few joints.

Up Vector

When the World Up Type is Object Rotation Up or Object Rotation Up 
(Start/End), the values in these fields specify vectors in the local space 
of the specified up objects. 

When the World Up Type is Vector or Vector (Start/End), the values 
in these fields specify worldspace world vectors.

The Up Vector fields are for the start joints, and the Up Vector 2 fields 
are for the end joints.

Note We recommend that you not use Closest for animation, because it 
is prone to cause flipping in the joint chain.
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World Up Object

When the World Up Type is Object Up, Object (Start/End), Object 
Rotation Up, or Object Rotation Up (Start/End), the name in this field 
specifies the object to use for computing the up vector. The name in 
this field connects the worldspace matrix of the transform with the IK 
handle.

The World Up Object field is for the start joint, and the World Up 
Object 2 field is for the end joint.

Twist Value Type

Set how the additional, user-defined twist is distributed along the 
joint chain.

Total Applies an additional amount of twist to the end 
joint in the chain. Twist is measured in degrees.

Twist values for the remaining joints are 
interpolated from 0 at the start joint. The type of 
interpolation used is determined by the Twist Type 
attribute.

Start/End Applies an additional amount of twist to the start 
and end joints in the chain. Twist is measured in 
degrees.

Twist values for the remaining joints are 
interpolated using the interpolation type specified 
by the Twist Type attribute.

Ramp Connects a texture to the Twist Ramp attribute to 
provide explicit twist values for the entire chain. 
Twist is measured in degrees.

Each joint is assigned a UV texture coordinate of 
(0,j/N), where j is the joint index in the chain and N 
is the number of joints in the chain. The alpha value 
returned by the texture is multiplied by the value of 
the Twist Ramp Multiplier attribute to produce the 
twist for each joint. 

Start/End Twist

Specifies the twist values for the start and end joints of the chain. 
These fields are available only when Twist Value Type is set to Start/
End.

Twist Ramp

Specifies twist along the chain by connecting to a texture. This field is 
available only when Twist Value Type is set to Texture.
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Twist Ramp Multiplier

Since textures generally return values in the [0, 1] range, this 
multiplier ensures that the twist values are mapped using an 
appropriate range. This field is available only when Twist Value Type 
is set to Texture.

Note The Twist Value attributes work well with the Roll and Root 
Twist Mode attributes, and do not interfere with or supersede 
their functionality.
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How do I? Use Fluids cache performance 
enhancements

Control the creation of temporary fluids cache 
files

Fluid caches are disk files with the extension .mcfp that are stored in your 
project's data directory. By default, when you open a scene file, Maya 
creates copies of a scene's fluids cache files and places them in your 
system’s temporary file directory. These temporary files are used to store 
any changes to your fluids cache that occur between file saves (File > Save 
Scene). 

In Maya 5.0.1, you can use the new Copy Locally attribute to turn off the 
creation of these local copies for any fluids playback cache file. This is 
useful if you are low on disk space or are using a network for distributed 
rendering. The Copy Locally attribute is a dynamic attribute that is 
automatically added to the diskCache node when you create your cache.

To turn off the creation of local temporary fluids cache files

1 Save your scene.

2 Select the cached fluid in your scene and open the Attribute Editor.

3 In the Cache_fluidShapen tab, expand the Extra Attributes section.

4 Turn off Copy Locally.

5 Save your scene once again.

Now when you open your scene, Maya does not copy your fluids cache to 
the temporary directory, and when you save your scene, Maya does not 
copy your fluids cache from the temporary directory to the permanent 
location.

Note You can use the diskCache -tmp MEL command to determine 
the location of your temporary disk cache files.

Warning When the Copy Locally attribute is off, you cannot append or 
truncate your fluids cache.
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To add the Copy Locally attribute to a pre-Maya 5.0.1 
diskCache node

You need to add the diskCache node to pre-Maya 5.0.1 scenes if you want 
to control the temporary caches files for your fluids animation.

1 Select your fluid.

2 In the Attribute Editor, select the Cache_fluidShapen tab and click 
Select.

Only the diskCache node now appears in the Attribute Editor.

3 From the Attribute Editor’s menu bar, select Attributes > 
Add Attributes.

The Add Attribute window appears.

4 In the New tab, type ‘copyLocally’ in Attribute Name field.

5 Turn off the Make Attribute Keyable option.

6 Set the Data Type to Boolean.

7 Click OK.

The copyLocally attribute appears in the Extra Attributes section of 
the diskCache node and the Add Attribute window closes.

Segment the fluids cache

The size of a fluids cache file depends on the resolution of the fluid being 
cached and the properties (density, velocity, and so on) stored in the 
cache. Some systems impose a limit on the maximum size a file can have, 
and large fluid caches can sometimes exceed this limit.

In Maya 5.0.1, we have included an unsupported script that lets you 
segment fluids caches. With this script, you can create a fluids cache that 
has multiple segments or chunks, where each segment contains a specified 
number of frames.

Warning • This feature is unsupported. Use at your own risk.

• Using segmented caches can affect playback 
performance.

Note • When segmenting a fluid, no local temporary copies of the 
fluid are placed in your temp directory.

• Fluids cache segmenting does not work if the diskCache 
node’s Copy Locally attribute is on.
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Example

For a fluids cache for frames 1 to 100 with a segment size of 30 frames, 
Create Cache Segment creates four different fluids cache files. Each 
segment is named according to the following naming scheme: 

   segmentPrefix%N_fluidShapeName__%F.mcfp

Where %N is the uniqueness identifier for segmentPrefix chosen by the 
system to guarantee unique file names among all diskCache nodes in the 
file scene and %F is the start frame for data in the cache file.

If the 100 frame cache in this example has a segment naming prefix of joe, 
the segmented fluids cache files might be named: 

   joe1_fluidShape12_1.mcfp     (frames  1-30)
   joe1_fluidShape12_31.mcfp    (frames 31-60)
   joe1_fluidShape12_61.mcfp    (frames 61-90)
   joe1_fluidShape12_91.mcfp    (frames 91-100)

To segment a fluids cache

1 Open your Maya.env file and add the following line:

MAYA_SCRIPT_PATH = $MAYA_LOCATION/scripts/unsupported

This adds the unsupported script directory to your Maya script path.

If you already have a line in your Maya.env file that defines the 
MAYA_SCRIPT_PATH variable, then just add a path separator such 
as ‘:’ or ‘;’ and the value:

$MAYA_LOCATION/scripts/unsupported

to the end of the existing line.

2 Save and close your Maya.env file.

3 If Maya is running, restart Maya.

4 Open the scene that contains your fluid, and then select the fluid.

5 In the Script Editor, type:

performFluidsDiskCacheSegment 1

and press Enter on the number pad. 

The Create Cache Segment Options window appears.

6 Create moderately sized cache segments (for example, cache segments 
of 50 frames each) for your fluids animation by setting the options. See 
”Create Cache Segment Options window” on page 56.

Hint You can drag this command from the Script Editor to the Shelf 
for easy access.
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7 Do one of the following:

• Click Create to segment your cache using the current cache 
segment settings. The Create Cache Segment Options window 
closes.

• Click Apply to segment your cache using the current cache 
segment settings. The Create Cache Segment Options window 
remains open.

• Click Close to close the Create Cache Segment Options window.

Maya caches your fluid in segments and adds the Segment Start 
Frame attribute to the Extra Attributes section of the 
Cache_fluidShapen tab.

8 Save your Maya scene.

To change your cache’s settings when creating a segmented 
cache

In addition to the options available from the Create Cache Segment 
Options window, you can also set the options that affect the segmented 
fluids cache from the Create Cache Options window. 

1 Select your fluid.

2 Open the Create Cache Options window and modify the settings.

3 Select Edit > Save Settings from the window and click Close.

4 Now use the Create Cache Segment Options window to create a 
segmented cache for your fluid. See ”To segment a fluids cache” on 
page 55.

Create Cache Segment Options window

Segment Prefix

Specifies the naming prefix for the cache segments. 

A unique identifier is automatically appended to the specified prefix.

Cache Start/End

Sets the Start and End frames that define the time range of the cache 
that is segmented.

Segment Size

Sets the number of frames per segment.

Limitations

• The segmentation of fluids caches is only available for caches created 
in Maya 5.0.1.
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• You can only segment a fluids cache when the Copy Locally attribute 
is off. See ”Control the creation of temporary fluids cache files” on 
page 53. This also means that you cannot edit (for example, truncate 
or append) segmented fluids caches.

• The segment size per fluids cache is fixed. Each fluids cache segment 
can only have the same number of frames.

Advanced fluids cache segmenting

When you create a segmented cache for a fluid, the Segment Start Frame 
attribute (segmentStartFrame) is placed in the Extra Attributes section of 
the diskCache node. This attribute connects to an expression node called 
%N_currentSegment, which uses an animation curve to determine the 
appropriate segmentStartFrame value for the disk cache at the current 
time. This attribute cannot be modified. For more information, see 
”Example” on page 55.

For example, in the ‘Segment the fluids cache’ example, 
segmentStartFrame has a value of 1 at frame 10 because the first cache 
segment contains the cache information for frame 10, and 
segmentStartFrame has a value of 61 at frame 75 because the third cache 
segment contains the cache information for frame 75.

When you have a segmented cache, you cannot assign a different cache to 
your fluid because the Browse button for the Cache File Name attribute is 
disabled. Instead, you can modify the expression to swap in new cache 
files.

To swap in new segmented cache files for a fluid

1 Modify the naming prefix in the %N_currentSegment expression.

2 Open the Expression Editor for the expression node that drives the 
diskCache node's segmentStartFrame attribute.

3 Change the prefix of the expression to the prefix of the segmented 
caches you want to assign to your fluid and click Create.

The Expression Editor closes and Maya now correctly swaps in the 
new segmented cache files.

Note • When swapping segmented caches, replace only the 
expression’s original prefix (for example, bob), not the 
prefix-with-uniqueID (bob1).

• You can only swap-in caches that were created using the 
same Create Cache Segment options and the same fluids 
resolution.
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For the ‘Segment the fluids cache’ example, you can view the simulation 
of the bob segmented caches by replacing the joe prefix of the 
joe1_fluidShape expression with ‘bob’. The segmented fluids cache files 
would then be named:

    bob1_fluidShape12_1.mcfp     (frames  1-30)
    bob1_fluidShape12_31.mcfp    (frames 31-60)
    bob1_fluidShape12_61.mcfp    (frames 61-90)
    bob1_fluidShape12_91.mcfp    (frames 91-100) 

What 
went 
wrong?

Troubleshooting the Fluids cache

Maya cannot read the fluids cache

The following sections apply to both playback and initial state fluids 
caches.

There is not enough space in your temp directory

Maya cannot read the cache for the current fluid because your default 
temp directory does not have enough space. You can either make space on 
the drive where your temp directory is located, or you can change the 
path of your temp directory by editing your TEMP environment variable 
definition.

The default temp directories are:

(Windows)   username\Local Settings\Temp

(Mac OS X) /Users/username/Documents/temp

(IRIX and Linux) /usr/tmp

To make space in your temp directory

1 Browse to your temp directory.

2 Delete any nonessential files to free-up space on the disk where the 
directory is located.

3 Check that there is now enough space in your temp directory for your 
fluids cache.

Note If your temp directory is set to something other than the default, 
you can still locate your temporary disk cache files using the 
diskCache -tmp MEL command. 
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access
To change the temp directory folder

1 Do one of the following:

(Windows) Open the Control Panel and select System > Advanced > 
Environment Variables. Select TEMP from the list of user 
(not system) variables and click Edit. Enter a new system 
path for the TEMP environment variable and click OK.

(Mac OS X) In the Maya.env file, type TEMP = path to define a new 
path for your temp directory. Save and close the 
Maya.env file.

(IRIX and Linux) In a UNIX shell type: setenv TMPDIR path and press 
Enter. path is the new path for the temp folder.

2 If Maya is running, restart Maya.

To turn off the creation of temporary cache files

See ”To turn off the creation of local temporary fluids cache files” on 
page 53.

The fluids cache is on a remote network drive that 
you are unable to access

Maya cannot read the current fluid’s cache because the cache is located on 
a remote network drive that does not have shared permissions. If this 
occurs, you need to make the file available again.

Maya cannot find the current fluids cache

When a Maya file and a fluids cache are copied to a new location, the path 
from the Maya file to its fluids cache may break. If this occurs, you need to 
re-establish the connection between the fluid and its cache.

To re-establish the link between the fluid and its cache data

1 Open your Maya file, select the fluid whose cache cannot be found, 
and then open the Attribute Editor.

2 In the Attribute Editor, select the cache or initial state node.

3 Click the folder button next to the Cache File Name field to browse 
(locally or over the network) for the current fluid’s cache.

4 Select the cache and click Assign to re-establish the connection 
between the current fluid and its cache.
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Maya is unable to create a playback cache for 
the current fluid

There is not enough space on the specified disk

The temp folder that you have designated as the destination for your 
fluids playback cache is on a disk that does not have enough space for the 
cache data.

To make more space on the disk

• Delete any unnecessary or non-essential files from the temp folder’s 
disk to free-up space for the fluids playback cache.

• Change the destination of the fluids playback cache data. For example, 
you can specify a new temp folder on a different disk as the 
destination for the fluids playback cache.

To turn off the creation of local temp fluids cache files

See ”Control the creation of temporary fluids cache files” on page 53.

When saving fluids caches on Windows or Linux 
systems, the resulting files are incomplete or contain 
blank frames. 

The size of the cache file cannot exceed 2 gigabytes (GB). Cache files larger 
than 2GB will fail to write out completely. When saving a fluids cache file, 
Maya writes out up to the 2GB limit and then ignores the rest of the cache. 
You can work around this limitation by creating your fluids cache as 
segments (for example, 500MB mini caches). Each cache segment can then 
be rendered separately. To segment your fluids cache, see ”Segment the 
fluids cache” on page 54.
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About Improvements to the UV Texture Editor

We’ve added an alternative display option in the UV Texture Editor to 
provide a workaround for some resolution and cropping limitations in the 
texture display. 

There are two options for displaying a texture in the UV Texture Editor.

• Texture Image Display - This is the display option the UV Texture 
Editor has always used. Click the Display Image button or select 
Image > Display Image to switch to Texture Image Display. 

• Editor Image Display - This is a new display option in the UV Texture 
Editor. Click the Editor Image button or select Image > Editor Image > 
Display to switch to Editor Image Display. 

How do I? Use Editor Image Display

Use Editor Image Display if you are experiencing resolution and cropping 
limitations in the Texture Image Display. With Editor Image Display, you 
can make changes and bake a texture to disk, and then reload it as a 
background image in the UV Texture Editor. 

Click the Editor Image  button or select Image > Editor Image > 
Display to turn on the Editor Image Display. 

When you select an object or a component, Editor Image Display will 
attempt to load a previously baked file texture; if one does not exist the 
following error will be printed:

// Error: fileNodeName has not been baked for object: 
fullPathToSelection and UV set: currentUVSet. //

To bake a texture to disk 

1 Select the textured object or component in the modeling view.
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2 In the UV Texture Editor click the Bake  button or select Image > 
Editor Image > Bake. 

An IFF image file is baked to disk using the convertSolidTx MEL 
command. 

The baked file is an accurate representation of the texture based on the 
current Texture Editor UV Range, any resolution, size, repeat, or 
coverage attributes on the file or procedural texture node, and all 
attributes of the related place2dTexture node if one exists. 

This file will be named according to the following template:

fileNodeName_SelectedObject_currentUVSet.iff

If there is no 'textureWindow' directory present in the sourceimages 
subdirectory of the active project, one will be created and the file 
texture will be placed inside.

The following is an example path:

C:/Documents and Settings/currentUser/My Documents/maya/projects/default/
sourceimages/textureWindow/file3_pPlane1_map1.iff

Reference Limitations

Rebaking

Each time you make a change to the texture (File node and place2dTexture 
node attributes), you have to rebake it. There isn’t any notification when a 
baked image becomes out of date. Whenever you bake a texture (click the 
Bake  button or select Image > Editor Image > Bake) a complete list of 
these of attributes is printed to the Script Editor. 

File texture size

Changes to the UV Range, Repeat, and Coverage attributes directly affect 
the size of the file texture. Therefore a baked file can become quite large. 
Consider a 256x256 texture that is repeated twice in U and V, and 
displayed over a UV range width of 2 and height of 3. The baked file will 
be a 1024x1536 image (4*256x6*256). In addition, baking a file of this size 
may be slow.

Due to physical memory limitations and memory fragmentation issues on 
certain operating systems, Maya may not be able to bake an image file of 
the requested size. To address this, the user can set upper bounds on the 
image resolution by selecting Image > Editor Image > Bake > . To 
guarantee successful behavior, the recommended upper limits are 2048 by 
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2048. Additionally, if Maya detects a shortage of memory resources it may 
further reduce the resolution of the baked image beyond the limits set by 
the user. 

UV Range

In the UV Texture Editor, changes to the UV Range affect all textures. 
However, in the Editor Image Display the UV Range is saved at the time 
of baking and when an image is loaded its UV Range is restored. 

To revert back to the UV Range values in effect before the Editor Image 
was loaded, open the Image Range Options window and click Apply and 
Close.

Objects and components

Object level selection and component level selection require separate 
bakes. If you select a textured object and bake, and then select a 
component of the textured object, such as a face or a series of UVs, you 
may get an error message notifying you that you need to bake the texture. 
To prevent this error you will need to bake a total of two times for any 
object: once with an object level selection and once with a component level 
selection.

Pixel Snapping and Preserve Image Ratio

Pixel snapping works on the Editor Image for both square and non-square 
textures; Preserve Image Ratio does not. Preserve Image Ratio is ignored 
when in the Editor Image Display.

Multiple selections

When a selection includes more than one textured object or component 
the Texture Image Display and Editor Image Display may differ in which 
selection item’s texture is displayed.
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