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1 THE BIG PICTURE

In its 3.0 release, Maya achieves best-of-class status as the premiere tool for
next-generation game development and the most powerful solution for
digital content creation.

Maya 3 provides numerous user interface and workflow improvements
throughout, making it even easier to learn and use.

What’s New in Maya 3 provides complete information on all the features
we’ve added in this release.

To help you decide what to look at first, we’ve summarized a few of the
highlights:

Stuart Little image
courtesy of Sony
Pictures
Imageworks.
Columbia/TriStar. All
rights reserved.
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What’s New in all Maya packages

Features common to Maya Builder, Complete, and Unlimited include:

• Cleaner interface—better use of space and quick access to items often used

• Trax nonlinear animation editor—a new way to mix animation sequences
with total control over motion blending

• Dense data editing and resampling—now you can use and manipulate
motion capture data more easily

• Improved animation—path animation and deformer refinements

• Improved polygonal architecture—new nonmanifold polygonal architecture

What’s New in Maya Builder

Maya Builder is our basic modeling, texturing, and animation package,
created especially for level designers and tool builders. Some of the
enhancements we’ve added to Maya Builder 3 include:

• Multiple UV per vertex support— you can apply multiple textures for a
variety of uses in games engines

• UV auto projection and relaxation—improves workflow for creative
texturing, especially larger models with more than 100 polygons

• Bezier improvements—The new Bezier surface editor and output as Bezier
has been added to a large number of surfacing operations. It provides full
access to curved surface representation for use in next-generation games.

Games-related features will also be supported in the new Maya Real Time
SDK, making it part of an integrated toolset that supports the “Art to
Engine” workflow for game developers. This integrated approach allows
games artists and programmers to work cooperatively in one unified
architecture to create and deliver cinematic quality for next-generation
games.

What’s New in Maya Complete

Maya Complete is Alias|Wavefront’s award-winning 3D modeling,
rendering, animation, and paint software. Maya Complete provides a full
range of dynamics, character setup, rendering, and effects software—
everything professional digital content creators need to produce world-class
animation and digital effects.
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Our new Universal Rendering policy provides all customers with unlimited
rendering. One floating license lets you render on up to 10,000 supported
platforms.

Maya Complete 3 includes all the enhancements listed for Maya Builder 3, as
well as:

• Global stitch—for Maya 3, we’ve moved this feature from Maya Unlimited
to help Maya Complete users address skinning problems

• Artisan Paint Textures—you can now use the Artisan brush to paint color,
bump, transparency and other renderable channels directly onto NURBS,
and polygonal models

• Instanced Paint Effects brushes on particles—you can instance Paint Effects
brushes on individual particles to generate a vast range of software-rendered
dynamics effects

• Displacement mapping—a totally new technique that delivers new levels of
speed of quality fully comparable with the best available anywhere

• Area lighting—greatly increases the subtlety, realism, and sophistication of
Maya lighting effects

• Multi-threaded interactive software rendering and shadow map
generation—just two of the many performance improvements for the Maya
renderer

• Faster raytracing—substantial performance increases

• New Layered Texture node—provides fast layering of multiple images
making realistic rendered textures easier and more efficient to design

• Render layer management—separates user-specified elements in a sequence
into different image layers to integrate Maya more tightly into the
compositing process

• Render pass management—greater flexibility for compositors to manipulate
the fine details of any sequence after final rendering is completed

• Improvements to cloud volume shader—provides substantial
improvements to the look and quality of particle rendering

• New Gas/Cloud turbulence—now it’s easier to generate realistic cloud and
gas motion effects with new turbulence, time random, and noise controls

• Volume particle controls and emitters—intuitive control of particles makes
dynamics easier to set up by the non-specialist
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• Particle disk caching and scrubbing—for accurate multi-processor
rendering of particle effects

What’s New in Maya Unlimited

Maya Unlimited is the most powerful software available for creating
computer-generated animation and special effects. It provides precision
matchmoving, digital cloth simulation, advanced modeling capabilities, and
realistic styling and rendering of hair and fur.

The major focus of Maya Unlimited completes the full subdivision surface
pipeline from modeling right through animation to final rendering.

In Maya Unlimited 3, we’ve added the features listed for other Maya
software, as well as:

• Integration of subdivision surfaces with hierarchical deformers/animation
tools—Subdivision surfaces are now fully equal citizens to NURBS and
polygons inside of Maya

• Subdivison hierarchy navigation and editing—lets you work at different
levels of detail

• Full and partial creasing—makes it easier to construct both rounded organic
forms and hard-edged objects

• Subdivision surface texturing and rendering—eliminates requirement to
convert subdivision surfaces to polygons before texturing and rendering in
many cases

• Artisan cloth property painting—naturalistic assignment of cloth properties
such as stretch or stiffness

• Maya Live tracker enhancements—blur before tracking eliminates film
grain and noise, allowing the tracker to more easily lock onto the target

• Enhancements in Fur offer increased efficiency and quality—Global Scale
per Fur Description, Area Value per Fur Description, Roll parameter,
separate shadow passes, new shadow map controls. Fur is both more stable
and easier to manipulate.
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2 BASIC FEATURES

We’ve made the following enhancements to the user interface and basic tools
in Maya 3.0.

Interface improvements

• “Layout improvements” on page 6

• “Menu changes” on page 9

• “Command option box improvements” on page 14

New features

• “New Isolate Select view” on page 15

• “New Import for Adobe Illustrator® and EPS files” on page 17

• “New Artisan Paint Textures tool” on page 18

• “New Preferences” on page 18

• “New Color Chooser features” on page 21

Improvements to existing functionality

• “Hotkey improvements” on page 23

• “Outliner and other editor improvements” on page 28

• “Project management improvements” on page 30

• “Basic modeling improvements” on page 31

• “File referencing improvements” on page 34

• “Add, Delete, and Rename custom attributes” on page 35
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Layout improvements

LAYOUT IMPROVEMENTS

The following illustration summarizes the various improvements we’ve
made to the Maya layout. In general, the improvements make better use of
space and give you quick access to items often used.

Button added
to show and
hide range
slider

See “Status
Line
changes”

See “Shelf
changes”

Buttons added to shorten or
widen the Channel box

See “Layer
bar changes”

Note:
Feedback line
removed (use
the Help line
instead)
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Status Line changes
To save space, the Status Line is now smaller in height. It also contains more
buttons that are commonly used. The following illustration summarizes
these improvements.

For better organization, the buttons are divided into groups that you can
expand and collapse, as shown in the following illustration.

Numeric Input field
The Numeric Input field has been moved to the right side of the Status Line.
Previously, it was on the Feedback line, which was removed.

There are also new capabilities in this field.

Quick Selection In this mode, you can type the name of objects or nodes in order to quickly
select them. Using wildcard characters (* and ?), you can select several items
with the same string in their names.

Quick Rename In this mode, you can type a new name for the selected object.

Buttons added to Create New,
Open, and Save scene

Buttons added for
Render and IPR Rende

Lock button
moved here

Click the expanded bar to collapse buttons

Click the arrow bar to expand buttons

Numeric Input field
moved to Status Line

New options from
pull-down menu
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Shelf changes
The Shelf tabs are no longer displayed; they are replaced by a button (but
you can display the tabs if you prefer them). The following illustration
summarizes these improvements.

Layer Bar changes
The Layer Bar now indicates whether a display layer is set to invisible,
template, or reference. The layer swatch is marked X if Visible is off, T if
Template is on, or R if Reference is on.

We also added pop-up commands when you right-click on the Create Layer
button.

Make New Layers Current

This is a new setting. When it is on, you can add a new layer and Maya
makes it the current layer. When this setting is off, the default layer or last
layer selected remains current.

Use Current Layer This setting was moved from the preferences. When it is on, objects you
create will be automatically assigned to the current layer. When it is off, you
must assign new objects to a layer.

Render layers

Maya 3.0 introduces a workflow enhancement called render layers. While
display layers are used to quickly select and hide groups of objects, render
layers are used to render objects in separate passes.

Button added to switch between shelves
instead of tabs. (If you prefer tabs, turn on
the new Shelf Tabs option.)

Pull down menu added for
shelf-related options
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You set up render layers from the Layer Bar. A new pull-down lets you
switch between Display Layers and Render Layers. The Layer Bar works the
same for render layers as display layers; see Using Maya: Essentials for
details.

Once you have render layers set up, you can take advantage of the Render
Layer/Pass Control settings in the Render Globals. For more information on
these settings, see “Render Layer management” in Chapter 9.

MENU CHANGES

We reorganized and simplified several menus. This section lists the
organizational changes and also lists some new menu selections that were
added as part of new features.

New Find Menu feature
To find the location of any menu item, choose Help > Find Menu and type
the menu name you want to find. The search is not case-sensitive. It accepts
wildcard characters (*), but if the menu was renamed or removed, type the
name in full.

Edit menu
We removed the Create New Display Layer menu item. You can still create
layers from the Layer Editor or the Layer Relationship Editor, or by clicking

on the Layer Bar.
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Menu changes

Modify menu
We moved Paint Selection Tool to Edit > Paint Selection Tool.

We moved the Measure submenu to Create > Measure Tools. The measure
tools are Distance, Parameter, and Arc Length.

There are also new selections: Delete Attributes and Rename Attributes.
Along with Add Attributes, these selections make it easier to create and
modify custom (or dynamic) attributes. (They are also available from the
Attribute Editor > Attributes menu.)

Display menu
The Display menu has a number of new submenus. The following
illustration summarizes these changes.

Heads Up Display submenu

This submenu includes the View Axis and Origin Axis options (previously
under the Display > Axis submenu), as well as other display options:

Added this submenu
(Replaces Axes submenu)Moved checkboxes

from Options menu
to this submenu

Separated Object
Components
submenu into these
two submenus
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• Poly Count is moved here from its previous location, Polygons > Display
Poly Count. It shows polygon statistics for the visible objects displayed in
the view panel. This feature is useful for games development.

• Frame Rate is a new command. It displays the frame rate in Hertz for the
current port.

UI Elements submenu

The UI Elements submenu contains the checkboxes from the Options menu,
which is now removed. See “Options menu” on page 13 for details. The last
two items on this submenu were also on the Options menu, but are
renamed.

• Hide UI Elements: Temporarily hides all UI elements except the workspace
panels. For example, you can maximize the scene view while working on
detailed models. Was Options > Show Only Viewing Panes.

• Restore UI Elements: Displays the UI elements that were hidden. Was
Options > Show All Panes.

Object Display and Component Display submenus

We separated the Display > Object Components submenu into two
submenus:

• Display > Object Display: contains controls for displaying object templates,
geometry, and bounding boxes.

• Display > Component Display: contains controls for all other component
display.

The Object Display submenu also contains a new option, Untemplate. For
more information, see “Object templates” on page 32.
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Window menu
The following illustration lists the Window menu changes.

Settings/Preferences submenu
We combined selections relating to preferences under one submenu. See the
following illustration for a summary. For more information on the new
Preferences window, see “Preferences window” on page 18.

Various preferences
combined here. See
next topic

Added Texture View for
polygonal modeling

Added Trax Editor

Added Raise Main
Window

Recent Commands
moved to Edit menu

Layer Editor
moved under
General Editors

Expression Editor
moved under
Animation Editors
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Options menu
We removed the Options menu. Most of the items on this menu are now
under the Window and Display menus. The following illustration lists the
new locations.

Were under Options >
Customize UI submenu

Were under Window >
General Editors

New window. Combines
settings from Options >
General Preferences and
Options > UI Preferences

Moved to
Display >
UI Elements
menu

Moved to Window >
Settings/Preferences
submenu

Moved to
File > Save
Preferences

Moved to Display >
UI Elements >
Restore UI Elements

Moved to Display >
UI Elements >
Hide UI Elements
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Command option box improvements

Lights and Shading menus
The Lights and Shading menus under the Render menu set are now
combined and labeled Lights/Shading.

Also, based on customer requests, we moved the light creation options from
the Lights menu to the Create > Lights submenu.

Polygon menus
The Polygon and Edit Polygons menus have been reorganized for ease of
use. See Chapter 4, “Polygonal Modeling” for details.

Dynamics menus
The Fields menu is simplified, the Connect/Add menu items are relocated to
more appropriate places, and various other menu items have been renamed.
See Chapter 8, “Dynamics” for details.

Subdivision surfaces menus
Both the Subdiv Surfaces menu and marking menu for selected subdivision
surfaces have been reorganized. See Chapter 5, “Subdivision Surfaces
Modeling” for details.

COMMAND OPTION BOX IMPROVEMENTS

We redesigned the buttons on the bottom of command option boxes, such as
Edit > Duplicate ❒. (Tool option boxes are not changed.)

Now you can either apply your settings and close the option box in one step,
or apply your settings first, check that they’re correct, and then close the
option box. The following illustration summarizes these changes.



BASIC FEATURES | 2
New Isolate Select view

WHAT’S NEW IN MAYA 3

15

NEW ISOLATE SELECT VIEW

Use the Isolate Select feature (Show > Isolate Select > View Selected) to
quickly isolate objects or components in a view panel. You simply select the
items, choose Show > Isolate Select > View Selected, and all other objects
and components in your scene become hidden.

Unlike the Display > Hide commands, which hide mostly objects, the Isolate
Select feature can also isolate components. For example, by selecting
polygonal faces, you could isolate the head of a model. Another difference is
Isolate Select affects screen display only, while Display > Hide commands
also affect rendering.

Perform the
action and
close the
option box in
one step

Perform the action
but keep the option
box open

Changed the
Save and
Reset buttons
to menu items

Close the
option box
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New Isolate Select view

Isolate Select works on a per-panel basis for any view panel (perspective or
orthographic). The components you can select for isolation are:

• CVs of NURBS surfaces

• faces of a polygon mesh

• faces of a subdivision surface mesh

Other components cannot be selected for isolation, such as NURBS patches,
curve segments, particles, or lattice points. However, you can still see and
manipulate other component types within the items you have isolated.

Use the new Show > Isolate Select menu to control the isolate select feature.
The menu options are described below.

View Selected Activates or deactivates the isolate select feature. When activated, the word
“Isolate” appears at the bottom of the panel and the current selection
becomes isolated.

Tip

Keep open at least one other workspace panel with isolate select turned
off so you can select other items. Also, tearing off the Isolate Select
submenu gives you quick access to these commands.
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Auto Load Selected Objects

Turn on to automatically update the isolate select panel when you change
your selection. If turned off, you must use the Load, Add, or Remove
Selected Objects options to update the panel.

Load Selected Objects
Add Selected Objects
Remove Selected Objects

If you don’t have auto load on, you can use these options to control the
isolate select display. Select items from the isolate panel or another panel
and then load, add, or remove them as needed. Note that Load Selected
Objects replaces the display with the current selection, while Add Selected
Objects adds the current selection to the selections already displaying.

Bookmarks Enables you to bookmark an isolated selection. To create a bookmark, choose
Show > Bookmarks > Bookmark Current Objects. Choose the option box if
you want to name the bookmark; otherwise, a default name is used.

To view bookmarked items, choose Show > Bookmarks > BookmarkName.
Choose it again to turn it off and return to the previous view. You can view
multiple bookmarks at the same time.

Bookmarks are saved with the scene as a set. You can manage them using
the Relationship Editor.

NEW IMPORT FOR ADOBE ILLUSTRATOR® AND EPS FILES

You can now import Illustrator and Encapsulated PostScript (EPS) files into
Maya. With this feature, you can create 3D models based on 2D graphics,
such as text or logos. Maya imports them as NURBS curves, which you can
then group into surfaces, convert to polygons, and so forth.

Support for Illustrator files extends from version 4 up to version 8. Any
versions before 4 or after 8 are not necessarily supported.

How curves are converted

The curves from Illustrator and EPS files are actually Bezier curve segments.
During import, Maya attaches the segments into a single curve. The Curve
Degree is set to 3 (cubic) and the Knot Spacing is set to Multiple End Knots.
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New Artisan Paint Textures tool

To import an Illustrator or EPS file:

1 Choose File > Import.

2 In the file browser, navigate to the Illustrator or EPS file.

3 If needed, click the Options button (NT) or choose Options > Options (IRIX)
to set the following controls.

Scale Factor Allows you to control the scale of the curves produced
from the import. It is the same operation as using the Scale
tool.

Group Turn on this option to group the imported curves. It is the
same operation as using the Edit > Group option.

4 Click Import.

NEW ARTISAN PAINT TEXTURES TOOL

We added a new Artisan paint tool, Paint Textures, that paints the following
texture attributes: color, transparency, incandescence, bump, specular color,
and reflectivity. It is located in the Rendering menu set, Lighting/Shading >
Paint Textures Tool.

This tool operates similar to other Artisan paint tools; however, some tool
settings are unique, such as Blend Mode. For information specific to this
tool, see Chapter 9, “Rendering.”

NEW PREFERENCES

We combined the General Preferences and UI Preferences windows into a
single, streamlined Preferences window. Plus, there are various new
preferences.

Preferences window
Preference settings now have a new window and a new menu location:
Window > Settings/Preferences > Preferences. Previously, preferences were
separated into the General Preferences and UI Preferences windows under
the Options menu.
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The categories listed on the left correspond to the tabs from the previous
preference windows, with a few exceptions. In some cases, such as Display,
the category is further subdivided to make it easier to find settings.

Saving and reverting changes
Your changes to the preferences are now saved automatically when you quit
Maya or when you click the Save button in the Preferences window. If you
need to revert to previous settings, you can use the options under the Edit
menu: Revert to Saved and Restore Factory Settings.

New preference settings
The following preferences are new.

Display category
Region of Effect This new option lets you turn on or off the region of effect display. Region of

effect is the part of an object that will potentially change as a result of
moving a selected CV. Note that curves now show the region of effect as
well as surfaces. Previously, only surfaces showed the region of effect.
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Selection category
Click Box Size This option controls the size of the selection area around the mouse pointer,

or click box. If you are having problems with selecting objects or components,
try adjusting this option. For example, a higher click box size might make it
easier to select curves. Increasing the click box size is also useful if you have
a high resolution screen display.

Snapping category
With these options, you can control the size region around the mouse
pointer that is used for the snap operation.

Use Snap Tolerance When on, the snap region is restricted to a square area around the cursor,
defined by the Snap Tolerance option. When off, the snap region is
unlimited; you can snap to anything viewable.

Snap Tolerance Controls the size of the snapping area around the cursor when Use Snap
Tolerance is on. For example, if you have two curves close together and you
try snapping to one of the curves, the object may snap to the wrong curve.
To avoid this, try using a small Snap Tolerance value.

Region of
Effect on

Region of
Effect off
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NEW COLOR CHOOSER FEATURES

The following illustration summarizes the changes made to the Color
Chooser window, which you open from the Colors window or Attribute
Editor.

Using the alpha slider
With the new A (alpha) slider, you can control the opacity or transparency of
the color you choose. Many Maya options already have an alpha or
transparency control, but if it does not or you are calling the Color Chooser
from the command line, you can use this slider to control the alpha channel.

More cells added
to store colors

To select a color,
left click it. To store
a color, right click it
(or select the tile
and click the arrow
button).

(Eyedropper
added in
Maya 2.5)

Click the arrow
button to expand
or collapse each
section

Blend and Palette
sections added

Alpha channel
slider added
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Using the Blend box
The Blend box creates a blend between colors so that you can select a new
color from the blended gradient. The following illustration explains how to
use it.

Using the Palette
In the Palette section, you can create and save custom color palettes. You can
also open Adobe color palettes (file extension .aco), if it is in one of the
following formats: RGB, HSV, CMYK, Lab, or Inverted Lab. (Other formats,
such as Pantone, are not supported.)

The following illustration highlights the palette components.

To create a custom palette

1 Select a color using any of the Color Chooser tools, such as the Wheel.

2 Right click on any tile to store the current color there.

3 To create a blended gradient, select several tiles by dragging the mouse, then
click Blend.

1. To set a blend color,
click a corner. It’s
replaced with the current
color in memory.

2. Click anywhere
in the blend box
to select a
blended color.

Choose a palette
from the pull-down Click Blend to

create a color
gradient between a
group of cells you
selectedLeft click a cell to

select a color
...or...
right click a cell to
store a color

Open, Save, and
Close palettes
Open, Save, and
Close palettes
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A color gradient is created between the first and last tiles in your selection.
For example, as shown below, you may want more color gradations than in
the default palette.

4 When finished assigning colors, click Save and specify the filename.

You can save the file in any directory. It is saved in ascii format.

HOTKEY IMPROVEMENTS

We improved the usability of the Hotkey Editor, made hotkeys visible on
menu labels, and changed the hotkey file structure to better preserve your
custom hotkey settings.

Warning
Do not copy hotkey preference files from a prior Maya version to the
Maya 3 directory. If you do, your custom changes become lost, because
Maya stores custom hotkeys in a new file and a different format. Simply
start Maya 3 and it will find and convert saved hotkey preferences to the
new Maya 3.0 structure.

Blended tiles
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Hotkey Editor reorganized
The Hotkey Editor is now reorganized to make it easier to use. Also keep in
mind that its new location is Window > Settings/Preferences > Hotkeys.

To assign a hotkey:

1 Choose Window > Settings/Preferences > Hotkeys.

2 Select the category and command.

3 In the Assign New Hotkey area, specify the key combination and other
settings. You can see a list of which keys are unmapped by clicking List All.
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Key Enter the key you want to assign to the selected command.
Enter a letter from A to Z (upper and lower case are
different keys) or a number from 0 to 9. You cannot use
more than one letter or number.

Or, choose a special key from the pull-down list. For
example, if you want the right arrow key to act as the
trigger, assign it here.

Modifier Select either Alt or Ctrl for the hotkey modifier.

Direction Use Press or Release to associate a command with the
press or a release of a key. For example, you can create a
hotkey to instruct Maya to snap to a curve when you press
a key, then turn off the snapping when you release it.

If you added a key to an operation ending with (Press) or
(Release), add the same key to the corresponding (Release)
or (Press) operation.

Repeatable Turn on so that this hotkey is repeatable using the Edit >
Repeat command. Turn off to prevent repeating the
hotkey using Edit > Repeat.

Query Click Query to determine whether the specified key
settings have already been assigned to a command.

Find Clicking Find highlights the category and command for
the key you enter in the Key field.

4 Click Assign.

The new hotkey should appear in the Current Hotkeys list.
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To list keys:

Click List All to view a list of mapped and unmapped keys. This opens a
window that allows you to sort the keys in various ways.

To print the hotkeys list to a file, click Save to File button and specify a
destination directory.

No Modifiers Lists only single hotkeys, without Ctrl or Alt.

Ctrl Lists only hotkeys with a Ctrl + key combination.

Alt Lists only hotkeys with an Alt + key combination.

List All Lists all hotkeys.

Ignore Release Turn on to ignore the hotkeys that activate when you release the key, versus
when you press the key. Turn off to see all hotkeys, including the ones
activated when you release the key.
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To create a new command for hotkey assignment:

1 Click Create.

2 Complete the Name and Description boxes.

These fields are for future reference. They only appear in the Hotkey Editor.

3 Enter or select a category in the Category box.

4 Enter the MEL command into the Command box.

5 Click Accept.

The command should appear under the chosen category. You can now
assign a hotkey to this command.

To search commands:

Click the Search button at the bottom of the Hotkey Editor to perform a
search through all existing commands. For example, you may want to
perform a search if you know part of a command name, but not the category.
Or, if you are creating a new command, you can first search for commands
that are related.

In the Search for Command window, you type a case-sensitive string. The
program searches for that string in the command names and command
syntax. You can use * to represent any character or characters. You can also
use brackets to enclose both capital and lower-case letters.

Hotkeys on menu labels
Hotkeys now display next to main menu labels. (This feature does not apply
to menu labels in the hotbox.)

When you assign a new hotkey to a menu item, the change also appears on
the main menu label.

Hotkeys shown
beside menu
selections
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Custom hotkeys preserved
Maya now saves your custom hotkey preferences so that they do not
interfere with the default Maya hotkey settings. Your preferences will not be
overwritten when you upgrade to the next Maya version.

The new file names containing hotkey preferences are userHotkeys.mel and
userNamedCommands.mel under the prefs directory. If you have hotkey
preferences saved from a previous version of Maya, it will be detected at
startup and converted to the new Maya 3.0 structure.

OUTLINER AND OTHER EDITOR IMPROVEMENTS

Outliner
The following changes affect the Outliner window, as well as the outliner
panes in the Graph Editor, Relationship Editor, and Dope Sheet.

• Hierarchies become highlighted if they are collapsed but contain an item
that is selected.

• As a quick way of expanding several collapsed hierarchies, you can select
them, expand one of them, and they all expand.

• You can now split the Outliner window in order to see either end of a long
list. To split the window, click the separator at the bottom of the window
and drag it up. Restore full display by dragging the separator back to the
bottom. As visual cue, moving your cursor over the separator bar changes it
to: (IRIX) or (Windows NT). (This capability is not available in the
Dope Sheet.)

Drag the
separator bar
to split the
outliner
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Script Editor
• We added the Edit > Clear All command to help remove clutter.

• Pressing Ctrl+Enter now executes commands. Previously, only Enter on the
keypad or Edit > Execute would execute commands.

Component Editor
To make this editor more usable, we markedly improved the performance
and added a slider bar for changing values.

Note
If you undo, redo, or modify components in the workspace, you must click
the Load Components button to refresh to Component Editor display. As
part of the performance improvements, the display no longer updates
automatically for these types of changes. However, it still refreshes when
you change your selection (provided List > Auto Update is on).

New slider bar
for editing
values
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Various editors
The following improvements affect various editors, as noted.

Clearing filter display

When you filter the display in the Outliner, Hypergraph, Graph Editor, or
Relationship Editor, you can now return to a display of all objects by clicking
the filtered display icon ( ).

Edit keys (IRIX only)

Because using the Expression Editor, Script Editor, and other input boxes
can involve text editing, we added support for the following edit keys:

• Ctrl+c: Copy

• Ctrl+x: Cut

• Ctrl+v: Paste

• Ctrl+k: Delete to end of line

• Ctrl+d: Delete next character

• Ctrl+a: Move cursor to beginning of line

• Ctrl+e: Move cursor to end of line

Previously, these edit keys were not supported on IRIX. However, the
Ctrl+c, Ctrl+x, and Ctrl+v keys have always operated on NT. Also, Ctrl+a on
NT selects all the text in the edit box.

PROJECT MANAGEMENT IMPROVEMENTS

• On Windows NT only, the Open and Save windows now display the path of
the current project in the window header.

• In the Set Project window (File > Projects > Set), the default path is now set
to the current project. Previously, the default path was set to a standard
location, which could be completely different from the location you typically
use.

• In the New Project window (File > Project > New), the Location field now
supports browsing. Click the browse button next to the Location field to
open a browse window and select a project directory.
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• The Maya file browser now remembers from session to session the last path
that was accessed.

• You can now set the project from the Open and Save windows.

• When you save or open files on IRIX, you can now use the tilde (~) character
to specify a user home directory, such as ~cbrown.

BASIC MODELING IMPROVEMENTS

This section explains basic modeling features that appear within the
standard menu set (File, Edit, Modify, Display). For more modeling changes,
see Chapter 3, “NURBS Modeling” and Chapter 4, “Polygonal Modeling.”

Reset and Freeze Transformations
The Reset and Freeze Transformations options under the Modify menu now
provide an option box to apply the operation separately for translation,
rotation, or scale. Previously, these operations applied to all three
transformations.

Freezing sets the existing translation, rotation, or scale for selected objects to
be the initial state. The result is that transform values change to zero (or one
for scale), but the object itself remains in place. Resetting, on the other hand,
transforms the object back to the translation, rotation, and scale it was when
created or last frozen.

To freeze an object:

1 Select one or more objects that you have moved, rotated, or resized.

2 Choose Modify > Freeze Transformations ❒.

3 In the option window, turn on or off Translate, Rotate, or Scale, as needed.

4 Click OK.

Enlarging manipulators with + hotkey
Pressing the + key (on the numeric keypad or on the top of the keyboard)
now enlarges the move, rotate, and scale manipulators. Previously, only the
= key would enlarge manipulators.
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Object templates
We changed the menu selection for creating object templates.

• Display > Object Display > Template: Makes an object into a template.

• Display > Object Display > Untemplate: Returns a template object back to
standard display. You must first select the template object through the
Outliner.

Previously, you used one menu selection, Display > Object Components >
Templates, to toggle between these operations.

Display surface origin
We added a new option to display surface origins. The option is: Display >
NURBS Components > Custom > Surface Origins.

Surface Origins is helpful for alignment and placement of the surface. The
command highlights the first U and V isoparms and labels them U and V. It
also draws a line indicating the surface normal direction. The colors used for
Surface Origins are defined in Window > Settings/Preferences > Colors >
Components.

Selection types
For greater selection control, we divided the Edit > Select All by Type >
NURBS Geometry menu item into the following selections:

• Select All by Type > NURBS Curves

• Select All by Type > NURBS Surfaces
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Three Point Snap
In Maya 3.0 you can snap three points (representing a plane) to another
three points. Instead of using the Move and Rotate tools, you can easily
move an object to a specific point by snap aligning the object.

In previous versions, you could only snap a single point to another single
point, or two points to two other points (defining an axis snap).

To snap three points to three points:

1 Select three points on an object.

2 Select three points on the destination object.

Select the points on the destination object in the order you want the snap to
occur. The first point should correspond to the first point selected on other
object, and so on.

3 Select Modify > Snap Align Objects > 3 Points to 3 Points.

Proportional Modification Tool
The Proportional Modification Tool (Modify > Transformation Tools >
Proportional Modification Tool) now rotates, scales, and translates (in
previous versions it only translated).

The manipulator for Proportional Modification is a combination of the move,
rotate, and scale manipulators. Click on the appropriate part of the
manipulator, depending on what type of transformation you want to
perform.

Rotate circle

Move arrow

Scale block
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Repeat Last
The Repeat Last and Recent Commands menu selections now let you repeat
commands invoked from Shelf icons, hotkeys, and option boxes. Note that
both Repeat Last and Recent Commands are relocated under the Edit menu.

Move Normal Tool
The Move Normal tool is now a separate menu item in the Modify >
Transformations Tools menu. In previous versions, Move Normal was only
available as an option in the Move Tool’s option box.

The Move Normal tool orients the manipulator axes along U, V and normal.
The standard move tool’s axes are oriented to the world coordinate axis by
default.

Normals Display Scale
We added an attribute called the Normals Display Scale to change the
display size of NURBS surface normals. The attribute is located in the
NURBS Surface Display section of the surface Attribute Editor.

FILE REFERENCING IMPROVEMENTS

To avoid errors, we improved the way Maya locates files that you specify
with imported objects, textures, MEL scripts, and other file referencing.

Using spaces in filenames
On both Windows and IRIX, Maya now accepts references to files with
spaces in the name.

Missing references fixed
We corrected problems involving missing references. The problem resulted
from the fact Maya stored references to textures and other project data using
a path relative to the project directory. If you referenced another scene file
outside of your project, textures and certain project data in the referenced
file would appear missing.
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Now, Maya saves all file references as full, absolute paths—including files
located below the current project directory. See the next topic for more
information on the way Maya searches for file references.

Search order for referenced files
You can still move your project without risk of references breaking, even
though Maya stores references as full paths. Rather than using a relative
path for file references below the current project directory, Maya adds an
extra slash in front of the project directory. The extra slash helps Maya
search for files if you move the project.

When you open a scene, Maya searches for referenced files in the following
order of locations:

• absolute, full path stored in the scene

• path below the project directory (as indicated by the extra slash)

• path relative to the current scene file location

If Maya cannot find the referenced file, use the dirmap command to remap
the file location. The dirmap command maps one or more directories to
replacement directories. Maya stores this mapping when you save the file.
See the online MEL Command Reference for details.

ADD, DELETE, AND RENAME CUSTOM ATTRIBUTES

We added menu selections to make adding, deleting, and renaming custom
(or dynamic) attributes easier and more intuitive. The following table lists
these new menu selections.

Task From Attribute
Editor menu

From main menu

Add attribute Attributes > Add Modify > Add Attributes

Delete attribute Attributes > Delete Modify > Delete Attributes

Rename attribute Attributes > Rename Modify > Rename Attributes
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3 NURBS MODELING

In Maya 3.0, we’ve added the following features and enhancements to
NURBS modeling:

• “Surface Editing Tool” on page 37

• “Breaking or smoothing tangents” on page 39

• “Rebuilding surfaces” on page 40

• “Creating output geometry as Bezier” on page 41

• “Lofting surfaces” on page 41

• “Attaching and aligning surfaces” on page 41

• “Extruding surfaces” on page 41

• “Rebuilding curves” on page 42

• “Creating text” on page 42

• “Selecting patches” on page 43

SURFACE EDITING TOOL

A new Surface Editing Tool lets you click a position on the surface, then
deform the region around the position with a manipulator. This provides a
handy alternative to working directly with CVs.

To use the Surface Editing Tool:

1 Select the surface.

2 Select Edit Surfaces > Surface Editing > Surface Editing Tool.

The tool manipulator appears on the surface.
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Move manipulator

Drag this manipulator in any direction to deform the surface in that
direction.

Manipulator positioner

Drag the manipulator positioner to reposition the move manipulator.
Alternatively, you can click anywhere on the surface to reposition the
manipulator.

You can use Snap to curve to snap the manipulator to an isoparm, or Snap to
grid to snap to a patch corner. The manipulator snaps to the isoparms or
patch corners that appear when you display the object with Display >
NURBS Smoothness > Rough—not the isoparms or patch corners that
appear only with finer Smoothness settings.

Tangent scale manipulator

Drag this manipulator forward or backward to scale the length of isoparms
that lie parallel to the tangent direction manipulator.

Tangent direction toggle

Aligns the tangent direction to one of three fixed surface directions: U, V, or
normal. Thereafter you can use the tangent scale manipulator in the
direction selected.

Manipulator positioner

Move manipulator

Tangent direction toggle

Tangent direction manipulator

Tangent scale manipulator

Tangent world axis selector
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Tangent direction manipulator

Click this icon to display a move manipulator that lets you drag the surface
tangent in any direction. This tangent works like an large metal plate welded
to the surface at the manipulator positioner. Moving this manipulator
generally bulges one part of the surface while indenting the surface on the
opposite side of the manipulator.

Tangent world axis selector

If you click one of the red, green, and blue dotted lines that make up the 3D
axes, the surface tangency deforms in the direction of the axis. This axis is
stationary and has the same spatial orientation as the world axis.

BREAKING OR SMOOTHING TANGENTS

You can now break isoparm tangents or make broken isoparm tangents
smooth.

To break a tangent:

1 Select the isoparm.

2 Select Edit Surfaces > Surface Editing > Break Tangent.

This inserts enough knots along the isoparm to allow the surface tangent to
be broken. The shape of the surface doesn’t immediately change. You can do
that with your subsequent surface deformations.

Note that if you break the tangent for a surface point rather than an isoparm,
Maya breaks the tangent in both directions. If you are using the Surface
Editing Tool, only the tangent being edited is broken.

To make a tangent smooth:

1 Select the isoparm that has the broken tangent.

Note
This Surface Editing Tool deforms a region within two spans of the
manipulator. Deformation decreases as distance from the tool position
increases.
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2 Edit Surfaces > Surface Editing > Smooth Tangent.

This moves the control vertices as necessary, but doesn’t change the number
of control vertices or spans. The surface position along that isoparm may
change.

Note that if you smooth the tangent for a surface point rather than an
isoparm, Maya smooths the tangent in both directions. If you are using the
Surface Editing Tool, only the tangent being edited is smoothed.

REBUILDING SURFACES

You can now set the following options in the Rebuild Surfaces options
window:

Rebuild Type End Conditions

Rebuilds the positioning of the surface’s end CVs and knots. If you select
End Conditions, two extra options appear for the End Conditions: No
Multiple knots and Multiple knots.

With No Multiple Knots turned on, the rebuilt surface doesn’t pass through
the end CVs. This makes the surface harder to control in some cases, but
makes other operations easier. For example, it’s easier to create smooth joins
between adjacent surfaces. (If you rebuild both surfaces with No Multiple
knots, you can snap CVs together to get exact tangency across the
boundary.)

If you turn on Multiple Knots, the surface touches the end CVs, making it
easier to control the surface boundaries and related tangency.

A surface rebuilt with End Conditions has the same degree as the original.

Trim Convert

Rebuilds a single-region trimmed surface (with four boundary curves) into a
non-trim surface. This option is displayed only for Maya Unlimited users.

Bezier

Rebuilds the surface as a Bezier surface. If you prefer working with Bezier
surfaces rather than NURBS surfaces, consider using this option to convert
the surface.

Keep NumSpans Gives the rebuilt surface the same number of spans as the original.
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Degree U/V Original

Makes the U/V degree of the rebuilt surface the same as the original surface.

You can turn on Degree U/V Original and Keep NumSpans to create a
uniform rebuild for several surfaces that have a different number of spans.

CREATING OUTPUT GEOMETRY AS BEZIER

All surface actions that let you create output geometry as Subdiv or
Polygons now let you create Bezier geometry. The actions and tools affected
are Revolve, Loft, Extrude Tool, Boundary, Square, and Bevel, Freeform
Fillet, and Fillet Blend.

LOFTING SURFACES

We’ve added the following option to the options window:

Section Spans

This option sets the number of spans between the lofted curves. Higher
numbers give finer control of surface deformations at the expense of extra
processing time.

ATTACHING AND ALIGNING SURFACES

Edit Surfaces > Attach Surfaces and Align Surfaces now compute the twist
values for edges, so you do not need to attach or align the surfaces then
toggle the twist attribute to get a clean join.

EXTRUDING SURFACES

We’ve added the following option to the options window:

Surface Degree

Select Linear to give the extruded surface sharp edges between isoparms.
Select Cubic for smooth edges. Be aware that Maya processes your
interactions with a complex surface much faster with the Linear setting.
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REBUILDING CURVES

We’ve added the following option to the options window:

Keep NumSpans Gives the rebuilt curve the same number of spans as the original.

CREATING TEXT

You can now use an extended character set to create text curves in Maya. For
example, you can use an e with an umlaut. This feature is available on
Windows NT only.

To specify a character from an extended character set:

1 Select Create > Text ❐ to open the options window.

2 Type a new word in the Text box.

3 To type the special character, select Programs > Accessories > Character Map
from the Windows NT Start menu.

This displays the Unicode Character Map window.

4 Choose the same font you selected in Maya’s Text Curves Options window,
select the font subset, then click the desired character in the window. Click
the Select and Copy buttons.

5 In Maya’s Text Curves Options window, use Ctrl-v to paste the text into the
Text field.

6 In the Text Curves Options window, click Create.

Important
To avoid pasting an incorrect character into the text field, make sure the
font you select in the Unicode Character Map window is the same as the
font you select in Maya’s Text Curve Options window.
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SELECTING PATCHES

You can now select NURBS patches the same way you select polygon faces.
This affects the operation of Edit Surfaces > Duplicate NURBS Patches,
which takes a connected group of patches and makes a new surface out of it.
Unlike polygonal facets, you cannot move, rotate, or scale a NURBS patch
that is a component of an object. You can move, rotate, or scale a NURBS
patch that is a new object created with Duplicate NURBS Patches.
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4 POLYGONAL MODELING

In addition to rewriting the underlying polygonal modeling engine to
provide improved performance and stability with large datasets, with this
release of Maya, we’ve added the following new features and improvements
to the polygonal modeling environment.

Interface improvements

• Menu reorganization

• Interface improvements and changes

New functionality

• New UV functionality

• New UV set options

• New multitexturing functionality

• New Convert Display colors option

• New Split vertex operation

• New Extrude commands

• New Texture View features

• New Normals options

Improvements to existing functionality

• Support for nonmanifold geometry

• Cleanup improvements

• Extract changes

• Merge Vertices improvements

• Hypershade workflow improvements
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MENU REORGANIZATION

The Polygon and Edit Polygons menus and submenus have been
reorganized in this version of Maya.

The Polygons menu now primarily contains commands that act on an entire
object, while the Edit Polygons menu contains commands that act on
components of an object.

Polygons menu reorganization

New. See Average Vertices.

Was in Edit Polygons menu.

Was in Edit Polygons menu.

Were in Edit Polygons menu.
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Edit Polygons menu reorganization

New. See:
Map UV Border
Relax UVs

New. See:
Create Empty UV Set
Copy Current UV Set

New. See:
Set Current UV Set
Rename Current UV Set
Delete Current UV Set

New. See New Convert
Display colors option.

Moved to Edit Polygons
menu.

New. See New split
vertex operation.

New. Used to be Extrude
in Polygons menu.
See New Extrude
commands.

Renamed.

Renamed.
Were in Polygons menu.

Was in Polygons menu.

Was Set Normal.

New. See Conform.

Reverse and Propagate
now a Reverse option. See
New Reverse options.
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INTERFACE IMPROVEMENTS AND CHANGES

As well as reorganized menu items, new options to existing tools have been
relocated and added throughout the polygonal modeling toolset.

• The Blind Data editor is now available from Window > General Editors >
Blind Data Editor

• The Texture View window is now available from the Window menu.

• Display Poly Count is now available from Display > Heads Up Display >
Poly Count.

NEW UV FUNCTIONALITY

This release of Maya introduces new functionality for creating and
manipulating UVs. Good UVs (non-overlapping and fitting in the 0 to 1
texture space) are an essential requirement for texturing, painting, and
adding Fur to polygonal objects. These new features are particularly useful
for larger polygonal models.

The new functionality includes:

• Automatic mapping

• Layout UVs

• Move and Sew UVs

• Creating good UVs on complex models

• Transfer

• Map UV border

• Relax UVs

Notes
This functionality is part of the polyUVsPlus.so plug-in (except for Map
UV Border and Relax UVs) which loads by default. If you do not see the
commands in the Polygons and Edit Polygons menus, select Window >
Plug-in Manager and load the plug-in. For information on loading plug-
ins, see Using Maya: Essentials.
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Automatic mapping
Use Automatic Mapping to create a texture map by simultaneously
projecting UVs onto multiple planes. You can choose a projection based on
shapes with 4, 5, 6, or 12 planes.

This technique is very useful in cases where the simple planar, cylindrical, or
spherical projections would result in severe distortion of UVs in some areas
(as is often the case in more complex models). Automatic Mapping maps the
model to multiple disjoint pieces in texture space. Automatic Mapping is
most useful for applying Fur or for texture painting using projection because
both Fur and texture painting can easily make use of UV meshes that are cut
into pieces.

In the following example, the planar, cylindrical, and spherical projections
all have overlapping UVs, and the cylindrical and spherical projections are
distorted. The automatic mapping projection automatically cut the
overlapping areas of the UV mesh and laid them out within the 0 to 1 texture
space.

12 planes4 planes 6 planes 8 planes5 planes

Polygonal model.
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Planar Projection.

(Overlapping and
distorted UVs.)

Cylindrical Projection.

(Overlapping and
distorted UVs.)

Spherical Projection.

(Overlapping and
distorted UVs.)
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Although the mesh is typically broken into many small pieces, and some of
the texture space is wasted, you can use the Move and Sew UVs command
to join the pieces together (see “Move and Sew UVs” on page 58). You can
also use the transformation tools in the Texture View to make better use of
the texture space.

To project UVs from multiple planes automatically:

1 Open the Texture View window (Window > Texture View) so you can view
the projection.

2 To clearly see the 0 to 1 texture space, change the texture Grid to 1, if it is not
already (View > Grid ❐). This is particularly important for Fur and Texture
Paint, which both require the mapping to be positioned entirely within this
space.

3 In the modeling view, select the faces you want to map (usually the entire
model).

4 Select Edit Polygons > Texture > Automatic Mapping ❐.

5 Select the required settings, then click Project or Apply.

Automatic Mapping.

(UVs cut and laid out in
the 0 to 1 texture space.)
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Automatic Mapping options

Planes Select the number of planes you are projecting from. The more planes used,
the less distortion occurs and the more pieces created. The default is 6.

Optimize Select how you want the projection optimized.

Less Distortion Projects all planes equally. While this method provides the
best projection for any face, you may end up with more
pieces. It is particularly useful if you have a symmetrical
model and you want the pieces of the projection to be
symmetrical.

Fewer pieces Projects each plane until the projection encounters a
projection angle that is not ideal. This can result in larger
pieces, and fewer of them. This is the default.

Layout Select where you want the pieces of the UV mesh to lie in the texture space.

Along U Positions the pieces along the U axis.

Less distortion Fewer pieces
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Into Square Positions the pieces within the 0 to 1 texture space. This is
the default.

Scale Select how you want the pieces of the UV mesh scaled within the texture
space.

None Performs no scaling.

Uniform Scales the pieces to fit the 0 to 1 texture space without
changing the aspect ratio. This is the default.

Stretch to
Square Stretches the pieces to fit the 0 to 1 texture space. The

pieces may become distorted.

Spacing Presets Maya puts a bounding box around each piece and lays out the pieces so that
the bounding boxes are very close together. If the pieces end up positioned
exactly next to each other, two UVs on different pieces can share the same
pixel and when texture painting, overscanning can also cause the paint to
spill onto the adjacent piece).

Along U Into Square

Uniform Stretch to Square
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To avoid this situation, ensure that there is at least a pixel between the
bounding boxes by selecting a spacing preset from this menu. Select a preset
that corresponds to your texture map size. If you don’t know the size, select
a smaller map, which will result in a larger spacing between adjacent pieces
in UV space. (The smaller your map in pixels, the bigger the UV spacing
must be between bounding boxes.)

Select Custom to set the size of the space as a percentage of the map size (in
the Percentage Space box).

Percentage Space If you select Custom beside Spacing Presets, enter the size of the space
between bounding boxes as a percentage of the map size.

Create New UV Set Turn this option on to create a new UV set and place the newly created UVs
in that set. Type the name of the set in the UV Set Name box.

Layout UVs
Use Layout UVs to lay out overlapping pieces of an existing UV mesh
(optionally, cutting them if necessary) so that they no longer overlap, either
along U or into a square. (Automatic Mapping does this automatically for
new mappings.)

For example, you could perform regular planar mapping on a character, and
then use the Layout UVs command to separate any overlapping pieces—this
typically separates the front and back pieces intact. Although in most cases,
other smaller pieces will also be produced, you can sew them back together

Note
After performing an Automatic Mapping projection, you can modify the
Planes, Optimize, Layout, and Scale settings for the projection in the
Channel Box. However, do not modify these settings after painting a
texture or applying Fur—the UVs may change drastically.
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using the Move and Sew UVs command (see “Move and Sew UVs” on page
58). You can also scale or stretch the UVs to fit within the 0 to 1 texture
space, and flip and reverse pieces.

To lay out existing UVs on an overlapping UV mesh:

1 Open the Texture View window (Window > Texture View) so you can view
the projection.

2 To clearly see the 0 to 1 texture space, change the texture Grid to 1 if it is not
already (View > Grid ❐). This is particularly important for Fur and 3D-paint,
which both require the mapping to be positioned entirely within this space.

3 In the modeling view, select the faces with UVs you want to lay out.

4 Select Edit Polygons > Texture > Layout UVs ❐.

5 Select the required options, then click Layout UVs.

Planar mapping. After Layout UVs.
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Layout UVs options
The default settings give the best results in most situations.

Separate Select how you want to cut, or separate overlapping pieces of the UV mesh.

Off Does not separate overlapping pieces of the mesh. Only
the Scale option has an effect.

Folds Separates only pieces where the surface normals of
overlapping pieces point opposite directions. This method
is faster, especially for larger models, however, you may
be left with overlapping UVs.

All Intersecting Separates all pieces where the UVs overlap. This is the
default.

Flip Reversed Turn this option on to flip pieces of the UV mesh that have normals pointing
in opposite directions.

Original polygon Flip Reversed off Flip Reversed on
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Layout Select where you want the pieces of the UV mesh to lie in the texture space.

None Does not lay out pieces after they have been cut. Some
pieces may lie on top of others.

Along U Positions the pieces along the U axis. This is the default.

Into Square Positions the pieces within the 0 to 1 texture space.

Scale Select how you want the pieces of the UV mesh scaled within the texture
space.

None Performs no scaling.

Uniform Scales the pieces to fit the 0 to 1 texture space without
changing the aspect ratio. This is the default.

Stretch to
Square Stretches the pieces to fit the 0 to 1 texture space. The

pieces may become distorted.

Spacing Presets Maya puts a bounding box around each piece and lays out the pieces so that
the bounding boxes are very close together. If the pieces end up positioned
exactly next to each other, two UVs on different pieces can share the same
pixel and when texture painting, overscanning can also cause the paint to
spill onto the adjacent piece).

To avoid this situation, ensure that there is at least a pixel between the
bounding boxes by selecting a spacing preset from this menu. Select a preset
that corresponds to your texture map size. If you don’t know the size, select

Tip
If your model is symmetrical (for example, a character’s face), you can save
texture space by turning this option off and superimposing the pieces of
UV mesh so they occupy the same texture space.
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a smaller map, which will result in a larger spacing between adjacent pieces
in UV space. (The smaller your map in pixels, the bigger the UV spacing
must be between bounding boxes.)

Select Custom to set the size of the space as a percentage of the map size (in
the Percentage Space box).

Percentage Space If you select Custom beside Spacing Presets, enter the size of the space
between bounding boxes as a percentage of the map size.

Move and Sew UVs
Use Move and Sew UVs to sew together separate pieces of the UV mesh by
merging selected edges and moving one piece (the smaller one) of the mesh
to the other (the larger one). You can quickly join separate pieces of the UV
mesh produced by Automatic Mapping or Layout UVs back to their
neighboring UVs.

There are two methods of moving and sewing UVs: manual and automatic.
With the manual method, you must select the edges you want to join. With
the automatic method, smaller pieces are moved and sewn automatically.
You define how small the pieces should be.

Before Move and Sew. After Move and Sew.

Manual Move and Sew.

Selected edges
(common).
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To move and sew pieces of UV mesh manually:

1 Select the edges you want to join. The common edges are highlighted in the
texture view and in the modeling view.

2 Select Edit Polygons > Texture > Move and Sew UVs ❐.

3 Turn off Limit Piece Size.

4 Click Apply.

To move and sew pieces of UV mesh automatically:

1 Select all the pieces.

2 Select Edit Polygons > Texture > Move and Sew UVs ❐.

3 Turn on Limit Piece Size and select the maximum number of faces a piece of
the UV mesh can have to be moved and sewn.

4 Click Apply.

Tip
After performing a Move and Sew operation, you can select the history
node (polyMapSewMove) in the Channel Box and adjust the Number of
Faces until you achieve the results you want.

Before Move and Sew UVs. After Move and Sew UVs
(moved and sewed only those
meshes with fewer than 50 pieces.)

Automatic Move and Sew.
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Average Vertices
Use Polygons > Average Vertices to smooth geometry by averaging the
values of vertices without changing the topology of the object. This method
of smoothing can be used with the Transfer command to easily produce
good UVs for texturing. For information on using Average Vertices and
Transfer to produce good UVs, see “Creating good UVs on complex models”
in Using Maya: Polygonal Modeling.

To average vertices (smooth them) without changing the topology:

1 Select the vertices you want to smooth.

2 Select Polygons > Average Vertices ❐.

3 Enter the required number of iterations then click Average or Apply.

Smaller iteration values produce more subtle results. Because iterations are
accumulative, the more iterations you enter, the more smoothing will take
place each time you average.

4 Click Average or Apply repeatedly until the desired smoothness is achieved.

Creating good UVs on complex models
Use Average Vertices to smooth geometry so that good UVs are simpler to
produce. (For example, the wrinkles on a model of a finger would likely
result in overlapping UVs because the angle necessary for a good projection
changes continuously.) You can then transfer the good UVs back to the
original model using the Transfer command.

Note
Using the Smooth operation of the Sculpt Polygons tool you can paint
vertices to produce the same result. For information on the Sculpt Polygons
tool, see the “Smoothing, Beveling, and Sculpting Polygons” chapter in
Using Maya: Polygonal Modeling.
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To average vertices for mapping without changing the model’s
topology:

1 Duplicate the original model.

2 On the duplicate model, select the vertices you want to smooth.

3 Select Polygons > Average Vertices ❐.

4 Enter the required number of iterations then click Apply.

5 Click Apply repeatedly until the desired smoothness is achieved.

6 Project the UVs onto the smoothed duplicate model using any of the
projection methods under Edit Polygons > Texture.

7 Use the new Transfer command (see next) to apply the UVs to the original
model.

Transfer
Use Transfer to transfer vertex positions, UV sets, and/or vertex color
between two models with identical topology. To create good UVs, you can
incorporate the Transfer tool into your workflow by first duplicating the
original model, manipulating the vertices so that it is more suitable for
projection using a method that does not change the topology (for example,
using Average Vertices, or the Sculpt Polygons tool), projecting the UVs on
the modified model, then using Transfer to copy them back to the original
model.

Note
You can also do this using the Smooth operation of the Sculpt Polygons
tool. For information on the Sculpt Polygons tool, refer to Using Maya:
Polygonal Modeling.
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Smoothed Duplicate
of complex model.

Complex model.

Planar projection of
smoothed duplicate.

Good UVs created using Map
UV Border and Relax UVs.

Good UVs
transferred back to
original model and
smoothed duplicate
deleted.
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To transfer UVs:

1 Select both the source object and the destination object, in that order.

2 Select Polygons > Transfer ❐.

3 Select the type of information you want to transfer (Vertices, UV Sets, Vertex
Color), then click Transfer.

Map UV border
With Map UV Border, you can automatically force the border of a UV mesh
to a square or circle shape fitting within the 0 to 1 texture space, optionally
maintaining a proportion of the original world space relationships between
the edges (Shape Detail). This is very useful for untangling borders, prior to
using a tool such as Relax UVs to untangle the interior UVs.

In the following example, UVs were cut along the inside and back of a torus,
creating a UV border. The UV border was mapped to a square, then relaxed
to eliminate overlapping UVs.

UVs on torus cut
to create UV
border.

Planar mapping of
torus with cut UVs.
Selected UV will map
to origin.

UVs mapped to square. Relaxed UVs.
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To map a UV border:

1 Select a UV on the border.

2 Select Edit Polygons > Texture > Map UV Border ❐, or in the Texture View,
select Edit > Map UV Border ❐.

3 Select the required options, then click Map.

Remember that you are only dealing with the border—don’t worry about
how tangled the interior UVs appear. You can untangle the interior UVs
using the Relax UVs tool (see “Relax UVs” on page 66).

Map UV Border options

Border Target Shape

Select the shape you want to map the UV border to (Circle or Square). The
Square option makes best use of texture space, but can result in faces having
zero or very little texture space around the edges of the mesh. The Circle
option is less likely to produce this type of problem, but uses texture space
less efficiently.

Note
The UV you select maps to a point on the diagonal of the 0 to 1 texture
space. It maps as closely as it can to the origin while containing the UV
mesh in the 0 to 1 space.
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Preserve Shape Detail

Automatic Turn on Automatic to map the UV border automatically using a Shape
Detail value (see next) that approximates the best use the texture space while
maintaining the world-space relationships between edges.

Shape Detail Turn off Automatic and use the slider or enter a value between 0 and 1 to
control the blend of the border with the specified shape. A value of 0
produces a border closest to the specified shape. A value of 1 produces a
border that closely represents the world-space relationships between edges,
but can result in concave areas along the border—these will produce
overlapping interior UVs once relaxed.

UV border mapped
to square.

UV border mapped
to circle.

These UV border mappings
produce overlapping UVs,
which can be fixed using the
Relax UVs tool.
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Relax UVs
Use Relax UVs to automatically untangle and even out UVs, while retaining
a fixed border or fixed UVs. This is extremely useful for untangling UV
meshes when used in combination with Map UV Border.

To relax UVs:

1 Select a UV within the UV mesh.

2 Select Edit Polygons > Texture > Relax UVs ❐.

Border Target Shape = Circle.

Shape Detail 1.0.

Shape Detail 0.3.

Shape Detail 0.

Concave areas produce
overlapping borders. In this
situation, reduce the Shape
Detail value.

Relaxed.

Relaxed.

Relaxed.

Reducing the Shape Detail
value eliminates the overlapping
borders while attempting to
minimize distortion.

A Shape Detail value of 0
eliminates the overlapping
borders, forcing them into the
set shape.
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3 Select the required options, then click Relax or Apply. You may need to click
Relax again until you achieve the desired results.

Relax UVs options

Edge Weights Select how the UV relax affects edges.

Uniform Attempts to make all of the edges the same length. This is
the default.

World Space Attempts to retain the original world-space angles (subject
to the restrictions of the pinned border).

Pin UVs

Use the following options to relax only selected parts of the UV mesh.

Pin UV Border Turn this option on to maintain the position of the border UVs. This is the
default.

Pin UV Border,
before Relax UVs.

Pin UV Border, after
applying Relax UVs
several times.
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Pin Selected UVs Turn this option on to maintain the position of selected UVs. For example, if
you want more texture space for an area on a face with very dense UVs, you
could select these UVs, scale them up, pin them, then relax the rest of the
UVs to eliminate any overlapping you may have introduced during the
scale.

Pin Unselected UVs Turn this option on to maintain the position of the unselected UVs. This
option is useful for relaxing only the selected UVs.

Stopping Conditions

Max Iterations Enter the number of relaxation iterations that will be performed on the
UVs—ideal UV relaxation is subjective and iterative.

NEW UV SET OPTIONS

The following options have been added to the Texture menu providing you
with a mechanism to create, name, and delete UV sets. Press ❐ for each of
these options to open the options window.

• Create Empty UV Set

• Copy Current UV Set

• Set Current UV Set

• Rename Current UV Set

• Delete Current UV Set

Pin Unselected UVs,
before Relax UVs.

Pin Unselected UVs,
after applying Relax
UVs several times.
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You can create and edit multiple UV sets for working with multitextured
objects which can be viewed in hardware shaded display mode as well as
software rendered.

You can create a new UV set when you do the UV mapping or you can
create an empty UV set independently of a projection.

To create a new UV set when you project a map:

In the projection option box, turn on Create New UV Set and type a name
for the set in the UV Set Name box.

To create a new empty UV set:

1 Select the object, then select Edit Polygons > Texture > Create Empty UV
Set ❐.

2 In the Create UV Set Name box, type the name of the empty set and click
Create.

To set a UV set to be current (select the set):

• Right-click on the object and drag down and select UV Sets > UVsetName,
where UVsetName is the name of the UV set you are selecting.

or

• In the Texture View, select Image > UV Sets > UVsetName, where UVsetName
is the name of the UV set you are selecting.

or

• Select the object, then select Window > Relationship Editor > UV Linking >
UV-Centric and click on the UV set name.

or

1 Select the object, then select Edit Polygons > Texture > Set Current UV Set ❐.

2 In the UV Set Name box, type the name of the UV set you are making
current.

To rename a UV set:

1 Select the set you want to rename.

2 Select Edit Polygons > Texture > Rename Current UV Set ❐.
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3 In the New UV Set Name box, type the new name for the set and click
Rename Current or Apply.

To copy values from one set to another existing set:

1 Select the set you want to copy from.

2 Select Edit Polygons > Texture > Copy Current UV Set ❐.

3 In the UV Set Name to Copy to box, type the name of the UV set you want to
copy the UVs of the selected set to.

To delete a UV set:

1 Select the set you want to delete.

2 Select Edit Polygons > Texture > Delete Current UV Set.

NEW MULTITEXTURING FUNCTIONALITY

Multitexturing is the layering and blending of multiple textures on an object,
potentially using a distinct UV set for each layer. Although it is not
necessary that each texture contains its own set of UVs, it is often an
important part of multitexturing.

In Maya 3, you can create and edit multiple UV sets for working with
multitextured objects which can be viewed in hardware shaded display
mode as well as software rendered.

New UV sets can be created and named when using polygonal UV
projection tools.

Applying layered textures to UV sets
Use the Layered Texture node to manage multiple textures. You can drag
and drop file textures onto this node using the middle mouse button, and
RGB and alpha connections are automatically made. You can alternatively
drag textures from Hypershade into the Layered Texture’s Attribute Editor.

The following workflow shows you how to create UV sets, layer textures,
and how to manage the correspondence between texture layers and UV sets.
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To create UV sets:

1 In the top view, create a polygonal plane, scale it larger than the default, and
select it.

2 Select Edit Polygons > Texture > Planar Mapping ❐ to open the Planar
Projections Options window.

3 Set the Mapping Direction to Camera, turn on Create New UV Set, and enter
lightUVs as the set name, then click the Project button.

The plane should now display the projection map manipulators.

Tip
From the top view panel’s menu, select Shading > Smooth Shade All and
Hardware Texturing to see the results when you have completed the
texture assignment.

Set Camera as
the Mapping
Direction.

Turn on
then enter
the new
UV set name.
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4 Select Window > Relationship Editors > UV Linking > UV-Centric.

5 Click map1 to make it current.

6 Select Edit > Rename UV Set and enter brickUVs in the Rename UV Set
options window.

The Relationship Editor displays both UV sets.
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7 Make sure brickUVs is selected in the Relationship Editor.

8 Select half the faces on the plane and then select
Edit Polygons >Texture > Unitize UVs to tile the UVs for the brickUVs UV
set.

To create texture layers:

1 In Hypershade, use the middle-mouse button to click-drag the Layered
Texture swatch from the Visor panel onto the material swatch in
Hypershade and connect it to one of the material’s attributes (such as Color.
Select Color from the material swatch’s pop-up menu).

or

Select Create > Textures > Other > Layered Texture, click in Hypershade and
middle-mouse-button drag the texture swatch over the material swatch to
connect it to an attribute.
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2 Double-click the Layered Texture swatch in Hypershade to open its
Attribute Editor. In the Layered Texture’s Attribute Editor, map the Color to
a file texture (for example, some kind of brick or stone texture you may
have). Rename this texture brickTexture.

3 Click in the top-most area of the Layered Texture Attributes section of the
Attribute Editor to create a second layer and click the box next to Color to
map it to another file texture. Rename this texture lightTexture.

Note
You can use any file texture and not necessarily a light map. See “Example
2” on page 78.

Result in the view panel.

Click to map a 2D file texture

Hypershade view.

to the Color attribute.
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4 In the lightTexture’s Attribute Editor, open the Effects section and turn on
Invert to invert the lightTexture.

Click in this section to
add another layer.

Click to map a 2D file texture
to the Color attribute.

Hypershade view.

Result in the view panel.
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5 In the Layered Texture’s Attribute Editor, click the lightTexture swatch and
set the Blend Mode to Illuminate (or Subtract).

Turn Invert on.

Result in the view panel.

Hypershade view.

Select the Illuminate or
Subtract Blend Mode.
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6 Click the brickTexture swatch and make sure the Blend Mode is None (the
default).

The order of layers within the Layered Texture Attribute Editor is important
since you want the light file texture to blend on top of the brick texture.
Make sure the brickTexture is first (the right-most texture).

To connect the UVs to the textures:

1 Open the Relationship Editor in UV-Centric mode (Window > Relationship
Editors > UV Linking > UV - Centric).

2 Select the plane to update the Relationship Editor.

3 Click the lightUVs UV Set in the left column, and click the texture items in
the right column to compare results. See the following examples.

Example 1

Shows brick UVs used to map brick texture
and light map UVs used to light map texture.
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Example 2

These next few images show what happens when you change the overlaying
texture by mapping another file and selecting the lightUVs set in the
Relationship Editor.

Shows light map UVs used to map both textures.

Double-click the texture swatch
to open its Attribute Editor and select
another file texture.

Rename the new file texture.
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Blend modes
Textures can be blended with the texture below them using the Texture
Blend attribute in the Layered Texture’s Attribute Editor.

The Blend Mode specifies how the currently selected layer blends with the
layers behind it. The following blend modes are available.

None The foreground texture covers up the background texture
entirely.

Over The foreground texture is applied like a decal to the
background. The blending of the decal is determined by
the foreground alpha.

In The result is the background texture cut in the shape of
the foreground alpha.
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Out The result is the opposite of In. It is as if the shape of the
foreground alpha has been cut out of the background.

Add The foreground color is added to the background color as
if being projected on the background through a slide
projector.

Subtract The foreground color is subtracted from the background
color.

Multiply The result color is the foreground color multiplied by the
background color.

Difference The result color is the difference between the foreground
color and the background color.

Lighten The result color of each pixel is the background color or
foreground color, whichever is lighter.

Darken The result color of each pixel is the background color or
foreground color, whichever is darker.

Saturate The result color is the background color with saturation
increased in proportion to the foreground alpha.

Desaturate The result color is the background color with saturation
decreased in proportion to the foreground alpha.

Illuminate The result color is the background color mixed with the
foreground color, brighter where the foreground color is
bright and darker where the foreground color is dark. It is
as if the foreground texture represents the light falling on
the background.

NEW CONVERT DISPLAY COLORS OPTION

Turn this new Colors option on or off to show colors in hardware texture
shaded mode (in the view) when appropriate.
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NEW SPLIT VERTEX OPERATION

You can now split a shared vertex into multiple vertices—one for each
polygon that shares it. This removes connectivity at the vertex, so you can
perform independent operations on the split edges.

To split a vertex:

1 Select the vertices you want to split.

2 Select Edit Polygons > Split Vertex.

NEW EXTRUDE COMMANDS

Previously, you could only extrude faces using Extrude. You can now
choose to extrude either faces or edges by selecting Extrude Face or Extrude
Edge from the Edit Polygons menu. Click ❐ next to the menu item to open
its associated option window.

Note
Any selected vertices that are not shared are ignored.
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NEW TEXTURE VIEW FEATURES

The following new features have been added to the Texture View:

• Select Shell and Select Shell Border

• Display Unfiltered

• Pixel Snap

Select Shell and Select Shell Border
You can easily select entire shells and shell borders using the Select Shell and
Select Shell Border commands, respectively.

To select a shell:

1 Do one of the following:

• Select a UV to select all UVs on the UV shell.

• Select a vertex to select all vertices in the polygon shell.

• Select an edge to select all edges in the polygonal shell.

• Select a face to select all faces in the polygonal shell.

2 In the Texture View, choose Select > Select Shell.

To select a shell border:

1 Do one of the following:

• Select a UV to select all UVs on the border of the UV shell.

• Select a vertex to select all vertices on the border of the polygon shell.

• Select an edge to select all edges on the border of the polygonal shell.

• Select a face to select all faces with edges on the border of the polygonal
shell.

2 In the Texture View, choose Select > Select Shell Border.
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Display Unfiltered
By default, images display filtered so that pixels blend into each other for a
smoother quality. You can display images unfiltered so that when you zoom
in you can see each pixel clearly. With pixels clearly displayed, you can use
the Pixel Snap option (see next) to snap UV points to precise points on the
texture.

To display images unfiltered, turn on Display Unfiltered in the Image menu
of the Texture View.

Pixel Snap
For greater control over UVs when you translate them, you can snap them to
pixels (like snapping to a grid).

To snap UVs to pixels:

1 Turn on Display Unfiltered in the Image menu.

2 Zoom in on the texture so you can see the pixels.

3 Select the UV you want to snap to a specific pixel and select the
transformation tool.

4 Drag the UV. It will snap to the closest pixel corner.

Filtered image display. Unfiltered image display.
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NEW NORMALS OPTIONS

The Reverse and Propagate option has been removed from the Normals
submenu and incorporated with the Reverse option.

Also, a new Conform option has been added to the Normals menu.

Modified Reverse option
Reversing face normals affects the orientation of the face and causes the face
normals to be computed in the opposite direction. Vertex normals are
computed from the face normals, so they are affected as well.

There are three ways to reverse normals. You can:

• Only reverse face normals.

• Reverse face normals and vertex normals and then extract the vertices.

• Reverse face normals and propagate the change to the rest of the normals in
the shell.

You can reverse face normals one at a time or reverse multiple face normals.
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To reverse polygonal face normals:

1 To display normals on an active object, select Display > Polygon >
Components > Normals.

2 Select the faces you want to reverse normals on:

• To reverse the normals on an entire object, marquee-select the object.

• To reverse normals on individual faces, press F11 or press the right mouse
button and select Face from the marking menu, then click to select the faces
whose normals you want to reverse and select Edit Polygons > Normals >
Reverse.

3 Select Edit Polygons > Normals > Reverse ❐.

4 Beside Mode, select how you want to reverse normals and click Reverse
Normals or Apply.

Reverse Maya reverses the normals on the selected faces.

Reverse and Extract Maya reverses the normals on the selected faces and then extracts, or splits
the vertices.

Note
Reversing normals using this option can make your geometry
nonmanifold. To correct nonmanifold geometry, perform a cleanup. For
details, see “Cleanup improvements” on page 89.

Inside hat

Select faces on hat
then select Reverse.

after Reverse.
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Reverse and Propagate

Maya reverses the normals on the selected faces and forces all the normals in
the shells to which the faces belong to go in the direction of the reversed
selection. This can come in handy if you create models where some of the
normals are pointing in the opposite direction of the others.

Conform
Using the Conform normals option you can make all the normals of selected
faces point in a consistent direction (no normals point in opposite
directions).

To conform normals:

1 Select the faces whose normals you want to conform.

2 Select Edit Polygons > Normals > Conform. Normals conform to the
direction shared by most of the faces.

SUPPORT FOR NONMANIFOLD GEOMETRY

Maya 3.0 supports geometry with nonmanifold topology. Nonmanifold
topology is illustrated by the following three examples:

Before Conform. After Conform.

Three or more faces
share an edge.

Two or more faces share a
single vertex but no edge.

Adjacent faces have
opposite normals.
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In the first example (the “T” shape), more than two faces share an edge.

In the second example (the “bowtie” shape), two faces share a single vertex
without also sharing an edge. This shape is also possible where two three-
dimensional shapes share a vertex (such as two cubes meeting at a single
point).

In the third example, a single shape has non-contiguous normals (without
border edges). This is a less obvious example of nonmanifold geometry.

The following operations can produce nonmanifold geometry:

• Extrude Edge

• Normals > Reverse (reverse normals without extracting geometry)

• Merge Vertices

• Delete Face (select the face and press the backspace key)

• Collapse (Face or Edge)

To keep the polygon count down and make tasks such as mapping textures
to your objects much easier and quicker, make the pieces of polygonal
geometry making up a model fit properly. Avoid creating a polygonal edge
that has no face. Also, try to create your polygons so that their normals point
in the same direction. Although it is technically valid for the normals to
point in opposite directions, textures may not behave as expected.

You can automatically make nonmanifold geometry 2-manifold (including
the less obvious case of adjacent faces with opposite normals) using
Polygons > Cleanup. For more information, see “Cleanup improvements” on
page 89.
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CLEANUP IMPROVEMENTS

A new section has been added to the Polygon Cleanup Options window
(Polygons > Cleanup ❐) so you can clean up newly supported nonmanifold
geometry.

Notes
• Boolean and Reduce operations have no effect on polygonal objects

with nonmanifold geometry.

• Merge Edge operations have no effect on nonmanifold edges,
although they work on 2-manifold edges that are part of
nonmanifold geometry.

Normals pointing
in opposite directions.

Complex polygonal object:
vertices/edges do not match up.

Edge that has no face.
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Other section

Nonmanifold geometry

Turn this option on to clean up nonmanifold geometry. Select one of the
following options to control what happens to the resulting normals. For
information on nonmanifold geometry, see “Support for nonmanifold
geometry” on page 87.

Normals and
Geometry Turn on this option to conform normals when cleaning up

nonmanifold vertices or edges.

Geometry Only Cleans up nonmanifold geometry without changing the
resulting normals.

EXTRACT CHANGES

When you extract faces, Maya now separates the extracted faces by default.
To extract faces without separating them, select Edit Polygons > Extract ❐
and turn off Separate Extracted Faces.
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MERGE VERTICES IMPROVEMENTS

Merge Vertices now provides the additional functionality of Merge Multiple
Edges as part of the same operation (providing the edges are coincident
within the specified tolerance). In addition, Merge Vertices also merges the
associated UVs, creating shared UVs.

HYPERSHADE WORKFLOW IMPROVEMENTS

It is now possible to assign textures directly to selected objects and
components in the view through Hypershade.

Right-click on a texture swatch and select Assign Texture's Material to
Selected Objects from the pop-up menu. The texture is assigned to the
selected objects and components in the view.

If the texture does not have an associated material, it automatically creates a
Lambert material, assigns the texture to the Color channel, and continues
with the assignment.

Note
Merging vertices can make your geometry nonmanifold. It is important to
be aware of the orientation of face normals and the existence of coincident
edges when performing this operation, and to consider this possibility
when cleaning up a model, or preparing for export.

To correct nonmanifold geometry, perform a cleanup. For details, see
“Cleanup improvements” on page 89.

Merged vertices. Merged vertices.

Coincident edges
merged automatically.
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For information on other Hypershade improvements, see Chapter 9,
“Rendering.”

Note
If a texture is associated with multiple materials, or any other ambiguous
shading network, the operation will fail.
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5 SUBDIVISION SURFACES
MODELING

With this release of Maya Unlimited, we’ve added new features and
improvements to the subdivision surfaces modeling environment.

Subdivision surfaces are now better integrated into Maya Unlimited’s
animation and rendering environments, and features improved
performance, stability, flexibility, and hierarchy navigation.

Subdivision Surfaces menu reorganization

Hierarchy and Polygon proxy modes

• Hierarchy mode

• Polygon proxy mode
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Navigating the hierarchy

Display filtering

New functionality

• Extract Vertices

• Full and Partial Crease Edge/Vertex

• Collapse hierarchy

• Display normals

• New Hull display

• Create Subdiv option window changes

• Mirror

• Attach

Performance tips

Rendering tips

SUBDIVISION SURFACES MENU REORGANIZATION

Both the Subdiv Surfaces menu and the marking menu for a subdivided
surface have been reorganized for Maya Unlimited 3.0.
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HIERARCHY AND POLYGON PROXY MODES

You can now use one of two modes when working with subdivision
surfaces:

• Hierarchy mode

• Polygon proxy mode

You can choose the mode when creating the subdivided object from the
polygon, switch between the modes using the
Subdiv Surfaces > Hierarchy Mode or Polygon Proxy Mode menu items, or
use the right mouse button to select a mode from the marking menu.

Hierarchy mode
In Hierarchy mode, the control points, edges, or faces at any level of the
hierarchy can be viewed, manipulated (rotated, scaled, or translated),
keyframed, etc. The subdivision surface will have no construction history
(no deformers, etc.).

New.

Was Crease.
New.
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You can also crease edges and vertices, and you can now manipulate edges
and faces (rotate, scale, translate) including the move normal and
proportional modification functionality.

You can switch to this mode from the polygon mode at any stage of
modeling. If you have deformations or any other construction history, it is
deleted when you switch into this mode. If the surface is bound to joints,
you cannot switch to polygon mode.

Polygon proxy mode
Switching into this mode creates a polygon that matches the level 0 (base)
control mesh of the subdivision surface.

In Polygon proxy mode, you can use the usual polygon tools and functions
to indirectly modify the level 0 (base) control mesh of the subdivision
surface since everything is connected through construction history. For
example, you can extrude a face or delete one. The hierarchical edits are
usually maintained.

You can switch to this mode from the hierarchy mode at any stage of
modeling. The subdivision surface should have no construction history
before you switch into this mode.

This mode also allows you to edit the UVs on the subdivision surface,
indirectly, by editing the UVs on the polygon proxy object.

Example

You create a model in Hierarchy mode and then decide you need to extrude
a face.

Notes
• When in polygon proxy mode, the polygon is not connected to any

shaders, so it will draw as wireframe even while in shaded mode.
This lets you see the resulting subdivision surface while
manipulating the polygon using the usual polygonal tools and
functions.

• Some polygonal operations will not maintain the hierarchical edits,
namely Boolean operations and Bevel.
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Switch to the Polygon proxy mode, extrude the face and return to hierarchy
mode.

NAVIGATING THE HIERARCHY

Subdivision surface components (faces, vertices, and edges) now have a
Display Level attribute, accessible through the Channel Box, that you can
use to navigate to different levels of the component hierarchy (see Display
filtering next).

These levels apply to components only. The object remains the same.

The levels are available from the pop-up menu or in the surface’s Attribute
Editor, although only refined levels are shown. (Levels 1 and 2 are refined
automatically and are always available from the pop-up menu).

You can select vertices from different levels using this navigation tool since
selections are not lost as levels are changed.

Shift-click and Ctrl-Shift-click to add vertices to the selection. This opens up
new opportunities deforming the surface at different levels.

Tip
Try to perform a limited number of topological changes (for example,
creating or deleting edges, faces or vertices) before returning to Hierarchy
mode. In a way, you “bake” the changes with that action. You can then
return into the polygon proxy mode to make new modifications.

Note
You cannot deform at different levels of the hierarchy using the same
deformer.
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DISPLAY FILTERING

A Display Filter attribute for subdivision surfaces is now available in the
Channel Box. You can use this attribute to hide and show specific types of
vertices.

Use the Display Filter pop-up menu to select the vertices you want to see.

• All displays all the vertices of the current level.

• Edited displays only edited vertices (vertices that have been transformed) at
the current level.

NEW FUNCTIONALITY

The following have been added or changed for subdivision surfaces in
Maya Unlimited 3.0.

Extract Vertices
Use the new menu item, Subdiv Surfaces > Extract Vertices, to create a
polygon that matches the control points of the subdivision surface (at a
given level) instead of one that matches the shape of the surface.

This option is equivalent to the Control Points option in the
Polygons > NURBS to Polygon function. The following shows the option
window for this new function:
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Full and Partial Crease Edge/Vertex
Subdiv Surfaces > Crease has been renamed Full Crease Edge/Vertex and
the Partial Crease Edge/Vertex function has been added.

Partial Crease Edge/Vertex lets you change the shape of the surface in the
vicinity of the selected vertex or edge without making a tangent break in the
surface.

Collapse hierarchy
Use this option to remove a number of levels of the hierarchy from the
coarsest level. This keeps the shape of the surface, but increases detail at the
base mesh. For example, if you collapse at level 2, previous level 2 vertices
now become level 0 vertices, level 3 vertices become level 1 vertices, level 4
vertices become level 2 vertices, and so on.

Display normals
You can now display the normals on a subdivided surface using
Display > Subdiv Components >Normals (shaded mode) while in shaded
mode.

To return to the original display mode, select
Display > Subdiv Components >Normals (shaded mode) again.
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Changing the normal size and resolution
You can also control the size and resolution of the displayed normals.

• Open the surface’s Attribute Editor.

• Click to open the Subdiv Surface Display section and use the Disp
Resolution and Normals Display Scale sliders to adjust the resolution and
size of the normals.

New Hull display
Hull display is simply a fast approximate display tool for subdivision
surfaces. Select Display > Subdiv Surface Smoothness > Hull for faster
interaction with your subdivided surfaces. This new feature can be useful
when working with deformations.

Default size and
resolution: 1 and 1.0.

Size set to 0.25. Size set to 0.25 and
resolution set to 2.
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Similar to Display > NURBS Smoothness > Hull display, CVs are joined
instead of drawing the entire surface. The CVs of the finest level faces that
have been edited are drawn. Using this display mode can be useful because
this mode shows any cracks if vertices have been edited at different levels.

Create Subdiv option window changes
The Create Subdiv option window has been changed for this release of
Maya. Instead of Replace, Hide, and Show options, the combination of Keep
Originals on or off and Hierarchy Mode and Object Proxy Mode options has
been added.

Mirror
Using Mirror, you can duplicate and flip a selected subdivision surface
relative to the x, y, and z axis.

Hull display off. Hull display on.
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To mirror a subdivision surface:

1 Select the subdivision surface.

2 Select Subdiv Surfaces > Mirror ❐.

3 Turn on the axes you want to mirror the surface along and click Mirror or
Apply. By default, Maya duplicates and flips the surface along the X axis.

Attach
Using Attach, you can merge two selected subdivision surfaces to create a
new single subdivision surface. For example, you can use Attach to merge
mirrored surfaces, or to attach an arm to a torso.

The edges of the surfaces will “stitch” together only if each surface has the
same number of polygonal edges at the base mesh level (level 0). If the
surface does not have the same number of edges, the surfaces combine, but
do not merge. Only edges within the threshold defined by Edit Polygons >
Merge Multiple Edges are merged. For information on Merge Multiple
Edges, see Using Maya: Polygonal Modeling.

Note
Do not mirror subdivision surfaces using a negative scale on a duplicate of
the surface. Hierarchical edits and normals behave differently on the
duplicate so you will be unable to successfully attach the mirrored
duplicate to its original.

Mirror X Mirror Y Mirror ZOriginal surface
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To attach subdivision surfaces:

1 Make sure the two surfaces you want to attach each have the same number
of polygonal edges at the base mesh (level 0). If they do not have the same
number of edges, the surfaces will combine, but not merge.

2 Switch to hierarchy mode, if you are not already in it (Subdiv Surfaces >
Hierarchy Mode).

3 If you are merging mirrored surfaces, delete the history on the mirror copy.

4 Select the surfaces you want to attach.

5 Select Subdiv Surfaces > Attach.

PERFORMANCE TIPS

• Use Display > Subdiv Surface Smoothness > Hull display for faster
interaction with subdivided surfaces.

• From the View panel, select Show > Isolate Select and choose a menu item to
view only parts of the subdivided surface. See the chapter, Basic Features,
for more information on the new Isolate Select feature.

• Converting a high resolution polygonal model to a subdivision surface
creates a dense subdivision surface, defeating the purpose of the subdivision
surface and decreasing performance.

RENDERING TIPS

• There are no multiple UVs on subdivision surfaces, so when converting from
polygonal surfaces to subdivision surfaces, only a single set of UVs is
inherited.

Note
If you mirror subdivision surfaces using a negative scale on a duplicate
instance of the surface, Attach will not successfully merge the duplicate to
the original.
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• Component level shader assignment is allowed on subdivided surfaces, but
should be assigned to level 0 (base mesh) or level 1 faces. When converting
from a polygon with component level shader assignment, the shaders are
assigned correctly to the newly created subdivided surface.

• Motion blur, displacement mapping, texturing, etc. all work on subdivision
surfaces. The tessellation controls for rendering are now available in the
Attribute Editor for a subdivided surface.

• Subdivided surfaces with component level shaders render (or IPR) correctly.

• Converting a subdivided surface to a polygon (tessellate or extract vertex)
assigns a default shader to the resulting surface and will not carry through
component level shader assignments.
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6 ANIMATION

In Maya 3, we’ve added many animation features, including the newTrax
Editor for creating nonlinear character animation. This chapter describes the
new animation features in Maya 3.0.

Character set up, animated, and rendered in Maya by Cristoph Berndt.
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Maya provides these animation enhancements:

Basic interface enhancements

• “Range Slider display” on page 107

• “Quick access to playback looping options” on page 107

• “Frame rate display” on page 107

Graph Editor improvements

• “Euler angle filtering” on page 107

• “Scaling keys within a region” on page 108

• “Outliner split control” on page 108

Motion path flipping improvement

Motion path camera direction control

Nonlinear character animation—the Trax Editor

• “About clips” on page 110

• “Using the Trax Editor window” on page 111

• “Understanding clips and poses in the Visor” on page 112

• “Working with clips” on page 113

• “MEL commands and dependency graph nodes” on page 131

Adding and removing tracks

Motion warping

Using poses

Exporting and editing character maps

Working with subcharacters in the Trax Editor



ANIMATION | 6
Basic interface enhancements

WHAT’S NEW IN MAYA 3

107

BASIC INTERFACE ENHANCEMENTS

Range Slider display

A new button next to the Timeline lets you quickly display or hide the
Range Slider.

Quick access to playback looping options
You can now quickly select playback looping options from the Timeline.

Press the right mouse button in the Timeline to display a pop-up menu and
select Playback Looping from that menu. Now, select Once, Oscillate, or
Continuous playback looping.

These are the same the playback looping options that appear in the
Preferences window (now under Animation Timeline and Playback).

Frame rate display
You can now display the actual frame rate of an animation in the workspace.
Select Display > Heads Up Display >  Frame Rate. The actual frame rate is
displayed in the lower right hand side of your current view.

This helps you remember which frame rate you are using, and can be useful
when providing demos of your work.

GRAPH EDITOR IMPROVEMENTS

Euler angle filtering
When you import motion capture data into Maya as animation curves, the
curves sometimes become mangled when the rotation values are restricted
to a specific range.

Range Slider display toggle
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To filter curves to correct mangling:

1 In the Graph Editor, select the mangled animation curves (for example,
Rotate X, Y, and Z).

2 Select Curves > Euler Filter.

Note that the filtering is always applied to entire curves, not just to selected
curve segments within some time range.

Scaling keys within a region
With the Graph Editor’s new Only Scale Specified Keys option, you can now
scale the keys in a selected region of the Graph Editor. The keys outside the
region are not affected by the scaling.

To scale the keys in a region:

Select Edit > Scale ❒.

Outliner split control
You can now split the Graph Editor’s outliner to view two different listings
at once. This helps you switch back and forth when working on different
sets of animation curves.

To split the outliner:

1 Move the cursor towards the bottom of the outliner.

The cursor icon changes into an up-down icon.

2 You can now drag the cursor to move the outliner separator, creating a
second outliner space.

Note you can also split the Relationship Editor’s outliner this same way.

MOTION PATH FLIPPING IMPROVEMENT

In Maya 3.0, you can prevent objects from flipping using the Attach to Path
Options menu.Previously, objects could suddenly flip during motion path
animation when World Up was specified as the Up Direction in the Attach
to Path Options menu (Animate > Paths > Attach to Path ❒).
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The Attach to Path Options menu now includes selections for World Up
Type, World Up Vector, and World Up Object. These options work in the
same manner as the options you set to prevent rolling effects with
constraints.

For example, you can now create a locator and designate it as the World Up
Object, then rotate it, as needed, to prevent flipping.

MOTION PATH CAMERA DIRECTION CONTROL

One common use for motion path animation is to animate a camera to move
forward along a curve. With the new Inverse Front attribute (and
Animate > Attach to Path ❒ options), it is now easier to turn a camera
around along the curve and point it forward. In previous releases, it was
sometimes difficult to get a camera to point forward because of the way the
camera aligned along the curve by default.

To animate a camera along a curve:

1 Attach the camera to the curve as before (Animate > Attach to Path).

2 Adjust the camera’s orientation by editing the motionPath node attributes as
usual (the Inverse Up, Front Axis, and Up Axis attributes).

3 Use the new Inverse Front attribute (next to Inverse Up in the Attribute
Editor) to quickly reverse the direction the camera is pointing along the
curve.

Typically, the camera will be pointing backwards along the curve. By
clicking Inverse Front on, you can point the camera point forward along the
curve.

Note that although this workflow is typically used for animating cameras, it
also applies to any object you want to animate along a curve.
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NONLINEAR CHARACTER ANIMATION—THE TRAX EDITOR

The Trax Editor lets you layer and blend character animation sequences
nonlinearly—independently of time. You can work with any type of keyed
animation, including motion capture and path animation. The Trax Editor
lets you synchronize animation created with a variety of Maya techniques.

About clips
At the heart of Trax Editor usage is the clip—a span of animation you obtain
from an existing animated character. The most commonly used clips are
independent, reusable animation sequences that are easy to merge or blend
with other clips. For example, a walk cycle, run cycle, jump, and tumble are
ideal candidates for clips because you can blend and sequence them in
various ways.

Common ways to work with clips follow:

• Move a clip to a different playback time.

• Cycle a clip to make animation repeat.

• Synchronize clips of a single character or of several characters. (See Using
Maya: Character Setup for details on characters.)

• Instance or copy a clip to new characters. You can even export, import, and
reference clips from other scenes.

The Trax Editor also helps you explore variations in animation without
losing your work. For instance, suppose you create a soldier walking, but
decide you want to lift the legs higher to make the character march rather
than walk. If you make the walk cycle a clip, you can set additional keys that
adjust the leg motion without affecting the rest of the character.

If you create a clip from the new leg motion, you can blend it with the old
leg motion or disable it if decide you don’t like it. By creating several clips
with different leg motion, you can experiment with various clips until you
get the desired results. No prior animation is destroyed in the process.
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Using the Trax Editor window
To understand the elements of the Trax Editor, display it by selecting
Window > Trax Editor.

The left side of the Trax Editor window lists the characters and
subcharacters in your scene. The right side of the window displays a
Timeline and tracks that contain the animation clips you create. You see
tracks (and characters) in the Trax Editor only if you’ve created characters in
your scene.

You can animate a character with one or more clips on one or more tracks. A
track can have multiple clips in sequence. Clips play from left to right as the
scene plays. If a character has multiple tracks, Maya uses the clips on all of
them. Overlapping clips have an additive effect. You can blend overlapping
clips to avoid doubling the motion.

Note you can create a character with the Trax Editor by selecting
Create > Character. This option is identical to Character > Create from
Maya’s main menus. See Using Maya: Character Setup for details.

Enhancing the Trax Editor display
Once you’ve learned to use the Trax Editor, there are several ways you can
enhance the display to provide information:

Characters

Timeline

Tracks

Clips
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To view only the current character’s clips:

1 In Maya’s main menus, select Character > Set Current Character > character.

2 In the Trax Editor, turn on View > List Current Characters Only.

To view the Trax Editor only where clips exist:

In the Trax Editor, select View > Frame All.

To view the entire Timeline range:

In the Trax Editor, select View > Frame Timeline Range.

To increase the view size of tracks:

1 In the Trax Editor, select Options > Preferences.

2 Select Large for the Track Height.

To display all of a character’s clips on a single track:

In the Trax Editor, click the triangle to the left of a character name.

The multiple tracks are displayed as a single blue track. If you move this
track to a different location, you move all tracks within it.

Understanding clips and poses in the Visor
The Animation section of the Visor shows the source clips that exist in a
scene. When you are considering whether to import, export, or copy and
paste clips from one character to another, you’ll likely want to display the
clips in the Visor.

To open the Visor from the Trax Editor, select File > Visor.
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Two folders are related to clips: Character(s) Clips & Poses and Unused
Clips & Poses. If there is a current character, the Clips folder under
Character(s) Clips & Poses contains source clips for that character only. If
there is no current character, it contains source clips for all characters in the
scene.

The Clips folder under Unused Clips & Poses contains source clips that
aren’t used by any characters in your scene. For example, if you’ve imported
a clip from another scene, it is stored here. If you paste it to a character, it
still appears in Unused Clips & Poses, but Maya adds an extra copy of the
clip to the character. After you’re done pasting the clip to a character, you
can delete it to avoid wasting memory.

A pose is a snapshot you create of a character’s current positioning for any
moment in the Timeline. (See “Using poses” on page 134 for details.)

If you select a character as the current character, the Poses folder under
Character(s) Clips & Poses contains poses for that character only. If there is
no current character, it contains poses for all characters in the scene. The
Poses folder under Unused Clips & Poses contains the poses that weren’t
derived from any character in your scene.

Working with clips
After you’ve animated a character, you can create a clip for all or part of its
animation. The following paragraphs describe how you can edit clips.

• “Creating clips” on page 114
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• “Editing clip attributes” on page 116

• “Editing source clip attributes” on page 119

• “Cutting, copying, and pasting clips” on page 120

• “Duplicating clips” on page 122

• “Instancing clips” on page 123

• “Splitting clips” on page 124

• “Merging clips” on page 125

• “Blending clips” on page 126

• “Viewing and editing a clip’s animation curves” on page 128

• “Editing a clip’s original keys” on page 129

• “Disabling and enabling clips” on page 129

• “Importing and exporting source clips” on page 130

• “Importing clips by reference” on page 131

Creating clips

To create a clip:

1 Select a character.

2 In the Trax Editor, select Create > Clip ❐ to display the options window.

You can alternatively select Animate > Create Clip ❒ from Maya’s main
menus to display the options window.

3 Set the following options and click the Create Clip button.

Name Specifies a name for the clip. Default is clipn.

Keys Leave Keys in Timeline leaves the character’s keys in the Time Slider’s
Timeline and puts the clip in the Visor (see “Understanding clips and poses
in the Visor” on page 112). This is useful if you won’t use the clip currently
but want to store it for future use. By leaving the keys in the Timeline, you
can create another clip with the keys.

With Leave Keys in Timeline off, you can choose whether to put the clip in
in the Visor only or in the Trax Editor and Visor. Put a clip in the Trax Editor
if you want to be able to play the clip immediately after you create it.
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With Leave Keys in Timeline off, you can no longer create a clip for that
character from the keys that were previously in the Timeline. Maya removes
the keys and leaves the Timeline empty so you can start to create a new clip.

If you want to create several clips for different time ranges of a character’s
animation, turn off Leave Keys in Timeline and turn on Put Clip in Trax
Editor and Visor. Create a clip with the entire range of desired keys, then
split the clip into the desired animation segments. See “Splitting clips” on
page 124.

Note that if you turn on Leave Keys in Timeline, the Put Clip in Trax Editor
and Visor option is dim to prevent keys in the Timeline adding to the clip
animation in the Trax Editor. This would have a doubling effect on the
animation. If you create a clip for a character and later key the character in
the Time Slider’s Timeline, the key animation is added to the clip animation.
This is called motion warping or nondestructive animation.

Clip Specifies where to put the clip you’re creating:

Put Clip in Visor Only is useful if you won’t use the clip currently but want
to store it for future use.

Put Clip in Trax Editor and Visor lets you work on the clip in the Trax Editor
now. This is the default setting.

Time Range Specifies the clip’s time range in the Trax Editor:

Use Selected uses a time range you’ve selected in the Timeline for the clip.
To select a time range, Shift-drag through the desired times in the Time
Slider’s Timeline.

Use Time Slider Range uses a time range defined by the Playback Start and
End times of the Timeline.

Use Animation Curve Range uses a time range that spans the range of the
character’s animation curves. That is, the start time is the time of the first key
on the character, and the end time is the time of the last key.

Specify Start and End uses a time range you enter directly in Start and End
boxes.

Start and End Specifies the start and end times of the clip. Available if Specify Start and
End is on.
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Subcharacters Include Subcharacters in Clip includes the animation for any subcharacters
in addition to the character’s animation. See “Working with subcharacters in
the Trax Editor” on page 136.

Editing clip attributes

To edit clip attributes:

1 In the Trax Editor, click a clip to select it.

2 In the Trax Editor, select Modify > Attribute Editor.

The following attributes are displayed:

Anim Clip Attributes

Weight Scales up or down the value of each attribute in the clip by the specified
percentage. The scaling occurs for the entire animation of the clip, and pivots
around the clip’s start value. For example, suppose an object’s translateX
attribute increases in value from 10 to 20 in 30 frames. If you set Weight to
0.5, the translateX attribute rises from 10 to 15 in 30 frames.

All attribute data types are effected by Weight except Boolean (on/off)
attributes.

Offset Specifies how Maya interprets attribute values for the clip if the attributes
were controlled by a prior clip or keys in the Timeline:

Absolute uses an attribute’s clip value regardless of the prior value.

Relative adds the attribute’s clip value to its prior value.

For example, suppose you’ve created two clips that play sequentially in the
Timeline. The first clip is a character walking away from the origin along the
X-axis, the second clip is the character running away from the origin along
the X-axis.

If you turn on Relative, the character walks away from the origin then starts
running from the position where the walking clip ends and the running clip
begins. If you turn on Absolute, the character walks away from the origin.
When the walking clip ends and the running clip begins, the character
moves instantly to the origin and starts running from that position.
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Note that if two clips overlap in a pair of tracks for the same character, Maya
adds the values of any redundant attributes, regardless of whether you use
Absolute or Relative. This compounding effect is typically undesirable
unless you blend the clips (see “Blending clips” on page 126).

Enable Disabling a clip turns off the animation controlled by the clip. Enabling turns
on normal animation. It’s often useful to disable clips you’re not working on
to lessen visual distraction.

Start Frame Specifies the starting time of the clip’s playback. You can alternatively drag a
clip left or right in the Trax Editor to change the Start Frame.

Cycle Specifies how many times the clip repeats. For example, suppose your clip
originally plays for 10 frames. A value of 2 causes the clip to play twice in 20
frames. A value of 0.5 causes the clip to play half its animation in 5 frames. If
you use a Cycle value over 1, the clip displays a small ruler-type marker to
indicate where each additional cycle begins.

As an alternative to typing a Cycle value, you can drag the lower right edge
of a clip to increase or decrease the value. As you drag, the following icon
appears on the clip:

Cycle markers
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Scale Expands or contracts the time range for which the clip plays. If you increase
the scale, the attributes animate slower. Decreasing the scale has the
opposite effect.

You can alternatively drag the upper right edge of a clip to change the Scale
value. As you drag, the following icon appears on the clip:

Source Clip Attributes

For more information, see “Editing source clip attributes” on page 119.

Node Behavior

Contains rarely used, general attributes. See Using Maya: Essentials for
details.

Cycle drag icon

Scale drag icon
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Extra Attributes

None, by default.

Editing source clip attributes
When you create a clip, Maya stores the entire range of the selected
character’s animation curves in a node named clipnSource in the Visor (see
“Understanding clips and poses in the Visor” on page 112). A clip in the
Trax Editor is a playback instance of the source clip. The playback range of
the clip in the Trax Editor can be part or all of the range stored in the source
clip.

You can edit a few attributes of the source clip, for example, the start time
that you originally selected when you created the clip. For instance, suppose,
in frames 1 to 100, you key a basketball player bouncing a ball repeatedly
then shooting. You then create a clip from frames 30 to 50 for a single
bounce. If you decide to extend the clip to be a single bounce followed by
the shot, you cannot extend the bounce by modifying the clip in the Trax
Editor. You must instead modify the Start attribute in the source clip.

Note that when you change an attribute of the source clip, each use of that
clip in the Trax Editor is modified.

To edit source clip attributes:

1 In the Trax Editor, right-click a clip and select Select Clip Source from the
pop-up menu.

2 In the Trax Editor, select Modify > Attribute Editor.

The following attributes are displayed:

Anim Clip Attributes

This area is dim because the attributes do not apply to the clip source. For
more information, see “Editing clip attributes” on page 116.

Tip
As an alternative to using menu items at the top of the Trax Editor, you can
right-click a clip to display menus applicable to that clip only.
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Source Clip Attributes

Pose If you created a pose for the character rather than a clip, the Attribute Editor
displays the Pose option as being turned on. See “Using poses” on page 134
for details on creating poses. This option simply lets you know that this clip
is a pose rather than an animation clip. Note that Maya puts poses in the
Visor.

Start Specifies the start time of the source clip.

Duration Specifies the amount of time the source clip range extends from the Start.

Node Behavior

This section includes rarely used, general purpose attributes not specific to
clips. See Using Maya: Essentials for details.

Extra Attributes

None, by default.

Cutting, copying, and pasting clips
You can cut or copy a clip from the Trax Editor, and you can copy a clip
from the Visor. After you cut or copy a clip, you can paste it to the same
character, or more typically, to a different character that has similar
attributes.

If you copy and paste a clip to the same character, you create a playback
instance of the clip (see “Instancing clips” on page 123). If you copy a clip
and paste it to a new character, you create a duplicate (see “Duplicating
clips” on page 122).

Note that you cannot paste over a selected clip to replace it. You must delete
the undesired clip, copy and paste the desired clip to the character, then
move the clip to the correct position.

It’s best to paste a clip only to a character that has similar attributes and
objects as the original. If the two characters differ, you’ll typically need to do
many extra steps described in “Exporting and editing character maps” on
page 135.

To cut a clip:

1 Select the clip.
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2 In the Trax Editor, select Edit > Cut.

To copy a clip from the Trax Editor:

1 Select the clip.

2 In the Trax Editor, select Edit > Copy.

To paste a clip to the same character:

1 Select the character.

2 In the Trax Editor, select Edit > Paste.

To paste a clip to a different character:

1 Select the character.

2 In the Trax Editor, select Edit > Paste ❒.

3 Set the following options and click the Paste Clip button:

Paste Method By Attribute Name pastes attribute values to the matching attribute names
of the receiving character. Object names are ignored.

By Attribute Order pastes attribute values to the receiving character based
on the descending order of attributes in the Channel Box.

By Node Name pastes attribute values to the matching object and attribute
names of the receiving character.

By Current Map is relevant only if you are doing the steps in “Exporting and
editing character maps” on page 135.

Example

Suppose you copy and paste a clip from a character named Mars to a
character named Earth. If you’ve animated the translate X, Y, and Z
attributes of Mars and you specify By Attribute Name, the animation will be
applied to the translate X, Y, and Z attributes of Earth.

If you instead specify By Attribute Order, the animation might or might not
be applied to the translate X, Y, and Z attributes of Earth, depending on
whether these attributes are listed in the Channel Box in the same
descending order for both characters.
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If you instead specify By Node Name, the animation will be applied to the
translate X, Y, and Z attributes of Earth only if the objects in Earth’s
hierarchy have identical names as those in Mars.

Note that Maya allows two characters to have identical object and attribute
names only if each character has its objects grouped under a group node.

Start Frame Specifies where in the Timeline the clip will be pasted:

Current Time specifies the current time of the Timeline.

Timeline Start specifies the Start Time of the scene.

Clipboard Start specifies the Start Time of the clip.

If the location in the Timeline is already occupied by a clip, Maya puts the
clip on the first available track below, adding a track if necessary.

To copy a clip from the Visor and paste it in the Trax Editor:

1 From the Trax Editor, select File > Visor.

2 From the Visor, middle-mouse drag the clip to the desired track and
position. Maya puts the clip where you click in the track unless a clip
occupies that spot. If occupied, Maya puts the clip on the first available track
below, adding a track if necessary.

If you middle-mouse drag to a character from a source clip from the same
character, Maya creates an instance of the clip (see “Instancing clips” on
page 123).

If you middle-mouse drag to a different character and you previously
created a character map between the characters, Maya pastes the clip using
the character map (see “Exporting and editing character maps” on page 135).
Otherwise, Maya pastes using the By Node Name paste method. If you want
to paste using a different method such as By Attribute Name, right-click the
clip in the Visor and select Copy, then use Edit > Paste ❒ and select the
desired method.

Duplicating clips
You can duplicate a clip to create a copy of the original source clip and all of
its animation curves. If you create a duplicate, you can modify the animation
of the original source clip without affecting the duplicate.
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For example, suppose you’ve created a jump clip you want to keep, but you
also want to create a slightly different jump clip. Simply duplicate the clip,
activate the duplicate’s keys, then modify them for the new jump. You won’t
affect the original jump clip or any of its instances. For details on activating a
clip, see “Editing a clip’s original keys” on page 129.

A source clip can be used by only one character, so you can’t duplicate a
source clip and use it with multiple characters. If you want to use a copy of a
source clip on a different character, you must copy and paste a clip from one
character to another.

To set duplicate clips options:

1 In the Trax Editor, select Edit > Duplicate ❒.

2 Set the following options and click the Duplicate Clip button:

Clip Specifies where to put the copy of the clip.

Put Clip in Visor Only is useful if you won’t use the clip currently but want
to store it for future use.

Put Clip in Trax Editor and Visor lets you work on the clip in the Trax Editor
now. Maya puts the playback instance of the clip in the Trax Editor at the
current time. This is the default setting.

Instancing clips
If you select a clip in the Trax Editor and instance it, the resulting clip uses
the animation curves of the selected clip’s source clip. If you modify the
animation for a source clip, you modify both clips. Instancing a clip uses less
computing resources than creating several different source clips for identical
animation.

An example illustrates the benefits of instancing. Suppose you create a clip
of a character jumping. If you want the character to jump several times,
you’ll use less computing resources by instancing several jumps rather than
making copies.

You can also use the Cycle attribute to play a clip repeatedly with the same
savings in computing resources. However, cycling plays a clip repeatedly
without allowing breaks between each playback of the clip. For details on
cycling, see “Editing clip attributes” on page 116.
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A source clip can be used by only one character, so you can’t create instances
from the same source clip to multiple characters. To animate several
character identically, you must copy and paste a clip from one character to
another.

To instance clips:

1 In the Trax Editor, select the clip you want to instance.

2 In the Trax Editor, select Edit > Instance.

You can alternatively instance a clip by middle-mouse dragging a source clip
in the Visor to the same character in the Trax Editor.

Splitting clips
You can split a clip to divide a character’s animation into multiple, reusable
clips. For example, suppose you’ve animated a character to do three moves:
a karate punch, a swinging leg kick, and a tumble. You can split the clip into
the three moves then rearrange their order.

To set split clip options:

1 In the Trax Editor, select Edit > Split ❒.

2 Set the following options and click the Split Clip button:

Source Clip Specifies what to do with the source clip for the clip being split:

Delete Original Source deletes the source clip before creating two new
source clips. Use this option if you know you won’t use the whole clip again.

Keep Original Source leaves the source clip in place before creating two new
source clips. If you think you might use the whole clip again in the future,
use this option.

The two new source clips are named clipnSourceStartSource and
clipnSourceEndSource, by default.

Split Time Specifies where to split the clip:

Current Time uses the current time in the Timeline.

Specify Time lets you enter the time where the split occurs in an entry box
labeled Split Time.
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Merging clips
You can merge two or more clips into a single clip. The clips to be merged
can be positioned sequentially in a track or above one another on different
tracks.

The benefits of merging clips follow:

• You can move, scale, and cycle a merged clip conveniently.

• You’ll have a clip that won’t be damaged if you edit the original clips.

• If you merge a pair of blended clips, the resulting source clip has keys for
the blended animation. You can activate the merged clip and edit its
animation in the Graph Editor.

• You can merge a single clip into a new clip. This is useful for creating an
absolute clip from a relative clip, or for splitting a cycled clip (see the prior
Tip).

• Because Maya lets you blend only pairs of clips, you can merge three or
more clips into a pair of clips, then blend the pair.

To merge clips:

1 Select the clips you want to merge.

2 In the Trax Editor, select Edit > Merge ❒.

3 Set the following options and click the Merge Clip button:

Name Specifies the name of the merged clip.

Keep originals
in Trax editor Leaves the original clips in the Trax Editor after creating the merged clip. If

you think you might use the original clips again in the future, turn on this
option. To use less memory, turn this option off.

Tip
You cannot split a cycled clip directly. Instead, merge the clip (with no
other clips) to create a clip that doesn’t cycle, then split the new clip.
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Blending clips
You can blend the common attributes of two clips of a character. This creates
a smooth transition between the motion of each clip. You’ll have best results
blending clips that have similar motion. For example, you can create a
smooth transition from a character walking then running.

Blending dissimilar motion might not work well. For instance, blending a
character running and tumbling might create an awkward transition.

After blending clips, you can edit the resulting blend or you can reposition
the clips in the Timeline to alter the range of the blend.

The clips to be blended can be overlapping one another in different tracks or
positioned sequentially in a track. You’ll typically blend partially
overlapping clips. If you blend two partially overlapping clips, Maya blends
only the overlapping region.

To blend clips:

1 Select the clips you want to blend.

The clips must have one or more common attributes or the Blend operation
will fail.

2 In the Trax Editor, select Create > Blend ❒.

3 Set the following option and click the Create Blend button:

Initial Weight Curve Specifies how the blend is interpolated at the beginning, middle, and end of
the clip:

Linear changes attribute values at a constant rate from beginning to end of
the clip.

Ease In changes attribute values slowly at the beginning and quickly at the
end.

Ease Out changes attribute values quickly at the beginning and slowly at the
end.

Ease In Out changes attribute values slowly at the beginning and end, and
quickly in the middle.

4 For overlapping clips, make adjustments to the clip positions in the Trax
Editor so the animation transitions smoothly from one clip to the other.
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To edit the blended animation:

1 Click the curved line that connects the two blended clips.

2 In the Trax Editor, select View > Graph Anim Curves.

The Graph Editor displays the blend curve in a time range of 0 to 1, which
represents the start and end of the blend. Maya ignores parts of the curve
that are outside the range 0 to 1. The first clip to play in the animation is
blended into the clip that plays second.

In the following figure, a linear blend curve connects the two clips.

At the first frame where the clips overlap, the top clip controls the motion
100% and the bottom clip controls the motion 0%. At the last frame where
the clips overlap, the bottom clip controls the motion 100% while the top clip
controls the motion 0%.

Click this curve to edit
blended animation

0

1

Playback time

Clip of character walking

Clip of character running

Blend curve in Graph Editor
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During playback, the top clip’s control decreases as the bottom clip’s control
increases. You can adjust the shape of the curve to alter the percentage of
control each clip has. For example, you could reshape the blend curve as
follows:

The top clip would start with 100% control at the start of the blend, decrease
to 0% at the middle, then increase to 100% control at the end. The bottom
clip would change correspondingly from 0% to 100% to 0% control during
the blend.

If you plan to add a key to the blend curve to alter its shape, make sure
Timeline Snapping is turned off in the Timeline settings of the Preferences
window. Otherwise Maya won’t allow keys at floating point values.

If you selected one type of blend, for instance, linear, and want to switch it to
another, delete the blend and add a new blend of the desired type. To delete
a blend, select it in the Trax Editor and press Delete on your keyboard.

If you blend two overlapping clips that start at the same time in the
Timeline, Maya uses the first clip selected before the Blend operation as the
initial 100% controlling clip.

If you move the first-playing clip to a position where it plays later than the
second-playing clip, you’ll likely get unexpected blend motion. The blend
operation is intended for blending a clip that plays first into the clip that
plays second.

If blending clips doesn’t provide the exact transition you want, try adding
motion warping to tune the transition. If this doesn’t work, you’ll need to
key the transition.

Viewing and editing a clip’s animation curves
You can edit a clip’s animation curves by opening the Graph Editor for a
selected clip.

To view and edit the animation curves of a clip:

1 Select the clip.

0

1
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2 In the Trax Editor, select View > Graph Anim Curves.

Editing a clip’s original keys
To edit the original keys of a clip while displaying them on the Timeline,
you must activate the clip. To return the clip to a state where you can’t edit
the keys inadvertently, you must deactivate the clip.

When you activate a clip, Maya displays the keys in the Timeline at their
original positions. (If you’ve moved the clip to a different Timeline location
in the Track Editor, the keys won’t be shown at the those positions.)

While a clip is activated, Maya ignores clip settings such as Weight, Offset
Relative, and so on. Maya disables all other clips on the character so that
their effects do not add to the activated clip.

If you set new keys on the clip that extend past the end of the original source
clip’s duration, the keys play while the clip is activated, but won’t be
included in the deactivated clip unless you modify the source clip’s duration
in the Attribute Editor. See “Editing source clip attributes” on page 119.

To edit the original keys of a clip:

1 Select the clip.

2 In the Trax Editor, select Modify > Activate/Deactivate Clip.

The keys appear in the Timeline and are available for editing.

To disable the ability to edit the keys of the clip:

1 Select the clip.

2 In the Trax Editor, select Modify > Activate/Deactivate Clip.

The keys are removed from the Timeline and are unavailable for editing.

Disabling and enabling clips
You can disable a clip to stop its playback. If you later decide you want the
clip to play again, enable the clip.

A useful animation technique is to create many clips for a combination of
motions, then control which clips apply in a situation by disabling and
enabling clips.
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To disable clips:

1 Select the clip you want to enable.

2 In the Trax Editor, select Modify > Enable/Disable.

To enable clips:

1 Select the clip you want to enable.

2 In the Trax Editor, select Modify > Enable/Disable.

Importing and exporting source clips
When you create a project, Maya creates a clips directory. If you export a
source clip from a scene, Maya stores it in a scene file in the clips directory of
your project. If you import a clip to your scene, Maya puts it in the scene’s
Visor.

Many animators use an otherwise empty scene file to store a collection of
generalized animation clips, for example, walking and running clips.

Maya applies imported clips to a character by node and attribute name. So if
you create a generalized library, use a naming scheme that allows you to
apply the clips to all the characters you plan to use.

To export clips from your current scene:

1 Select the clip(s).

2 In the Trax Editor, select File > Export Clip.

In the file browser window, select a filename to which you want to export
the clip(s), then click Export.

To import clips:

1 In the Trax Editor, select File > Import Clip.

2 In the file browser window, select the file that contains the clip(s), then click
Import.

The clip is listed in the Visor under Unused Clips & Poses.

3 To use the clip, middle-mouse drag it to the Trax Editor or copy and paste it
to a character with Trax Editor menu items.
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Importing clips by reference
When you export a clip, it is saved in a scene file, but without links to any
character. It’s essentially a collection of animation curves independent of the
attributes they controlled. If you import a previously exported clip, you
cannot paste it with the By Current Map option. You can work around this
limitation by referencing a scene that has the character with the clips you
want to import.

To import a clip by referencing:

1 Open the file that contains the destination character— the character to which
you want to apply the clip.

2 Reference the file that contains the source character—the character with the
clip you want to use.

3 Open the Trax Editor and copy and paste from the source character to the
destination character.

4 Select File > Reference Editor.

5 Select the reference in the Reference Editor then Edit > Remove Reference.

This procedure is preferable to importing a scene containing a character,
because removing the reference removes all source character scene elements.
You won’t have useless extra nodes in your scene.

Note that you can create a MEL script for this procedure to import various
motion capture data into clips.

MEL commands and dependency graph nodes

MEL commands
MEL commands related to the Trax Editor are:

• character

• clip

• clipEditor

• clipEditorCurrentTime

• clipScheduler

• pose
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For more information about these commands, refer to the online MEL
Command Reference documentation.

Dependency graph nodes
The dependency graph nodes related to the Trax Editor are:

• animation clip source node, or clip node (animClip node, default name:
clipn)

• blend node (animBlendInOut node, default name: blendn)

• clip library node (default name: clipLibraryn)

• clip scheduler node (default name: clipSchedulern)

• character node (default name: charactern)

For more information, refer to the online DG Node Reference documentation.

ADDING AND REMOVING TRACKS

For a selected character, you can add or remove an empty track. If you add
multiple tracks to a character, you can put several similar clips in identical
time ranges and conveniently compare the animation of each. Disable all but
one of the clips and play the animation. Repeat this for each clip.

To add a track:

1 Select the character for which you want to add a track.

2 In the Trax Editor, select Modify > Add Track.

Maya adds the track below the lowest track that contains a clip for the
selected character.

To remove an empty track:

1 Select the character for which you want to remove the track.

2 In the Trax Editor, select Modify > Remove Track.

Maya removes the selected character’s lowest empty track.
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MOTION WARPING

You can set keys on a character that already has an animation clip. The keys
have effect on the character relative to existing clip animation. The technique
of applying animation on top of existing animation is known as
nondestructive animation or motion warping. Motion warping is useful in
these situations:

• You’re satisfied with an existing clip but want to make subtle changes
without destroying your work.

• You’ve created animation clip instances for various characters, for instance, a
street gang walking down an alley, but want to impart a unique walking
motion to each character.

• You’ve created dense key data for a character, for instance, with motion
capture, and you want to adjust the motion without altering the keys.

As you set keys on your character, the range of the motion warp appears in
the Trax Editor as a blue region on the Timeline.

Before you add the motion-warping keys, first set keys (without changing
attribute values) at the start and end of the clip region you want to modify.
These bounding keys delimit the start and end of the motion warp. Then set
the additional keys within the delimited region. Play the animation
repeatedly to make sure the warp works as you expect. When you’re
satisfied with the additional keys, create a clip for them so you can modify
the Weight to tune the motion.

For example, suppose you have a clip of a soldier marching. You like the
general motion, but you want to raise the soldier’s foot higher during the
march. First, set bounding keys at both frames where the foot is on the
ground, without changing any attribute values. Then, where the foot is
raised, move it a little higher and set a key in this position. Create a clip for
the keys and try different Weight values to tune the animation.

Motion warping might have undesirable results if you do it over relative
clips, including cycled clips. If you want to create a motion warp on a
relative or cycled clip, make the clip absolute by using Edit > Merge on it.
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USING POSES

After you’ve animated a character, you can store a snapshot of its current
positioning, known as its pose, for any moment in the Timeline. You can
instance, copy, and paste poses to the Trax Editor the same as for clips. The
following examples illustrate how poses can be useful:

• You can use a pose for positional comparison as you animate the character.
For example, if you animate a character walking in a circle, you can display
the pose of the character at its first step so you know where it must return in
its circular route.

• You can create poses for Maya’s Blend Shape feature to create combinations
of blendShape sliders. For example, if you define blendShape sliders for all
facial muscles, you can create poses from the weight settings that produce all
phonetic positions of English speaker.

• As a lead animator, you can create various key poses for a lengthy character
animation sequence and give your coworkers the creative freedom to
animate the character’s motion between the key poses.

To create a pose:

1 Select the character.

2 Click the frame in the Timeline.

3 In the Trax Editor, select Create > Pose ❒ to display the options window.

You can alternatively use Maya’s main menus to select Animate > Create
Pose ❒.

4 Enter a name for the pose in the Name box, then click the Create Pose
button.

When you create a pose, Maya stores the pose in the Visor. To put the
character in the pose position thereafter, right-click the desired pose in the
Visor and select Apply Pose from the pop-up menu.

To return the character to the actual animation position, rewind and play the
animation or click a frame in the Timeline.

In the Visor, you can also right-click a clip and select Apply Pose. This moves
the character to the clip’s starting position without you having to change the
current scene time.
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EXPORTING AND EDITING CHARACTER MAPS

When you copy a clip from one character and paste it to another, the
receiving character’s attributes might not animate as expected. For example,
the foot might rotate instead of the neck.

If this problem occurs, it’s likely the attribute animation was applied, or
mapped, to a character with attributes or objects that differ from the original
character. To fix the mapping so the character acts like the original, you must
export a character map and edit its incorrect attribute mapping.

To export a character map and fix the mapping:

1 Delete or undo the pasted clip.

2 Select the two characters.

3 In the Trax Editor, select File > Export Character Map ❒.

4 Set the following option:

Map Method Specifies how to format the map:

By Attribute Name creates a map where the copied character’s attribute
values are mapped to the counterpart attribute names of the receiving
character.

By Attribute Order creates a map where the copied character’s attribute
values are mapped to the receiving character based on the descending order
of attributes in the Channel Box.

By Node Name creates a map where the copied character’s attribute values
are mapped to the counterpart object and attribute names of the receiving
character.

By Current Map works only if you’ve already exported a character map and
executed the resulting mel script as described in the following steps. This
option creates a map with the current mapping for the selected characters.
This is useful if you’ve already exported a map to fix character mapping,
then later add new attributes to the character. If you use By Current Map,
you’ll be able to edit fewer attribute mappings—only those you’ve added
since the last time you corrected the mapping.
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The best Map Method option you choose depends on which map you expect
will be easiest to edit. You’ll need to know the attributes (and possibly their
ordering) of both characters.

5 Click the Export button.

A file browser window appears.

6 In the file browser, specify a filename and your loginname/maya/scripts
directory as the location to export the character map, then click Write. The
character map is a .mel file. (See Using Maya: MEL for details on scripts.)

7 Open the script with a text editor and correct the attribute mapping.
Instructions for editing the file are in the file.

8 In the Script Editor, select File > Source Script to source the script into the
scene. Then type the script name (without the filename extension) in the
Script Editor and press the Enter key on the numeric keypad.

9 Copy and paste the clip as you originally did, except select Edit > Paste ❒
and turn on By Current Map as the Paste Method.

10 Play the animation and check the results.

WORKING WITH SUBCHARACTERS IN THE TRAX EDITOR

A subcharacter bundles related attributes of a character so you can key them
in unison. If you set keys for a character, Maya also sets keys for all its
subcharacters. With the Trax Editor, you can use subcharacters when you
need to create one clip with a Relative offset and another for the same
character with an Absolute offset. (See “Editing clip attributes” on page 116.)

For example, suppose you animate a character walking. The character root
moves forward and the arms and legs rotate. Suppose further you create the
root as the main character and the arms and legs as a subcharacter. You can
create a clip for the entire character in which the main character clip uses
relative attributes and the subcharacter clip uses absolute attributes.
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Using clips on a character with subcharacters
If you turn on Include Subcharacters in Clip when you create a clip, Maya
creates a single source clip that includes all animation curves for the
character and all its subcharacters. In the Visor, you can instance the source
clip to a single subcharacter or to the entire character by middle-mouse
dragging to the desired tracks.

To copy a source clip with subcharacter data to a new character, first export
a character map that establishes a relationship between the two characters
and their subcharacters. (See “Exporting and editing character maps” on
page 135.) Then paste the source clip to the character and its subcharacters
using the By Current Map option.

Using clips on a subcharacter
To create a source clip that contains only the animation curves for a single
subcharacter, set the current character to be the subcharacter and create the
clip.

A source clip can be used by only one subcharacter, so you can’t create
instances from the same source clip to multiple subcharacters. To animate
several subcharacters identically, you must copy and paste a clip from one
subcharacter to another.

Creating subcharacters on a character with clips
If you create a subcharacter on a character that has existing clips, the
subcharacter inherits the existing clips so that no animation is lost.
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7 CHARACTER SETUP

Maya 3.0 includes several important new features for character setup. This
chapter summarizes the new character setup features in Maya 3.0:

• “Blend shape slider orientation control” on page 140

Character set up, animated, and rendered in Maya by Olivier Junquet, University of
Paris, Department of Arts and Images Technology. Visit http://www.splotsh.com.
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• “New advanced deformer creation options” on page 140

• “Mirroring smooth skin weights” on page 141

• “Copying smooth skin weights” on page 142

• “Holding smooth skin weights” on page 143

• “Improved smooth skin influence object behavior” on page 145

• “Control of smooth skin weight normalization” on page 145

• “New create character options” on page 146

BLEND SHAPE SLIDER ORIENTATION CONTROL

You can now control the orientation of the sliders in the Blend Shape
window (Window > Animation Editors > Blend Shape). You can arrange the
sliders vertically or horizontally, whichever is most intuitive for you.

To orient the sliders vertically, select Options > Orientation >  Vertical (the
default).

To orient the sliders horizontally, select Options > Orientation > Horizontal.

NEW ADVANCED DEFORMER CREATION OPTIONS

Maya 3.0’s new advanced deformer creation options provide a more robust
workflow for creating a deformer that can affect more than one surface.

Previously, when you created a deformer for more than one surface, and
specified a new (not currently existing) exclusive partition, you could get as
many partitions as surfaces instead of just one partition as needed.

For example, in Maya 2.5, if you were to select CVs of several surfaces,
create a lattice deformer with Exclusive advanced creation option checked
on, and specify a new name for the partition (select Deform > Create
Lattice ❒, click Advanced tab, check on Exclusive, and specify a new
partition name), you would get as many partitions as surfaces.

To correct this problem, Maya 3.0 now includes new advanced deformer
options. These new options are Partition to Use and New Partition Name.
Partition to Use lists all the existing partitions and a default selection Create
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New Partition. If you select Create New Partition, you can edit the New
Partition Name field to specify the name of a new partition. This workflow
eliminates the problem that can happen with multiple surfaces.

Note that these two new options (Partition to Use and New Partition Name)
replace the Exclusive Partition and Existing Partitions options.

MIRRORING SMOOTH SKIN WEIGHTS

You can now mirror smooth skin weights, either from one smooth skin
object to another, or within the same smooth skin object. Mirroring smooth
skin weights greatly speeds up the process of editing and fine-tuning skin
deformation effects. For example, you can perfect the smooth skin weighting
for a character’s right shoulder area and then simply mirror the weighting to
the character’s left shoulder. Mirroring smooth skin weights can save you a
lot of time, and greatly improves the overall skinning workflow.

To mirror smooth skin weights:

1 Select the smooth skin object(s), then select Skin > Edit Smooth Skin > Mirror
Skin Weights ❒.

2 In the Mirror Skin Weights Options window, specify the plane about which
you want to mirror (the Mirror Axis) as XY, YZ, or XZ.

Note that the planes are the planes of Maya’s global workspace axis, so for
the mirroring to work properly the skin objects (or character) should be
centered on the global axis, or at least aligned along the axes you want to
mirror about.

3 Specify the Direction of the mirroring as Positive to Negative (on) or
Negative to Positive (off).

4 Click the Mirror button.

The new MEL command for this feature is copySkinWeights, which carries
out both mirroring and copying.
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COPYING SMOOTH SKIN WEIGHTS

You can now copy smooth skin weights from one smooth skin object to
another, or from one group of smooth skin objects to another. As with the
new mirroring smooth skin weights feature, copying smooth skin weights
dramatically improves the overall skinning workflow. You no longer have to
tackle the tedious, uncreative task of painting several characters each in the
same way.

For example, suppose you have created a team of very similar characters for
a football game, and you’re at that point in the character setup process
where you have just skinned them all and are about to paint the smooth skin
weights to perfect the deformation effects. You first paint the weights of the
quarterback. Next you have to paint the weights of all the other players.
Instead of having to paint the players individually, you can copy what you
did for the quarterback to each of the other players. You might then want to
fine-tune the weights of the various other players, but by copying the
weights you have still saved yourself a lot of time. You can focus on the
creative challenges unique to the case of a particular character rather than on
doing the same type of painting over and over again.

• For best results, the skeleton of the character you are copying from and the
skeleton you are copying to should have the same structure. If the skeletons
are similar, Maya will still try to copy the weights. However, if the skeletons
are radically different, Maya may not be able to copy the weights.

• Also, for best results, the skeletons of each character should be in the same
pose during copying. If the orientation of the joints are not similar, the
copying can lack some precision, which means you may have to do some
touch up painting to the results.

• If the skin objects have different numbers of CVs, or if the ordering of the
CVs is different, the copying will intelligently take into account the
differences and provide the same type of weighting. This is very useful if
you want to apply the smooth skin weighting from a high-res character to a
low-res version of the character.

You can copy smooth skin weights between skin objects of different types:
for example, you can copy from a subdivision surface to a NURBS surface or
a polygonal surface.
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To copy smooth skin weights:

1 Select the two smooth skin objects (or two groups of objects)

2 Select Skin > Edit Smooth Skin > Copy Skin Weights.

The new MEL command for this feature is copySkinWeights.

HOLDING SMOOTH SKIN WEIGHTS

Typically, when you change (edit or paint) the weights of smooth skin
objects, the weights of one object can affect the weights of other objects. This
is because Maya considers the weights of all skin objects that are influenced
by a particular influence object to be relative to each other. Maya does this
by requiring that all the weights add up to one. When you change certain
weights, Maya can automatically change various other weights so that the
total of all the weights continues to be one. This allows Maya to know the
relative influences of the weights.

The process of scaling some numbers so they add up to one is called
“normalization.” By constantly normalizing weight values, Maya keeps track
of their relative influences.

Sometimes when you change the weights of smooth skin objects, you may
not want the weights of other objects don’t change. If you’ve perfected the
weighting of a particular object, you might want to make sure that its
weights are not going to undergo any normalization changes. Maya now lets
you “hold” the weights of particular smooth skin objects so that their values
don’t change when you are editing other smooth skin objects. You can hold
weights by:

• “Specifying weight holding when adding influence objects” on page 144

• “Editing weight holding of joints” on page 144

• “Editing weight locking of smooth skin influence objects” on page 144

• “Holding smooth skin influence weights from Component Editor” on page
144

Note that if you hold the weights of many objects at the same time, Maya
might not be able to normalize the rest of the weights properly, and you
could get an error message. In general, you should not hold the weights of
many objects at the same time. Typically, you would want to hold the
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weights of only one or two objects. However, if you don’t want to stop
holding the weights of any of the objects, you can turn off weight
normalization directly from Maya’s interface (see “Control of smooth skin
weight normalization” on page 145).

Specifying weight holding when adding influence objects
We’ve added two new options for locking weights. You set these options
when you set add influence options (Skin > Edit Smooth Skin > Add
Influence ❒). The displayed Add Influence Options window now includes
Weight Holding and Default Weight options. With Weight Holding’s Hold
Weights on, you specify that Maya hold the weights of the specified
influence object to their current value (or to a value specified in Default
Weight).

Editing weight holding of joints
You now specify whether a particular joint’s weights are locked using the
new Hold Weights option in the Smooth Skin Parameters section of the
Attribute Editor for the joint. Turn Hold Weights on to set the skinCluster’s
corresponding Hold Weights attribute on; turn it off to set the corresponding
Hold Weights attribute off.

Editing weight locking of smooth skin influence objects
You can specify whether a particular smooth skin influence object’s weights
are locked by setting the new Hold Weights option in the Smooth Skin
Parameters section of the Attribute Editor for the object. Turning on Hold
Weights sets the skinCluster’s corresponding Hold Weights attribute on;
turning it off sets the corresponding Hold Weights attribute off.

Finally, you can also change whether the Hold Weights settings for joints or
smooth skin influence objects are on or off by telling the Component Editor
to “hold” the weights.

Holding smooth skin influence weights from Component Editor
When you are directly editing joint smooth skin influence object weights
with the Component Editor, you can now quickly specify whether the
weights of particular joints or smooth skin influence objects can change.
Under the skinClusters tab, note the new Hold row.
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For each joint or smooth skin influence object, the value for Hold
corresponds to the skinCluster Lock Weights[n] attribute (and to the Lock
Weights settings for the Attribute Editor’s Smooth Skin Parameters). If Hold
is on, Maya holds weights at their current values when you modify the
weights of other influence objects. However, you can still modify the
weights by entering new values in the Component Editor.

In summary, you can use Hold to hold weights at their current values while
you modify the weights of other influence objects. However, you still can
change these values directly with the Component Editor.

IMPROVED SMOOTH SKIN INFLUENCE OBJECT BEHAVIOR

Beginning with Maya 2.5.2, smooth skinning’s skinCluster node includes a
new useComponentsMatrix attribute. This attribute enables you to improve
the component-based influence object behavior when the influence object is
on a skin that changes its scale. In Maya 2.5.2, this new attribute is off by
default so that the behavior of scenes created prior to Maya 2.5.2 are not
changed by default. However, in Maya 3.0, the attribute is now on by default
for all newly created smooth skinning (skinCluster) nodes. When the
attribute is on, the influence object uses a new deformation algorithm that
allows you to create a component-based influence object on a character that
changes scale.

To set the attribute, select the skinCluster node acting on the object and set
the useComponentsMatrix attribute to true in the Channel Box or Attribute
Editor.

CONTROL OF SMOOTH SKIN WEIGHT NORMALIZATION

You can now control whether Maya will normalize smooth skin weights
directly from Maya’s interface. Normalizing weights means scaling the
weights so their values all add up to one. Previously, you would have to use
the skinPercent command’s normalize option to control weight
normalization. Now you can do this without having to use MEL.

Select Skin > Edit Smooth Skin, and note the new Disable Weight
Normalization, Enable Weight Normalization, and Normalize Weights
options. These options allow you to turn normalization off or on, and to
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normalize weights. After skinning, you can specify normalization with the
skinCluster node’s new Normalize Weights attribute, which is included in
the Attribute Editor and the Channel Box.

NEW CREATE CHARACTER OPTIONS

Maya now includes new create character options (Character > Create ❒) that
you can use to exclude certain attributes from being keyable. In the Create
Character window, under All Keyable except, you can set the Translate,
Rotate, Scale, and Visibility attributes as all keyable or non-keyable. By
default, Scale and Visibility are on, so that by default only those attributes
are non-keyable. With these options, you can quickly control the number of
attributes included in a character as you create the character. This can save
you time, reduce the number of attributes listed in the Channel Box, and
help make your animation work more efficient.

NEW SUBCHARACTERS FEATURE

You can now define subcharacters within previously defined characters.
This is useful because you can now apply the power of Maya’s character
animation features to parts of a character’s hierarchy.

Creating subcharacters is similar to creating characters: you select a
character’s objects that you want to define as a subcharacter (for example,
the objects that make up the character’s face) and then select
Character > Create Sub-Character. The creation options for subcharacters are
the same as the options for creating characters.

NEW CHARACTER CHANNEL EDITING CAPABILITIES

When you create a character, the character set can include quite a few
channels (keyable attributes) that might not be pertinent to what you want to
animate. During creation you can have some control over what channels are
included with the new create character options (see “New create character
options” on page 146). You can now also add and remove channels after you
have created a character. To do so, use the new Character > Add To
Character and Character > Remove From Character selections.
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8 DYNAMICS

We’ve added the following new features and improvements to Dynamics in
Maya 3.0.

Summary of usability improvements

• “Usability improvements” on page 148

New features

• “New Volume emitters” on page 148

• “New Volume Axis field” on page 157

• “New Volume fields” on page 161

• “New particle caching” on page 164

Improvements to existing features

• “Improved particle rendering attribute control” on page 175

• “Improved particle cloud shader” on page 193

• “Improvements to particle lifespan” on page 197

• “Increased control over randomness” on page 200

• “Instancing strokes from Paint Effects” on page 202

• “Dynamics menu improvements” on page 203

• “Improvements to particle attribute editor” on page 205

• “Directional emission from curves” on page 205

• “New attributes for position of emitted particles” on page 205

• “Improvements to Turbulence field” on page 205

• “Changes to Air field defaults” on page 207

• “Fixes to particle scaling” on page 207

• “Changes to file loading” on page 207



WHAT’S NEW IN MAYA 3

148

DYNAMICS | 8
Usability improvements

• “New command line functionality” on page 208

USABILITY IMPROVEMENTS

For Maya 3.0, we’ve made it easier and faster to create effects with
Dynamics. Improvements include:

• Particle cache on save. This avoids run-up when loading files. See “New
particle caching” on page 164 for details.

• Reorganization of dynamics menus for greater ease of use and learning. See
“Dynamics menu improvements” on page 203 for details.

• Improvements to the particle attribute editor to make it easy to find all
relevant nodes (shaders, springs, etc.) affecting a particle object. See
“Improvements to particle attribute editor” on page 205.

• Pop-up help in all the field and emitter option boxes.

• Improved layout of field and emitter option windows so they match the
Attribute Editor.

• New attributes that make it easy to create random particle speeds without
using expressions. See “Increased control over randomness” on page 200 for
details.

• New control to restart emitter streams without using expressions (similar to
Power Animator’s time random feature). See “Increased control over
randomness” on page 200 for details.

• Simplification of particle lifespan controls. Easy workflow to generate
random lifespans without expressions. See “Improvements to particle
lifespan” on page 197).

NEW VOLUME EMITTERS

For Maya 3.0, we’ve added volume-controlled emission based on the
“volume lights” of Power Animator. In Maya, you don’t emit from a light,
like Power Animator but we’ve added attribute controls on the emitter to
give you similar functionality.

The volume emitters draw arrows to illustrate the speed values you have set.
These are not manipulators. You can turn them off, if you wish.
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Creating volume emitters
Volume emitters emit particles from a closed volume. We’ve provided five
volume shapes to choose from: cube, sphere, cylinder, cone, and torus.

To create a volume emitter:

1 Select Particles > Create Emitter ❒.

2 Under Basic Emitter Attributes, set the Emitter Type to Volume.

3 Under Volume Emitter Attributes, click Volume Shape and select a shape
from the menu.

4 Set the Volume Emitter attributes as desired. See “Setting volume emitter
attributes” on page 150 for information on the volume emitter attributes.

5 Click Create.

The implicit shape of the volume emitter is displayed on the screen. You can
move, rotate, scale, or shear the emitter.
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To hide the shape of the volume emitter:

• Select the emitter and select Display > Hide > Hide Selection.

Setting volume emitter attributes
In the Attribute Editor and the Create Emitter option window, attributes not
applicable to a volume shape are dimmed. However, the Channel Box does
not support dimming. We recommend you use the Attribute Editor to edit
emitter attributes until you become familiar with the attributes that apply to
each volume shape.

To set volume emitters’ attributes:

1 Select the emitter and display the Attribute Editor.

2 You can set the following volume and speed emitter attributes:

Volume Emitter Attributes

Volume Shape Specifies the shape of the volume.

Volume Offset
X, Y, Z Offsets the emitting volume from the location of the

emitter. If you rotate the emitter, you also rotate the offset
direction because it operates in local space.

Volume Sweep Defines the sweep of rotation for all volumes except cubes.

Note
You can’t deform the volume or use an arbitrary volume.

Tip
Now you can select the particle object and the Attribute Editor displays a
tab for the emitter.
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Section Radius (Torus only) Defines the thickness of the solid portion of
the torus, relative to the radius of the torus’s central ring.
The radius of the central ring is determined by the
emitter’s scale. If you scale the emitter, the Section Radius
will maintain its proportion relative to the central ring.

Die on Emission
Volume Exit If you turn this attribute on, the emitted particles die when

they exit the volume. Although this is a particle shape
attribute, you can initially set it using the Emitter options
window.

If you want to edit this attribute after you create the
emitter, display the particle shape attributes in the
Attribute Editor Volume Exit (under Emission Attributes).

Volume Sweep
of 180o

Volume Sweep
of 360o

Section Radius
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Volume Speed Attributes

The Volume Speed Attributes apply only to the initial velocity of the
particles. To affect particles as they move through the volume, use the
Volume Axis field (see “New Volume Axis field” on page 157).

Away From
Center Specifies the speed at which particles move away from the

center point of cube or sphere volumes.

Away From Axis Specifies the speed at which particles move away from the
central axis of cylinder, cone, or torus volumes.

Along Axis Specifies the speed at which particles move along the
central axis of all volumes. The central axis is defines as
positive-Y for cube and sphere volumes.

Around Axis Specifies the speed at which particles move around the
central axis of all volumes.

Random
Direction Adds irregularity to the direction and initial speed of the

particles Volume Speed attributes, somewhat like Spread
does for other emitter types.

Directional
Speed Adds speed in the direction specified by the Direction

XYZ attributes of all volume emitters.

Scale Speed by
Size If you turn this attribute on, when you increase the size of

the volume, the speed of the particles increases.

Display Speed Turns on the display of arrows indicating speed.
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Emitter attributes and Power Animator equivalents
If you are a Power Animator user, the following table summarizes the
emitter attributes and their equivalent settings in Power Animator.

Attribute Name Function Types of
emitters it
applies to

PA Equivalent

Basic Emitter Attributes

Emitter Type Determines the type of
emitter. There is a new
choice, Volume.

All emitters None

 Use Rate PP No change Omni,
Directional

None

Need ParentUV When turned on in surface
emitters, adds parentU and
parentV attributes to the
particle shape.

Surface None

Spread No change Directional,
Curve

None

 Rate No change All Particles/Sec

Scale Rate By Object
Size

If turned on (the default),
object size affects number of
particles emitted per frame.
If turned off, it does not.

All except
volume.
(Always turned
off in Volume
emitters.)

Turn off to make
Rate work as it did
in PA.
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Cycle
Emission=None
(timeRandom off);
Cycle
Emission=Frame
(timeRandom on)"

Restarts the random
number sequence of the
emission. If set to Frame,
the sequence is restarted
after the number of frames
specified by the
cycleInterval attribute.

All timeRandom. We
put the name
timeRandom
directly into the
value so former PA
users recognize it.
PA timeRandom on
is equivalent to
cycleEmission=
Frame;
cycleInterval = 1.

Cycle Interval Defines the interval
between reseeds (in frames)
for cycleEmission.

All See comments on
cycleEmission. This
attribute takes the
timeRandom
functionality
beyond where it
was in PA.

Basic Speed Attributes

Speed Same as now for all except
volume emitters. Does not
apply to volumes

All except
volume

Speed

Attribute Name Function Types of
emitters it
applies to

PA Equivalent



DYNAMICS | 8
New Volume emitters

WHAT’S NEW IN MAYA 3

155

Speed Random If set to a positive value, the
emitter generates random
speeds for each particle,
with Speed as the mean,
and speedRandom defines
the width of the
distribution. Each particle’s
speed will be a random
value between speed -
speedRandom/2 and
speed+speedRandom/2.

All Speed Range

Tangent Speed No change All except
volume

-

 Normal Speed No change All except
volume

-

Volume Emission Attributes

Volume Shape: Cube,
Sphere, Cylinder,
Cone, Torus

Determines extent of
volume where particles are
emitted. For the solids of
rotation (cylinder, cone, and
torus), the major axis of the
solid defines the action of
the volume speed
attributes. Note that the
major axis of the torus is
defined as the circle that
runs through the center of
the solid portion of the
torus, in the local XZ plane,
not the vertical axis.

All volumes Shape

Attribute Name Function Types of
emitters it
applies to

PA Equivalent
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Volume Offset Offsets the emitting volume
from the location of the
emitter. Operates in local
space; if you rotate the
emitter, you will also rotate
the offset direction.

All volumes None

Section Radius Defines thickness of solid
portion of torus. Same as for
polygonal torus primitive.
(Note: There is no radius
attribute; scale the object
up, using the scale
manipulator.)

Torus only torusRadius

Volume Sweep Defines sweep of rotation
for the solids of rotation,
same as in NURBS
modelling.

All volumes
except cube

Arc

Volume Speed Attributes

Away From Center Speed away from center
point of volume.

Cube, sphere concentric

Away From Axis Speed away from central
axis of volume. For
cylinder, for example, gives
component of velocity in
XZ plane.

Cylinder, cone,
torus

concentric

Along Axis Speed along central axis of
volume.

All volumes directional

Around Axis Speed rotating around
central axis of volume

All volumes radial

Attribute Name Function Types of
emitters it
applies to

PA Equivalent
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NEW VOLUME AXIS FIELD

The new Volume Axis field lets you move particles in various directions in a
volume. The motion imparted on the object is relative to the axis of the
volume.

You can use the Volume Axis field to create effects such as particles flowing
around obstacles, solar flares, mushroom clouds, explosions, tornadoes, and
rocket exhaust.

For example, you can specify the speed at which particles move around the
central axis of a volume. If you use a a cylinder volume shape, this can create
swirling gaseous effects.

 Random Direction Adds a random component
to the speed. This
components adds to the
others, so in effect it gives
some irregularity to the
direction and speed of the
particles, much like spread
does for other emitter types.

All volumes -

 Directional Speed Adds a component of speed
in the direction specified by
the directionX/Y/Z
attributes.

All volumes -

Scale Speed By Size If true, scaling the volume
up increases the speed of
the particles.

All volumes -

 Display Speed Turns on or off the display
of arrows showing speeds

All volumes -

Attribute Name Function Types of
emitters it
applies to

PA Equivalent
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The Volume Axis field provides most of the volume speed controls of the
volume emitter in the form of a field, and its attributes work just like the
corresponding volume emitter attributes. You can also invert the attenuation
(see the Invert Attenuation attribute on page 160).

Like the emitter, the volume field draws arrows to illustrate the speed values
you have set. These are not manipulators. As with the emitter, you can turn
them off, if you wish.

Creating volume axis fields
Volume axis fields affect particles and rigid bodies in an area defined by a
closed volume. We’ve provided five volume shapes to choose from: cube,
sphere, cylinder, cone, and torus.

To create a volume axis field:

1 Select Fields > Volume Axis ❒.

2 In the Volume Axis Options window, select a shape from the Volume Shape
pulldown menu.

If you set the Volume Shape to None, it disables the field.

3 Set the volume axis field attributes as desired. See “Setting volume axis field
attributes” on page 158.

4 Click Create.

The implicit shape of the volume axis field is displayed on the screen. You
can move, rotate, scale, or shear the field.

Setting volume axis field attributes
In the Attribute Editor and the Create Emitter option window, attributes not
applicable to a volume shape are dimmed. However, the Channel Box does
not support dimming. We recommend you use the Attribute Editor to edit
volume attributes until you become familiar with the attributes that apply to
each volume shape.

Note
You can’t deform the volume or use an arbitrary volume.
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To set volume axis field attributes:

1 Select the field and display the Attribute Editor.

2 You can set the following attributes:

Magnitude Specifies the strength of the volume axis field.

Attenuation Sets how much the strength of the field diminishes from
the central axis of the volume axis field.

A value greater than 0 makes the strength of the field
diminish to 0 at the edge of the volume. The greater the
value, the more rapidly the strength decreases.

A value of 0 makes the strength remain constant from the
central axis of the volume axis field to its edge (see also
the Invert Attenuation attribute on page 160).

Max Distance Sets the maximum distance at which the field has an
effect. You must also turn on Use Max Distance for Max
Distance to take effect.

Tip
Now you can select the particle object connected to the field and the
Attribute Editor displays a tab for the field.

Note
The Max Distance and Attenuation attributes operate in a special way for
the Volume Axis field. For all volume axis shapes except sphere, distance
(for both the Max Distance and Attenuation attributes) is defined as the
distance from the volume’s central axis to the point.

For cylinder, cone, and cube, the central axis is the positive Y axis. For
torus, the central axis is the ring in the center of the solid part of the torus.
The sphere volume is an exception— it uses the center point, not the center
axis (it works like the other fields).

This special definition of distance applies only to the Volume Axis field. It
does not apply to other fields even when they are using volumes.
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Volume Offset
X, Y, Z Offsets the volume axis field from the actual location of

the field.

Volume Sweep Defines the sweep of rotation for all volume shapes except
cube.

Section Radius Defines the thickness of the solid portion of a torus
volume shape.

Invert
Attenuation When you turn on Invert Attenuation and you have

Attenuation set to a value greater than 0, the strength of
the volume axis field is strongest at the edge of the
volume and diminishes to 0 at the central axis of the
volume axis field (see also the Attenuation attribute on
page 159).

Away From
Center Specifies the speed at which particles move away from the

center point of cube or sphere volumes. You can use this
attribute to create explosive effects.

.
Cylinder volume
axis field with
Attenuation set to 2
and Invert Attenuation
turned off. Notice the particles
are moving faster in the
center of the cylinder.

.
Cylinder volume
axis field with
Attenuation set to 2
and Invert Attenuation
turned on. Notice the particles
are moving faster in the
edge of the cylinder.
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Away From Axis Specifies the speed at which particles move away from the
central axis of cylinder, cone, or torus volumes. For torus,
the central axis is the ring in the center of the solid part of
the torus.

Along Axis Specifies the speed at which particles move along the
central axis of all volumes.

Around Axis Specifies the speed at which particles move around the
central axis of all volumes. When used in conjunction with
a cylinder volume shape, this attribute can create swirling
gaseous effects.

Directional
Speed Adds speed in the direction specified by the Direction

XYZ attributes of all volumes.

Direction X, Y, Z Moves particles in the directions specified by the X, Y, and
Z axes.

NEW VOLUME FIELDS

For Maya 3.0, we have added volume control of fields.You can select a
volume to define the region in space in which particles or rigid bodies are
affected by any field in Maya. The volume shapes we’ve added include cube,
sphere, cylinder, cone, and torus.

For example, if you create a Turbulence field and set its volume shape to
cube, only particles or rigid bodies within the region of the cube are affected
by the turbulence.

We’ve also added a new ninth field that uses the volume to define its motion
(see “New Volume Axis field” on page 157).

Tip
When working with volumes, it’s sometimes useful to set the Conserve
attribute to 0 in the particle shape. This keeps the particles within the
volume. Particles will not exit the volume unless other forces act on them
to make them do so. Also, see “Keeping particles inside the volume” on
page 164.
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Creating volume fields
Volume fields affect particles and rigid bodies in an area defined by a closed
volume. We’ve provided five volume shapes to choose from: cube, sphere,
cylinder, cone, and torus.

To create a volume field:

1 Select Fields fieldname ❒.

2 In the field’s options window, from the Volume Shape pulldown, select a
shape (other than None).

None means that the field acts as in previous versions of Maya, with no
volume.

3 Set the volume field attributes as desired. See “Setting volume field
attributes” on page 162.

4 Click Create.

The implicit shape of the volume field is displayed on the screen. You can
move, rotate, scale, or shear the field.

Setting volume field attributes
In the Attribute Editor and the Create Emitter option window, attributes not
applicable to a volume shape are dimmed. However, the Channel Box does
not support dimming. We recommend you use the Attribute Editor to edit
volume field attributes until you become familiar with the attributes that
apply to each volume shape.

To set volume field attributes:

1 Select the field and display the Attribute Editor.

Note
You can’t deform the volume or use an arbitrary volume.
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2 You can enter values for the following volume shape attributes:

Volume
Exclusion When Volume Exclusion is turned on, the volume defines

the region in space where the field has no effect on
particles or rigid bodies.

Volume Offset
X, Y, Z Offsets the volume from the location of the field. If you

rotate the field, you also rotate the offset direction because
it operates in local space.

Volume Sweep Defines the sweep of rotation for all volumes except cubes.

Section Radius Defines the thickness of the solid portion of the torus,
relative to the radius of the torus’s central ring. The radius
of the central ring is determined by the field’s scale. If you
scale the field, the Section Radius will maintain its
proportion relative to the central ring.

Tips on using volume fields

• The action of a vortex field is still controlled by its Axis attribute, even for a
Torus field. If you want a circular motion around the section axis of the
torus, use the new Volume Axis field (see“New Volume Axis field” on page
157).

• You cannot deform or tweak the field volume. You are restricted to the
volume types we provide—you can’t use general volumes.

• The field Max Distance attribute still applies with volumes.

Tip
Now you can select the particle object connected to the field and the
Attribute Editor displays a tab for the field.

Note
Offsetting the volume changes only the volume’s location (and therefore,
which particles the field affects). It does not change the actual field location
for purposes of computing field force, attenuation, etc.
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• There is no API support for volume fields in 3.0 but there is some support
for the Volume Axis field.

• There are no manipulators for any of the new field attributes in 3.0.

Keeping particles inside the volume
You can keep particles inside a volume by using a radial field that affects
only particles outside the volume you are interested in, and pushes the
particles back in. You can also use this procedure to keep particles inside an
emission volume.

1 Create the particles (or emitter) and the field whose volume you want the
particles to stay inside.

2 Select the particles and select Fields > Radial ❒.

3 Set the volume shape of the radial field to be the same as for the field you
created in step 1.

4 Turn on Volume Exclusion.

5 Set the radial field magnitude to a negative value.

Try a value which is about one-half the magnitude value of your first field,
but is negative. For example, if the first field has magnitude 10 or -10, use a
radial field magnitude of -5.

6 Parent the radial field to the first field, and reset the radial field’s transform
to be the identity.

This makes the radial field have the same volume as the original field.

Whenever particles move outside the original field volume, the radial field
pushes them back in. You may want to tune the radial field magnitude and/
or transform values to get the exact look you want.

NEW PARTICLE CACHING

We’ve added two new types of particle caching for Maya 3.0—particle disk
caching and particle start-up caching.

Particle disk caching lets you cache complete sequences to disk. You can use
the cache for batch rendering and playback. Disk caching has the following
advantages:
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• It lets you render more efficiently, especially when using multi-processor
batch rendering. Maya loads the particles from the disk cache instead of
re-computing them. This avoids the particle “run-up” at the start of the
render.

• It lets you play the scene faster and scrub in the time slider.

• You can also use particle disk caching to create different caches for the same
scene. This lets you create and quickly play back variations on a scene.

Particle start-up caching avoids run-up. It’s used when you save your scene at
some frame greater than the start frame (it’s on by default). In the past, Maya
needed to “run up” your animation in such a situation. The start-up cache
lets you save your particle data for that one frame to disk so no run-up is
needed.

Particle disk caching

Specifying where the cache files are stored
In Maya 3.0, we’ve added an additional workspace directory for particles. By
default, this is given the name particles. You can specify your workspace
particles directory using the Project Editor, the same as for all the other
workspace directories.

If you are using an old workspace from a previous version of Maya, Maya
creates the particles directory for you the first time you create a particle disk
cache.

The disk cache files are stored in subdirectories of the particles directory.
You can specify what subdirectory name you want to use by entering the
name in the Cache Directory box of the Particle Disk Cache Options window
(see “Setting particle disk cache options” on page 167). Before each new
caching operation, Maya automatically deletes any cache files existing in the
specified subdirectory.

Determining the frame range
If Maya can’t find a cache file for the given frame, but finds cache files both
for frames greater and lesser than the current frame it is evaluating, it
interpolates between them. If the frame difference is large, you see the
results of interpolation rather than the results of solving frame by frame.
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In simple cases, to evaluate a given frame, Maya usually needs the particle
cache files only for that frame. However, Maya may need to access the state
of particles at some other frame in order to resolve expressions, rigid body
motion, motion blur, etc. If you are in doubt, we recommend caching out all
frames. For example, if you want to render starting at frame 100, cache all
frames up to 100 as well.

Creating a particle disk cache
After you have created a particle disk cache, Maya uses the cached particle
data, no matter what changes you make to your scene, until you explicitly tell
it not to.

For example, if you cache the scene, then apply a gravity field to a particle
object, you will not see any effect from that field because Maya is using the
cached particle motion. To see the effect, you must turn off Use Particle Disk
Cache (see “Editing particle disk cache settings” on page 168).

However, if you make a change that does not alter per-particle attributes,
such as changing the render type from blobby to streak, you will see the
change without turning off Use Particle Disk Cache.

To create a particle disk cache:

1 Select Solvers > Create Particle Disk Cache.

Maya plays through the scene once using the current time slider playback
range and writes out cache files. Maya does not re-draw the screen during
this playback. If you want to cache a different range, you can either change
the current range of your time slider or use the range in Render Globals (see
“Use Render Globals Range” on page 168).

Maya must play the scene through once to create the cache. If you don’t
want to wait through the playback, you can interrupt it by pressing the ESC
key, but the cache won’t be created.

Tip
We suggest you name your scene before creating a particle disk cache;
otherwise, Maya saves the particles in a directory named untitled.
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2 After creating the cache, save your scene so any settings you made to the
Particle Render Cache Option window get saved with the scene. Otherwise
Maya might not know to look for your cache or might not be able to find it.

When you create the cache in the above manner, Maya creates a cache for all
particles in the scene. If you want to cache some particles objects and not
others, see “Caching a single particle object” on page 172.

Setting particle disk cache options
You can set the following particle disk cache options before creating the
cache. These options affect all subsequent caching operations.

To set the particle disk cache options:

1 Select Solvers > Create Particle Disk Cache ❒.

2 Set the following options:

Cache Directory Specifies where to store the disk cache. See “Specifying where the cache files
are stored” on page 165.

• If you don’t specify a name, Maya uses a directory that matches your current
scene name. If that directory doesn’t exist, Maya creates it.

• If you specify a name that is different from the current scene name, Maya
prompts you to be sure you want to use it. It is generally preferable to use
the name of the scene because if two scenes are cached in the same directory,
a new caching operation overwrites the old cache.

This same prompt appears if you cache a scene, save the scene under a
different name, and re-cache the scene. When you try to re-cache, Maya
detects that the cache name now differs from the scene name and asks you to
confirm.

• Don’t specify an absolute directory name. Maya considers the cache
directory always to be relative to the Particles directory of your workspace.
However, you can set the Particles directory of your workspace to an
absolute directory name using File > Project > Edit Current.

Important!
Be sure to save your scene after creating the cache. Otherwise, Maya won’t
know about the cache when batch rendering.
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• The name of the directory used is stored with your scene, so if you change
the name of the scene, Maya is still able to find your disk cache. The name is
stored in the dynGlobals node (see “Editing particle disk cache settings” on
page 168).

Use Render
Globals Range If you turn on this option, Maya caches particles for the frame range

specified in the defaultRenderGlobals instead of for the current playback
range. Turn on this option if you plan to use the render globals range in your
render.

Editing particle disk cache settings

To edit particle disk cache settings:

1 Select Solvers > Edit Oversampling or Cache Settings.

The Attribute Editor for the dynGlobals node is displayed.

2 Expand the Particle Disk Cache settings.

3 Enter values for the following:

Use Particle
Disk Cache This determines whether Maya uses the cache. When you create a cache, this

attribute is turned on automatically. Turn off Use Particle Disk Cache if you
don’t want Maya to use the cache. For example, if you have made changes to
certain emitter attributes that affect playback, such as speed or emitter type,
turn off this attribute to see the effect of your changes. You can also recreate
the cache.

Cache Directory This attribute lets you specify the directory where Maya looks for the cache.
You can use this to choose which of several saved caches you want to use
(see “Playing back different caches” on page 169).

For example, you could cache one simulation to a directory named cache1
and another to a different directory called cache2. Enter the name of the
Cache Directory you want Maya to use.

Important!
Be sure to save your scene after editing any of these values. Otherwise,
Maya won’t know about them when batch rendering.
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This directory is always relative to the Particles directory of your workspace.
Don’t type an absolute path name.

Entering a name here does not re-create the cache—you do that using
Particle Disk Cache > Create. Entering a name here also does not change the
name of your existing cache directory. If you want to rename your directory,
use your operating system.

Min Frame Cached,
Max Frame Cached These attributes record the minimum and maximum frames that were stored

at the most recent caching operation. You can’t enter values here—these
attributes are for your information only. Because they describe the most
recent caching operation, if you choose a different cache directory using
Cache Directory, the values in Min Frame Cached and Max Frame Cached
won’t necessarily correspond to what is stored in that directory.

Playing back different caches
You can use particle disk caching to create different caches for the same
scene. This lets you create and quickly play back variations on a scene.

To create and play back different caches:

1 Create your scene and name it.

2 Select Solvers > Create Particle Disk Cache ❒.

3 Enter a name for the Cache Directory or leave the default name, which is the
scene name.

4 Click Create to create the cache.

5 Make any changes to your particles.

6 Select Solvers > Create Particle Disk Cache ❒.

7 Enter a new name for the Cache Directory and click Create.

Tip
Solver > Create Particle Disk Cache ❒ also has a Cache Directory attribute.
If you enter a value in the dynGlobals Attribute Editor, that value becomes
the default for the option box. Any different value that you enter in the
option box is displayed in the dynGlobals node.
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8 Continue this process to create as many caches as you want.

9 To choose a cache for playback, select Solvers > Edit Oversampling or Cache
Settings, and enter the cache name in the Cache Directory box.

10 Press the play button to see the scene play back from the specified cache.

Re-creating the cache
Once you have created the cache, Maya uses that cache until you tell it not
to. It ignores any changes in emission, forces, etc. on that particle object.

If you change something in the scene that alters per-particle attributes, you
must re-create your cache in order to get correct renders. Maya writes out
the disk cache only when you select Create Particle Disk Cache. That menu
item does not turn on a “caching state.” This is an important difference
between memory caching and disk caching. Maya does not automatically
update or re-create your disk cache.

To re-create your cache:

• Select Solvers > Create Particle Disk Cache.

You don’t need to re-create the cache if you make a change that does not
alter per-particle attributes. For example, you could change a particle shape’s
render type from blobby to cloud, save the file, and re-render. Or you could
change keyframed colorRed/colorBlue/colorGreen attributes. In both these
examples, you would not need to re-create the cache because the attributes
involved are not per-particle.

Be careful, however, because attributes such as colorRed can indirectly affect
per-particle attributes. In the previous examples, if you had a per-particle
expression on some particle object that made use of the render type or
colorRed as an input, the results of that expression would be affected, so you
would need to re-create the cache.

Particle disk cache files
Maya saves one cache file for each particle for each frame. These binary files
have the extension .pdc, which stands for particle data cache. This is a new
file format for Maya 3.0. Maya uses the dynExport command to write these
files.
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You can’t read .pdc files. If you want to output particle data files you can
read, see the online documentation in the dynExport command for
information on outputting .pda and .pdb files, and also the gifts/readpdb
directory. See Appendix A, “PDC File Format” for information on writing
your own reader.

Deleting cache files
There is no way to delete cache files or directories from within Maya. Delete
them using your operating system.

Caching tips

Ramps

If you are animating per-particle rendering attributes by ramps, and you
change those ramps, you’ll see the change in playback even if the cache is
enabled. This also applies to changes in hardware display/rendering
attributes such as pointSize. To avoid any confusion, turn off the Use Particle
Disk Cache attribute before you make changes to your scene, and re-create
your cache just before you render.

If you are animating any attribute with expressions, or animating
rampPosition, rampVelocity, or rampAcceleration with ramps, any changes
you make to those expressions or ramps will not be visible in playback as
long as the cache is enabled. Turn off Use Particle Disk Cache.

Particle collisions with rigid bodies

If you have a rigid body being driven by particle collisions, and you
disk-cache the particles, the rigid bodies will no longer evaluate correctly. In
effect, the caching takes away the dynamic properties that allow the rigid
bodies to evaluate and they can’t detect the collisions any more. To cache
such a scene, first bake out the rigid bodies (see “Baking rigid bodies,”
below), then disk-cache the particles. The same limitation and same
workaround apply to in-memory caching as well.
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Baking rigid bodies

The particle disk cache always applies to particles only. It does not apply to
rigid bodies. In most cases, rigid bodies can compute their positions without
needing to do a run-up. If you encounter any problems in this area, you can
resolve them by baking out your rigid bodies, using the bakeResults
command.

For example, to bake out rigidBody1 for frames 1 to 100, do this:

bakeResults -t "1:100" -simulation true rigidBody1;

You can’t use the bakeResults command to bake out particle motion. It bakes
out animation channels, such as translateX/Y/Z, not particle positions.

Even if unbaked rigid bodies do cause a run-up, the run-up will go faster if
your particles are cached, because the particles are loaded from the disk
cache instead of being recomputed.

Caching a sequence in two parts

You may find it necessary to cache two parts of a sequence separately. For
example, if you cache frames 1 to 45 in one place, and frames 46 to 90 in
another place, you must be sure that the two caches “line up” so there is no
discontinuity from 45 to 46.

Make sure that the animation and dynamics the first time you cache are
consistent with the second. Make sure you didn’t add or change anything, or
have something changed for you.

In particular, if you have expressions that use the MEL rand() function, you
must make sure your expressions are properly reseeded (see “Reproducing
Randomness” in Chapter 5 of Using Maya: Expressions).

Caching a single particle object

Using Solvers > Create Particle Disk Cache caches all particle objects in the
scene. You can cache a specified object from the command line using the
dynExport command (see the online Command documentation for
information on the dynExport command).

You can also get this same result by using your operating system to delete
the cache files for all objects you don’t want read from the cache.
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Caching only certain attributes

By default, all attributes are cached. However, you can cache only certain
attributes using the dynExport command (see the online Command
documentation for information on the dynExport command).

Particle start-up caching
The particle start-up cache lets you save files at frames greater than the start
frame without doing a run-up. It saves a copy of the particle shape’s
attribute values in a different file than the particle disk cache files.

Using the start-up cache
Using the start-up cache lets you save and quickly re-load scenes at frames
greater than the start frames of your particle objects. If you always save your
files at the particles’ start frames, you can turn off Save Start-up Cache to
save disk space.

The disk space used for the particle cache is determined by how many
particles are in your scene at the frame saved, and how many attributes they
have. Likewise, the time savings at file load is determined by how heavy
your scene is and how long it takes to play back. There is no simple
formula—you must assess the trade-off between file size and time savings.
Because of this, we made this a preference you can turn on or off. It is turned
on by default.

To use the start-up cache:

1 Select Window > Settings/Preferences > Dynamics.

2 Turn on Save Start-up Cache for Particles.

When this option is turned on (the default), Maya automatically saves the
start-up cache for all your particles every time you save the file. Unlike
particle disk caches, you don’t have to create the start-up cache explicitly
every time.

When the file is loaded (in either interactive or batch mode), the particle
shape’s current state is read from the start-up cache and no run-up occurs. If
Maya cannot find or read the cache file, it gives you a warning and then runs
the scene up. This would happen, for example, if you copied the file into a
different workspace and did not also copy the start-up cache. If you re-save
the scene at that point, Maya re-creates the start-up cache.
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Location and names of start-up cache files
Start-up cache files are kept in a subdirectory of your workspace particles
directory. Each scene has a separate start-up cache directory.

Normally, Maya names this directory by appending _startup to your scene
name. For example, if your scene is called myScene, Maya puts the start-up
cache in a directory called myScene_startup.

However, if you have created a particle disk cache for that scene, Maya uses
the name of that particle disk cache directory in place of your scene name.
For example, if you store your particle disk cache in a directory safePlace,
Maya calls the start-up cache safePlace_startup. (By default, the disk cache
directory name is the same as the scene name.)

If you first disk cache the scene under one name, then rename the scene, any
start-up file written uses the first name (because that’s the name your disk
cache was created under). We recommend that you name your scene when
you start and don’t change it.

Using start-up caches with batch rendering
Maya uses the start-up cache in batch rendering only when you are
rendering the exact frame for which the start-up cache was saved. It does not
use the start-up cache when you are rendering other frames. When
rendering sequences, or rendering in distributed or multiprocessor fashion,
we recommend that you use the particle disk cache and not rely on the
start-up cache.

Using disk caches and start-up caches
If you have both a particle disk cache (a complete sequence) and a start-up
cache, the particle disk cache takes precedence. Maya searches for caches in
the following order:

• Maya first looks for a particle disk cache.

• If it can’t find a particle disk cache, it looks for a start-up cache.

• If it can’t find either, it runs the scene up (only when rendering).

If you have a particle disk cache, but you want to save a state that is
different from what’s stored in the particle disk cache, be sure to turn off Use
Particle Disk Cache before saving the file. Otherwise, Maya saves what was
in the disk cache, using that cache until you specify not to use it.
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IMPROVED PARTICLE RENDERING ATTRIBUTE CONTROL

In Maya 3.0, we’ve improved control over particle rendering attributes. A
new particle rendering utility node, called the Particle Sampler Info node,
replaces the four utilities previously available in the Hypershade window
under Create > Utilities > Particle. These were particle color mapper,
transparency mapper, incandescence mapper, and age mapper.

The Particle Sampler Info node lets you:

• Use particle object attributes (including ramps and particle expressions) to
drive particle shader attributes on a per-particle basis.

• Use rgbPP and opacityPP attributes in software rendering. Previously, you
could use these attributes only in hardware rendering.

• Have more control over texture placement nodes for particles, including the
use of per-particle attributes for texture coordinates.

Using the Particle Sampler Info node
The Particle Sampler Info node provides particle shape attributes to either a
particle shader, texture, or texture placement node for use in software
rendering.

When you use a Particle Sampler Info node, you connect one or more of its
outputs to attributes of a particle shader or texture placement node. This
tells the shader to get the per-particle information from the Particle Sampler
Info node. It also tells the Particle Sampler Info node which attributes to get
from the particle shape.

Types of outputs
The Particle Sampler Info node has the following types of outputs:

Tip
If you believe you have rendering problems that are due to the start-up
cache, create a particle disk cache for the complete sequence.
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• A uv coordinate output designed to drive the uv coordinate input for texture
placement nodes. This is somewhat like the output from the old particle
utilities, but more powerful.

• Outputs that correspond to predefined attributes of the particle shape, such
as Rgb PP. These are used to drive attributes of shaders or textures on a
per-particle basis.

• Ten predefined outputs for user-defined attributes that you can add to the
particle shape. Five are scalar attributes and five are vector (see “Using
user-defined attributes” on page 190).

• Two outputs, birthPosition and worldBirthPosition, that correspond to two
optional attributes (with the same name), which you can add to your
particles.

The Particle Sampler Info node has no association with any particular
camera, unlike the samplerInfo node. The two nodes are similar in that both
provide data to shaders to use in shading samples. They are different in that
much of the data the samplerInfo node provides is camera-dependent.

Creating a Particle Sampler Info node
This is the general procedure for creating a Particle Sampler Info node. These
are general steps—we’ve included examples of specific tasks in “Examples
of using the Particle Sampler Info node” on page 177.

To create a Particle Sampler Info node:

1 Create your particles and set the Render Type Cloud, Blobby, or Tube.

2 Determine which particle attribute you want to use to drive a shader
attribute.

Note
You still have to add attributes to the particle shape, where applicable. The
Particle Sampler Info node just gets attribute values, if they are present. For
example, making a connection from the Particle Sampler Info node
parentU to the shader tells the sampler info node to get parentU if it’s
there, and use it in the shading. You still have to add parentU to the
particle shape.
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3 Add that attribute to the particle shape, if necessary.

4 Select the particles and display the Attribute Editor. Click the Attribute
Editor tab for the shader, and find the shader attribute you want to drive
with the particle attribute.

5 Click the (map) button next to that attribute to display the Create
Render Node window.

6 In the Create Render Node window, select the Utilities tab. Under Particle
Utilities, click the Particle Sampler Info button.

This displays the Connection Editor with the Particle Sampler Info node on
the From side and the shader on the To side.

In the case of color, transparency, and incandescence, the Connection Editor
is not displayed when you click the Particle Sampler Info button. Instead,
Maya creates the new Particle Sampler Info node for you, and automatically
makes the following default connections:

• outColor -> color

• outTransparency -> transparency

• outIncandescence -> incandescence

7 Using the Connection editor, connect Particle Sampler Info node attributes to
shader node attributes however you wish.

The connection between the particle shape and the Particle Sampler Info
node is implicit— you don’t actually make it. The only connection you make
is between the Particle Sampler Info node and the shader.

Examples of using the Particle Sampler Info node
To help you use the Particle Sampler Info node: we’ve included the
following examples to help you learn how to use the Particle Sampler Info
Node to achieve some commonly used effects. Refer to “Setting Particle
Sampler Info node attributes” on page 187 provides complete information on
Particle Sampler Info node attributes

• “Example: Using the particles’ age to color particles:” on page 178

• “Example: Using the Particle Sampler Info node with rgbPP:” on page 181

• “Example: Creating fading particles:” on page 184

• “Example: Creating smoke:” on page 185



WHAT’S NEW IN MAYA 3

178

DYNAMICS | 8
Improved particle rendering attribute control

Strategies for using the Particle Sampler Info node
There are two basic strategies for using the Particle Sampler Info node to
control your particles:

• The first strategy uses the Particle Sampler Info node to drive a texture
placement node. The setup is:

The advantage of this strategy is two-fold: you can use any type of texture,
and you can use the controls on the texture placement node.

• The second strategy uses the Particle Sampler Info node to feed per-particle
attributes, such as rgbPP, directly to the shading or texture node. The setup
is:

The main advantage of this strategy is that it lets you control the per-particle
attribute using expressions, ramps, or the Component Editor and see the
result in the shading or texture node.

Using the Particle Sampler Info node to drive a texture
placement node
Here is an example of the first strategy—using the Particle Sampler Info
node to drive a texture placement node, which textures the shader color. In
this example, we’ll use the particles’ age to color the particles.

Example: Using the particles’ age to color particles:

1 Make a cone emitter emitting upwards with a speed of 8, set the particles’
Lifespan Mode to Constant with a Lifespan of 2, and set their Render Type
to cloud.

To do this, you can copy the following Mel commands from the online help
and paste them into the Script Editor:

Particle
Sampler
Info node

Texture
placement Texture Shader

Shading nodeParticle
Sampler
Info node

or
Texture node
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emitter -pos 0 0 0 -type volume -r 100 -vsh cone -alx 8;
particle;
connectDynamic -em emitter1 particle1;
setAttr particleShape1.lifespanMode 1;
setAttr particleShape1.lifespan 2.0;
setAttr particleShape1.particleRenderType 8;

2 Select the particle shape and display the Attribute Editor.

3 Select the particleCloud tab, and press the button next to Life
Incandescence to display the Create Render Node window.

4 Click the Ramp button.

This creates a new ramp, a texture placement node, and a Particle Sampler
Info node. Life Color isn’t actually an attribute at all—it’s just a control in the
Attribute Editor that tells Maya to set up these connections to color for you.

5 Play the scene back and render.

You’ll see the particle color textured by the ramp as the particles age.

Now we’ll change some of the controls in the Particle Sampler Info node.

6 Select the particle shape and display the Attribute Editor. Click the
particleSamplerInfo1 tab.

Tip
Incandescence is the same as color but is self illuminating so you don’t
need to add a light.
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7 Turn on Inverse Out Uv and re-render.

The colors are reversed—instead of the particles changing from red to green
to blue, they change from blue to green to red.

Now we’ll change a control on the texture node.

8 In the particle shape Attribute Editor, click the particleCloud tab.

9 Click the Input Connection button next to Life Incandescence.

10 Click place2DTexture1.

11 Set Noise UV to 1.0 and 1.0 and re-render.

Noise is applied to the placement of the ramp creating randomness in the
red, green, and blue particles.

12 Change Noise UV back to 0.0 and 0.0.
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13 Click Load Attributes and display the particle shape Attribute Editor.

14 Change Lifespan Mode to Live forever.

15 Select the tab for the Particle Sampler Info node.

16 Change the Out Uv Type to Absolute Age and set a normalization value of 1.

17 Rewind, play about 100 frames, and render.

Notice that the particles cycle through the ramp more than once as they age.

Using the Particle Sampler Info node with per-particle
attributes
Here is an example of the second general strategy—driving shader color
directly with rgbPP. Use this strategy when you want to use expressions or
ramps driven by something other than age.

Example: Using the Particle Sampler Info node with rgbPP:

1 Make a cone emitter emitting upwards with a speed of 8, set the particles’
Lifespan Mode to Constant with a Lifespan of 2, and set their Render Type
to cloud.

To do this, you can copy the following Mel commands from the online help
and paste them into the Script Editor:

emitter -pos 0 0 0 -type volume -r 100 -vsh cone -alx 8;
particle;
connectDynamic -em emitter1 particle1;
setAttr particleShape1.lifespanMode 1;
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setAttr particleShape1.lifespan 2.0;
setAttr particleShape1.particleRenderType 8;

2 Select the particle shape and select Fields > Create Gravity.

3 With the particle shape selected, display the Attribute Editor.

4 Under Add Dynamic Attributes, click Color.

The Particle Color window is displayed.

5 Click Add Per Particle Attribute and click Add Attribute.

6 In the Attribute Editor, click the particleCloud1 tab.

7 Next to the Incandescence attribute (not Life Incandescence), press the

map button to display the Create Render Node window.

8 Click the Utilities tab, and under Particle Utilities, click the Particle Sampler
Info button.

This automatically creates a new Particle Sampler Info node and connects its
color output to the incandescence. (If you had already created a Particle
Sampler Info node, you could use that and connect it directly, in the
connection editor.)

9 Select the particle shape tab in the Attribute Editor. Under Per Particle
(Array) Attributes, right click on rgbPP and select Runtime Expression.

10 In the Expression Editor, enter the following expression:

particleShape1.rgbPP = << mag(particleShape1.velocity) /
10, 0.0, 1 -mag(particleShape1.velocity)/10 >>;

This tells Maya to change the particle color from blue to red as the velocity
increases.

11 Play about 75 frames and render.

Tip
We used an expression in this example to achieve a specific effect.
However, you don’t have to use expressions with the Particle Sampler Info
node. You can also use a ramp, which will give you a different effect.
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Notice that the Particle Sampler Info node outIncandescence output
automatically uses rgbPP if that attribute is present. If there is no rgbPP, it
uses colorRed/colorGreen/colorBlue, if they are present.

The advantage of using rgbPP is that you can set or animate its value in any
of the ways available for per-particle attributes, and see the results in
software. You will also then be using the same color attribute in both
hardware and software rendering.

However, rgbPP can be animated only with expressions and ramps (or the
component editor). The advantage of using Life Color is that you get a
texture placement node and can make use of its additional controls. In
particular, you can use any texture, not just a ramp, since you get both u and
v control. You can connect any compatible Particle Sampler Info node
attribute you want.

Setting transparency with the particle info node sampler
As with color, Life Transparency is still available. It uses the outUvCoord
attribute of a Particle Sampler Info node in conjunction with a texture
placement node, instead of a particle transparency mapper and age mapper.

And as with color, you can use per-particle attributes such as opacityPP
directly. You use the outTransparency attribute of the Particle Sampler Info
node.
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Example: Creating fading particles:

1 Make a volume emitter with the shape of a flat cylindrical disk, with Speed
Away From Axis equal to 1 and other speeds zero.

To do this, you can copy the following Mel commands from the online help
and paste them into the Script Editor:

emitter -pos 0 0 0 -type volume -r 100 -sro 0 -spd 1 -vsh cylinder -afx 1;
scale -r 5 0.5 5 ;
particle;
connectDynamic -em emitter1 particle1;

2 Reduce emission rate to 50 and set the particle radius to 1.5.

3 Set the particle’s render type to cloud. Click Add Attributes for Current
Render Type and set the Radius to 1.5.

4 In the Attribute Editor, under Add Dynamic Attributes, click Opacity. Turn
on Add Per Particle Attribute and click Add Attribute.

5 Under Per Particle Attributes, right click on opacityPP and select Runtime
Expression.

6 In the Expression Editor, enter the following expression and click Create:

opacityPP = 1 / (0.01 + mag( position ));

(We added 0.01 in the denominator to avoid dividing by zero when particle
is at the origin.)

7 Select the particleCloud shader tab and click the map button for
Transparency (not Life Transparency).

8 In the Create Render Node window, click the Utilities tab and click the
Particle Sampler Info button (under Particle Utilities).

This create a new Particle Sampler Info node and connects its
outTransparency to the shader transparency. As with color and
incandescence, the outTransparency output automatically uses opacityPP, if
that attribute is present, otherwise it uses opacity.

Opacity and transparency have an inverse relationship: the more opaque
something is, the less transparent it is. If you connect the outTransparency
output of the Particle Sampler Info node, then the node automatically
converts opacity to transparency so that you get the right result.
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9 Add a light, play the scene about 50 frames, and render. A camera view from
the top, looking down the y-axis, is best. The particles will appear more
transparent the further they are from the origin.

Controlling noise on a per-particle basis
You can connect any per-particle attribute to the attribute in the shader that
you want to control. You can then put an expression on the per-particle
attribute to control it exactly the way you want.

Example: Creating smoke:

1 Make a simple curve emitter emitting particles vertically upward.

To do this, you can copy the following Mel commands from the online help
and paste them into the Script Editor:

curve -d 3 -p -6.861087 0 7.36723 -p -2.43128 0 2.685247 -p 2.685247 0 -2.43128
-p 6.968851 0 -6.714884 -k 0 -k 0 -k 0 -k 1 -k 1 -k 1 ;

emitter -type curve -r 100 -sro 0 -nuv 0 -cye none -cyi 5 -spd 6 -srn 0 -nsp 0
-tsp 0 -mxd 0 -mnd 0 -dx 0 -dy 1 -dz 0 -sp 0 ;

particle;
connectDynamic -em emitter1 particle1;

2 Set the particles’ lifespan mode to random range. Set lifespan to 2 and
lifespanRandom to 2.

3 Set the particle rendering type to cloud. Click Add Attributes for Current
Render Type, and set Radius to 1.5.
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4 Select the particleCloud tab, and set the color to a light gray color, or any
other color you like.

Now we’ll use any per-particle attribute you aren’t using. For example, we
have no need of parentU and parentV here, so we’ll use that.

5 Select Attributes > Add Attributes. Click the Particle tab in the Add attribute
window.

6 Select parentU and click Add. Select parentV and click Add. Click OK.

7 Right-click on either parentU or parentV, select Runtime Expression, and
add the following expression:

parentU = 0.7 + 2*(age/finalLifespanPP)
parentV = age /(1.5*finalLifespanPP);

We want the particles to get less dense and more noisy as they age, the way
smoke would.

8 In the particleCloud Attribute Editor, click the map button next to
noise.

9 The Create Render Node window, click the Utilities tab and click the Particle
Sampler Info button (under Particle Utilities).

The Connection Editor is displayed.

Note
For simplicity, we used parentU and parentV in this example because they
are easily added and weren’t being used. However, you can use any
dynamic attribute—even those you define yourself.

Tip
We used an expression in this example to achieve a specific effect.
However, you don’t have to use expressions with the Particle Sampler Info
node. You can also use a ramp, which will give you a different effect.
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10 Connect the Particle SamplerInfo node’s parentU to Noise, and connect
parentV to Density.

11 Add a light. Play the scene to about frame 60 and render.

Setting Particle Sampler Info node attributes
The Particle Sampler Info node attributes provide all the functionality of the
old particle color mapper, transparency mapper, incandescence mapper, and
age mapper.

To set the Particle Sampler Info node attributes:

1 Select the particle shape and display the Attribute Editor. Click the
particleSamplerInfo tab.

The particle shape Attribute Editor includes a tab for each Particle Sampler
Info node associated with that shape. The two sections in the Attribute
Editor: Common Read-Only attributes and More read-Only attributes list the
attributes that the node knows about by default. You can also use your own
user-defined attributes.

2 You can set the following attributes:

Out Uv Coord By default, Out U Coord and Out V Coord give you the normalized age of
the particles. The outUv Coord attribute is comprised of Out U Coord and
Out V Coord.They are provided in this form so that you can use this
attribute to control texture placement nodes.

Out Uv Type Specifies how Out Uv Coord is computed. You have four choices:
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Normalized
age The particle’s age divided by its finalLifespanPP. The

finalLifespanPP attribute is used for the particle’s age.
This works in all Lifespan Modes of the particle shape. But
if Lifespan Mode is set to Live forever, all lifespans are
effectively infinite, so normalized age is always zero.

Out UV Type set to Normalized age is the default; you
don’t need to set a use relative age attribute as you did in
previous releases.

You can use this output of the Particle Sampler Info node
regardless of whether the particle shape has an
ageNormalized attribute.

Absolute age Uses the Normalization Value attribute of the Particle
Sampler Info node, in place of finalLifespanPP. This is
useful if you want to have the particles live forever, or if
you want to cycle through a texture a number of times
during the lifespan.

Parent UV and
Collision UV Use these attributes of the particle shape as the u and v

values. This gives you more power than you had before,
because in addition to age, you can use these attributes to
define your own texture coordinates for the particles.

Normalization
Method (Applies only if the Out UV Type is set to Absolute age.) Specifies how to apply

Absolute Age and particle age to compute the Out UV Coord. The age
ranges from 0 to the value specified by the Normalization Value.

Oscillate As the particle’s actual age increases, Maya cycles through
the normalization range repeatedly. For example, if the
normalization value is 2, as the particle age, Maya uses the
following values:

Actual particle age Value Maya uses

0 0

0.1 0.1
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Clamp If the actual age exceeds the normalization value, Maya
uses the normalization value. For example, if the
normalization value is 2, as the particle age, Maya uses the
following values:

Normalization value (Applies only if the Out UV Type is set to Absolute age.) Specifies upper value of
the age range. For example, if you use a value of 2, the particles’ ages range
from 0 to 2.

Inverse Out Uv Uses 1 - Out Uv Coord in the final computation (instead of Out Uv Coord).
For example, if you have out Uv Type set so that the value is 1 when the
particle is born and 0 when it dies. This applies to all Out UV types.

1 1

2 2

2.1 0.1

3 1

4 2

actual age value to use

0 0

0.1 0.1

1 1

2 2

2.1 2

3 2

4 2

Actual particle age Value Maya uses
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Re-using a Particle Sampler Info node
In most cases, you need to make a new Particle Sampler Info node only the
first time you want to map attributes for a particular shading node. If you
decide later that you want to map another attribute, you can re-use the
existing Particle Sampler Info node.

By reusing the Particle Sampler Info node, you can reduce clutter. However,
if you want different attribute settings for different purposes. you can use
more than one Particle Sampler Info node.

To re-use a Particle Sampler Info node:

1 Select Window > Hypershade.

2 Locate the Particle Sampler Info node on the left side of the Hypershade
window.

3 Middle-mouse-drag it on top of the shading node.

The Connection Editor is displayed.

Using user-defined attributes
In addition to its many outputs for predefined attributes of the particle
shape (such as position, radiusPP, and so on), the Particle Sampler Info node
includes ten predefined outputs for user-defined attributes, which you can
add to the particle shape.

Five of these are scalar and five are type; they are called userScalar1PP,
userVector1PP, and so on.

If you connect one of these to a shading attribute, the Particle Sampler Info
node looks for an attribute of the identical name on the particle shape, and
fetches those values. For example, if you connect userScalar1PP to shader
noise, then the Particle Sampler Info node looks for a userScalar1PP attribute
on the particle shape.

Tip
If you are not sure which Particle Sampler Info node goes with which
shader, put the shader in the workspace and use Graph | Up and
Downstream Connections to display the associated utility nodes.
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Adding user-defined attributes
To use any of these attributes, you must add an attribute of the identical
name and type to the particle shape.

You cannot add attributes of arbitrary names and use them with the Particle
Sampler Info node. However, you can assign the value of any of your
attributes to the one that the particle sampler info node recognizes, using an
expression.

To add a user-defined attribute:

1 Create an emitter.

2 Display the Attribute Editor and select Attributes > Add Attributes.

3 Click the Particle tab in Add Attribute window.

4 Scroll down the list and select a userScalar#PP or userVector#PP attribute.
Click Add.

Example 1

Suppose you want to make the particles more noisy the further they are
from the origin. To do this you would animate the noise parameter of the
shader as a function of the magnitude of the particle’s position vector.

1 Create an emitter.

2 Select the particle shape and set the Render Type to Cloud.

3 Display the Attribute Editor and select Attributes > Add Attributes.

4 Click the Particle tab in Add Attribute window.

5 Add the userScalar1PP attribute to the particle shape.

6 Assign it a value with this runtime expression:

    userScalar1PP = mag(position);

Tip
Although this example uses an expression to achieve its effect. you can use
a ramp to animate userScalar1PP.
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7 Select the particleCloud1 tab in the particle Attribute Editor.

8 Click the (map) button next to the Noise attribute.

9 In the Create Render Node window, select the Utilities tab. Under Particle
Utilities, click the Particle Sampler Info button.

10 In the left column of the Connection Editor, select UserScalar1 PP and in the
right column, select Noise. Click Close.

This connects the Particle Sampler Info node’s User Scalar1 PP output to the
shader’s Noise input.

The Particle Sampler Info node will fetch the value of userScalar1PP and
pass it to noise. In this example, we assigned userScalar1PP a value using an
expression, but we could have used a ramp to assign it a value.

11 Add a light, play the scene. Select Window > Rendering Editors > Render
View and test render.

Example 2

Suppose you already had an attribute called myNoise, which you had already
written an expression on or connected to a ramp, and you wanted to pass
this value to the Particle Sampler Info node. Then you would do this:

1 Add the userScalar1PP attribute to your particle shape.

2 Add this as the last line of your expression:

    userScalar1PP = myNoise;

3 Select the particleCloud1 tab in the particle Attribute Editor.
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4 Click the (map) button next to the Noise attribute.

5 In the Create Render Node window, select the Utilities tab. Under Particle
Utilities, click the Particle Sampler Info button.

6 In the left column of the Connection Editor, select UserScalar1 PP and in the
right column, select Noise. Click Close.

Now the Particle Sampler Info node fetches userScalar1 PP, which gets the
value of myNoise, as desired. Do this with expressions and do not try to
simply connect myNoise to userDefined1PP.

IMPROVED PARTICLE CLOUD SHADER

We’ve greatly enhanced the look and control of the particle cloud shader for
Maya 3.0 in several ways. The new particle cloud shader has Noise turned
on by default and the default value has been increased from 0 to 0.75, which
is good for volumetric clouds.

The clouds also look brighter with raytracing turned on because more light
is allowed by default to penetrate. We’ve added a new Translucence
attribute (with a default of 0.5) that gives you additional control over how
much light can generate a particle.
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To give you more control over the particle cloud shader, we’ve added the
following attributes:

Roundness Controls the noise’s irregularity. The smaller the value, the less rounded the
shape.

Translucence Specifies a scaling factor for density that is used only to compute shadows.
The larger the translucence value, the more light penetrates. The formula is:

Roundness=1 Roundness=0
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density * (1 - translucence)

Noise Anim Rate Specifies a scaling factor that controls the rate of built-in noise changes
during an animation.

Solid Core Size Determines the size of the core, which is the area where the particle is
opaque.

Diffuse Coeff Controls how much of the light in the scene is reflected from the particles.
Most materials absorb some of the light falling on them, and scatter the rest.

The default value is 0.0. If you set this to 1.0, all the light falling on the
material is reflected. Use a high value when you are creating dense clouds. If
you set this to 0.0 (the minimum), no light is reflected and no surface
shading occurs.

The surface color is modulated by the transparency. This value can be
greater than 1.0, so the surface property can still appear even when the
material is transparent.

Surface Color Specifies the basic color of the particle cloud surface (as opposed to the
inside of the cloud). Diffuse Coeff must be set to a value greater than 0 to
enable this option.

Bump Mapping Makes the surface appear rough or bumpy by altering surface normals
(during rendering) according to the intensity of the pixels in the bump map
texture. Diffuse Coeff must be set to a value greater than 0 to enable this
option.

A bump map does not actually alter the surface. A silhouette of the surface
will appear smooth.

Translucence=0.4 Translucence=0.6
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Translucence Coeff Simulates the way light diffusely penetrates through translucent objects.
This means that when light shines on one side of the object, the other side is
partially illuminated. You can use this to create effects such as clouds, fur,
hair, marble, jade, wax, paper, leaves, etc. If you set Translucence Coeff to 0
(the default), no light shows through the object. If you set Translucence
Coeff to 1, all the light shows through. Diffuse Coeff must be set to a value
greater than 0 to enable this option.

Surface Shading
Shadow Determines if the surface shading is combined with the pre-illumination,

which contains shadows, if enabled (see the Filter Radius attribute). Diffuse
Coeff must be set to a value greater than 0 to enable this option.

Filter Radius Volumetric particles use pre-illumination, which evaluates the lighting at
each particle’s center by default. This can sometimes cause popping if the
illumination changes too fast in an animation, and is especially noticeable if
Surface Shading Shadow is on.

Filter radius lets you filter the pre-illumination results so the value at each
particle’s center will be the average of all the pre-illumination results within
the filter radius. Higher values increase render time but produce smoother
images.

This cloud shader uses
Surface color and Surface
Shading Shadow to create
an explosion.
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IMPROVEMENTS TO PARTICLE LIFESPAN

Maya 3.0 contains a significant improvement to make it easier for you to
work with lifespans and to generate random particle lifespans without using
expressions.

In past versions of Maya, the only way to generate random lifespans for
particles was to add lifespanPP and then write a creation expression for it.
You also had to reseed the Mel random number stream for your expressions.

Now you never need to add lifespan attributes. The lifespan attributes are
already in the particle and displayed on a new section in the particle
attribute editor. Also, you can now generate simple random lifespans
without expressions.

In Maya 3.0, all particle shapes have the following attributes:

• lifespanMode

• lifespan

• lifespanPP

• finalLifespanPP

The first two attributes are per-object and the other two are per-particle.
These attributes are used together to control lifespan, as follows:

• If you set mode to Live Forever, all particles live forever, regardless of the
values of the other lifespan attributes.

• If you set mode to Constant, all particles get a lifespan equal to lifespan, and
the other lifespan attributes are ignored.

• If you set mode to Random Range, the particle object generates a random
lifespan for each new particle. This lifespan is uniformly distributed with
Lifespan as the mean and Lifespan Random as the width of the distribution.

For example, if Lifespan is 3 and Lifespan Random is 2, then each particle is
will have a lifespan between 2 and 4. The resulting value is stored in an
attribute called finalLifespanPP (see“Understanding finalLifespanPP” on
page 198).

• If you set mode to lifespanPP only, then the lifespanPP attribute (with any
associated expressions) is used to control all particles’ lifespan.
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Understanding finalLifespanPP
A new read-only per-particle attribute called finalLifespanPP stores the final
result of lifespan computations no matter what mode you are using. The
particle shape uses finalLifespanPP to kill particles and to drive ramps.

• In Constant or Random Range mode, the value computed from lifespan/
lifespanRandom is stored for each particle.

• In lifespanPP only mode, the value of lifespanPP is stored.

• In Live Forever mode, a maximum-value float is stored.

You cannot set the value of finalLifespanPP yourself in any way (for
example, with an expression, ramp, or component editor). Like age, it is an
attribute the particle shape computes for you. But you can read its value (but
not assign its value) in an expression (see “Using lifespan in expressions” on
page 198).

In Random Range mode, lifespans are determined for each particle when it
is born, and are stored in finalLifespanPP at that time. If you change lifespan
or lifespanRandom, it affects new particles but does not affect particles that
are already born. If you rewind and re-play, all particles are affected.

Using lifespan in expressions
If you are using any lifespan mode other than lifespanPP only, then you
should use finalLifespanPP on the right-hand side of all expressions. For
example, in past versions of Maya you might have written:

opacityPP = 1 - age/lifespanPP;

This works in Maya 3.0, but only if have you have lifespan mode set to
lifespanPP only. The better way to write this expression now is:

opacityPP = 1 - age/finalLifespanPP;

This works for all lifespan modes because finalLifespanPP always stores the
actual lifespan being used for the particles in all modes.

Existing expressions that refer to lifespanPP work as long as you set the
lifespan mode to lifespanPP only. You need to have finalLifespanPP on the
right-hand side only if you wish to use Constant or Random Range mode.
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If you always used lifespanPP anyway and will not use any other mode, you
can read (but not set its value) in your expressions. You need to use
finalLifespanPP only if you intend to make use of one of the other lifespan
modes.

Using Random Range mode
The random number stream for Random Range lifespan mode is maintained
inside the particle object and is automatically reseeded when you rewind.
You do not have to reseed it yourself.

If you want to specify the seed, it is stored in the attribute generalSeed.
Normally this is not something you have any need to control.

File compatibility
Files written out by previous versions of Maya will load and play correctly.
Maya detects the presence of lifespan, lifespanPP, and useLifespanPP
attributes and sets lifespanMode accordingly. If your particle shape is
missing either lifespan or lifespanPP, Maya adds it for you.

Script compatibility
Scripts written for previous versions of Maya will work with two changes:

• You need to add a line to your script setting the lifespan mode.

• You need to remove all addAttr statements for lifespan and lifespanPP.
These addAttr statements will produce errors with Maya 3.0 because those
attributes are already present in all particle objects.

For example, if you have a script which writes an expression on lifespanPP,
you need to remove any addAttr statements for lifespanPP, and you need to
add this line:

setAttr <shape name>.lifespanMode 3

Note
While lifespan = 4, lifespanRandom = 2 is mathematically equivalent to the
expression lifespanPP = 3 + rand(2), these two methods of setting lifespan
will not give identical results because the random number streams are
different.
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to set the lifespan mode to lifespanPP only. The lifespanPP attribute will
govern particles’ lifespan and your expressions will work.

Deleting Lifespan and LifespanPP
We strongly recommend that you never delete the lifespan and lifespanPP
attributes.

INCREASED CONTROL OVER RANDOMNESS

We’ve added a number of attributes to give you more control over
randomness in the emission without using expressions. Some of these are
based on Power Animator attribute such as Time Random.

The new particle lifespan attributes also give increased control over
randomness (see “Improvements to particle lifespan” on page 197).

New Basic Emitter Attributes

Scale Rate by
Object Size If you turn on this attribute, the size of the object emitting

the particles affects the rate of particles emitted per frame.
The larger the object, the greater the rate of emission.

If you turn off this attribute, the emission rate is absolute,
as it was in Power Animator, instead of relative to object
size.

Need Parent UV
(NURBS) (Surface emitters only.) If you turn this on in the Emitter

Options window (before you create the emitter), Maya
adds parentU and parentV attributes to the particle shape
(NURBS only) and sets the needparentUV attribute to on.
You can use parent UVs to drive the value of some other
parameter such as color or opacity.

Warning
Do not use pre-Maya 3.0 versions of clip effect scripts with Maya 3.0. Maya
3.0 has new versions of clip effects.
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If you turn this on in the Attribute Editor or Channel Box
(after you create the emitter). Maya sets the needParentUV
attribute to on, it does not add the attributes.

Cycle Emission Cycle Emission is familiar to Power Animator users as
Time Random. We’ve extended it in Maya so you can also
create simple cycles for games work.

Cycle Emission lets you restart the random number
sequence of the emission. If you set it to Frame, the
sequence is restarted after the number of frames you
specify in Cycle Interval (same as Time Random on).

If you set it to None, the random number generator is not
restarted (same as Time Random off).

Cycle Interval Defines the interval in frames for restarting the random
number sequence when using Cycle Emission.

New Basic Emission Speed Attribute

Speed Random The Speed Random attribute lets you add randomness to
your emission speeds without using expressions. If you
set Speed Random to a positive value, the emitter
generates random speeds for each particle. The Speed
value is the mean speed; Speed Random defines the range
of the speed variation.

Each particle’s speed is a random value between:

Speed - Speed Random/2
Speed + Speed Random/2
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INSTANCING STROKES FROM PAINT EFFECTS

You can now use strokes from Paint Effects as instanced objects for particles.
The image below was created using Paint Effects strokes instanced to
particles.

See Using Maya: Paint Effects for information on painting in your scene, and
see “Instancing animated geometry to particles”in Using Maya: Dynamics for
information on instancing.

Centering strokes on particles
When you instance an object to a particle, the local origin of the object is
instanced to the particle. With spheres and cubes, the local origin is the
center of the object.

With the NURBS curves that comprise the strokes in Paint Effects, however,
the local origin is not directly related to the geometry of the curve. No
matter where you actually draw the curve, its origin is the world origin. For
example, if you draw a short stroke in the workspace at position 5,0,5 to get
a single flower and instance it to a particle object, the flowers will be offset
from the particles by 5,0,5.
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To center the Paint Effects geometry on your particles, there’s a few things
you can do. The obvious one is to start your curve at the origin.
Unfortunately, this is hard to do in regular Paint Effects mode because you
draw the curve, instead of placing down the CVs with grid snapping. We
suggest the following procedures:

To center instanced strokes on particles-method 1:

1 Draw your curve near the origin.

2 Unhide the curve.

3 In component mode, select all of the CVs in the curve and use the Translate
tool to move the CVs so the base of Paint Effects geometry (like the base of
the flower) is at the origin.

You move the CVs instead of the transform because the top-most translation
and rotation of the instanced hierarchy is ignored.

To center instanced strokes on particles-method 2:

1 Group the stroke.

2 Move the transform of the stroke so that the base of the Paint Effects
geometry is at the origin of the new group node.

3 Instance the group instead of the stroke.

This has the same effect as moving the CVs.

DYNAMICS MENU IMPROVEMENTS

We have made some improvements to the Dynamics menus for version 3.0.
To summarize the changes, we:

• consolidated entries in the Field menu

Tip
Turn on Tube Completion. This lets you make a very short stroke while the
tube continues to grow until it reaches the end of its number of segments.
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• eliminated the Connect menu and moved its relevant entries to more
appropriate places

• changed some of the menu labels to make it easier to understand for
first-time users

For those of you already familiar with Dynamics menus from previous
versions, the following is a guide to the changes.

Old menu item New name or new workflow

 Fields > Create... Fields > fieldname. The Add menu entries are gone.
The new entries are the equivalent of the old Create.
These entries no longer fail if you have certain
inapplicable entries set in the option box.

 Fields > Add ... Create the field, then use Fields > Attach to Selected
Object as Source

 Particles > Add Emitter  Particles > Emit from Object

 Connect/Add > Connect to Field  Fields > Affect Selected Object

 Connect/Add > Connect to Emitter  Particles > Use Selected Emitter

 Connect/Add > Connect to Collision  Particles > Make Collide

 Connect/Add > Connect to Time  Particles > Connect to Time

 Connect/Add > Add to Owner  Fields > Attach to Selected Object as Source

Tip
To find the location of any menu item, choose Help > Find Menu and type
the menu name you want to find. The search is not case-sensitive. It
accepts wildcard characters (*), but if the menu was renamed or removed,
type the name in full.
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IMPROVEMENTS TO PARTICLE ATTRIBUTE EDITOR

We’ve made it easy to find all relevant nodes such as springs, fields, and
shaders affecting a particle object. When you select a particle object and
display the Attribute Editor, you’ll see tabs for the relevant nodes associated
with that particle object.

For example, if your particle render type is set to Cloud and you select the
particle object and display the Attribute Editor, you’ll see a tab for the
particleCloud shader. If you change the render type. the Attribute Editor
does not refresh. You must reselect the particle object.

DIRECTIONAL EMISSION FROM CURVES

You can now set the Direction X, Y, and Z attributes for curve emitters.

NEW ATTRIBUTES FOR POSITION OF EMITTED PARTICLES

We’ve added two new optional attributes that you can add to emitted
particles—birthPosition and worldBirthPosition.

The birthPosition attribute stores the position at which each particle was
born in the particle’s local space. The worldBirthPosition attribute stores the
position at which each particle was born in world space.

IMPROVEMENTS TO TURBULENCE FIELD

We’ve improved the Turbulence field to make more realistic clouds and
gases.

In previous versions of Maya, the Turbulence field had a a single (scalar)
attribute called Phase that caused a disruption in the Z direction. In Maya
3.0, the Turbulence field has three attributes Phase X, Phase Y, and Phase Z,
which cause disruption in the corresponding directions.

The Phase manipulator for the Turbulence field now manipulates Phase Z,
so it has the same effect as in previous releases. There are currently no
manipulators for Phase X and Phase Y.
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Backward compatibility

Old scenes with the Turbulence field will load correctly in Maya 3.0. The old
Phase attribute get copied to the new Phase Z. The -phase option on the
turbulence command still works (for backward compatibility) and is
equivalent to the new -phaseZ.

The API function set for Turbulence accesses Phase Z, so code written using
that function set will have the same effect as in previous releases.

New attributes
In addition to the phase attributes, we’ve added two noise attributes and an
interpolation type to make more realistic turbulence.

Noise Level
To get a more natural, irregular look, you now have the option of telling the
Turbulence field to do more than one lookup into the noise table. The Noise
Level is the number of additional lookups you want done. A value of 0 does
only one lookup and is equivalent to previous versions of Maya. The total
turbulence value is a weighted average of the lookups.

Noise Ratio
Noise Ratio is the weighting of successive lookups. The weights are
cumulative. For example, if you set Noise Ratio to 0.5, then successive
lookups are weighted 0.5, 0.25, and so on. Noise ratio has no effect if the
Noise Level is set to 0.

Interpolation Type
In previous versions of Maya, the Turbulence field did a linear interpolation
between values in the noise table. This could create noticeable breaks along
lines of force. You now have the option of using quadratic interpolation for a
smoother look. Quadratic interpolation does require noticeably more
execution time. You set interpolation type in the Attribute Editor or Channel
Box.
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CHANGES TO AIR FIELD DEFAULTS

We’ve changed the defaults of two option boxes in the Air field in Maya 3.0
to make it to work better with volumes:

• Inherit Rotation is not turned on

• Direction is now 0,1,0

This will not affect any existing files or scripts.

FIXES TO PARTICLE SCALING

Particle rendering in Maya 3.0 now correctly handles the situation of
transforms on the particle object:

• In previous versions, scaling of particle or camera transforms did not
correctly affect the radius of cloud particles. This has been fixed.

• In previous versions, scaling of the particle shape was not handled correctly
if the particle shape’s isDynamic attribute was set to false. This has been
fixed.

CHANGES TO FILE LOADING

In past versions of Maya, if you saved a file at a time greater than the start
time, particles would automatically run up when the file was loaded
(requiring that the scene be played forward to the current time). In Maya 3.0,
this is no longer true. Particles will run up in this way only if you have
turned on Run Up To Current Time under Dynamics Preferences (Window >
Settings/Preferences > Preferences > Dynamics).

If you haven’t turned on this preference, your scene will load at the desired
frame, but the particles will not run up (and will not, in general, be in the
correct positions). To see your particles, you need to rewind and play
forward.

A warning message appears to remind you to do this. You’ll most likely get
this message when loading pre-3.0 scenes into Maya 3.0. If you play the
scene forward to the desired frame and save the scene using Maya 3.0 (with
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Save Startup Cache for Particles turned on, which happens by default), the
message won’t appear anymore and your particles will load at the correct
positions.

NEW COMMAND LINE FUNCTIONALITY

Reading particle PP array attributes into an array variable

We have added a new option, -array, to the getParticleAttr command. The
-array option lets you query a block of data from particles all at once. For
example, you can return an array containing the positions of all particles in a
given particle object or component. This can be useful for writing
expressions and scripts. See the online command documentation for
getParticleAttr.
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9 RENDERING

In Maya 3, both Maya Complete and Maya Unlimited customers have
unrestricted use of the Maya Batch Renderer. Up to 9,999 supported licenses
are provided at no extra charge. Universal rendering is available for both
IRIX and Windows NT users.

With this release of Maya, we’ve added new features and improvements to
the rendering environment. The following describe Maya 3.0’s new
rendering features and improvements:

General improvements

Image quality improvements

• “New Area lights” on page 211

• “Displacement mapping improvements” on page 214

• “Crackless tessellation” on page 216

• “Raytrace Shadow transparency improvement” on page 217

Performance improvements

• “Multi-threaded shadow maps” on page 217

• “Multi-threaded interactive rendering” on page 217

• “Ray tracing” on page 219

• “Speed” on page 219

Hypershade/Visor improvements

• “New Hypershade File menu” on page 219

• “Hypershade Edit menu changes” on page 220

• “Hypershade menu bar changes” on page 220

• “Easier directory access from the Visor panel” on page 222
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• “Texture assignment improvement” on page 223

Polygonal texture mapping improvements

• “Multitexturing” on page 223

• “Baking shadows” on page 224

New Layered Texture Node

New Movie Texture

New Paint Textures Tool

• “Paint Textures Tool and texture naming” on page 232

• “About switch nodes and painted textures” on page 233

• “Using the Paint Textures Tool” on page 234

• “Masking polygonal faces while painting” on page 235

• “Painting and IPR rendering” on page 236

• “Determining stamp spacing and brush depth” on page 239

• “Selecting and painting attributes” on page 240

• “Placing painted 2d textures” on page 245

• “Assigning, saving, and reloading textures” on page 246

2D/3D Integration enhancements

• “Render Layer management” on page 249

• “Render Layer/Pass Control” on page 250

• “Render Pass management spreadsheet” on page 251

New Render Globals Field Options
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GENERAL IMPROVEMENTS

• You can now software render subdivision surfaces (for Maya Unlimited only).

• In Maya 3.0. a “-rep” command line option in batch rendering has been
added to avoid rendering onto a filename that already exists.

• Modifications have been made to improve the camera dolly and track when
zoomed in.

• Image view can now save to non-IFF image formats.

IMAGE QUALITY IMPROVEMENTS

The following lists the rendering improvements to image quality for this
release of Maya.

New Area lights
Area lights are two-dimensional rectangular light sources.You can use area
lights to simulate the rectangular reflections of windows on surfaces. An
area light is initially two units long and one unit wide. You re-size and place
area lights in your scene using Maya’s transformation tools.

Specular highlight size and orientation

1 Position and scale the Area light using Maya transformation tools (such as
standard or light-specific manipulators, through the Channel Box, Attribute
Editor, etc.).

2 Use the IPR window to view the specular highlight interactively.

Tip
Make sure you use a specular material (any material other than Lambert).
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Soft lighting distribution

The size and orientation of the area light icon controls the light distribution.
A large area light emits more light. The light can be non-proportionally
scaled to modulate the distribution. The farther away the object is from the
light, the less light is cast onto the object.

Realistic shadows

You can achieve realistic shadows using raytracing. Select Raytracing in the
Render Globals window, then select Use Ray Trace Shadows in the area
light's Attribute Editor. Again, the size and orientation of the light control
the shadow color distribution.

A car lit by area lights.

Notice the long thin highlights.

Lit and shaded by Sanjay Bakshi
Model by Dua Xiong

Ball lit by area lights.

produced by the area light

The color of the lights are set
to imitate color bleeding.
Notice the soft blues and reds

on the sides of the ball.

Image by Josh Cameron
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Depthmap shadows also work, but you cannot create shadows that vary
from hard to soft. Adjust the filter size to control the uniform softness of the
shadow.

Optical effects

Any light that is visible to the camera lens can produce an optical effect (or
light glow) on the film. This is also true for area lights. In Maya 3, we’ve
improved Maya's postprocessing so that optical effects for an Area light
reflect the shape of the Area light. This is particularly evident in a halo effect.

Note
You may have to increase the number of sample rays to ensure high
quality shadows. This can be expensive.

Notice how the shadow dissipates
as the receiving surface sees more

Pillars illuminated by an area light.

of the Area light.

The camera is oriented to look directly

A Linear Halo Type is selected

into the Area light.

in the OpticalFX Attribute Editor

The Post Process OpticalFX utility
is linked to the Area light.
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Displacement mapping improvements
Displacement mapping can now capture all the details of the displacement
map and result in good tessellation quality. Additionally, this improvement
means that you do not have to implicitly add a bump node. The following
are examples of the new and improved feature-based displacement mapping
functionality.

Example 1

The image on the left is rendered using Maya2.0. The image on the right is
rendered by the new feature-based displacement map. The object in this
simple test is a NURBS plane with a wavy ramp texture used as
displacement-map.

Maya 2.0 produced 9522 triangles to generate the left image. The feature-
based displacement map needed 1326 triangles for the right image. With this
new improvement, Maya only tessellates the surface where needed.

Maya 2.0 displacement mapping. Maya 3.0 displacement mapping.
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Example 2

The following illustration shows a rendered surface without the
displacement map (on the left) and the texture used to displacement map the
surface (on the right).

The image on the left shows the final tessellation mesh illustrating where the
triangles are concentrated. Use Lighting/Shading > Displacement to Polygon
to see the triangles in the view. Once you are done viewing the result, you
can select the mesh and backspace to delete it. The image on the right
displays the final rendered image.

Notice how tightly the mesh becomes only where the texture is finer in
detail.
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Example 3

In this example, a NURBS cube was mapped with a simple 2D file stone
texture then displacement mapped to provide a realistic looking 3D stone
wall.

Crackless tessellation
The tessellation of shared curves between adjoining surfaces results in no
cracks between the adjoining surfaces if the shared curves are the same.
Turn on Smooth Edge in the object’s Attribute Editor to view the result.

Before displacement mapping.

Hypershade view.

After displacement mapping.
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Raytrace Shadow transparency improvement
Maya can now alternate refractions improving the quality of Raytrace
Shadow transparency. See the following illustrations:

PERFORMANCE IMPROVEMENTS

Multi-threaded shadow maps
Shadow map generation at the beginning of rendering is now fully multi-
threaded. With multiple processors, this provides significant speed
improvements. The improvement depends on the complexity of the scene
and number of shadows casting lights.

Multi-threaded interactive rendering
Maya 3.0 provides multi-threaded interactive rendering in the Render View.
The same type of performance gain is true for the batch renderer.

You can now specify the number of CPUs used for interactive rendering can
in the Memory and Performance Options section of the Render Globals
window. This value is saved with the scene which can be very helpful
should you have MP problems.

Result pre-Maya 3.0 Result in Maya 3.0
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By default, all available CPUs are used. If toggled off, the slider below the
option is enabled.

The slider can be dragged from values 1 to 8, but larger values up to 256 can
be entered if needed. Entering a value of 0 or turning the option off enables
all CPUs for interactive rendering.

Batch Render window and Multi-thread interactive rendering

There are no changes to the batch renderer. However, if you want to use an
MP batch render, specify the number of processors to use in the Batch
Render window or use the -n flag.

Notes
• If IPR is in use, the number of CPUs cannot be changed until the

current IPR session is closed. The following warning displays:

// Warning: IPR will need to be closed
before this change in CPUs will take
effect. //

• There is no environment variable to set the number of threads of
CPUs. Setting MAYA_IPR_THREADS no longer has an effect.

Default setting:

Slider and field
enabled when

Use all available CPUs
toggled on.

toggled off.
Use all available CPUs
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Ray tracing
Ray tracing performance has been improved up to 40%.

Speed
• Across-the-board 5 to 10% speed improvements.

• Additional across-the-board 5 to 10% speed improvements on IRIX.

• File I/O is faster the first time an image is written or read.

• Reduction in memory usage for poly structures.

HYPERSHADE/VISOR IMPROVEMENTS

• The Hypershade panel background is now black by default.

• Import and Export Selection menu items have been added to the
Hypershade.

• Set Default Shading Group and Parent Texture to Selected items are now
available in the Hypershade.

• A Rearrange Graph button is now included in the Hypershade menu bar.

• The feature is now the default operation.

• You can now access your directories from the Visor panel. You can create a
folder in the Visor that displays the files for any directory on your disk.

• Maya now provides predefined swatch sizes for the Visor panel.

New Hypershade File menu
These menu items let you import or export textures, lights, or rendered
scenes to your directory. The file browser opens to a specific directory
within the current project. You can point the file browser to any directory.

Hypershade
menu bar
File menu Right mouse click

File menu
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Import Reads elements from another file and loads them into the
current file.

Export
Selection Exports the selected item into a new file. The file browser

opens to its best guess directory, but can browse to any
directory, or cancel, before exporting.

Hypershade Edit menu changes
The Set Default Shading Group and Parent Texture to Selected items are
now available in the Hypershade Edit menu.

Set Default
Shading Group This setting sets the highlighted shading group as the

default shading group. All new geometry is shaded with
the default shading group. Changing the default shading
group does not change the color of existing geometry,
only geometry created after the change. The default
shading group is not a Hypershade preference, and is not
saved when you end the Maya session.

Parent Texture
to Selected
items Requires that you highlight a 3D Texture Placement and

select geometry in the view. Creates a connection between
the placement and the geometry so that translating the
object does not result in the object swimming through the
texture.

Hypershade menu bar changes
The Hypershade menu bar has been updated and a new button, Rearrange
Graph, has been added.

Note
If you deform an object, this option will not prevent the swimming. To
solve this situation, either use reference objects or Convert to File Texture.
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Rearrange
Graph Also found in the Hypergraph’s Graph menu, this handy

button is now readily accessible from the menu bar. It
rearranges the nodes in the current layout so you can see
all the nodes and networks without overlaps.

Clear Before
Graphing This Options menu item clears the Hypershade layout

every time you drag a new node into the Hypershade.
Previously you had to toggle this option on. It is now the
default operation.

Hypershade

Previous Next

Show Upstream Connections

Show Downstream Connections

Show Up and Downstream Connections

Layout menu

Visor

Clear View

Rearrange Graph

Graph Materials on
Selected Objects
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Easier directory access from the Visor panel
It is now easier to access your Maya files from any directory. Just click the
right mouse button in the Visor panel and select Add New Disk Folder to
link to your directories. Select a folder (directory) from the browser and drag
your icons to the Hypershade panel to either open a file or import a texture.

To remove a folder, place the cursor in the directory area or highlight the
directory name, right mouse click and select Remove this folder.
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Texture assignment improvement
You can now assign textures directly to selected objects and components in
the view through the Hypershade.

Select the objects or components in the view, right-click on a texture swatch
in the Hypershade, and select Assign Texture's Material to Selected Objects
from the pop-up menu. The texture is assigned to the selected objects and
components in the view.

If the texture does not have an associated material, it automatically creates a
Lambert material, assigns the texture to the Color channel, and continues
with the assignment.

POLYGONAL TEXTURE MAPPING IMPROVEMENTS

Multitexturing
Multitexturing is the layering and blending of multiple textures using a
distinct UV set for each layer. You can now create and edit multiple UV sets
for working with multitextured objects, which can be viewed in hardware
shading display mode and software rendered.

New UV sets can be created and named when using polygonal UV
projection tools.

Use the New Layered Texture Node node to manage multiple textures. You
can drag and drop file textures onto this node using the middle mouse
button, and RGB and alpha connections are made. Alternatively, you can
drag textures into the texture field of the Layered Texture node’s Attribute
Editor.

UV set editing is managed through the Relationship Editor using UV-centric
or texture-centric management of UV sets. In the Relationship Editor, you
can duplicate UV sets, as well as remove and rename them, and UV sets can
be hidden and shown individually.

Note
If a texture is associated with multiple materials or any other ambiguous
shading network, the operation will fail.
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See Chapter 4, “Polygonal Modeling” for more information.

Baking shadows
You can now use Convert to File Texture to bake shadows. A new option,
Bake Shading Group Lighting, bakes the lights that illuminate the selected
surface into the new image file when you convert a texture or material into
an image file.

The new image file looks like it is lit by the same lights that are linked to the
surface in the scene. This option is ideal for color matching. You must select
a surface and a shading group (not a material) when you use Bake Shading
Group Lighting.

NEW LAYERED TEXTURE NODE

Maya 3.0 now provides a quicker way to layer single attributes, such as color
attributes, using the new Layered Texture node.

You can use Layered Texture to create a texture that consists of two or more
of the textures already in the scene composited together in a certain way.
You use textureA and textureB to produce a textureC in which textureA is
applied as a decal over textureB.

Previously, you uses the Layered Shader node with the Compositing Flag set
to Layered Texture. The problem with this approach is that textures typically
consist of Color and Alpha. The Layered Shader node, even when used in
layered texture mode, consists of Color, Transparency (not Alpha), and
Glow. Also, the Layered Shader node provides only one way to blend/
composite layers together. The new Layered Texture node provides
numerous choices (see “Layer is Visible” on page 228).
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To create a layered texture node:

1 In the Hypershade, use the middle mouse button to drag the Layered
Texture swatch from the Visor panel onto the material swatch in the
Hypershade and connect it to one of the material’s attributes (such as Color).

or

Select Create > Textures > Other > Layered Texture, using the middle mouse
button, click in the Hypershade and drag the texture swatch over the
material swatch to connect it to an attribute.

2 In the Layered Texture’s Attribute Editor, select the layer you want to edit.

When you select a layer, Maya updates the Color, Alpha, Blend Mode, and
Layer is Visible attributes to reflect the properties of the selected layer.

Tip
You can add layers into the original Layered Texture’s Attribute Editor by
dragging and dropping them from the Visor panel or Hypershade panel, or
by clicking in the Layered Texture Attributes section of the editor.
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You can also re-order the layers in the Layered Texture’s Attribute Editor.
Using the middle mouse button, drag the texture swatch to the place where
you need it.

To change a specific layer’s texture attributes, click the tab at the top of the
Attribute Editor to access that texture’s attributes. See the following
example.

Middle mouse drag these
swatches to re-arrange layers.
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Layer is Visible

The Layer is Visible attribute specifies whether the layer should be taken
into consideration during computation of the result color and alpha of the
layered texture. If toggled off, it is as if the layer does not exist. Use this
when you want to verify how a particular layer looks by itself. See the
following examples.

Alpha is Luminance

This check box lets you specify that the Alpha should be the luminance of
the Out Color, as with other 2D textures, such as a File texture.The slider
value determines the extent of the blend. For instance:

Alpha = 0 results in the background texture

Alpha = 1 results in a full blend

Alpha = anything between 0 and 1 results in some background texture, and
some blend. This slider essentially controls an Over of the full blend on the
background texture.

Hardware Color

This lets you specify the color you want to objects using this texture to
display in the view while in hardware shading mode (not hardware
texturing mode).

Blend Modes

The new Blend Modes are supported by the layered texture and layered
shader nodes. Using one of these blend modes, you can define how each
layer in the layered texture and layered shader blends with the underlying
layer.

Layer is Visible on Layer is Visible off.
(default).
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The Blend Mode specifies how the currently selected layer blends with the
layers behind it. The following lists the blend modes:

Normal Edits or paints each pixel to make it the result color. This
is the default. (Normal mode is called Threshold when
you’re working with a bitmapped or indexed-colored
images).

Over The foreground texture is applied like a decal to the
background. The shape of the decal is determined by the
foreground alpha.

In The background texture is cut in the shape of the
foreground alpha.

Out The result is the opposite of In. It is as if the shape of the
foreground alpha has been cut out of the background.

Add The result color is the foreground color added to the
background color as if being projected on the background
through a slide projector. The result color is then applied
over the background color using the foreground alpha to
define the opacity of the result.

Subtract The result color is the foreground color subtracted from
the background color. The result color is then applied over
the background color using the foreground alpha to define
the opacity of the result.

Multiply Looks at the color information in each channel and
multiplies the base color by the blend color. The result
color is always a darker color. Multiplying any color with
black produces black. Multiplying any color with white
leaves the color unchanged. When you’re painting with a
color other than black or white, successive strokes with a
painting tool produce progressively darker colors. The
effect is similar to drawing on the surface with multiple
magic markers.

Difference Looks at the color information in each channel and
subtracts either the blend color from the base color or the
base color from the blend color, depending on which has
the greatest brightness value. Blending with white inverts
the base color values; blending with black produces no
change.
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Lighten Looks at the color information in each channel and selects
the base or blend color, whichever is lighter, as the result
color. Pixels darker than the blend color are replaced, and
pixels lighter than the blend color do not change.

Darken Looks at the color information in each channel and selects
the base or blend color, whichever is darker, as the result
color. Pixels lighter than the blend color are replaced, and
pixels darker that the blend color do not change.

Saturate Creates a result color with the luminance and hue of the
base color and the saturation of the blend color. Painting
with this mode in an area with no (0) saturation (gray)
causes no change.

De-saturate The result color is the background color with saturation
decreased in proportion to the foreground color scaled by
foreground alpha. If the foreground color is red, for
example, the result color will be the background color
with desaturated reds.

Illuminate Creates a result color with the hue and saturation of the
base color and the luminance of the blend color. This
mode creates an inverse effect from that of the Color
mode.

NEW MOVIE TEXTURE

The movie node is a file node with two important differences:

• It assumes that a multiple frame sequence is all stored in a single multiple
frame file (a movie file) instead of a sequence of individual image files.

• It is optimized for reading and displaying those frames interactively as
quickly as possible.

Movie Texture attributes

The file node attributes let you animate the texture. These attributes are:

• File Texture Name

• Use Frame Extension

• Frame Extension.
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If Use Frame Extension is on, the file node constructs the name of the actual
image file to use from the File Texture Name and the Frame Extension.

The movie node has the exact same attributes and uses them the exact same
way. The only difference is that the movie texture node assumes that all the
frames are stored in the single file named by File Texture Name instead of
separate files.

If Use Frame Extension is on, Frame Extension will be the number of the
frame to load from the movie file.

If Frame Extension specifies a frame before the beginning or after the end of
the movie, the first or last frame will be displayed.

For performance reasons, if any image filter type is specified, it is treated as
if it were a box filter.

This node is intended to allow you to put higher performance but perhaps
lower quality animated images into your scenes. For example, you could
take a movie file and use it as the texture on the face of a television. The
image on the TV should update relatively quickly as frames change.

On the other hand, if you need good quality filtered textures for a final
render, you may want to use a file texture node and a lot of images on disk.

NEW PAINT TEXTURES TOOL

Maya now provides you with the Paint Textures Tool which you can use to
paint renderable attributes such as color, bump, transparency, and specular
color, on either polygons or NURBS. You can also paint on file textures
assigned to your objects.

Note
The first time you access a frame from an MPEG file, it may take a while to
load. The movie library has to scan to the end of an MPEG file to see how
many frames are in it as this information is not available in the movie
header.
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See Using Maya: Essentials for information on how to set Paint Texture Tool
options common to Artisan tools, such as pressure sensitivity in the Stroke
tab, and the hotkeys such as b to resize the brush, or alt F to flood the
surface.

Paint Textures Tool and texture naming
When you enter the Paint Textures Tool, Maya checks to see if there are any
file textures already assigned to the selected surfaces for the current attribute
(such as color or bump maps). If any of the surfaces do not have file textures
assigned, Maya prompts you to assign textures to the surfaces. Maya names
the new textures based on the current scene, shape and attribute names and
places them in the current project’s textures directory.

If there are existing file textures, Maya checks to see if their names match the
current shape, scene and attribute names. If they do not, Maya copies the
textures to the correct names. This prevents you from overwriting existing
file textures, and makes it easier for the tool to keep track of the textures.

Example:

Scene name: myPaintScene

Shape names: ballShape, planeShape

Attributes: color, transparency

Resulting texture names:

myPaintScene_ballShape_color.iff,
myPaintScene_ballShape_transparency.iff,
myPaintScene_planeShape_color.iff,
myPaintScene_planeShape_transparency.iff

.iff is the default file format. When you Assign Textures you can choose to
save the file as Maya IFF (the default), SGI, SoftImage, TIFF, Alias PIX, GIF,
RLA, JPEG, EPS, and Quantel.

Note
For polygonal objects, you must have non-overlapping UVs which fit
within the 0 to 1 texture space to achieve expected results. See Using Maya:
Polygonal Modeling for details about polygons.
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About switch nodes and painted textures
Maya creates switch nodes for each material attribute for multiple painted
surfaces. This lets you use a single material for multiple painted surfaces by
assigning the correct file texture to each surface. For a single surface, no
switch node is created.

When assigning a texture to multiple surfaces attached to the same material,
tripleShadingSwitch or singleShadingSwitch swatches, file texture swatches,
and the place2dTexture swatches display in Hypershade.

Notes
• A bump map attribute displays as normalCamera in the scene name.

• If the original textures were not a power of 2 in each dimension
(such as 512 x 512, 256 x 128), Maya resizes the copies to the
nearest power of 2. This makes the Paint Textures tool more
efficient.

• If you change the shape or scene name, for example by renaming a
surface, or by saving the scene as a new name, the next time you
enter the Paint Textures tool, the textures are copied to the new
name.

• To ensure your textures are in sync with your scene name, you
should enter the Paint Textures tool and display each painted
attribute (such as color, bump) AFTER changing your scene name
using File > Save Scene As. This prevents you from overwriting the
newer scene’s textures if you return and edit an earlier version of
the scene.
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Full color (RGB) attributes, such as Color, Transparency, and Incandescence,
create a tripleShadingSwitch.

A single channel attribute, such as BumpMap, Diffuse, and Translucence,
create a singleShadingSwitch node. If you paint color on one of these
attributes, it automatically displays as grey.

See also the table under the heading “Texture attribute availability” on page
240.

Using the Paint Textures Tool

To use the Paint Textures Tool:

1 Select the surface or surfaces you want to paint.

2 Open the Paint Textures Tool options window from the Lighting/Shading
menu (click the ❐).

3 Select the attribute you want to paint from the Texture Attribute to Paint
pop-up menu.

If you have not previously painted or assigned file textures to one or more of
the surfaces, a warning prompt displays in the Command Feedback line:

Some surfaces have no file textures assigned.

4 Press the Assign Textures button and select the required size and file format
for the textures from the Assign File Textures window that displays.

Hypershade view.
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5 By default, the Texture Attribute to Paint is Color. Select a color from the
Color Chooser and paint on the surface. You can use either UV texture mode
or Projective paint mode. Select the mode from the Misc tab.

Once you finish painting one attribute, you can paint another attribute.

6 Select Save Textures at any time to checkpoint your work—you can retrieve
the saved textures by pressing the Reload Textures button.

If AutoSave on Exit is not turned on (under the Misc tab), you are prompted
to save the textures when exiting the tool, or when selecting a new attribute
to paint. Maya saves the textures to the textures directory of the current
project with a name derived from the scene, the surface, and the attribute
being painted. You should not change the name of these textures.

Masking polygonal faces while painting
When painting polygonal objects, you can choose to paint on only selected
faces to mask out the rest of the faces and protect them from the paint.

To mask polygonal faces while painting:

1 Select the faces on which you want to paint.

2 Enter the Paint Textures tool and proceed as normal. An outline displays
around the selected faces.

See the procedure, “Painting polygonal faces” on page 237 to get an idea of
how this works.

Note
The texture size is currently limited to 2048 x 2048 and must be a power of
2 in each dimension. The default is 256 x 256. Smaller textures provide
faster performance.

Tip
For increased performance, hide the surfaces you are not painting.
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Painting and IPR rendering
The following procedure shows you how to paint more than one attribute
and IPR render the scene.

The model used is a tiara, which is a polygonal object. The procedure is
broken into a series of steps:

• “Painting a model” on page 236

• “Painting polygonal faces” on page 237

• “Painting transparency” on page 237

• “Painting bump maps” on page 238

Painting a model

1 Select the tiara and enter the Paint Textures tool.

2 Select Color as the Texture Attribute to Paint, click the Assign Textures
button, and make sure 512 x 512 is the size in the Assign File Textures
window.

3 Select a color from the Color Chooser, such as gold (click the Color Value bar
to open the Color Chooser) and paint the crown. Select Flood to complete.

4 Change the color (drag the slider to make it darker), lower the opacity value
and paint some dirt.

Notes
• Flood ignores the selection and paints the entire polygonal mesh.

• If you want to change your selection, you must exit the Paint
Textures tool, make your new selection, and then re-enter the tool.
There is no need to re-assign the textures.
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Painting polygonal faces

1 Select the tiara (if not already selected), press the right mouse button while
over the tiara and select Face from the marking menu to enter polygon
component selection mode.

2 Select the four front gemstones, which are two rubies and two emeralds, and
paint them red and green (Shift-select all the faces of two gemstones, paint
them red, then Shift-select the faces on the other two and paint them green).
Once you select all the faces of the gemstones, a heavy line displays.

Painting transparency

The gemstones are semi-transparent. Use this method to paint them.

1 Shift-select the faces of the gemstones.

2 Select Transparency and Assign Textures, 512 x 512.

3 Flood the tiara with black, select Color and paint the four stones light grey.
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Painting bump maps

To add depth and a few ornamental decals to the tiara, you can paint bump
maps.

1 Select the tiara (right mouse click and choose Select All from the marking
menu).

2 Select BumpMap and Assign Textures, 512 x 512.

3 Select UV Texture Paint mode (under the Misc tab), and turn on Reflection
(under the Stroke tab).

This next step is optional. You can also open the Render View outside of the
panels and when you click Maya’s select icon to get out of the tool, the IPR
view updates.

4 Select the panel layout Persp/RenderView. Select
Panels > Layouts > 2 Side by Side, Panels > Perspective >persp in one view
and Panels > Render View in another view.

5 Marquee-select some pixels at the front of the tiara in the Render View, then
click the IPR icon to IPR render.

6 In the perspective view, click the tiara and Flood with a mid grey color.

7 Select a slightly darker grey and paint ornamental swirls on the front of the
tiara. Repeat this using a lighter grey color. Change the Shape of the brush if
you want.

8 Press Save Textures to see the update in the IPR.

Note
Reflection is only available in UV Texture Mode and provides good results
only when the UVs are symmetrical in texture space.
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To save the texture automatically at the end of the stroke, turn on AutoSave
on Stroke (under the Misc tab). Use with caution, though, because this
removes the ability to undo.

9 Repeat painting and updating the textures if you want. The following shows
the finished tiara.

Determining stamp spacing and brush depth
Maya also provides you with options to adjust the stamp spacing, and
control the brush depth.

Changing the Stamp Spacing
If you find your stroke is broken or dotty, try decreasing the Stamp Spacing
(Misc tab) slightly. Conversely, if you find that your stroke is too slow, your
Stamp Spacing may be set too low. The default setting is 1.0. The ideal value
will vary depending on your model and your texture size.

Default Stamp Spacing=1.0

Stamp Spacing set to 10.0

Stamp Spacing set to 0.5.
Slower feedback.
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Changing the Brush Depth
The brush depth is indicated by the vertical line through the center of the
brush. The Brush Depth value determines how far the paint is projected. For
example, when you are painting where there are folds in the surface,
decrease the Brush Depth value so the paint does not run into other areas of
the object. The default setting is 0.5.

Selecting and painting attributes
In the File Texture section of the Tool Settings window, Maya provides you
with a number of attributes you can paint onto your objects.

Texture attribute availability
Select an attribute from the pull-down menu, then click the Assign Textures
button to paint the attribute onto the object. The following table shows
available attributes and whether they are RGB or single channel.

RGB Single Channel

Color BumpMap

Transparency Reflectivity

Brush Depth
set to 0.1.

Brush Depth
default=0.5.

The paint
projects
beyond the

The paint is
only projected
on the

front front surface.
surface.
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Available attributes vary depending on the material type. For example,
Specular Color is not available for a Lambert material. If you want to paint
other attributes, drag and drop another material from Hypershade onto your
model.

Painting attributes not shown in the Texture list
You can drag and drop textures directly onto attributes in a material’s
Attribute Editor. This means that even though the attributes are not shown
on the Texture list, you can connect the texture to the attribute of your
choice. Try the following example.

To paint attributes not shown in the Texture list:

1 Create a polygonal Plane primitive.

2 Create a material, such as Blinn, and assign it to the plane.

• In the Blinn’s Attribute Editor, assign a Ramp texture to the Color attribute.

• In the Ramp texture’s Attribute Editor, click one of the color boxes with an X
through it to delete the color, and change the Type to Circular.

Incandescence Diffuse

Specular Color Translucence

Ambient Color

Reflected Color

RGB Single Channel
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3 Select the plane and enter the Paint Textures Tool.

4 Select Transparency as the Texture Attribute to Paint and assign a texture.

Flood the plane with a flesh tone. Click the Color Value bar and use the
Color Chooser to create a flesh-toned color, click the brush on the plane, then
click the Flood button.

Click the Color Value bar and select another color from the Color Chooser to
paint a mouth, then select another color to paint a pair of eyes.

5 Select Incandescence and assign a texture to the plane. Choose a color and
paint hair all over the plane.

6 Exit the Paint Textures Tool.

7 Double-click the Blinn swatch in Hypershade to open its Attribute Editor
and change Hardware Texturing back to Color.

Tip: Select Textures from the
Hypershade menu to quickly
see the texture swatches.

Result in view.

Hypershade view of textures.Result in view.
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8 Open the Ramp texture’s Attribute Editor and click the bottom color dot.
From Hypershade, use the middle mouse button to drag and drop the first
file texture (the face) onto the Selected Color attribute.

Click the bottom color dot and drag and drop the second file texture (the
hair) onto the Selected Color attribute.

9 In the material’s Attribute Editor, break the connections for both
Transparency and Incandescence (right mouse click while the cursor is over
the name of the attribute and select Break Connection).

To test the results, open the Ramp texture’s Attribute Editor and drag the
color dots up and down. Notice how the face and hair fade in and out as you
drag.

Note
If you have painted multiple surfaces, drag the switch node instead.

Click the color dot,
and drag and drop
the texture onto the
Selected Color attribute.
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If you connect a triple channel attribute to a single channel attribute, such as
Color to Glow Intensity in the following example the Connection Editor
displays. Select an Output channel for the switch utility and click to connect
it to the attribute you want.

Note
If you want to use the texture on a full-color (RGB) attribute, make sure
you choose to paint an attribute, such as Incandescence, which has three
channels. See the table under the heading “Texture attribute availability”
on page 240 for details.

Tip: Watch the Texture Sample
at the top of the Attribute Editor
as you drag the color dots.
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Placing painted 2d textures
Maya also creates a place2dTexture node when you paint a surface using the
Paint Textures Tool. That means you can place the texture using
manipulators or by changing the attributes under the place2dTexture tab in
the material’s Attribute Editor.

To quickly access the place2dTexture attributes, click the place2dTexture
swatch in Hypershade. See Chapter 36, “Place 2d & Place 3d Utilities” in the
online Maya Rendering: Reference book for details about the attributes.

In the following, a bump map is painted onto the object, and the texture is
placed by changing various place2dTexture attributes.

Switch node dropped onto
Glow Intensity attribute.

click Output, select
a channel and connect
it to the material’s attribute.

In the Connection Editor,
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In this next example, the Color texture is placed.

Assigning, saving, and reloading textures
Use the three buttons at the bottom of the Paint tab to assign, save, or reload
your paint textures.

Original painted bump map texture.

Bump map texture altered by changing
various place2dTexture attributes.

Original painted color texture.

Color texture altered by changing place2dTexture attributes
(set both Repeat U and V values to 10.).
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Assigning textures
You must click this button once you have selected an object or objects (or
faces) and an attribute to paint. If you have not previously painted or
assigned file textures to one or more of the surfaces, a warning prompt
displays in the Command Feedback line:

Some surfaces have no file textures assigned.

Saving textures
Click the Save Textures button at any time to checkpoint your work. You can
also determine when you want to save the texture, meaning when you exit
the tool or when you’ve finished a stroke. Under the Misc tab in the Tool
Settings window, the AutoSave section contains two options: AutoSave on
Exit (on by default), and AutoSave on Stroke.

AutoSave on Exit—Saves the textures when you exit the Paint Textures
Tool, or when you select a new attribute to paint.

If off, Maya prompts you to save the textures when you exit the tool or select
another attribute.

AutoSave on Stroke—This option is off by default. Turn this option on if
you want to save each stroke you paint on the object. Use this option when
IPR rendering. As you release the stylus (or mouse) at the end of each stroke,
the texture is updated and the IPR render refreshes to reflect your changes.

Reloading textures
Click the Reload Textures button to retrieve any textures you saved (if you
clicked the Save Textures button).

Note
Turn this option on only in circumstances when you know you will not be
making too many errors because you cannot undo your strokes when this
option is on.
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Tips on texture and paint modes (under the Misc tab)

• UV Texture Paint may be faster when you have good, non-overlapping,
contiguous UVs, and also allow the reflection mode to be used if the UVs are
symmetrical in texture space—for NURBS, this is always the case. For
polygons, it may not be.

• Projective Paint works best when the UV mesh is cut into multiple pieces,
and also virtually eliminates brush distortion at seams and at areas where
there is uneven parameterization.

2D/3D INTEGRATION ENHANCEMENTS

The addition of render layers and render passes provides a mechanism to
easily break down a scene so that its parts can be quickly re-rendered.

By rendering each individual layer and pass and compositing them, you can
dramatically improve iteration times versus repeated re-rendering of the
entire scene.

You can control the creation and options on each render layer from the
Layer Bar. This bar contains both Display Layers and Render Layers. Select
Render Layers from the pull-down menu to access this functionality. See the
chapter, Basic Features in this document for more information on the Render
Layer bar.

In addition, a new section, Render Layer/Pass Control, has been added to
the Render Globals window.

Notes
• You will have to assign textures for each attribute you choose to

paint the first time you choose to paint that attribute.

• When painting grayscale attributes such as bump, the color you
paint with automatically converts to grayscale.
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Render Layer management

User-defined output of specified layers
The new render layer and pass functionality provides you with the
following options:

• Each object can only be in one layer and all objects are in a layer.

• Objects only cast shadows on other objects in the same layer.

• Objects not in the current layer are oblivious to the renderer—it treats each
layer as if it came from a separate scene.

• In interactive mode, when you request a test render, all layers with
renderable attributes set on are rendered into the window.

• In batch mode, each layer is rendered to a separate file for off-line
compositing.

You can control which passes are rendered from the pull-down menu
associated with each layer in the render layer bar. These options can only be
used if Enable Render Layers is toggled on in the Render Layer/Pass
Control section of the Render Globals window (see next).

You can also use the Render Pass management spreadsheet to quickly
control the rendering state of the layers. Options include Beauty, Color, and
Shadow. The layer portion of this spread sheet is available when either
Enable Render Layers or Enable Global Passes are toggled on in the Render
Globals window.
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Render Layer/Pass Control

Enable Render Layers

Tells the renderer to render only the layers for which renderable is turned
on.

In interactive mode, all layers with renderable toggled on are rendered into a
single image. In batch mode, each layer is output to a file named:

camera_filename_layername_passname.ext

Enable Render Layer Passes

This option is available when Enable Render Layers is toggled on and allows
for individual passes to be rendered for each layer.

Enable Global Passes

This option is available when Enable Render Layers is toggled off and allows
for passes to be rendered for the entire scene.
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Output to Subdirectories

This option places files from each separate layer and/or pass into their own
directory, and any given directory only contains files from the specific layer
or pass. Files are named:

.../layerName/passName/camera_filename_layername_passname.ext

Render Pass management spreadsheet
Depending on the settings for layers and passes, this spreadsheet provides
control over all current rendering options. This is a quick way to control all
the render layers and/or passes. You can choose rendering passes for each
layer (layer passes), or rendering a specific pass for all objects in a scene
(global passes).

Turn on either Enable Render Layer Passes or Enable Global Passes to
display the spreadsheet.

This spreadsheet provides access to the passes, Beauty, Color, and Shadow,
for the appropriate layers.

Enable Global Passes

When Enable Global Passes is selected, only one layer, the Global Layer, is
available.

Enable Layer Passes

When Enable Layer Passes is on, all layers are available.

Beauty The Beauty pass is used by default and produces a
complete rendering of all the components.

Color The Color pass produces only the color component of the
image. No shadow information is produced.

Shadow The Shadow pass produces only the shadow component
of the image. No color information is produced.

When combined, the Color and Shadow components produce the same
image as the Beauty pass. The benefit is that you can now tweak the
shadows independently in a compositing/paint package.

Troubleshooting

Q: I've turned off some layers but they are still being rendered.
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A: Remember to turn on Render Layers in the Render Globals window.

Q: I've turned on the shadow pass but some shadows are not being
rendered.

A: Objects can only catch shadows from objects in that layer. Make sure the
object casting the shadow and the object on which the shadow should fall
are in the same layer.

NEW RENDER GLOBALS FIELD OPTIONS

The Field Options control how Maya renders images as fields. With this
release, new options are provided.

Fields

Controls whether Maya renders images as frames or fields. Select an option
from the pull-down menu. Options include:

Frames Render regular frames.

Both Fields,
Interlaced Render both odd and even fields (for video) and

automatically interlace the results into a full frame.

Both Fields,
Separate Same as above, except no interlacing occurs. The result is a

sequence of odd and even field images.

Odd Field Render odd fields only.
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Even Field Render even fields only.

Field Dominance

Controls whether Maya renders Odd Fields at time “x” and even fields at
time “x+0.5”, or Even Fields at time “x” and odd fields at time “x+0.5”.

To render fields for NTSC systems, set Field Dominance to Odd Field first.

To render fields for PAL systems, set Field Dominance to Even Field first.

Zeroth Scanline

Controls whether the first line of the first field Maya renders is at the top of
the image or at the bottom of the image.

At Top/At
Bottom Set the At Top option (unless you encounter problems

with a test rendered animation). At Top is set by default.

If you encounter problems in an animation where objects
vibrate up and down, change the Zeroth Scanline setting,
and render the animation again. If this does not solve the
problem, or if objects in the animation vibrate left to right,
try different combinations of Field Dominance and Zeroth
Scanline, and render the animation until the problem is
solved.

No Field
Extension No extension is added to odd and even field file names.

Note
If the Render Field Option is set to Frames, the Field Dominance options
are not available. If set to Both Fields Interlaced, Maya sets the appropriate
field dominance based on the format standard (NTSC or PAL).

Note
If the Render Field Option is set to Frames or Both Fields, Interlaced, the
Zeroth Scanline options are not available. Maya chooses the appropriate
setting based on the format standard, NTSC or PAL.
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Default Field
Extension
(o and e) Maya saves the two field image files by adding an “e” (for

even fields) and an “o” (for odd fields) onto your frame
number extension or file name. For example,
name.001e.iff  and name.001o.iff . This is the default
setting.

Custom Extension

Set this option on to specify custom extensions to add to odd and even field
file names.

For example, if you type x , the result is name.001x.iff .

Odd Field The extension to add to odd field file names.

Even Field The extension to add to even field file names.
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10 PAINT EFFECTS

With this release of Maya, we’ve added improvements and bug fixes to the
Paint Effects environment.

Improvements

• Instancing Paint Effects strokes

• New Primary Visibility option

• Rendering Paint Effects strokes at test resolutions

• Rendering strokes without depth output

• Rendering multiple images and stitching

• Disappearing file textured leaves and flower petals

• Dragging and dropping textures onto the canvas

INSTANCING PAINT EFFECTS STROKES

You can now instance a Paint Effects stroke to Dynamics particles. For
details, see the “Dynamics” chapter in What’s New in Maya 3.0.

NEW PRIMARY VISIBILITY OPTION

There is a new Primary Visibility option on the stroke node (select the stroke
and click the strokeShape node in the Attribute Editor).

When Primary Visibility is turned on, the stroke is visible in the view and
renders. When its turned off, the stroke is visible in the view but it does not
render. Note that if Primary Visibility is turned off and Cast Shadows is
turned on, the stroke’s shadow renders.
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RENDERING PAINT EFFECTS STROKES AT TEST RESOLUTIONS

When you render Paint Effects strokes at test resolutions, the Paint Effects
strokes are now modified appropriately.

RENDERING STROKES WITHOUT DEPTH OUTPUT

When you render a scene with Paint Effects strokes, depth output is no
longer forced. In previous versions, final images always incorporated depth.

RENDERING MULTIPLE IMAGES AND STITCHING

When you render multiple images and stitch them together, Paint Effects
renders will now match seamlessly. However, glow and light glow will still
not match across the seams.

DISAPPEARING FILE TEXTURED LEAVES AND FLOWER PETALS

In previous versions of Maya, if you turned on Time Clip and turned off
Leaf Use Branch Tex, file textured leaves and flower petals disappeared,
which affected growth animation for any presets with textured leaves. This
limitation has been fixed for Maya 3.0.

DRAGGING AND DROPPING TEXTURES ONTO THE CANVAS

in previous versions of Maya, dragging and dropping a new file texture onto
the Paint Effects canvas and turning on Auto Save was not always
successful. This limitation has been fixed for Maya 3.0.
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11 CLOTH

In Maya 3.0, you can use Artisan paint tools to paint properties and
wrinkling effects across the entire surface of a garment. This lets you apply
properties to portions of the cloth panel instead of the entire panel.

Using the new Cloth Property Paint tool, you can apply properties such as
stiffness to isolated parts of the garment rather than to whole panels, much
like spraying starch on a collar.

Stuart Little image courtesy
of Sony Pictures
Imageworks. Columbia/
TriStar. All rights reserved.
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When you select a property attribute to paint, a paint attribute is
dynamically added to the cloth. The paint attribute is used as a multiplier or
“weight.” The property attribute value is multiplied by the paint attribute
value.

NEW ATTRIBUTE FOR PAINTING WRINKLES

Cloth has a new attribute—bendAngle—to make it easy to paint wrinkles on
your cloth. The bendAngle attribute is dynamically added to the cloth when
you choose bendAngle from the Cloth Property Paint tool.

The bendAngle attribute specifies the resting angle of the cloth. Initially, the
resting angle value for each edge of each triangle of the cloth mesh is
zero.The cloth solver uses the bendAngle to bend the cloth mesh about the
each triangle edge. When painting, you can see the final values for each
vertex in the Script Editor.

For example, in the image below notice the wrinkles on the cloth sheet.

Remember…
Cloth is available only in Maya Unlimited.
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If you want to see a larger wrinkle propagated along the diagonal, you can
use the Property Paint tool to paint a bendAngle value on this area.



WHAT’S NEW IN MAYA 3

260

CLOTH | 11
New attribute for painting wrinkles

After the area is touched up, you simulate the cloth. The bendAngle attribute
causes the cloth to bend or wrinkle in this region during the simulation.

To paint properties on cloth:

1 Select Shading > Smooth Shade Selected Items.

2 Select the cloth you want to paint property attribute values on.

3 From the Cloth menu set, select Simulation > Properties > Paint Property ❒.

The Cloth Property Paint Tool is displayed.

4 From the Paint Attribute pulldown menu, select the property attribute you
want to paint values for. If you want to paint wrinkles, select the bendAngle
attribute.

For information on the property attributes see “Applying properties to
panels” on page 104 of Using Maya: Cloth.

5 Define the Cloth Paint settings, if required.

For each property attribute, the initial value is set to 1.0. For information on
defining settings, see “Setting Script Paint Tool options” on page 442 of
Using Maya: Essentials. The Cloth Paint setting are the same as Script Paint
settings.
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6 Move the pointer over the cloth.

The pointer becomes a paintbrush.

7 Paint along the triangle edges.

The value of the property attribute in the painted area is modified according
to the settings of the Cloth Property Paint tool. Look in the Script Editor to
see the values.

Painting U/V attributes

For attributes with U and V settings, such as U Scale, V Scale, U BendRate
and V BendRate, the U and V share one paint attribute.

For example, if you select the Scale property from the Paint Attribute
pulldown, U Scale and V Scale are both affected by the Scale weight. The
formula is:

the final uscale = uscale * scaleWeight

the final vscale = vscale * scaleWeight

CHANGING THE CLOTH PAINT TOOL SETTINGS

You can change the Cloth Paint Tool settings to create different effects.
Again, these are the same as the Artisan Paint Tool settings.

Stroke

The stroke defines how the brush moves across the selected surface.

• For information on changing the stroke, see “Changing brush stroke
settings” on page 397 of Using Maya: Essentials.

Display

Display defines how the brush and screen are displayed.

• For information on changing the display, see “Changing display settings” on
page 404 of Using Maya: Essentials.

Miscellaneous

Less frequently used tool settings are stored under the Misc tab.
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• For information on changing miscellaneous settings, see “Changing
miscellaneous tool settings” on page 406 of Using Maya: Essentials.
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12 FUR

With this release of Maya, we’ve added the following new features and
improvements to Fur.

• New Global Scale fur attribute

• New Roll fur attribute

• New shadow map setting

• Fur Globals improvements

• Batch rendering is now per frame

• Baking improvements

• Fog now renders with fur

Remember…
Fur is available only in Maya Unlimited.
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NEW GLOBAL SCALE FUR ATTRIBUTE

You can now scale the Base Width, Tip Width, and Length values all at once
for a fur description (including mapped values) using the new Global Scale
fur attribute.

NEW ROLL FUR ATTRIBUTE

The Roll fur attribute rotates hair about the surface V axis. You can achieve
almost any fur angle using Polar and Inclination, so use this option only
when the fur has curl and you want the curls to lie flat. Use the following
settings as guidelines.

0.0 -90 degree rotation.

0.5 No rotation. This is the default.

1.0 90 degrees rotation.

New

Value 0 Value 0.5 Value 1
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NEW SHADOW MAP SETTING

The Threshold value determines how much of the pixel must be covered by
hair before hair depth information is stored in the shadow map. Use this
option to prevent very fine hairs from showing up in the shadow map—this
can cause fine hairs to cast thick shadows, although it is rare).

Use the following settings as guidelines.

0 Stores a depth value for each pixel if hair exists in that
pixel, no matter how fine the hair.

0.5 Only stores hair depth information for pixels that are
covered 50 percent or more by hair.

FUR GLOBALS IMPROVEMENTS

Some additions and changes have been made to the Fur Globals (Fur > Fur
Globals).

New
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Fur Render Options
Calc. Area Values replaces Area Values, with options described next Keep
Intermediate Files is now Keep Temp Files and is off by default.

Calc. Area Values

Calc. Area Values replaces Calc. Area Values. Use this setting to specify how
you want hair to be distributed across surfaces.

Replaces Area Values
and has new options

New

Was
Keep Intermediate Files

Was Render Fur
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If you select Globally or Per Fur Description, hairs are distributed evenly
across furry surfaces by taking the largest piece of furry geometry in the
scene, assigning it a value of 1, then calculating values proportional to that
surface for all the other furry surfaces in the scene. Then each surface
receives a proportion of the density value set in the fur description assigned
to the surface, based on the calculated area value.

For example, if the Density is set to 10,000, the largest furry surface will
receive 10,000 hairs, whereas a surface in the scene that is half that size will
receive 5,000 hairs.

Off Each surface receives the same number of hairs specified
by the Density value for the fur description. This works if
your character is made up of a single surface, or distinctly
different surfaces. In these cases, you can use Baldness to
roughly control relative densities within a single fur
description.

Globally This option is the equivalent of toggling Area Value on in
previous versions of Fur. For models made up of multiple
patches, this gives an even distribution on hairs across
different sized surfaces.

The density of each fur description is distributed evenly
over all surfaces with fur descriptions attached, regardless
of which fur description is attached.

Per Fur
Description Distributes hairs evenly across multiple different sized

surfaces. The distribution of hair for one fur description
does not affect the distribution for another fur description,
unlike the Globally option. This is the default.

New advanced options
The following new advanced options have been added:

Enable Fur Image Rendering

Turn this option off to render only the geometry and fur shadows on
geometry (no fur images).
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Enable Shadow Map Rendering

Turn this option off to render the fur and geometry as if the lights in the
scene had no fur shadowing attributes.

Disable Maya Rendering (batch only)

Turn this option on if you are using a distributed or batch renderer and want
to render only the fur images.

NURBS Tesselation

In previous versions, the tesselation factor Fur used for NURBS surfaces was
hard coded and was often higher than the default tesselation factor used by
Maya for the NURBS surface. The sometimes resulted in mismatched
composites.

This option allows you to set the tesselation factor of the NURBS surface
used by the Fur render.

The tesselation factor Fur uses for NURBS surfaces is sometimes higher than
the default tesselation factor used by Maya for the NURBS surface. This
sometimes results in mismatched composites.

Use this option to set the tesselation factor of the NURBS surface used by the
Fur renderer.

Fur Image Rendering
Hairs/Pixel Specify the number of hairs per pixel that are tracked for fur images. Lower

values use less memory while higher values produce better quality renders.

Mismatched composite Matched composite
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Use Fur Shading/Shadowing on Fur

Turn this option off to cast fur shadows on geometry but not on fur for
shadow map lights.

Shadow Map Rendering
Hairs/Pixel Specify the number of hairs per pixel that are tracked for shadow maps.

Lower values use less memory while higher values produce better quality
renders.

BATCH RENDERING IS NOW PER FRAME

When you batch render a scene, Fur now completes rendering both the fur
images and the geometry for each frame before starting the next. In previous
versions of Fur, all the Fur images would be rendered for all the frames, then
all the geometry would be rendered.

BAKING IMPROVEMENTS

Rebaking maps now overwrites the old maps and puts them in the
furAttrMap directory rather than the source images directory.

FOG NOW RENDERS WITH FUR

You can now render fog with fur. In the Render Globals window (Window >
Render Globals), expand Render Options and turn on Apply Fog in Post
before rendering.
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13 LIVE

In Maya 3.0, we’ve added the following features to Maya Live:

• “Tracker improvements” on page 271

• “New Locator Summary panel” on page 273

• “New infinite and locked points” on page 274

• “New Filter for Solve task” on page 276

• “Camera rotation order improvement” on page 277

As of Maya 3, the Comprehensive solver is discontinued and Live now uses
the Root Frame solver exclusively. Any mention of the solver refers to the
Root Frame solver.

TRACKER IMPROVEMENTS

We’ve added features to help the tracker follow image changes better and
stay locked on the target. The new features are:

• blurring

• adjusting for rotation and scale

Blurring By default, the tracker now blurs images to compensate for interference
within the images, such as film grain. You don’t actually see the blur (it is
done in memory only), but it helps the tracker stay on target.

You can control the amount of blur by adjusting the Blur Radius parameter
on the Track Options control panel. For example, if you are tracking a subtle
feature, the default amount of blur may be too much. A value of zero
disables the blur.

Remember…
Live is available only in Maya Unlimited.
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Rotate and Scale The target box now automatically adjusts in shape to compensate for
rotation or scale changes in the target image. This feature helps with the
most common reason for tracking failures: shape changes in the feature you
are tracking.

You can control the amount of rotation or scale by adjusting the Use Rotate
and Use Scale parameters on the Track Options control panel. If you find the
tracker is falling off target, adjusting the value for these parameters may
help.

Track box rotationStarting track box
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NEW LOCATOR SUMMARY PANEL

The Solve task now includes a Locator Summary panel. This panel graphs
locator and frame slip quality, which were previously displayed in the Track
Summary. The Track Summary now graphs only track information.

Use the Locator Summary panel to evaluate how closely the 3D locators
created by the solver match with the 2D track points. Also use it to make
points infinite or locked. This is a new feature; see “New infinite and locked
points” on page 274 for more information.

Locator quality Graphically indicates the amount of pixel slip between each locator and its
corresponding track point. Pixel slip is the distance in pixels between the
track point and it’s locator. Like the Track Summary, green is good quality,
yellow is a warning, and red is a strong warning.

Frame Slip Graphs the average pixel slip for all locators.
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NEW INFINITE AND LOCKED POINTS

You can now make points infinite or locked in the Locator Summary panel.
These new designators are another way to help the solver, like survey
constraints.

To make a point infinite or locked, simply click next to the locator in the
Locator Summary panel. To return a point to normal, click the icon again.
See the following illustration.

Infinite Tells the solver to treat the point as infinitely far from the camera, such as a
cloud, mountain, or any feature in the distant background. Knowing a point
is infinite, the solver can use it exclusively for calculating camera movement.
It does not need to determine the point’s position in space, so the locator
becomes hidden.

By making two or more points infinite, you can significantly help the solver
calculate zoom shots, provided those points are visible long enough.

Locked point

Infinite point

Lo
ck

In
fin

ite
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Lock Locks the locator point to a specific 3D location. A locked point is exactly
like assigning it to a survey Point constraint, but the workflow is easier.
Simply click the lock icon and move or snap the locator to a given position.
However, Point constraints are still required if you want it to be used for
registration only.

There are several uses for locked points:

• to lock points onto a model you created or imported

• to help resolve ambiguities for the solver by specifying exact locations for
two or more points, taken from survey data

• to register the whole scene around a certain point, such as the origin

Infinite points help define camera movement
(notice it has no 3D locator)



WHAT’S NEW IN MAYA 3

276

LIVE | 13
New Filter for Solve task

NEW FILTER FOR SOLVE TASK

To correct for unwanted jitter in your camera move solution, we’ve added a
filtering process and Filter Level control on the Solve control panel. Filtering
specifically corrects the jitter that can occur around frames where the
solution is mathematically ambiguous or uncertain. The root frame solve
process tends to amplify these ambiguities, creating jitter in the camera’s
motion. Filtering finds the frames with ambiguities and applies a strong
filter to those areas in the camera curves. The filtering occurs during the
Finish step.

Adjust the Filter Level if you want more filtering or if the precision of the
solution suffers as a result of too much filtering. A value around ten is the
upper limit, while zero disables the filter.

Filter Level vs. Smoothing Interval

Filter Level is different from Smoothing Interval, which is also on the Solve
control panel. Smoothing Interval corrects for isolated jumps in camera
motion curves around frames where track points appear or disappear. Filter
Level, on the other hand, corrects for overall camera jitter wherever it occurs.

Solution without filter Solution with filter
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CAMERA ROTATION ORDER IMPROVEMENT

You can now change the Rotate Order attribute of the shot camera for your
solutions. You can find the Rotate Order attribute in the Attribute Editor,
under the shotCamera node, Transform attributes. For example, if you
wanted to modify the camera solution as if it was on a tripod, you could
change the Rotate Order to ZXY.
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14 MAYA DOCUMENTATION

For Maya 3, we’ve updated the documentation to include information on the
features that have been added since Maya 2. This chapter describes the
improvements we’ve made to documentation for this release, including:

• “Online improvements” on page 279

• “Printed or online?” on page 280

• “What’s New in Maya 3” on page 280

ONLINE IMPROVEMENTS

For Maya 3, we’ve completely updated our online look. We hope that you’ll
find the new online books more pleasant to view and easier to find
information in. We now provide documentation for the full Unlimited
product, no matter which version of the software you’re using

New Search tools
We’ve provided an enhanced Library search tool in Maya 3.0. You can use
the Library Search tool without installing the documentation files on a
server. To access the Library Search tool, return to the main Maya Library
page and select Library Search.

A Book Search tool is also provided in the left frame of most books. Use this
tool when to look for an item in the book you are viewing currently.

Maya Glossary
For 3.0, we’ve provided an online glossary so you can look up meanings of
words you encounter which are new or confusing.



WHAT’S NEW IN MAYA 3

280

MAYA DOCUMENTATION | 14
Printed or online?

PRINTED OR ONLINE?
Most Maya documentation is available in both html (viewable) form and pdf
(printable) form. To access pdf files, insert your Maya CD and open
/pdf/library.pdf. Additional printed document sets are available from
Alias|Wavefront.

WHAT’S NEW IN MAYA 3
For Maya 3, this What’s New includes information on the new features that
appear throughout the Maya software. This information is much more
complete than in previous releases, so that you can learn about the new
features without referring to other books.

Note
Online help requires version 4 or higher of either Netscape Communicator
or Internet Explorer.

To print the pdf files, you must have Adobe Acrobat Reader.
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15 EXPRESSIONS AND MEL

This chapter describes Maya 3.0 improvements to expressions and MEL
scripts.

• “Script and Expression Editor improvements” on page 281

• “Simplified expressions for particle lifespan” on page 282

• “New capabilities for making attributes paintable” on page 282

SCRIPT AND EXPRESSION EDITOR IMPROVEMENTS

• We’ve added the Edit > Clear All command to help remove clutter.

• Pressing Ctrl+Enter now executes commands. Previously, only Enter on the
keypad or Edit > Execute would execute commands.

Edit keys (IRIX only)

Because using the Expression Editor, Script Editor, and other input boxes
can involve text editing, we’ve added support for the following edit keys:

• Ctrl+c: Copy

• Ctrl+x: Cut

• Ctrl+v: Paste

• Ctrl+k: Delete to end of line

• Ctrl+d: Delete next character

• Ctrl+a: Move cursor to beginning of line

• Ctrl+e: Move cursor to end of line

Previously, these edit keys were not supported on IRIX. However, the
Ctrl+c, Ctrl+x, and Ctrl+v keys have always operated on NT. Also, Ctrl+a on
NT selects all the text in the edit box.
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SIMPLIFIED EXPRESSIONS FOR PARTICLE LIFESPAN

Maya 3.0 simplifies the way you work with particle lifespan. No longer do
you need to use an expression to set random or constant lifespans on a per
particle basis. See Using Maya: Dynamics for details.

If you are using any lifespan mode other than lifespanPP only, you may read
but not assign to finalLifespanPP in expression statements. For example, in
past versions of Maya you might have written:

opacityPP = 1 - age/lifespanPP;

This works in Maya 3.0, but only if have you have lifespan mode set to
lifespanPP only. Now the way to write this expression is:

opacityPP = 1 - age/finalLifespanPP;

This works for all lifespan modes because finalLifespanPP always stores the
actual lifespan used for the particles in all modes.

Pre-Maya 3.0 expressions that refer to lifespanPP will work correctly now as
long as you select lifespanPP only as the lifespan mode. If you select Constant
or Random Range mode, you can read the value finalLifespanPP, not
lifespanPP. You need to use finalLifespanPP only if you intend to make use
of one of the other lifespan modes.

NEW CAPABILITIES FOR MAKING ATTRIBUTES PAINTABLE

To make an attribute paintable by the Attribute Paint Tool, it must be
registered in the MEL script ArtisanRegistPaintAttrCmd.mel. This attribute
registration process now has added capabilities.

For a full explanation of how to register a paintable attribute, see Using
Maya: MEL, Chapter 13 “Setting Up Artisan MEL Scripts.” In brief, the
registration command format is:

attrPaintCtx -e -rpa <nodeName> <displayName> <type> <attribute1> <attribute2>
<getGridCmd> ‘currentCtx’;

New capabilities:

• There are additional attribute data types you can register as paintable:
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multiDouble
multiFloat
multiInt (mutli integer)
multiVector

Specify the attribute data type in the third variable position; for example:

attrPaintCtx -e -rpa "polyReduce" "thresholds" "multiFloat"
‘currentCtx’;

• You can now specify which component mask you want to be painted: faces,
edges, or vertices. If left undefined, the paint tool applies to all vertices.

To specify a component mask, first register the attribute, then enter this
additional command:

attrPaintCtx -e -acm <nodeName> <attribute> <componentMask>
‘currentCtx’;

For example, the following command limits the paint tool to faces:

attrPaintCtx -e -acm "polyExtrudeFaceW" "weights" "faces"
‘currentCtx’;

• We’ve added a command for situations where the paintable attribute affects
the surface topology. For example, you might create a paintable attribute to
reduce the number of polygons. To keep the surface shape frozen, you need
to reference a geometry node that remains unaffected by the paintable
attribute.

The command is:

attrPaintCtx -e -ish <nodeName> <geometryAttribute>
‘currentCtx’;

For the <geometryAttribute> variable, specify the name of an attribute in the
paintable node that is connected to a geometry node you can use as a static
reference. In the following example, “ip” is the node used as a static
reference:

attrPaintCtx -e -ish "polyReduce" "ip" ‘currentCtx’;
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16 API AND DEVELOPER’S
TOOL KIT

With this release of Maya, we’ve added new features and improvements to
Maya’s API and Developer’s Tool Kit:

General improvements

• Upgrading existing plug-ins for Maya 3.0

• Plug-in compatibility changes made in Maya 2.0

New features

• New API for subdivision surfaces (for Maya Unlimited)

• Support for Multi UV's on Polygons

• New API classes

• Enhanced API classes

• Corrections to existing functionality

• Documentation corrections

• Miscellaneous corrections

GENERAL IMPROVEMENTS

Upgrading existing plug-ins for Maya 3.0
All plug-ins that were written with a previous version of Maya must be re-
compiled under the Maya 3.0 API to load and run without problems.

Source code compatibility between versions has always been a goal of the
Maya API, however there are a few changes that will have to be made to the
source code of plug-ins in order to rebuild them on Maya 3.0.
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Before starting this procedure, you should be aware that the header file,
MTypes.h, defines a preprocessor macro, MAYA_API_VERSION, that is set
to the current API version. This variable defines the current version of the
Maya API and lets you write plug-ins that compile differently on different
Maya releases.

The variable is numeric and corresponds to the Maya version number with
the “.” (dot) characters removed. For example, Maya 1.0.1 would be 101,
Maya 1.5 would be 150 and Maya 3.0 would be 200. Since the variable was
not defined for Maya 1.0, its value defaults to 0 in that release.

Compiler requirements
IRIX: For Maya 3.0 plug-in we recommend the SGI MIPSpro 7.3.1.1m
compiler. As of the time that Maya 3.0 shipped, no patches to this compiler
were required to successfully build Maya plug-ins.

NT: For Maya3.0 plug-ins the Microsoft Visual C++ v6.0 is required. The
most current service pack for this compiler should also be installed.

Plug-ins that use the class MFnLightDataAttribute require a small code
change

A new feature has been added to the Maya 3.0 rendering software that will
require a source code change to plug-in shaders that use this the
MFnLightDataAttribute class. The scope of the change is that a new attribute
has been added to the compound light data structure and needs to be
declared and created within the MFnLightDataAttribute constructor so your
plug-in will compile in Maya 3.0. The two affected methods in this class are:
create and setDefault both of which now require an additional argument.

There are 6 example plug-in shaders in the Developers Tool Kit that used
this class and these have all been modified to take this change into account.
The modified example files are:

• backfillShader.cpp

• lambertShader.cpp

• lightShader.cpp

• phongShader.cpp

• shadowMatteShader.cpp

• anisotropicShader.cpp
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Please refer to the example source code files, and the additional declaration
and handling of the attribute named aBlindData.

Plug-in compatibility changes made in Maya 2.0
If you are upgrading from a Maya 1.0 or Maya 1.5 directly to Maya 3.0, you
will also need to know what source code compatibility changes were made
to the API between Maya 1.x and Maya 2.0. The information in this section
has been reproduced verbatim from the Maya 2.0 “What’s New” document.

Multiple OpenMaya libraries for modularization
The Maya Developers Kit now offers multiple libraries to effectively
modularize the code into various components of Maya.

As a result of this change, you have to modify your Makefiles or project files
to add the appropriate link directives for the OpenMaya library in addition
to libraries your plug-in requires. We have added an indicator to each class
definition to indicate which library will be required when using that class.

The developers libraries now exist in several shared libraries as follows:

Plug-in autoload
Previously, when a plug-in was marked for autoload it was recorded in the
userPrefs.mel prefs file as an absolute pathname to the plug-in. Now just the
plug-in name is stored in userPrefs.mel and the standard
MAYA_PLUG_IN_PATH environment variable is used to locate the plug-in.

OpenMaya: All base API functionality that is shared between the
other libraries. Also includes all NURBS and
polygon support.

OpenMayaUI: User-Interface related classes.

OpenMayaAnim: Animation related classes.

OpenMayaFX: Dynamics related classes.

OpenMayaRender: Software rendering related classes.
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UI methods moved from MGlobal class to M3dView class
As part of the modularization effort described above, the following static
methods were moved from the class MGlobal to the class M3dView:

• active3dView

• numberOf3dViews

• get3dView

• display

• deviceContext

• applicationShell

If you used any of these methods in your plug-in, you will have to change
the class name appropriately and add OpenMayaUI to the link directives for
the plug-in.

New MPxIkSolverNode class

Replaces MPxIkSolver class for registering and creating user defined
IK solvers

IK solvers are now being registered as Maya nodes. In prior versions of
Maya, IK solvers were registered using a special registration mechanism,
MFnPlugin::registerIkSolver. This registerIkSolver method is problematic as
the plugin needs to be unloaded and reloaded after a File > New. The class
MPxIkSolverNode has been added from which IK solvers should be derived.
The previous class, MPxIkSolver, and the method
MFnPlugin::registerIkSolver will be removed in a post 2.0 release of Maya.

If your solver was written using the old MPxIkSolver class, you can convert
it to derive from the new MPxIkSolverNode class.

Note
The registration of an IK solver as a regular Maya node makes it possible to
use plug-in IK solvers in the same way that non-default IK solvers (for
example, ikMCsolver) are used.
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To use the new MPxIkSolverNode class:

1 Add an empty initialize method and node id to the class derived from
MPxIkSolverNode. For example:

static MStatus initialize();
static MTypeId id;
MTypeId simpleSolverNode::id(0x81234);
MStatus simpleSolverNode::initialize()

{ return MS::kSuccess; }

2 Change registerIkSolver to registerNode, and pass the node id and initialize
method as additional arguments. For example:

plugin.registerNode(“simpleSolverNode”,simpleSolverNode::id,
&simpleSolverNode::creator,

&simpleSolverNode::initialize,
MPxNode::kIkSolver);

plugin.deregisterNode(simpleSolverNode::id);

3 Create a solver, using the createNode. For example:

createNode simpleSolver;

MPxNode::addAttribute

Now fails on duplicate attributes

In previous versions of Maya, if an attempt was made to create an attribute
whose long or short names conflicted with those inherited from parent
nodes, the attempt would fail, but addAttribute would not return an error
indicating the failure.

In Maya 2.0, the method MPxNode::addAttribute now fails if:

• you attempt to add an attribute more than once

• the long and short name of an attribute are identical

• the long name of the attribute is used as the long name of any previously
added attribute

• the short name of the attribute is used as the short name of any previously
added attribute



WHAT’S NEW IN MAYA 3

290

API AND DEVELOPER’S TOOL KIT | 16
General improvements

The API is now reporting a latent bug that went unreported in previous
versions. If you are checking the return status of addAttribute you will start
getting failures from your node’s initialize routine and will have to correct
the names used for the node’s attributes.

MStatus::error

No longer returns incorrect boolean value

In previous versions of Maya, this method was wrong. The method returned
true when there was no error and false if there was—exactly the opposite of
how it was documented to behave. This has been corrected for Maya 2.0. If
you wrote code to accommodate this bug in previous versions of Maya, you
will have to change your code to accept the new (correct) return value.

MPxContext::setImage method

Replaces addToolIcon and removeToolIcon functionality

The addToolIcon and removeToolIcon MEL subroutines were added in
Maya 1.5 to allow you to associate an icon with your tool context. This
allowed Maya to display the icon for your context in the 6th position of the
Maya mini-bar.

In Maya 2.0, the new way to accomplish this is to use the new setImage
method in the MPxContext class. The addToolIcon and removeToolIcon
interfaces have been modified so they will continue to work but support for
them will be removed in a post 2.0 release.

Signature of MDagPath::getAPathTo method changed
The method, getAPathTo, in the MDagPath class has been changed so that it
returns an MStatus and provides its result in a reference parameter. A
compatibility method using the old signature exists, but will be removed in a
post 2.0 release of Maya.
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getRotation, setRotation in MFnIkJoint,
MTransformationMatrix signatures

Classes have changed

The methods getRotation and setRotation in MFnIkJoint and
MTransformationMatrix have been changed to no longer accept a space
parameter as these rotations are only valid in transformation space.
Compatibility methods that contain the old signatures exist, but will be
removed in a post 2.0 release of Maya.

Layers no longer accessed with the MFnSet class
In previous versions of Maya, layers were implemented using sets so that
when you created a layer a special kind of set was created. In Maya 2.0,
layers are implemented using their own dependency node and are no longer
related to sets in any way. This change resulted in the removal of the isLayer
parameter from the create method in the MFnSet class. To create a layer
node, create a dependency node of type MFn::kDisplayLayer.

To make the old signatures compatible with the changes, you must set the
isLayer to false. Otherwise an invalidParameter error is displayed.

The method isLayer is now obsolete. A compatibility method with this name
still exists, but it will unconditionally return false. The replacement for this
method is to use the hasFn method of MObject, and see if the node supports
the type MFn::kDisplayLayer.

MFnNurbsSurface tessellate method

New argument and new return value

A new argument, parentOrOwner, has been added to the
MFnNurbsSurface::tesselate method to specify the owner of the new surface.
The return value has also changed depending on the usage of the new
argument. Source code that uses the previous versions function signature
will result in a new transform created for the mesh and added to the DAG.
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M3dView::refresh method

New force argument

A new argument, force, has been added to the refresh method of the API
class M3dView. The default setting is false, which maintains the previous
behavior of the method. However, if it is set to true, the views are refreshed
even if they do not require it.

NEW FEATURES

New API for subdivision surfaces (for Maya Unlimited)
Maya implements fully hierarchical Catmull-Clark quad based subdivision
surfaces. You can use them without any hierarchical edits, but their full
power is only realized when you do use the hierarchy. Using the hierarchy
lets you access additional vertices on the existing faces. For example, a single
4 vertex plane can give you access, through hierarchy, to over 16,000,000
points at the finest level of the hierarchy (please don't try it). Additionally,
the points at the finer levels are created only as you need them and only in
the areas where you need them, giving you an implied level of detail
workflow.

The “base” mesh is sometimes used to describe the coarsest level of the
hierarchy. Once we go one level finer (to level “1”) all faces are four sided
(though not all vertices are of valence 4). At that point, each face can be
considered to have 4 “children” faces. Starting with a 4 vertex single face
plane, there will be 4 faces (and 9 vertices) at level 1, 16 faces (and 25
vertices) at level 2, etc. You can go as deep as level 12.

Please consult Maya documentation on subdivision surfaces for more
details.

Caution!
The force option should be used with extreme caution. Extra refreshes will
greatly hinder application performance. The only time it will likely be
necessary to use this option is from a command that intends to use
something like glReadPixels to snap an image of the screen.
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The subdivision surface API consists of 3 classes:

MFnSubd

This function set provides access to subdivision surfaces. Objects of type
MFn::kSubdiv, MFn::kSubdivData, and MFn::kSubdivGeom are supported.
MFn::kSubdiv objects are shapes in the DAG, MFn::kSubdivGeom objects
are the raw geometry that the shapes use, and MFn::kSubdivData objects are
the data that is passed through dependency graph connections.

MFnSubdNames

This function set provides some simple utilities for the interpretation and
manipulation of the subdivision surface vertex, edge and face ids.

MFnSubdData

MFnSubdData allows the creation and manipulation of Subdivision Surface
data objects for use in the dependency graph.

If a user written dependency node either accepts or produces Subdivision
Surfaces, then this class is used to extract or create the data that comes from
or goes to other dependency graph nodes. The MDataHandle::type method
will return kSubdiv when data of this type is present.

If a node is receiving a Subdivision Surface via an input attribute, the
asSubdSurface method of MDataHandle can be used to access that input
Subdivision Surface.

If a node is to create a Subdivision Surface and send it via an output
attribute, a new MFnSubdData must be instantiated and then the create
method called to build the actual data block as an MObject. This MObject
should be passed to the MFnSubd::create method as the parentOrOwner
parameter so that the Subdivision Surface will be constructed inside the data
block. The MDataHandle::set routine is then used to pass the data block
down the connection.

Support for Multi UV's on Polygons

Multi Texturing in MFnMesh, MItMeshFace and MItMeshVertex

Modifications to support Multi Texturing have been added to the MFnMesh,
MItMeshFace and MItMeshVertex classes. These modifications provide
access to the multi texture data via the API.
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New API classes

MAnimUtil
A class that contains static animation helper methods such as “isAnimated”
that allows you to determine if a particular object or plug is animated. Other
methods allow you to find the animCurve node or nodes that drive the
animation.

MConditionMessage
A new class derived from the MMessage class that is used to register
callbacks for changes to specific conditions. The complete list of conditions
available in Maya can be found in the documentation for the scriptJob
command under the “listConditions” flag. Some example conditions are
“DynamicsExists” and “isPlayingBack”, and “readingFile”.

MEventMessage
A new class derived from the MMessage class that is used to register
callbacks for changes to specific events. The complete list of events available
in Maya can be found in the documentation for the scriptJob command
under the “listEvents” flag. Some example events are “NewSceneOpened”
and “playbackRangeChanged”, and “SelectionChanged”.

MUiMessage
A new class derived from the MMessage class that is used to register
callbacks to track the deletion of UI objects.

MFnAreaLight
Provides methods to that allow you to create and manage “area lights”,
which are a new Rendering feature in Maya 3.0.

Note
These classes are software compatible with Maya 2.5 plug-ins.
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MFnSubd, MFnSubdData and MFnSubdNames
These classes are part of the new subdivision surface API and are described
previously in the “New Features” section of this document.

MUint64Array and MFnUInt64ArrayData
New classes that manage arrays of unsigned 64-bit values. These are
currently used as part of the subdivision surface API.

MFnVolumeAxisField
Provides methods to that allow you to create and manage “volume access
fields”, which are a new Dynamics feature in Maya 3.0.

MPxGlBuffer
A new proxy class that allows you to create an user-defined off screen
rendering buffer. Maya can now be directed to render to this buffer instead
of to the screen.

MRenderCallback
A new class that is used to register callbacks to gain access to Maya's
rendering information during software rendering. You can modify Maya's
shadow maps, RGB pixmap, and depth map to composite your own
rendering effects into Maya's rendering.

Enhanced API classes
• Two new methods, numNonZeroSpansInU and numNonZeroSpansInV,

have been added to the class MFnNurbsSurface. These are needed to
compute the number of patches on Bezier surfaces.

• Four new methods have been added to the MString class. Two overloaded
“set” methods now allow you to initialize the string with a double. As well,
operator= and operator+ methods that take double arguments were added.
These methods allow you to add numeric values to strings without first
converting them to strings.

• Two new overloaded “setResult” methods have been added to the
MPxCommand class that take MIntArray and MDoubleArray arguments
respectively.
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• Two new methods, “getAffectedAttributes” and “getAffectedByAttributes”
have been added to the MFnDependencyNode class. These methods allow
you to determine which attributes of a node are affected by a particular
attribute or which attributes affect a particular one. See the new example
plug-in, getAttrAffectsCmd for an example that shows how to use these new
methods.

• A new method, parentNamespace, has been added to the
MFnDependencyNode class, which returns name of the namespace in which
a node resides.

• A new overloaded “intersect” method has been added to the
MFnNurbsSurface class. This method returns an MPointArray that contains
all intersection points of the given ray with the surface.

• Two new methods: rotateOrientation and setRotateOrientation were added
to the class MFnTransform to allow manipulation of the rotation orientation.

• Four new methods: setExistWithoutInConnections,
existWithoutInConnections, setExistWithoutOutConnections and
existWithoutOutConnections have been added to the MPxNode class. These
allow you to define whether or not your new node should be deleted when
the last node to which it has an input or output connection is deleted.

• A new method, uvPoint, as been added to the MDynSweptTriangle class.

• New overloaded create methods were added to the MFnDependencyNode
and MFnDagNode classes that allow you to specify an initial name for
newly created nodes.

• New “copy” methods have been added to the classes: MDoubleArray,
MFloatArray, MFloatPointArray, MFloatVectorArray, MIntArray,
MPointArray and MvectorArray.

• The new enum element, kIprRender, was added to the MRenderState enum
in the MRenderUtil class to allow a plug-in to determine if an IPR render is
in progress.

• The cleanup method of the MLibrary class has been enhanced so that it now
accepts an exit code as a parameter. If provided, when the cleanup code
causes your application to exit, it will exit with the given value.
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Corrections to existing functionality

Improvements in API classes
• In previous releases it was impossible to add shapes to a set that had been

created by the create method of the MFnSet class when the kRenderableOnly
flag was provided to the create call.

• The operator*= method in the MMatrix class has been fixed.

• The missing documentation for the registerShape method in the MFnPlugin
class has been added.

• Maya will no longer crash if a call to the isPlaying method of the
MAnimControl class is made from a multi-threaded plug-in on a multi-
processor machine.

• A new virtual method, isAbstractClass, has been added to the class
MPxNode class. If it is defined to return true, Maya will consider the new
plug-in node type to be “abstract”. That is, it will not be possible to create an
instance of that node type. The node type can however still serve as a base
class for other derived plug-in nodes.

• Maya will no longer crash if the tessellate method of the MFnNurbsSurface
class is called with a “parentOrOwner” set to NURBS Data and the MObject
for the new surface is defined prior to that of the data.

• In the MFnCamera header file, the example parameter names “near” and
“far” were changed. When using certain compiler flags, these names are
reserved keywords in Visual C++ and could cause compile problems.

• In previous releases, if you were in a plug-in tool, and used the delete key to
delete an object, that delete action would not get registered on the undo
queue. This would cause serious problems if you tried to undo the
operation.

• The projectionMatrix method of the MFnCamera class has been fixed.

• The setDrawColor method of the M3dView class now correctly sets the
alpha value of the color.

• If you tumble the view while in a plug-in tool, the cursor now gets changed
back to the tool’s cursor when the tumble is complete.

• Maya no longer crashes if you load and unload a tool plug-in numerous
times.
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• The MItDependencyNodes class now checks the first node seen against the
filter. Because of the way that Maya scenes are initialized, the iterator would
fail in previous releases when using a MFn::kTime filter.

• The MAYA_FILE_ICON_PATH environment variable is no longer used by
Maya, and thus is no longer used to specify the location of bitmap files used
by plug-in file translators. As of Maya 3.0, the XBMLANGPATH variable is
used to specify the location of all types of bitmap files on all platforms.

• Maya stand-alone applications no longer crash if a call is made to the
getConnectedShaders method of the MFnMesh class.

• Maya stand-alone applications could crash in previous releases with some
MTesselationParams settings were used when making a call to the tessellate
method of the MFnNurbsSurface class. This has been corrected.

• The copy constructor of the MSelectionList class has been fixed.

• The isZAxisUp method of the MGlobal class no longer returns false
unconditionally.

• The upAxis method of the MGlobal class no longer returns [0, 0, 0]
unconditionally.

• The C++ preprocessor defines “STRICT” and “EXPORT” have been removed
from the MTypes.h header file. They were unused in previous release and
could cause compile problems in certain circumstances.

• The setUIUnit method of the MAngle class has been fixed.

• The MSelectionList parameter to the MItSelection list constructor was
erroneously not declared “const” in previous releases. This has been
corrected.

• Maya no longer crashes if a plug-in node that has had dynamic attributes
added to it is duplicated.

• The isFlipNorm method of the MFnNurbsSurface class could cause Maya to
crash under some circumstances. This has been corrected.

• In Maya 2.0 and Maya 2.5, Maya would sometimes crash in the setWeight
method of the TdnWeightGeometryFilter class if this method was called
while iterating over the components of a NURBS surface via the
MItGeometry class. This has been corrected.
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Documentation corrections
• Documentation has been updated to getConnectedSetsAndMembers and

getConnectedShaders methods of MFnMesh to indicate that they only work
when the function set is initialized with a kMesh (a shape) node. These
methods will not work with kMeshData objects.

• Fixed a formatting problem in the MAnimUtil class that made it very hard to
read.

• Corrected the documentation for the getBlindDataTypes method of
MFnMesh. Previously, the list of documented parameters was not the same
as the list of actual parameters.

• Fixed the description of the components of the transformation matrix in the
MTransformationMatrix class.

• Added detailed documentation for the MSpace class to the API class
documentation.

• Updated the documentation of the MItDag class to indicate that the root of
the traversal is included.

• A section was added to the API Developer's manual in the Chapter on
writing commands that describes how to return values from commands.

• In the MFnLight class, added a new overloaded lightDirection method that
returns the direction the light is pointing. Fixed the documentation for the
existing lightDirection method to indicate that it is only operational during
rendering.

Miscellaneous corrections
• A new plug-in, “swissArmyManip.” was added to the devkit example plug-

ins. This contrived example shows how to create every available kind of
plug-in manipulator.

• In the plug-in manager, if you mark the plug-in for autoload without first
loading it, the plug-in will now be autoloaded the next time you start Maya.
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baking

Fur changes 269
particles 164

Base Width 264
basic tools

changes 5

batch rendering
changes 269
-rep command line
option 211

bendAngle attribute in cloth 258
Bezier

Rebuild Surfaces option 40
birthPosition attribute 205
Blend

box 22
clips 126
modes 79, 228

Blend shape slider orientation
control 140

Blind Data editor 48
Blur Radius 271
blurring 271
bookmarks 17
Border Target Shape map UV

border option 64
Both Fields

Interlaced 252
Separate 252

Brush Depth
Paint Textures Tool 240

bump mapping
attribute 195
painting 238

By Attribute Name
Export Character Map 135
Paste 121

By Attribute Order
Export Character Map 135
Paste 121

By Current Map
Export Character Map 135
Paste 121

By Node Name
Export Character Map 135
Paste 121



WHAT’S NEW IN MAYA 3

302

INDEX

C
cache

creating for particles 166
cache files

deleting 171
cache settings for particles

editing 168
options 167

caching
particle start-up 173
recreating the cache 170
single particle object 172
tips 171
using start-up with batch
rendering 174

caching particles
playing back 169

Calc. Area Values 266
cameras

moving forward along a
curve 109

character maps
exporting and editing 135

character setup
changes 139

Character(s) Clips & Poses
Visor 113

characters
attributes as all keyable or
non-keyable 146

new creation options 146
Clear All command 281
Click Box Size 20
Clip

Create Clip 115
Clipboard Start

Paste 122

clips
blending 126
copying 120
creating 114
cutting 120
disabling 129
duplicating 122
editing animation curves 128
editing attributes 116
editing blended 127
editing original keys 129
editing source attributes 119
in Visor 112
instancing 123
merging 125
pasting 120
splitting 124
Trax Editor 110, 111

Cloth
changes 257

cloud shader 193
Color Chooser

changes 21
Command option box

changes 14
commands

executing 29
compiler requirements 286
Component Display submenu 11
Component Editor 29

Hold 144
component-based influence

object behavior 145
Comprehensive solver 271
Conform normals 87
Continuous selection 107
Convert Display colors 80
Copy

clips 121
Copy Current UV Set 68

copySkinWeights 141, 143
crackless tessellation 216
Create Character window 146
Create Clip 114
Create Empty UV Set 68
Create New Display Layer menu

item 9
Create New UV Set

automatic mapping option 54
Create Pose 134
Current Time

Paste 122
Split 124

custom attributes 35
Custom Extension attribute 254
Cut

clips 121
Cycle

clip attribute 117
Emissions attribute 201
Interval attribute 201

D
Default Field Extension (o and e)

attribute 254
deformers

new advanced creation
options 140

Delete Attributes option 10
Delete Current UV Set 68
Delete Original Source

Split 124
Developer’s Tool Kit

changes 285
deviceContext 288
Die on Emission Volume Exit

attribute 151
Diffuse Coeff attribute 195
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Direction 25
Direction X, Y, Z attribute 161
Directional Speed attribute 152,

161
Disable Maya Rendering 268
Disable Weight

Normalization 145
disabling

clips 129
disappearing file textured

leaves 256
displacement mapping 214
Display category 19
Display menu 13

changes 10
Display Poly Count 48
Display Speed attribute 152
Display Unfiltered 84
documentation

changes 279
dolly 211
dragging and dropping

textures 256
Duplicate

clips 123
Duration

source clip attribute 120
Dynamics

changes 147
Dynamics menu

improvements 203

E
Ease In/Out

Blend 126
Edge Weights relax UVs

option 67
edit keys 30, 281

Edit Polygons menu 14, 46, 47
editing weight locking

of joints 144
of smooth skin influence
objects 144

empty UV set 69
Enable

clip attribute 117
Enable Fur Image

Rendering 267
Enable Shadow Map

Rendering 268
Enable Weight

Normalization 145
Enable/Disable

clips 130
Encapsulated PostScript files

importing 17, 18
End Conditions

Rebuild Surfaces option 40
enlarging manipulators 31
EPS files

importing 17, 18
Euler angle filtering 107
Euler Filter 108
Even Field attribute 254
Even Fields 253
Exclusive Partition creation

option 141
executing commands 281
Existing Partitions creation

option 141
Export Character Map 135
Export Selection option

Hypershade 220
exporting

clips 130
Expression Editor

changes 281

Expressions
changes 281

extracted faces 90
Extrude commands 81

F
Feedback line 6
Fewer pieces 52
Field Dominance

Even Fields 253
render options 253

Field Dominence
Odd Fields 253

Field Options attributes 252
Fields attribute 252
Fields menu 14
File menu

Hypershade 219
File Texture

Paint Textures Tool 240
file textured leaves 256
filter display

clearing 30
Filter Level 276
Filter Radius attribute 196
finalLifespanPP 198
Find 25
Find Menu 9
Flip Reversed layout UVs

option 56
flipping during path

animation 108
flower petals 256
Frame All

Trax Editor 112
Frame Rate 11, 107
Frame Slip 273



WHAT’S NEW IN MAYA 3

304

INDEX

Frame Timeline Range
Trax Editor 112

Frames
render 252

Freeze Transformations 31
freezing an object 31
Fur

changes 263
Fur Globals

changes 265
Fur Image Rendering 268
Fur Render Options 266
furAttrMap directory 269

G
General Preferences 18
get3dView 288
Global Scale fur attribute 264
glossary 279
Graph Anim Curves

clips 127
Graph Editor

outliner split control 108
Group option

for file import 18

H
hair

rotating about surface V
axis 264

Hairs/Pixel 268, 269
header file 286
Heads Up Display 10, 107
Hide UI Elements 11
Hold 144
Horizontal slider option 140

Hotkey Editor
changes 24

hotkeys 28
+ 31
on menu labels 27

Hypershade 219
changes 91

I
IK solvers 288
Illustrator

Adobe 17, 18
images

displaying unfiltered 84
importing

clips 130
clips by referencing 131
EPS and Adobe Illustrator
files 17, 18

Inclination 264
Include Subcharacters in Clip

Create Clip 116, 137
Infinite 274
infinite points 274
Initial Weight Curve

Blend 126
Instance

clips 124
instancer

centering strokes on
particles 202

using Paint Effects
strokes 202

instancing Paint Effects
strokes 255

interactive rendering, multi-
threaded 217

Interpolation Type 206

Into Square 53
Inverse Front attribute 109
Invert Attenuation 160
IRIX edit keys 281
Isolate Select 15, 16

K
Keep Original Source

Split 124
Keep originals in Trax editor

Merge 125
Keys

Create Clip 114
keys 25

listing 26

L
Layer bar

changes 6, 8, 9
Layer Editor 12
Layer is Visible 228
layer swatch 8
Layered Texture node 224

creating 225
layered textures 70
layers

creating 9
render 8
texture 73

Layout
automatic mapping option 52
layout UVs option 57

Layout UVs 48, 54, 55, 56
options 56

Leave Keys in Timeline
Create Clip 114
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Length 264
Less Distortion 52
Library search tool 279
lifespan

in expressions 198
particle 282

Lights
area 211
menu 14

Linear
Blend 126

List Current Characters Only
Trax Editor 112

Live
changes 271

Load Components button 29
Load Selected Objects 17
Locator quality 273
Locator Summary panel 273
Lock 275
locked points 274

M
Magnitude attribute 159
Make New Layers Current 8
management

project 30
mangled animation curves 107
manipulator(s)

Surface Editing Tool 37
manipulators

enlarging 31
Map Method

Export Character Map 135
Map UV border 48

options 64
Max Distance attribute 159

Max Iterations relax UVs
option 68

MAYA_PLUG_IN_PATH 287
measure submenu 10
measure tools 10
MEL

changes 281
menu labels

hotkeys on 27
menu name

finding 9
Merge

clips 125
Merge Vertices

changes 91
MFnLightDataAttribute 286
Mirror button 141
mirroring smooth skin

weights 141
modeling

changes 31
Modified Reverse option 85
Modifier 25
Modify menu

changes 10
motion capture 107
motion path animation 109

flipping improvements 108
motion warping 115, 133
Move and Sew UVs 48, 58
Move Normal Tool 34
MPxIkSolverNode class 288
MTypes.h 286
multiple images

rendering and stitching 256
multitexturing 70
multi-thread interactive

rendering 217
multi-thread shadow maps 217

N
Name

Create Clip 114
Merge 125

Need Parent UV attribute 200
New Partition Name creation

option 140
No Field Extension attribute 253
No Multiple Knots

Rebuild Surfaces option 40
Noise Anim Rate attribute 195
Noise Level attribute 206
Noise Ratio attribute 206
nondestructive animation 115,

133
non-IFF image formats 211
nonlinear character

animation 105
nonmanifold geometry 87, 88, 91

cleanup option 90
making 2-manifold 88

Normalize Weights 145, 146
normals

conforming 87
option changes 85
reversing 85
reversing and
propagating 87

shells, when reversing 87
Normals Display Scale 34
Normals menu

Reverse 85
Reverse and Propagate 87

NTSC video 253
numberOf3dViews 288
Numeric Input field 7
NURBS modeling

changes 37
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NURBS Tesselation 268

O
Object Components submenu

changes 11
object templates 32
Odd Field 252

attribute 254
Offset

clip attribute 116
Once selection 107
OpenMayaAnim

287
OpenMayaFX

287
OpenMayaRender

287
Optimize automatic mapping

option 52
Options menu 13

changes 11
Origin Axis 10
Oscillate selection 107
Outliner

changes 28
splitting 28

outliner seperator 108
outliner split control 108
overlapping UVs, relaxing 66

P
Paint Effects

changes 255

Paint Effects strokes
instancing 202, 255
rendering at test
resolutions 256

rendering without depth
output 256

Paint Selection Tool 10
Paint Textures Tool 18, 231

assigning textures 247
AutoSave on Exit 247
AutoSave on Stroke 247
Brush Depth 240
File Texture 240
masking polygonal faces 235
painting bump maps 238
polygonal faces 237
Reload Textures button 247
Save Textures button 247
Stamp Profiles 239
Stamp Spacing 239
texture attributes 240
texture naming 232
transparency 237
using 234, 236, 237

paintable attributes 282
painting

using the Paint Textures
Tool 234, 236

wrinkles 258
PAL video 253
palette 22

custom 22
Parent Texture to Selected items

option
Hypershade 220

particle attribute editor 205
particle caching 164
particle cloud shader 193

particle disk cache 165
creating 166
deleting 171
editing 168
playing back 169
recreating 170
setting options 167
tips 171

particle lifespan 197
expressions for 282

particle sampler info node 175
creating 176
examples 177
re-using 190
setting attribute 187

Partition to Use creation
option 140

Paste
clips 121

Paste Method
Paste 121

path
current project 30
default project 30

Per Fur Description 267
Percentage Space

automatic mapping option 54
layout UVs option 58

Pin Selected UVs relax UVs
option 68

Pin Unselected UVs relax UVs
option 68

Pin UV Border relax UVs
option 67

Pin UVs 67
Pin UVs relax UVs options 67
pixel slip 273
pixel snap 84
pixels

snapping to 84
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Planes option 52
playback looping options 107
Playback Looping selection 107
Plug-in autoload 287
plug-ins

upgrading 285
Point constraint

vs locked point 275
Polar 264
Poly Count 11
Polygon Cleanup Options 89
Polygon menu 14, 46

changes 14
polygonal face normals

reversing 86
polygonal faces

painting 237
polygonal modeling

changes 45
polygonal texture mapping 223
Polygons menu 46
polyUVsPlus.so plug-in 48, 60,

61
Pose

source clip attribute 120
poses

creating 134
in Visor 112

Preferences
submenu 12
Trax Editor 112
window 18

Preferences window 18
Preserve Shape Detail map UV

border options 65
Primary Visibility option 255
project management

changes 30
Projective paint mode 235

Propagate option 85
propagating and reversing

normals 87
Proportional Modification Tool

changes 33
Put Clip in Trax Editor and Visor

Create Clip 115
Duplicate 123

Put Clip in Visor Only
Create Clip 115
Duplicate 123

Q
Query 25
Quick Rename 7
Quick Selection 7

R
Random Direction attribute 152
Random stream 199
Range Slider 107
Range Slider display toggle 107
ray tracing 219
Rearrange Graph button

hypershade 221
rebaking 269
recompiling plug-ins 285
referencing

clips 131
Region of Affect 19
registration process

attribute 282
Relative offset

clip attribute 116
Relax UVs 48

options 67

relaxing UVs 66
Reload Textures

Paint Textures Tool
button 247

Remove Selected Objects 17
Remove Track

clips 132
Rename Attributes option 10
Rename Current UV Set 68
render layer management 249
Render Layer/Pass Control 9
render layers 8
render pass management 251
rendering

changes 209
Paint Effects strokes 256
particles, in software 175
universal 209

-rep
command line option, batch
rendering 211

Repeat Last 34
Repeatable 25
Replaces Axes submenu 10
requirements

compiler 286
Reset 31
Restore Factory Settings 19
Restore UI Elements 11
Reverse and Extract option 86
Reverse and Propogate

option 87
Reverse normals

description 85
Reverse option 85, 86
reversing and propagating

normals 87
Reversing face normals 85
Revert to Saved 19
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Roll fur attribute 264
Root Frame solver 271
Rotate Order for Maya Live 277
rotating hair about surface V

axis 264
Roundness attribute 194

S
Save Textures

Paint Textures Tool
button 247

Saving and reverting changes 19
Scale

automatic mapping option 53
clip attribute 118
layout UVs option 57

scale changes to smooth
skin 145

Scale Factor 18
Scale Rate by Object Size

attribute 200
Scale Speed by Size

attribute 152
Script

changes 281
Script Editor

changes 29
search tool 279
Section Radius attribute 151,

160
Select Shell 83
Selection category 20
selection types 32
Separate Extracted Faces 90
Separate layout UVs option 56
Set Current UV Set 68

Set Default Shading Group
option

Hypershade 220
Shading menu 14
Shadow Map Rendering 269
shadow map setting 265
shadow maps, multi-

threaded 217
Shape Detail map UV border

option 65
Shelf

changes 6, 8
tabs 8

shell border 83
shells 83

when reversing normals 87
skinCluster node 145
smooth skin influence object

behavior
improvement 145

smooth skin weights
copying 142
locking influence objects 143
mirroring 141
normalizing 145

smooth skinning
changing scale
improvements 145

improved component-based
influence object
behavior 145

smoothing
Average Vertices 60

Smoothing Interval
vs Filter Level 276

Snap Tolerance 20
snapping

category 20
three points 33
to pixels 84

Solid Core Size attribute 195
Solve task 273
solver

Comprehensive 271
Root Frame 271

Source Clip
Split 124

source clip
editing attributes 119

spaces in filenames 34
Spacing Presets

automatic mapping option 53
layout UVs option 57

Specify Start and End
Create Clip 115

Specify Time
Split 124

specifying weight locking when
adding influence
objects 144

speed improvements 219
Speed Random attribute 201
Split

clips 124
Split Time

Split 124
Split vertex operation 81
splitting a vertex 81
Stamp Profiles

Paint Textures Tool 239
Stamp Spacing

Paint Textures Tool 239
Start

source clip attribute 120
Start and End

Create Clip 115
Start Frame

clip attribute 117
Paste 122
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start-up caches
using with batch
rendering 174

Status bar changes 7
Status Line

changes 6, 7
stitching images 256
Stopping Conditions relax UVs

options 68
strokes

rendering 256
Subcharacters

Create Clip 116
subcharacters 146

using in clips 136
Subdiv Surfaces menu 14
subdivision surfaces

software render 211
subdivision surfaces modeling

changes 93
Surface Color attribute 195
Surface Editing Tool 37
surface origin

displaying 32
Surface Shading Shadow

attribute 196
Switch utilities

and paint multiple
surfaces 233

T
templates 32

menu selection 32
tessellation, crackless 216
Texture Attribute to Paint

Paint Textures Tool 240
Texture Blend attribute 79
texture layers 73

texture mapping
automatic 49, 52
laying out UVs 54, 55, 56
moving and sewing UVs 58
polygonal 223
relaxing UVs 66
UV border 63

Texture View
changes 83
window 48

textures
assigning, Paint Textures
Tool 247

attributes for Paint Textures
Tool 240

dragging and dropping 256
layered 70
painting with Paint Textures
Tool 231

reloading, Paint Textures
Tool 247

saving, Paint Textures
Tool 247

Three Point Snap 33
Threshold 265
Time Range

Create Clip 115
Timeline 107

Trax Editor 111
Timeline Start

Paste 122
Tip Width 264
topology

nonmanifold 87
track 211
tracker

changes 271
tracks

adding and removing
clip 132

Transfer 48

Translucence attribute 194
Translucence Coeff attribute 196
transparency

painting 237
Trax 105
Trax Editor 110, 111

dependency graph
nodes 132

enhancing display 111
MEL commands 131

Trax Gems 107
Trim Convert

Rebuild Surfaces option 40
Turbulence field

Improvements 205

U
UI Preferences 18
unfiltered images

displaying 84
universal rendering 209
Untemplate 11, 32
Unused Clips & Poses

Visor 113
Use Animation Curve Range

Create Clip 115
Use Current Layer 8
Use Fur Shading/Shadowing on

Fur 269
Use Rotate 272
Use Scale 272
Use Selected

Create Clip 115
Use Snap Tolerance 20
Use Time Slider Range

Create Clip 115
useComponentsMatrix

attribute 145
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user interface
changes 5

UV set
applying layered textures
to 70

copying values to 70
creating 69, 71
deleting 70
empty 69
renaming 69
selecting 69

UV texture mode 235
UVs

automatic mapping 49, 52
changes 48
connecting to textures 77
laying out 54, 55, 56
mapping border 63
moving and sewing 58
on complex models 60
relaxing 66
untangling 66

V
vertex

splitting 81
Vertical slider option 140
vertices

smoothing 60
View Axis 10
View Selected 16
Visor 219

clips and poses 112
Volume Axis Field 157
volume emitters 148

creating 149
setting attributes 150, 158,
162

volume fields 161
keeping particles inside the
volume 164

Volume Offset attribute 150
Volume Offset X, Y, Z

attribute 160
Volume Shape attribute 150
Volume Sweep attribute 150,

160

W
Weight

clip attribute 116
What’s New in Maya 3 280
Window menu 13

changes 12
World Up Object option 109
World Up Type option 109
World Up Vector option 109
worldBirthPosition attribute 205

Z
Zeroth Scanline attribute 253


