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What's New in General

Alembic file format support

You can now load, save, and play back Maya scenes as Alembic-
based cache files. The Alembic file format is an open-source format
developed for exchanging complex 3D geometry data. Alembic
files are highly portable and application independent so they can
be shared, processed, and played back by a number of content
creations applications.
In Maya, Alembic caches provide a number of performance im-
provements, including quicker loading time of large scenes, faster
play back of complex character animations, and real-time play
back of geometry data with topology changes.
Alembic files also let you easily share large scenes between various
areas of your production pipeline without the large memory
overhead of fully editable scene files.
Options in a new Alembic menu, located in the Maya main menu
bar, let you configure settings for loading and saving Alembic
files.

■ Import and export Alembic files (page 2)

■  Watch: Alembic file import and export

Run Maya with a Simplified Chinese interface

Maya is now available with a Simplified Chinese inter-
face. For instructions on how to run Maya with a Sim-
plified Chinese interface on a different operating sys-
tems, see Run Maya with a Japanese or Simplified
Chinese user interface (page 7).
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Import and export Alembic files

Overview

You can save and load Maya scene files as Alembic cache files. The Alembic
file format is an open-source format developed for exchanging complex 3D
geometry data. Alembic files are highly portable and application independent
so they can be shared, processed, and played back by a number of content
creations applications.

In Maya, Alembic caches provide a number of performance improvements,
including quicker loading time of large scenes, faster play back of complex
character animations, and real-time play back of geometry data with topology
changes. Complex scenes and animations can be exported as an Alembic file,
and then re-imported into Maya to improve play back performance and reduce
memory use. This workflow lets you easily pass complex scene data to various
areas of your production pipeline, such as between animation and simulation
or animation and lighting, without the large overhead of fully editable scenes.

For example, you can export a polygon mesh created from an nParticle effect
to an Alembic file, then play the simulation back in Maya solely as a polygon
object.

You can use the Alembic Import and Alembic Export windows to
configure settings for loading and saving Alembic files. You can access the
Alembic Import and Alembic Export windows from the Alembic menu
located on Maya main menu bar. You can also use MEL commands to import
and export Alembic files.

See Alembic > Alembic Import (page 3) and Alembic > Export (page 4).

To import and export Maya scenes as Alembic files, the AbcImport.mll and
AbcExport.mll plug-ins must be loaded. Open to the Plug-in Manager (
Windows > Settings/Preferences > Plug-in Manager) to ensure these
plug-ins are loaded into Maya.

For information about loading plug-ins see Load or unload Maya plug-ins.
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Use MEL commands to import and export Alembic files

You can use the AbcImport and AbcExport MEL commands to import and
export Alembic files. For example, use the following to export a polygon torus:

AbcExport-j "-frameRange 1 120 -root pTorus1 -file c:/temp/test.abc";

NOTE  When specifying a file path for the exported file in the -f argument, the
path cannot contain spaces. For example, you cannot specify:

C:\My Documents\maya\2012\Alembic Files.

You can instead use C:\maya\2012\AlembicFiles.

Help for the commands is available in the Script Editor using either
AbcExport -h; and AbcImport -h;.

Related topics

■ Alembic > Alembic Import (page 3)

■ Alembic > Export (page 4)

Alembic > Import Alembic

Loads Alembic files into the existing scene.

Alembic > Import Alembic > 

Opens the Alembic Import window from which you can set options for
loading an Alembic file.

Mode

Open Opens the selected Alembic file.

Import Imports the selected Alembic file into the current scene.

Replace Replaces the selected polygon and NURBS object(s) with the
Alembic-based object(s) contained in the imported file. Only one instance of
each Alembic-based object is imported, even when multiple objects are selected
in the scene.

Alembic > Import Alembic | 3



Fit Time Range Updates the timeslider range of the current scene to match
the timeslider range of the imported Alembic file.

Set Current Time to Start Frame Sets the current time of the scene to the
start frame of the imported Alembic file.

Insert Under Current Selection Parents an object selected in the scene to the
imported Alembic-based object(s). If multiple objects are selected, the
Alembic-based objects become children of the object that is selected first.

Debug Prints debug information to the Script Editor window.

Related topics

■ Import and export Alembic files (page 2)

■ Alembic > Export (page 4)

Alembic > Export

Exports either all objects or selected objects to an Alembic cache file.

Alembic > Export All in Alembic >  and Alembic > Export Selection in

Alembic > 

Opens the Alembic Export  window from which you can set options for
exporting Alembic files. Selecting Export All in Alembic exports all polygon,
NURBS, and subdivision objects in the scene to an Alembic file. Selecting
Export Selection in Alembic exports selected objects to an Alembic file.

General Options

Cache time range

Render Settings Specifies that your current Render Settings determine the
Cache Time Range.

Time Slider Specifies that the current playback range in your Time Slider
determines the Cache Time Range.
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Start/End Specifies that the range of frames between (and including) the
specified Start and End times determines the Cache Time Range.

Start/End These fields let you specify a Start and End time for the Cache
Time Range.

Evaluate every When creating an Alembic file, one sample of your object's
transformations is taken every frame and saved to the Alembic file by default.
Evaluate every specifies how often samples are taken during file creation.
For example, a value of 2 caches the transformations of the current object at
every other frame of the Cache Time Range.

Pre Roll Start Frame Specifies at which frame to start the scene evaluation.
Use this option to set the starting frame for time dependent translations that
require run-ups

Advanced Options

Don't Skip Unwritten Frames Evaluates every frame regardless of whether
or not there are changes in object translation values between frames.

Verbose  Outputs frame number information to the Script Editor or output
window.

No Normals When on, normal data from the original polygon objects is not
included in the exported Alembic cache file.

Renderable  When on, any non-renderable nodes or hierarchy, such as hidden
objects, are not included in the Alembic file.

Strip Namespaces When on, any namespaces associated with the exported
objects are removed from the Alembic file. For example, an object with the
namespace taco:foo:bar appears as bar in the Alembic file.

UV Write  When on, UV data from polygon meshes and subdivision objects
are written to the Alembic file. Only the current UV map is included.

Whole Frame Geo  When on, geometry data at whole frames is sampled and
written to the file. When off, geometry data is sampled at sub-frames and
written to the file. This is the default setting.

World Space When on, the top node in the node hierarchy is stored as world
space. By default, these nodes are stored as local space.

Write Visibility  When on, the visibility state of objects is stored in the
Alembic file. Otherwise, all objects are considered visible.

Alembic > Export | 5



Callbacks

A recommended way to use callbacks with the Alembic export, is to first define
a global procedure. For example, in the Script Editor, define the following:

global proc perFrameCallback(int $frame)
{

print $frame;
}

The full MEL callback is then:

perFrameCallback(#FRAME#)

NOTE

For correct syntax, callback commands cannot contain the following:

■ Spaces between characters. For example, ( ).

■ Single quotes. For example, (').

■ Double quotes. For example, (").

Per Frame Callback MEL When each frame is evaluated, the string specified
is evaluated as a Mel command. For example, print("#FRAME#").

Post Job Callback MEL When the translation has finished, the string specified
is evaluated as a Mel command. For example, print("Done!").

Per Frame Callback Python When each frame is evaluated, the string specified
is evaluated as a python command. For example, print("#FRAME#").

Post Job Callback Python When the translation has finished, the string
specified is evaluated as a python command. For example, print("Done!").

Related topics

■ Import and export Alembic files (page 2)

■ Alembic > Alembic Import (page 3)
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Run Maya with a Japanese or Simplified Chinese
user interface

The Maya user interface automatically appears in Japanese/Simplified Chinese
when launched within a Japanese/Simplified Chinese operating system
environment. If you wish to run Maya with a Japanese or Simplified Chinese
UI on a system that is enabled to run in multiple languages, you must set the
operating system preferences for that operating system. The steps for doing
this differ depending on the operating system:

To run Maya in Japanese/Simplified Chinese on a Windows operating system
(Windows XP)

1 From the Start menu, select Settings > Control Panel, and
double-click the Regional and Language Options.

2 In the Regional and Language Options window, click the Advanced
tab and set the Language for non-Unicode programs setting to
Japanese or Chinese (PRC).

3 Click OK.

The Windows operating system will indicate it needs to be restarted for
the changes to take effect.

4 Once Windows restarts, you can launch Maya and the Maya user interface
will appear in Japanese or Simplified Chinese, depending on your setting.

To run Maya in Japanese/Simplified Chinese on a Windows operating system
(Windows 7)

1 From the Start menu, select Control Panel, and select the Clock,
Language, and Region option; then select Region and Language.

2 From the Regional and Language window, click the Administrative
tab and select Change system locale. Change the Current system
locale setting to Japanese or Chinese (Simplified, PRC).

3 Click OK.

The Windows operating system will indicate it needs to be restarted for
the changes to take effect.

Run Maya with a Japanese or Simplified Chinese user interface | 7



4 Once Windows restarts, you can launch Maya and the Maya user interface
will appear in Japanese or Simplified Chinese, depending on your setting.

To run Maya in Japanese/Simplified Chinese on a Mac OS X operating system

1 From the Apple menu, select System Preferences.

2 In the Personal section of the System Preferences, click the Language
and Text icon.

3 In the Languages list, click-drag the text titled Japanese or Simplified
Chinese upwards so it appears at the top of the list.

The next time you launch Maya, the user interface will appear as Japanese
or Simplified Chinese, depending on your setting.

NOTE

If you want to run the English language user interface of Maya when
operating on Mac OS X, you can click-drag the text titled English that
appears in the list of languages up to the top of the Languages list. The
next time Maya is launched; the English language user interface will
appear.

Related topics

■ Run Maya in English within a Japanese environment

■ Japanese Maya Overview

■ Prepare Maya files containing Japanese text
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What's New in Basics

Node Editor

The Node Editor presents an editable schematic of the
dependency graph, displaying nodes and the connec-
tions between their attributes. It allows you to view,
modify and create new node connections. You can ac-
cess the Node Editor from the Windows menu. (
Window > Node Editor).

You can graph the network of nodes of your choice,
and build networks by using the Tab key and dragging
lines from one node to another. Using this method,
you can easily edit existing networks. All attribute ports
and connection lines are represented by different colors
so that connections can be easily read. In addition, you
can create bookmarks to return to previous graph lay-
outs for easy navigation.
■ Node Editor (page 38)

■ Using the Node Editor (page 10)

■ Watch: Node Editor: Creating a shading network

■ Watch: Node Editor: Sample rigging workflow

■ Watch: Node Editor: Synchronizing selection and creation
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Using the Node Editor

Displaying connections

When you first open the Node Editor, it displays empty. To graph the node
network of your choice, see the following sections.

Displaying node connections

To display node connections, do as follows:

1 Select any node or object in Maya, and click the  icon in the Node
Editor toolbar to display the input and output node connections.

For a legend of what each connection color represents, see Connection colors
in the Node Editor (page 32).

Displaying node attribute connections

To display the attribute connections between nodes, do as follows:

1 Without selecting any nodes, click the  icon on the toolbar to
expand each node to its full mode.

You can now see all the attributes of each node and how they are
connected to each other.
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TIP You can also mouse over a connection to see its details.

Order of the attributes

The attributes for each node are ordered as follows:

1 Attributes that can act as both input and output.

2 Attributes that can act only as output.

3 Attributes that can act only as input.

Using the Node Editor | 11



Graph shading network for selected object(s)

You can graph the shading network for the object(s) selected in the scene
view.

1 In the scene view, select the object(s) for which you want to graph the
shading network.

2  on any empty area in the Node Editor to access the work area
marking menu and select Graph Materials on Viewport Selection.

Related topics

■ Node Editor menu and toolbar (page 44)

■ Node Editor marking menus (page 53)

Create a node

To create a node, do as follows:

Create a node (Method 1):

1 Click Tab and enter the type of your node.

You can enter the keyword for the node that you want to create. As you
enter a keyword, the Node Editor updates in real time and only nodes
with names that match what you entered are displayed.
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TIP Click Tab to select the first node in the list of available nodes. In the example
above, clicking Tab selects phong. Click Tab once again to create the phong node.

TIP If there is only one node that matches what you have entered, then clicking
Tab automatically creates the node. In this example, a polySphere node is created
automatically when you click Tab.

NOTE If you attempt to create a node type that does not exist in Maya, an error
message appears informing you that the node cannot be created. The Tab creation
UI then remains open for you to correct the error.

Create a note (Method 2):

1  any empty area in the Node Editor to access the work area marking
menu and select Create Node.

Alternatively, you can select Window > Create Node to open the
Create Node window.

2 Middle-drag a node into the Node Editor, and drop it in the desired
location. Alternatively, you can click the node that you want and it will
appear in the Node Editor.

Create a node (Method 3):

1 Select Window > Rendering Editors > Hypershade to open the
Hypershade.

2 From the Create bar in the Hypershade, middle-drag a node into the
Node Editor, and drop it in the desired location. Alternatively, you can
click the node that you want and it will appear in the Node Editor.

Using the Node Editor | 13



NOTE You can copy multiple nodes from the Hypershade to the Node Editor
by selecting them in the Hypershade and then dragging and dropping them to
the Node Editor.

Creating 2D Textures and selecting a mapping method

When creating a 2D texture, you can select among one of three mapping
methods: create normally (create texture), create as projection, and create as
stencil.

When creating a node in the Node Editor using the Tab key, as you enter
the name of your desired 2D texture type, three variations of the texture appear
(Projection, Stencil, Texture), allowing you to select among the three mapping
methods. See Create a node (page 12) for more information on how to create
a node using the Tab key.

Related topics

■ Mapping methods

Locking the Node Editor view

You can lock your Node Editor view so that any new nodes you create do
not appear in the graph.
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Click the lock icon  to lock your view. The Node Editor view is
unlocked by default.

When in locked mode  , you can still use the following methods to
create new nodes, and they will appear in the Node Editor:
■ Tab key. See Create a node (page 12) for more information.

■  a node from the Hypershade or Create Node window or Outliner
to the Node Editor (drag and drop creation).

NOTE You can still perform delete and undo in locked mode.

However, nodes created in the scene view, or by clicking in the Create Bar
in the Hypershade and Create Node window (in other words, not drag and
drop creation), do not appear in the Node Editor.

TIP You can also lock the view by disabling the Options > Add to Graph on
Create option under the Node Editor Options menu or from the Node Editor
work area marking menu. See Node Editor Options menu (page 46) and Node
Editor marking menus (page 53) for more information.

Changing view mode for nodes

There are three ways to view nodes within the Node Editor: simple, connected
and full. See Node Editor view modes (page 38) for more information on the
view modes.
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Changing the view mode for individual nodes

You can change the view mode for each node by clicking the  , 

, or  icons on the top right corner of each node.

Changing the view mode for selected nodes

Select the nodes for which you want to change the view mode and click the

 ,  , or  icons on the Node Editor toolbar.

Alternatively, you can select the Edit > Simple Mode (  +S), Edit >

Connected Mode (  +C), or Edit > Full Mode (  +F) options
from the Node Editor menu bar. See Node Editor menu bar (page 45) for
more information.

Changing the view mode for all nodes

When none of the nodes are highlighted (active) in the Node Editor, clicking
the icons in the toolbar, or selecting the same options from the Node Editor
Edit menu, or using the Edit menu shortcuts, affects all nodes.

NOTE

You can also customize this option in the Preferences window, and your
nodes are displayed in the view mode you selected the next time you create
a Node Editor window. See Node Editor Preferences (page 55) for more
information.

Resizing nodes
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You can resize any node in any of the view modes: simple, connected or full.

The resize corner  on the bottom right corner of a node denotes that it
can be resized.

Renaming Nodes

You can rename the nodes in the Node Editor using either of these two
methods:

Method 1

■ Double-click on the node name in the node to rename it.

Using the Node Editor | 17



Method 2

■ Right-click on the node to access the node marking menu and select
Rename.

Selection in the Node Editor

There are four types of selection states in the Node Editor. A node can be:
■ selected in the scene view but not in the Node Editor

■ highlighted in the Node Editor, but not selected in the scene view
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■ selected in the scene view and highlighted in the Node Editor (in sync)

■ unselected in the scene view and not highlighted in the Node Editor (in
sync)
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NOTE Selected states are always outlined in green. An outline of white indicates
that the node is active in the Node Editor but not selected in the scene.

You can customize whether or a not a node is also selected in the scene view
when it is highlighted in the Node Editor, and vice versa. Select Options
> Sync Node Editor/Model Selection so that, if you click on a node in
the Node Editor, the same node is also selected in the scene view and vice
versa. You can also select this option via the work area marking menu. For
more information about marking menus, see Node Editor marking menus
(page 53).

You can also set this option as a preference via Windows >
Settings/Preferences > Preferences > Settings > Node Editor. If you
select this option under the Preferences window, the changes are applied
the next time you open the Node Editor.

Pinning a node to the Node Editor view
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You can click the pin icon  to pin a node so that it stays within the Node

Editor view and retains its position even after a regraph.  indicates that

the node is pinned and  indicates that it is unpinned.

Pinning/unpinning multiple nodes

You can select multiple nodes and pin or unpin them all at once. Select

multiple nodes and then click the  icon in the toolbar to pin or the 
icon to unpin.

TIP If none of the nodes are highlighted (active) in the Node Editor, then clicking

the  and  icons affects all of the nodes.

Zooming in and out of the Node Editor

Zooming in

You can zoom into the Node Editor in one of the following ways:

■ Marquee select zoom:  +  +left mouse drag (from left to
right) to create a marquee box to zoom into.
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As you drag a box shape, the zoom in  icon appears at the
bottom right corner to denote that you are zooming in.

■ Selecting View > Zoom In

■ Using the hotkey +

Zooming out

You can zoom out of the Node Editor in one of the following ways:

■ Marquee select zoom:  +  +left mouse drag (from right to
left) to create a marquee box to zoom out of.

As you drag a box shape, the zoom out  icon appears at the top
left corner to denote that you are zooming out.
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■ Selecting View > Zoom Out

■ Using the hotkey -

Disabling swatch rendering

You can disable swatch rendering in the Node Editor, Hypershade and
Attribute Editor to help improve performance slowdowns caused by swatch
refresh.

To disable swatch rendering in the Node Editor, Hypershade and Attribute
Editor for the startup state of Maya

1 Select Window > Settings/Preferences > Preferences to open the
Preferences window. Under Display, disable Render swatches
(startup).

To disable swatch rendering in the Node Editor, Hypershade and Attribute
Editor for the current session of Maya

1 Disable Options > Render Swatches from the Node Editor Options
menu.

NOTE As soon as you disable swatch rendering, all existing swatches should stop
updating. Swatches that are already drawn remain visible but are not updated.

TIP You can disable swatch rendering via the Preferences window so that swatch
rendering is disabled upon startup, then override this option for your session by
enabling this option in the Node Editor Options menu.
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Connect nodes

Connect nodes by dragging connection lines

Method 1

To connect attributes using connection lines

1 In the Node Editor, click on the  icon on the top right hand
corner of each node to expand it to its full mode.

2 Middle-mouse or left-mouse drag to create connection lines between
your output and input attributes.

If you mouse over a compound attribute, the Node Editor automatically
expands to expose its children to which you can make a connection.

In addition, it also snaps to the ports to which you can make a
connection. This allows you to easily identify the attributes that you can
connect to.
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NOTE As you mouse over the available inputs, all inputs that can receive the
connection are highlighted. This indicates that it is possible to make a connection
with this input.
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TIP When connecting compound attributes (for example, a parent attribute such
as Color, with Color R, G, B child attributes), if you try to make a connection to a
parent attribute (Color) when the child attribute (for example, Color R) is already
connected, the connection to the child attribute will become disconnected.

Method 2

To connect attributes without expanding the nodes

1 Click the output master port of the node to display the menu of available
output attributes. A list of common output attributes is displayed; or,
select Other to display the Connection Editor, Output Selection
window. From this window, you can select the output of your choice.

2 Drag the connection line to the input master port of the node receiving
the input connection. A list of common input attributes is displayed; or,
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select Other to display the Input Selection window. From this window,
you can select the input of your choice.

NOTE The Input Selection window only lets you select an attribute that
is compatible with the previously selected output attribute.
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Related topics

For more information regarding the different views of the nodes, see Node
Characteristics (page 38).

For more information regarding the connection lines in the Node Editor,
and what each color represents, see Connection colors in the Node Editor
(page 32).

Connect nodes using their default connections

To connect nodes using their default connections (Method 1):

1 Ctrl+  a node onto another in the Node Editor. The default
connection is created.

To connect nodes using their default connections (Method 2):

1 Ctrl+  a node from the Node Editor onto a node in the
Hypershade. The default connection is created.

Connect nodes using the Connection Editor

Connect nodes using the Connection Editor (Method 1):

1 Shift+  a node onto another in the Node Editor. The Connection
Editor appears so you can select your output and input attributes.
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Connect nodes using the Connection Editor (Method 2):

1 Shift+  a node from the Node Editor onto a node in the
Hypershade. The Connection Editor appears so you can select your
output and input attributes.

Connect default output to a specific input attribute

Method 1:

 a node from the Node Editor into a field in the Attribute Editor.

Method 2:

 a node from the Node Editor onto a node in the Hypershade.

Select the attribute you want to connect to from the pop-up menu that appears.

Change existing node attribute connections

You can drag on a connection line to break and recreate a connection.

Reconnecting an input to a different output

1 Drag on a connection line from the output side to disconnect it, and
reconnect it to a different output.
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Reconnecting an output to a different input

1 Drag on a connection line from the input side to disconnect it, and
reconnect it to a different input.

Delete a connection

To delete a connection (Method 1)

1 Drag on a connection line and release the mouse in the background to
delete a connection.

To delete a connection (Method 2)

1 Click the connection line(s) you want to delete (marquee-select to select
more than one).

The lines are selected.

2 Press Backspace (Windows and Linux) or Delete (Mac OS X) to delete
the connections.

The lines are deleted and the swatches in the Node Editor update to show
the changes.

To delete a connection (Method 3)

1 Press  ,  ,  to draw a line in the Node Editor.
Release to delete the connections crossed by the line.

Connection colors in the Node Editor
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All ports and connection lines are represented by different colors to denote
the attribute type for the input or output, for example, integer, string, boolean
and so forth. The connection line takes on the color of the output.

The following is a legend of the various connection colors in the Node Editor.

Numeric (double, float: for example, 2
values of double, 3 values of float, and so
forth)

Integer (for example, 2 values of 16-bit
integers or 3 values of 32-bit integers and
so forth)

Boolean

String

Multi-ambiguous (for example, compound
or enum attributes)

Curve

Rotation

Matrix

Color
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Array

Displaying a node's Attribute Editor

You can display a node's Attribute Editor by double-clicking on it in the
Node Editor.

Create customizable marking menus

You can customize the node marking menus. The following is an example
using Python to add a custom node marking menu item to the
plusMinusAverage node.

Create the plusMinusAverage node in the Node Editor, then run the following
script in the Script Editor.

from maya.app.general import nodeEditorMenus
from maya import cmds

def addPMAMenuItems(ned, node):
"""
Check for plusMinusAverage node and create necessary

menu items
"""
type = cmds.nodeType(node)
if type == 'plusMinusAverage':

def doSomething(*args):
cmds.confirmDialog(title="Something",

message="Ok?")
cmds.menuItem(label="PlusMinusAverage! Do

something!", c = doSomething)
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return True
else:

return False

# register the custom callback with nodeEditor
#
nodeEditorMenus.customInclusiveNodeItemMenuCallbacks.append(addPMAMenuItems)

The plusMinusAverage node now includes the custom menu item
"PlusMinusAverage! Do something!".

Related topics

■ Node Editor marking menus (page 53)

Creating and using bookmarks in the Node Edit-
or

You can create bookmarks in the Node Editor to store the current node graph
as a quick reference.

Creating a bookmark

Creating a bookmark (Method 1)

1 Select Bookmarks > Create Bookmark.
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The Name Bookmark window appears. You can provide a custom name for
your bookmark; otherwise, it is assigned a default name.

Creating a bookmark (Method 2)

1 Click  on the toolbar.

The Name Bookmark window appears. You can provide a custom name for
your bookmark; otherwise, it is assigned a default name.

Loading an existing bookmark

Loading an existing bookmark (Method 1)

1 Select Bookmarks > <bookmark name>.

Loading an existing bookmark (Method 2)

1 Click the  and  buttons in the toolbar to step through the

bookmarks. Click  to load the previous and to  load the next
bookmark.

Editing bookmarks

You can edit bookmarks by using the Bookmark Editor. Select Bookmarks

> Bookmark Editor or click  on the toolbar to open the Bookmark
Editor.

Deleting a bookmark

1 Right-click the bookmark that you want to delete in the Bookmark
Editor and select Delete Bookmark.

NOTE You can also delete all existing bookmarks by right-clicking and selecting
Delete All Bookmarks.
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Renaming a bookmark (Method 1)

1 Right-click the bookmark that you want to rename in the Bookmark
Editor and select Rename Bookmark.

NOTE The Name Bookmark window appears and allows you to rename your
bookmark.

Renaming a bookmark (Method 2)

1 Under the Bookmarks menu, click  beside the bookmark name.

NOTE The Name Bookmark window appears and allows you to rename your
bookmark.

Updating a bookmark

You can replace an existing bookmark with your current graph layout as
follows:

1 Right-click the bookmark that you want to update in the Bookmark
Editor and select Replace Bookmark.

NOTE Now, when you select this bookmark via Bookmarks > <bookmark name>,
the updated graph network is displayed.

Assign materials to surfaces

To assign a material to surfaces (Method 1)

1 In the scene view, select the object(s) that you want to assign the material
to.

2 In the Node Editor, right-click the material to expose its marking menu
and select Assign Material to Viewport Selection.
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To assign a material to surfaces (Method 2)

1 From the Node Editor,  the material node over the surface(s) to
which you want to assign the material.

Related topics

■ Node Editor marking menus (page 53)

Node Editor

The Node Editor presents an editable schematic of the dependency graph,
displaying nodes and the connections between their attributes. It allows you
to view, modify and create new node connections. You can access the Node
Editor from the Windows menu. (Window > Node Editor).

Node view modes

There are three ways to view nodes within the Node Editor: simple, connected
and full.

The simple mode shows one input and one output master port, represented

as circles. The  icon also denotes that you are in the simple mode.

The connected mode shows the input and output master ports, as well as any
connected attributes. These attributes have their own ports, which are displayed
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as small circles. The  icon also denotes that you are in the connected
mode.

The full mode shows the input and output master ports, as well as primary
node attributes. The set of primary attributes for a given node is based on the
properties of the attributes such as whether they are keyable or dynamic. The

 icon also denotes that you are in the full mode.

Input attributes are displayed on the left side of a node in full mode. Output
attributes are displayed on the right side. To expand a node's attribute list,

click the  located next to the attribute. If an attribute can be connected as
either an input or an output, a port is available on both the left and right sides
of the node. For more information on node connections, see Displaying con-
nections (page 10).
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You can select the Show All Attributes option from the node marking
menus to temporarily replace the full mode for a node with a listing of all of
the attributes. The displaying of all of its attributes is only valid for this draw
instance. If you regraph the node, or if you change the view mode of the node,
you must re-select this option to see all of its attributes again. See Node Editor
Marking Menus (page 53) for more information about the Node Editor
marking menus.
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Changing view modes for multiple nodes

You can change the view mode for multiple nodes in one step by selecting
the nodes and selecting the desired mode icon in the toolbar. You can also
do the same via the menu options (Edit > Simple Mode, Connected Mode,
Full Mode) or their shortcuts. See Node Editor Edit menu (page 45) and Node
Editor Toolbar (page 48) for more information.

NOTE When none of the nodes are highlighted (active) in the Node Editor,
clicking the icons in the toolbar, or selecting the same options from the Node
Editor Edit menu, or using the Edit menu shortcuts, affects all nodes.

Toggling swatch size

In any view mode, you can toggle between a larger and a smaller version of

the node swatch by  the node and selecting Toggle Swatch Size from
the node marking menu.
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Functionality

The following table lists the functionality of the Node Editor at a glance.

Do thisTo...

Select a node and click the  icon in the toolbar to display
the input and output node connections.

Display connections.

Click Tab and enter the type of your node. Alternatively, you can

 drag and drop from the Create bar in the Hypershade or
the Create Node window.

Create a node.
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Do thisTo...

You can  a node from the Outliner to bring it into the Node
Editor.

Copy a node into the Node Editor.

Expand the node to its full mode by clicking  . Middle-
mouse or left-mouse drag to create connection lines between
your output and input attributes.

Create a connection using connection lines.

 +  a node onto another in the Node Editor.

Create a default node connection.

 +  a node onto another in the Node Editor.
Connect nodes using the Connection Ed-
itor.

Drag on a connection line and release the mouse in the back-
ground area to delete a connection.

Delete a connection.

Or, you can click the connection line(s)/marquee-select and press
Backspace (Windows and Linux) or Delete (Mac OS X).

Drag on a connection line to disconnect and then reconnect with
a new input/output.

Change an existing connection.

Click the  icon to lock your view so that any new nodes
you create do not appear in the graph.

Lock the view.

Or, you can disable the Add to Graph on Create option from
the Node Editor work area marking menu.

You can resize any node in any of the view modes: simple, con-

nected, or full. The resize corner  on the bottom right corner
of a node denotes that it can be resized.

Resize nodes.
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Do thisTo...

You can pin a node so that it stays within the Node Editor view

and retains its position even after a regraph. Click  to pin

Pinning a node to the view.

and  to unpin. You can also pin or unpin multiple nodes
in one step via the toolbar icons.

 a node from the Node Editor onto a field in the Attribute
Editor.

Connect a node to an attribute in the At-
tribute Editor.

In the scene view, select the object(s) that you want to assign
the material to. Then, in the Node Editor, right-click the mater-

Assign a material.

ial to expose its marking menu and select Assign Material to
Viewport Selection.

Or, you can  a shader or material from the Node Editor
onto an object in a model pane.

Related topics

■ Using the Node Editor (page 10)

■ Connect Nodes (page 24)

■ Node Editor Preferences (page 55)

■ Hypergraph

■ Hypershade

Node Editor menu and toolbar
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Node Editor menu bar

Edit menu

Simple Mode Change the view mode of the selected nodes to simple mode
so that only the input and output master ports are shown. See Node view
modes (page 38) for more information about the Node Editor view modes.

You can also do the same via the toolbar icons or via the  + S shortcut.

You can also customize this option in the Preferences window, and your
nodes are displayed in simple mode the next time you create a Node Editor
window. See Node Editor Preferences (page 55) for more information.

Connected Mode Change the view mode of the selected nodes to connected
mode so that the input and output master ports, as well as any connected
attributes, are shown. See Node view modes (page 38) for more information
about the Node Editor view modes. You can also do the same via the toolbar

icons or via the  + C shortcut.

You can also customize this option in the Preferences window, and your
nodes are displayed in connected mode the next time you create a Node
Editor window. See Node Editor Preferences (page 55) for more information.

Full Mode Change the view mode of the selected nodes to full mode so that
the input and output master ports, as well as primary node attributes, are
shown. The set of primary attributes for a given node is based on the properties
of the attributes such as whether they are keyable or dynamic. See Node view
modes (page 38) for more information about the Node Editor view modes.

You can also do the same via the toolbar icons or via the  + F shortcut.

You can also customize this option in the Preferences window, and your
nodes are displayed in full mode the next time you create a Node Editor
window. See Node Editor Preferences (page 55) for more information.

NOTE When none of the nodes are highlighted (active) in the Node Editor,
selecting any of these options or using their corresponding shortcuts will affect all
nodes.

Pin When you pin a node, it stays within the Node Editor view and retains
its position even after a regraph. You can pin multiple nodes in one step by
selecting multiple nodes and then selecting this option. You can also do the
same via the toolbar icons.
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Unpin When you pin a node, it stays within the Node Editor view and
retains its position even after a regraph. You can unpin multiple nodes in one
step by selecting multiple nodes and then selecting this option. You can also
do the same via the toolbar icons.

NOTE When none of the nodes are highlighted (active) in the Node Editor,
selecting either the Pin or Unpin menu item will affect all nodes.

View menu

Frame All Adjusts the graph view to fit all objects in the editor. You can also
use the hotkey A.

Frame Selection Adjusts the graph view to fit all selected objects in the editor.
You can also use the hotkey F.

Zoom In Zoom into your graph. You can also use the hotkey +.

Zoom Out Zoom out of your graph. You can also use the hotkey -.

TIP If you find it difficult to read your node name when you are zoomed out of
your graph, mouse over the node and a tool tip with the node name pops up.

Bookmarks menu

Create Bookmark Select this option to create a bookmark to store the current
node graph as a quick reference.

Bookmark Editor Select this option to open the Bookmark Editor to edit
your bookmarks. See Bookmarks in the Node Editor (page 35) for more
information on editing bookmarks.

<bookmark name>  A list of existing bookmarks is listed under this menu.

Select the bookmark name to load each bookmark. You can also click the 
beside each bookmark name to rename your bookmark.

Options menu

Render Swatches Disable this option to disable swatch rendering in the Node
Editor, Hypershade, and Attribute Editor for the current session of Maya.

NOTE As soon as you disable swatch rendering, all existing swatches should stop
updating. Swatches that are already drawn remain visible but are not updated.

You can also set this option in the Preferences window by selecting Window
> Settings/Preferences > Preferences > Display > Render swatches
in editors and your setting will be applied upon the startup of Maya. For
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example, you can disable this option via the Preferences window to improve
performance when loading a scene, then re-enable swatch rendering for your
Node Editor session by enabling this option via the Node Editor Options
menu.

Sync Node Editor / Model Selection Enable this option so that if you
highlight a node in the Node Editor, the same node is also selected in the
scene and vice versa. See Selection in the Node Editor (page 18) for more
information.

Add to Graph on Create Enable this option so that when you create a node
in the scene, it is also added to the Node Editor. If this option is disabled,
only nodes that you create using the Node Editor (for example, using Tab
creation or drag and drop creation; see Create a Node (page 12) for more
information) are shown. You can also disable this option by clicking the lock

 button to lock the view. See Locking the view (page 14) for more
information.

NOTE You can also control the Sync Node Editor / Model Selection and Add
to Graph on Create options by selecting Windows > Settings/Preferences
> Preferences > Settings > Node Editor. If you select these options under the
Preferences window, the changes are applied the next time you open the Node
Editor. See Node Editor Preferences (page 55) for more information.

NOTE You can also select these options via the work area marking menu. See
Node Editor marking menus (page 53) for more information.

Display menu

Customize your graph in the Node Editor by selecting any of the provided
options.

Shapes Choose among the options to customize which shapes are displayed.

Transforms Select this option to include transform nodes in your graph.

Extend to shapes Select this option to include child shape nodes for selected
transforms.

You can also select the All Shapes, All Shapes Except Shading Group
Members, and No Shapes options from the Node Editor toolbar. See Node
Editor toolbar (page 48) for more information.

You can also select these options via the work area marking menu. See Node
Editor marking menus (page 53) for more information.
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You can also control these options by selecting Windows >
Settings/Preferences > Preferences > Settings > Node Editor. If you
select this option under the Preferences window, the changes are applied
the next time you open the Node Editor. See Node Editor Preferences (page
55) for more information.

Show menu

Objects Select which object types to show in the Node Editor. Select Clear
Below to turn off all filters. You can also select these options via the work
area marking menu. See Node Editor marking menus (page 53) for more
information.

Show All Turns off all filters in the Show menu.

Show Selected Type(s) Shows only object types of the same type as the current
selection. This option lets you create a filter that limits the types of objects
displayed in the Node Editor to the same type of object as the current
selection.

Show Auxiliary Nodes Shows node types that the Node Editor normally
does not show because they are rarely needed (such as underworld nodes).

Auxiliary Nodes Lets you set which nodes are considered “auxiliary”.

You can customize which nodes are hidden to reduce clutter in the editors.
Generally, these are nodes that are not normally useful to see or edit. Select
this option to display the Auxiliary Nodes editor and customize the node
types that are hidden in editors.

Help menu

Help Lists various learning options, including links to the Maya Help and the
Learning Path.

Node Editor toolbar

Text Filter Indicator

Click to clear any applied filters (beyond the implicit one) and return the
graph to its default contents.
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Enter text to filter listing You can enter syntax to limit the node listing in
the Node Editor. The syntax is case sensitive. For example, P* shows only
nodes beginning with the letter P. Every listed child node is displayed with
its corresponding parent node even if the parent node would not otherwise
be shown because of the filter.

Display All Shapes

Customize your graph by selecting this option to display all shapes. You can
click the icon to select this option, or select it from the Display menu. The
option that you have selected is also reflected in the toolbar: the corresponding
icon is highlighted.

You can also customize this option in the Preferences window, and your
setting is applied the next time you create a Node Editor window. See Node
Editor Preferences (page 55) for more information.

Display All Shapes Except Shading Group Members

Customize your graph by selecting this option to display all shapes except
shading group members. You can click the icon to select this option, or select
it from the Display menu. The option that you have selected is also reflected
in the toolbar: the corresponding icon is highlighted.

You can also customize this option in the Preferences window, and your
setting is applied the next time you create a Node Editor window. See Node
Editor Preferences (page 55) for more information.

Display No Shapes

Customize your graph by selecting this option to refrain from displaying
shapes. You can click the icon to select this option, or select it from the
Display menu. The option that you have selected is also reflected in the
toolbar: the corresponding icon is highlighted.

You can also customize this option in the Preferences window, and your
setting is applied the next time you create a Node Editor window. See Node
Editor Preferences (page 55) for more information.
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Create a new bookmark

Select this option to create a bookmark to store the current node graph as a
quick reference.

Open the Bookmark Editor window

Select this option to open the Bookmark Editor to edit your bookmarks.
See Bookmarks in the Node Editor (page 35) for more information on editing
bookmarks.

Load previous/next bookmark  / 

Click  to load the previous and  to load the next bookmark.

Clear the graph

Clears the current Node Editor layout.

Remove selected nodes from graph

Customize the layout of your graph by removing the selected nodes. To remove
a node from the graph, select it and click this icon.

Layout the graph

Takes the current collection of nodes being displayed in the Node Editor
and re-arranges them.
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Input connections

Displays only the input connections of selected nodes. See also Connect Nodes
(page 24).

Input and output connections

Displays the input and output connections of selected nodes. See also Connect
Nodes (page 24).

Output connections

Displays only the output connections of selected nodes. See also Connect
Nodes (page 24).

Increase/decrease traversal depth

You can customize how far you can see the connections graphed in the Node
Editor. By default, depth traversal is unlimited (set to -1).

Use the arrows or enter an integer into the numeric field of the menu bar to
change the depth traversal value. Click the Unlimited button or set the number
to -1 to remove the depth traversal limit.

Simple Mode

Change the view mode of the selected nodes to simple mode so that only the
input and output master ports are shown. See Node view modes (page 38) for
more information about the Node Editor view modes. You can also do the

same via Edit > Simple Mode or via the  + S shortcut.
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You can also customize this option in the Preferences window, and your
nodes are displayed in simple mode the next time you create a Node Editor
window. See Node Editor Preferences (page 55) for more information.

Connected Mode

Change the view mode of the selected nodes to connected mode so that the
input and output master ports, as well as any connected attributes, are shown.
See Node view modes (page 38) for more information about the Node Editor
view modes. You can also do the same via Edit > Connected Mode or via

the  + C shortcut.

You can also customize this option in the Preferences window, and your
nodes are displayed in connected mode the next time you create a Node
Editor window. See Node Editor Preferences (page 55) for more information.

Full Mode

Change the view mode of the selected nodes to full mode so that the input
and output master ports, as well as primary node attributes, are shown. The
set of primary attributes for a given node is based on the properties of the
attributes such as whether they are keyable or dynamic. See Node view modes
(page 38) for more information about the Node Editor view modes. You can

also do the same via Edit > Full Mode or via the  + F shortcut.

You can also customize this option in the Preferences window, and your
nodes are displayed in full mode the next time you create a Node Editor
window. See Node Editor Preferences (page 55) for more information.

NOTE When none of the nodes are highlighted (active) in the Node Editor,
selecting any of the simple, connected or full mode icons will affect all nodes.

Pin selected nodes / Unpin selected nodes  / You can select
multiple nodes and pin or unpin them all at once. When you pin a node, it
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stays within the Node Editor view and retains its position even after a

regraph. Select  to pin and  to unpin.

NOTE When none of the nodes are highlighted (active) in the Node Editor,
clicking either the pin or unpin icon will affect all nodes.

Allow/disallow new nodes to be automatically added to the graph 

/ 

Click this icon to lock your Node Editor view so that any new nodes you

create do not appear in the graph.  indicates the unlocked state and

 indicates the locked state. See Locking the view (page 14) for more
information. You can also do the same by disabling the Add to Graph on
Create option via the work area marking menu or the Options menu. See
Node Editor marking menus (page 53) for more information.

Node Editor marking menus

In addition to the Node Editor toolbar and menu, the Node Editor marking
menus provide an additional way for you to customize your Node Editor
graph.

Work area marking menus

Access the work area marking menus by right-clicking on any empty area in
the Node Editor.

Create Node Select this option to open the Create Node window.

Select All in Graph Select this option to highlight all of your nodes in your
Node Editor graph.
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Graph Materials on Viewport Selection Select this option to graph the
shader(s) applied to the object(s) selected in your scene view.

Sync Node Editor/Model Selection Enable this option so that if you highlight
a node in the Node Editor, the same node is also selected in the scene and
vice versa. You can also select this option from the Node Editor Options
menu. See Selection in the Node Editor (page 18) for more information.

Add to Graph on Create Enable this option so that when you create a node
in the scene, it is also added to the Node Editor. If this option is disabled,
only nodes that you create using the Node Editor (for example, using Tab
creation or drag and drop creation; see Create a Node (page 12) for more
information) are shown. You can also select this option from the Node Editor
Options menu; or, you can also enable/disable this option by clicking the

lock  button to lock/unlock the view. See Locking the view (page 14)
for more information.

Display Customize your graph in the Node Editor by selecting any of the
provided options. You can also select these options via the Node Editor
Display menu. For a description of the available options, see Node Editor
Display menu (page 47) for more information.

Show Select which object types to show in the Node Editor. You can also
select these options via the Node Editor Show menu. For a description of
the available options, see Node Editor Show menu (page 48) for more
information.

Hypershade Select this option to enable the Hypershade.

Hypergraph Select this option to enable the Hypergraph.

You can also select the Display menu options, and the Sync Node
Editor/Model Selection and Add to Graph on Create options by
selecting Windows > Settings/Preferences > Preferences > Settings
> Node Editor. If you select these options under the Preferences window,
the changes are applied the next time you open the Node Editor. See Node
Editor Preferences (page 55) for more information.

Node marking menus

Access the node marking menus by right-clicking on any node in the Node
Editor.

Inputs  Use the menu items provided to select, enable, and disable all inputs.
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Outputs  Use the menu items provided to select, enable, and disable all
outputs.

Rename Select this option to rename your node.

Toggle Swatch Size Select this option to toggle between a larger and a smaller
version of the node swatch.

Show All Attributes Select this option to change the node to full mode and
to display all of its attributes. The displaying of all of its attributes is only valid
for this draw instance. If you regraph the node, or if you change the view
mode of the node, you must re-select this option to see all of its attributes
again.

Add Attributes Select this option to open the Add Attribute window. See
Create, edit or delete custom attributes for more information.

Delete Attributes  Select this option to open the Delete Attribute window
to delete a custom attribute.

Related topics

■ Node Editor menu and toolbar (page 44)

■ Hypergraph

■ Hypershade

Node Editor Preferences

You can customize the following options for the Node Editor. They are
applied the next time you create a Node Editor window.

Display

Customize your graph in the Node Editor by selecting any of the provided
options.

Shapes Choose among the options to customize which shapes are displayed.

Transforms Select this option to include transform nodes in your graph.
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Extend to shapes Select this option to include child shape nodes for selected
transforms.

Default node view mode
■ Simple Mode: Set the view mode of nodes to simple mode so that only

the input and output master ports are shown.

■ Connected Mode: Set the view mode of nodes to connected mode so
that the input and output master ports, as well as any connected attributes,
are shown.

■ Full Mode: Set the view mode of nodes to full mode so that the input
and output master ports, as well as primary node attributes, are shown.
The set of primary attributes for a given node is based on the properties
of the attributes such as whether they are keyable or dynamic.

You can also customize these options from within the Node Editor.

You can select the All Shapes, All Shapes Except Shading Group
Members, and No Shapes options from the Node Editor toolbar or from
the Display menu or from the work area marking menus. See Node Editor
menu bar (page 45), Node Editor toolbar (page 48), and Node Editor marking
menus (page 53) for more information.

You can select the Transforms and Extend to shapes options from the
Display menu or from the work area marking menus. See Node Editor menu
bar (page 45) and Node Editor marking menus (page 53) for more information.

You can change the view mode (Simple Mode, Connected Mode, and Full
Mode) for multiple nodes interactively in the Node Editor using one of
these methods: from the Edit menu, via shortcuts, or from the toolbar. See
Changing view modes for multiple nodes (page 41), Node Editor menu bar
(page 45) and Node Editor toolbar (page 48) for more information.

Refresh Graph Defaults

Sync Node Editor/Model Selection Enable this option so that if you highlight
a node in the Node Editor, the same node is also selected in the scene, and
vice versa. See Selection in the Node Editor (page 18) for more information.

Add to Graph on Create Enable this option so that when you create a node
in the scene, it is also added to the Node Editor. If this option is disabled,
only nodes that you create using the Node Editor (for example, using Tab
creation or drag and drop creation; see Create a Node (page 12) for more
information) are shown.
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NOTE You can also control these options from the Options menu within the
Node Editor or from the Node Editor work area marking menus. See Node
Editor marking menus (page 53) for more information.
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What's New in Rendering
and Render Setup

New render passes added

Two new multi-render passes have been added: UV pass
and world position pass.

A UV pass converts UV values to R/G values and creates
a rasterized version of UV space. Using a UV pass, you
can replace textures in 3d renderings as a post-process,
without having to worry about tracking new textures
in place.

A world position pass converts position (x,y,z) values
to R,G,B values. Use the world position pass for relight-
ing workflows in compositing.

NOTE You must save to the openEXR file format when
rendering the UV pass and world position pass.

mental ray Satellite rendering support

mental ray satellite rendering can take place on four
remote machines, with up to four processors each and
an unlimited number of cores.
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UV multi-render pass workflow

A UV pass converts UV values to R/G values and creates a rasterized version
of UV space. Using a UV pass, you can replace textures in 3d renderings as a
post-process, without having to worry about tracking new textures in place.

To create a UV pass for your workflow, do as follows:

1 Create a pass contribution map for the object(s) for which you want to
retexture.

Select your object, and in your Render Layer Editor, select
Contribution > Create and Associate Pass Contribution Map.

2 Open the Render Settings window; select mental ray as your
renderer, and click the Passes tab. Click the Create new render pass

button  and select UVPass from the Create Render Passes
window and click Create and Close to create the UV pass.

3 Click the Associate Selected Passes button  to associate the UV
pass with your scene, and then with your pass contribution map.

4 In the UV pass Attribute Editor, select Hold-Out. This option blacks
out all other objects in your scene other than the object you are
retexturing.

Ensure that Filtering is disabled.

NOTE In general, it is not advisable to perform filtering on a UV pass.

5 Select Embed object ID in Blue channel. Selecting this option
embeds values from the miLabel attribute on shape nodes directly to
float values in the empty blue channel in the UV pass.

This option allows you to separate the object(s) in your compositing
software in order to make further changes.

6 Create and add the miLabel attribute to the object's shape node. Click
Select in the object's shape node Attribute Editor. Then select
Attributes > Add Attribute.
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7 Enter miLabel as the Long name and select Integer as your Data
Type.

NOTE You must use the name miLabel spelled exactly as stated.

You can now see the MI Label attribute under the Extra Attributes section
of the shape node.

8 Enter your MI Label value. To group objects, give all objects an identical
MI Label.

9 Under the Passes tab, click  again and select Coverage from the
Create Render Passes window and click Create and Close to create
a coverage pass. The coverage pass provides the alpha for the object you
want to retexture.

10 Click  to associate the coverage pass with your render layer and
then with your pass contribution map.

11 Render your pass using the .exr format. In the Common tab, select
OpenEXR (exr) under File Output > Image format.

NOTE Currently, only the OpenEXR file format is supported.

NOTE  Under the Quality tab, Framebuffer section, you must set your
Data type to 32-bit float or 16-bit half float to avoid your image being
clamped.

In your compositing software, you can then do as follows:
■ use your UV pass to displace a new image into your scene's texture

co-ordinates to produce a re-textured image that can be multiplied by your
coverage pass and merged back into your original render

■ use expressions or keying to extract the value of your blue channel and
then use it to apply changes to your objects

NOTE

You may want to render textures and lighting as separate passes to facilitate
re-lighting in compositing. You can do so by multiplying the Diffuse Material
Color pass by the Direct Irradiance pass after using the UV pass to retexture.
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What's New in Dynamics

MayaBullet physics simulation plug-in

Maya now includes the MayaBullet physics simulation
plug-in. Built from the Bullet physics library, the plug-
in lets you use the Bullet physics engine to create large-
scale, highly-realistic dynamic and kinematic simula-
tions. MayaBullet simulations can include interacting
soft body and rigid body objects, as well as constrained
collision objects, all contained in a single dynamic sys-
tem within Maya.

MayaBullet automatically installs with Maya on Win-
dows 64-bit, Mac OS, and Linux systems. MayaBullet is
not available for Windows 32-bit systems.

For documentation on the MayaBullet plug-in, browse
to the doc folder located in the Bullet2012 installation
directory For example:

C:\Program Files\Autodesk\Bullet2012\doc.

For more information about Bullet Physics, see ht-
tp://www.bulletphysics.org.
■ Load the MayaBullet plug-in (page 64)
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Load the MayaBullet plug-in

The MayaBullet plug-in automatically installs with Maya on Windows 64-bit,
Mac OS, and Linux platforms. MayaBullet is not available for Windows 32-bit
systems. Before using the MayaBullet for the first time, you need to load the
plug-in using the Plug-in Manager. To do this:

1 Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager.

The Plug-in Manager opens.

3 Locate bullet.mll and turn on Loaded. To load the plug-in
automatically every time you start Maya, turn on Auto load.

4 Click Close.

In Maya, a Bullet menu is added to the Maya main menu bar and a Bullet
item is added to the shelf. Use these items to access MayaBullet.
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