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1 What’s New in 
Maya 5 
What’s 
New

Introduction

This book describes the new features we’ve added in Maya 5. 

For the first time, we include information about Maya 5 on all four 
platforms in this book (Windows, Linux, IRIX, and Mac OS X). All 
features are common to all four platforms unless otherwise indicated. 
Some features, Fluid Effects, Cloth, Fur, and Live, are only found in Maya 
Unlimited (available on Windows, Linux, and IRIX platforms).

For your convenience, we’ve included complete procedures for using the 
new features in this book. 
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1 | What’s New in Maya 5 
What’s New > Introduction
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2 General
We’ve added some new features to Maya to enhance your Maya 
experience.

Online help changes

We are making changes to the Maya online help to increase ease of use 
and power. Behind the scenes, the help pages are being served to your 
browser by a small Java-based web server.

Improved search

Previous versions of Maya used various workarounds (Java applets, 
ActiveX controls) to allow something that is normally very difficult to 
achieve: local search from HTML pages. While these workarounds 
allowed a certain level of functionality, each had limitations.

In Maya 4.5 we introduced server-side search scripts, which gave faster 
and more reliable search functionality when you view the online help 
from a Web server.

By shipping a small, dedicated Web server with Maya, we can now make 
the server-side search the norm, allowing everyone to take advantage of 
faster and more reliable search.

The search available in the help server is significantly improved over 
previous search engines included with Maya:

• Many times faster than previous versions.

• Phrase searching (enclose words in quotation marks to search for the 
entire phrase).

• Boolean searches and wildcards.

• Additional search syntax for power users.

• Improved result ranking.

Identical help experience on all platforms

The help server allows us to deliver the same online help experience to all 
platforms, using standard Web-based technologies.

New capabilities for the next generation of online 
help

The help server is a base that allows us to explore new possibilities for 
help and user assistance tools in future releases of Maya.
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2 | General 
 > Move along rotation axes
Move along rotation axes

The Move tool now has a Move: Along Rotation Axis option to orient the 
move manipulator to the local rotation axes of the object.

New attribute to reverse rotation

When parent nodes have negative scaling factors they can make dragging 
the manipulator rotate the object in the opposite direction.

To correct for this effect, create a dynamic boolean attribute called 
flipRotateManip on the transform node and turn it on.

Dynamics performance improvements on 
Windows

We have switched to the Intel C++ compiler for compiling Dynamics. As a 
result, the performance of Dynamics in Maya for Windows has improved 
by 20-90%.
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3 Modeling
This version of Maya includes significant improvements to polygon 
reduction, as well as new extrude and chamfer actions and a toolbar in the 
UV texture editor.

Extrude edges or faces along a path curve

1 Select the edges/faces you want to extrude and the curve you want to 
extrude along.

2 Select Edit Polygons > Extrude Face > ❒  or Edit Polygons > Extrude 
Edge > ❒ .

3 Turn on the Use selected curve for extrusion option.

4 Click Extrude.

5 Use the controls in the attribute editor or channel box to edit the 
extrusion.

Options/Attributes

Twist

Rotates the extruded polygons as they travel along the curve.

Taper/Taper Curve

Scales the extruded polygons as they travel along the curve.

To control the taper exactly, open the Taper Curve section and use the 
graph control to set scaling along the length of the curve.

Poly Extrude Face History

Divisions

The number of subdivisions along the length of the extrusion.

Keep Faces Together

When this option is on, Maya extrudes each face separately. When this 
option is off, Maya extrudes the faces as a whole.

Extrude a vertex

Extrudes the selected vertex along its vertex normal, creating additional 
faces for each face that shares the vertex.

1 Select the vertex you want to extrude.

2 Select Edit Polygons > Extrude Vertex > ❒ .
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3 | Modeling 
 > Options/Attributes
3 Set the length to extrude the vertex and click Extrude.

Options/Attributes

Length

The distance to move the extruded vertex along its normal.

Divisions

Controls number of sections along the extrusion.

Chamfer a vertex

Removes a vertex and creates a chamfered corner.

1 Select the vertex you want to chamfer.

2 Select Edit Polygons > Chamfer Vertex.

Notes

Due to the way Chamfer Vertex works internally, the node it creates has 
Length and Divisions attributes. These attributes are not meaningful to 
edit and are left locked.

Options/Attributes

Delete Faces

When this option is on, Maya does not fill the chamfered area with 
new faces.

Reduce the number of faces in a mesh

Polygons > Reduce is substantially improved over previous versions.

• Speed and quality are improved.

• The reduction can now respect UV borders and vertex colors as it 
reduces. This results in much better feature and texture placement 
retention.

In the following illustration, the center model has been reduced by 
90% to produce the models on the left and right.

The model on the left was reduced with Influence Reduce: Color Per 
Vertex on. The reduction uses the color changes on the vertices to 
choose which areas to reduce, giving much better feature retention 
than the reduction on the right.
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3 | Modeling

 > Reduce the number of faces in a mesh
• You can now use Maya paint technology to paint reduction amounts 
on the original model and watch the reduced model update 
automatically.

To get finer control over what areas are reduced

1 Select the faces you want to reduce.

2 Select Polygons > Reduce > ❒ .

3 Set the general reduction percentage and turn on Keep Original, then 
click Reduce.

The reduced mesh appears next to the original along the X axis.

4 Select Edit Polygons > Paint Reduce Weights Tool.

5 Paint reduction values on the original.

Two reductions of the center model, both at 90%.

Vertex colors influence reduce Original No influence.

To... Do this

Reduce the number of faces in 
the selection.

Select Polygons > Reduce > ❒ , set 
the reduce options, then click Reduce.

Reduce the number of faces in 
a subset of a mesh.

Select the faces you want to reduce, 
then select Polygons > Reduce > ❒ .

Keep the current polygon mesh 
so you can compare the 
original and reduced versions 
as you change options.

In the Polygon Reduce Options 
window, turn on the Keep Original 
option.

The reduced mesh appears next to 
the original along the X axis.
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3 | Modeling 
 > Notes
Darker areas will be reduced more. Lighter areas will be kept as-is as 
much as possible.

As you paint on the original, the reduced version will update.

Notes

• You cannot paint reduce weights on the reduced version. You must 
use the Keep Original option and paint on the original object.

If you try to paint reduce weights on the reduced version, Maya will 
automatically select the original instead.

• When you select faces to reduce (rather than reducing the entire 
polyset), faces bordering the selection may move or be reduced as 
well.

You can avoid this effect by extracting the polygons from the mesh 
before reducing them. Turn on the Preserve: Mesh Borders option so 
the extracted mesh can be reattached later.

• When you are painting reduce weights, the Paint Attributes tool’s 
default is to only update when you finish a stroke. This is because the 
reduce operation can take a noticeable amount of time on large 
polysets.

If you want the reduced version to update as you paint, select Modify 
> Attribute Paint > ❒ , open the Stroke section, and turn on Update 
Continuously.

• Reduce Weights are a bias, not an absolute control. In some extreme 
cases polygons that you painted white but are not needed will still be 
reduced to preserve shape elsewhere.

• Reduce can work with quads and n-sided polygons, however:

• Unless you really need to preserve non-triangles, leave the 
Triangulate option on for better reduction.

• Non-planar polygons can become deformed and do not reduce 
well.

Options/Attributes

Reduce by (%)

Maya tries to reduce the number of polygons in the selected mesh or 
meshes by the specified percentage. The actual reduction may not 
match this number exactly.

Triangle Compactness

Controls the degree to which Maya sacrifices mesh shape accuracy to 
produce better triangles, as a number from 0 to 1.
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3 | Modeling

 > Options/Attributes
0 means try to reproduce the original mesh shape as accurately as 
possible while reducing, no matter what kind of triangles are 
produced. 1 means sacrifice accuracy as much as possible to produce 
regular equilateral triangles.

Numbers closer to 0 can produce long skinny triangles that can be 
hard to work with. Numbers closer to 1 can produce reduced meshes 
that do not match the shape of the original.

Triangulate

Converts the polygons to triangles before reducing them.

Unless you really need to preserve non-triangles, leave this option on 
for better results.

Influence Reduce

These options take extra information (in addition to shape) into account 
when reducing the mesh.

UVs

Reduces polygons to preserve UV mapping as much as possible. 
Turning this option on will preserve texture placement between the 
original and reduced polygons.

Color per Vertex

Reduces polygons so that color per vertex data (such as prelighting 
and painting) is preserved as much as possible. Turning this option on 
will devote more polygons in the reduced mesh to areas with color 
changes, and fewer polygons to areas with flat color to preserve the 
look of the original.

Preserve

Mesh Borders

Maya attempts to preserve the shape of polygon borders (edges that 
are not shared by other polygons).

UV Borders

Maya attempts to preserve the shape of UV borders as it reduces.

Hard Edges

Maya attempts to preserve the shape of edges marked “hard” as it 
reduces.

You can set edges on a mesh to be hard or soft using Edit Polygons > 
Normals > Soften/Harden > ❒ .
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3 | Modeling 
 > Compatibility with previous versions
Marking edges as “hard” can result in more shape retention than 
painting reduction weights.

Compatibility with previous versions

Maya now uses an improved reduce method which gives better results 
and allows you to preserve important details in your model.

Scene files created with previous versions of Maya may contain reduce 
nodes created by the old reduce method. The nodes in these scenes 
continue to use the old method. New reductions use the new method.

Show only a subset of all UVs

Maya lets you switch the texture editor between showing all UVs in the 
current set and only showing a selected subset in isolation. This can make 
it easier to work on part of the model without disturbing or accidentally 
selecting other UVs.

To show a subset of UVs

1 If you already have a subset isolated, click the Remove all button on 
the toolbar, or select View > Isolate Select > Remove All. 

2 Select the UVs you want to isolate.

3 Click the Toggle isolate select button on the toolbar, or select View > 
Isolate Select > View Set.

To switch back to showing all UVs, click Toggle isolation again, or 
turn off the View > Isolate Select > View Set menu item.

To add to the isolated subset

1 Click the Toggle isolate select button on the toolbar, or select View > 
Isolate Select > View Set to switch back to showing all UVs.

2 Select the UVs you want to add to the isolated subset.

3 Click the Add selected button on the toolbar, or select View > Isolate 
Select > Add Selected.

To remove UVs from the isolated subset

1 Select the UVs you want to remove from the isolated subset.

2 Click the Remove from isolation button on the toolbar, or select View 
> Isolate Select > Remove Selected.

Copy UVs to another UV set

1 In the texture editor, select the UVs you want to copy.
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3 | Modeling

 > UV texture editor toolbar
2 In the texture editor panel, open the panel’s Polygons menu, open the 
Copy UVs to UV Set sub-menu and choose a UV set.

UV texture editor toolbar

Most of the items on the texture editor toolbar are shortcuts for actions in 
the menus. Right-click a button to show its options.

UV position buttons

Flip UVs U, Flip UVs V

Flips the positions of the selected UVs. Shortcuts for Edit 
Polygons >Texture > Flip UVs.

Rotate UVs clockwise, Rotate UVs counterclockwise

Rotates the positions of the selected UVs. Shortcuts for Edit 
Polygons >Texture > Rotate UVs.

Cut UVs along selection

Separates UVs along the selected edges, creating borders. 
Shortcut for Edit Polygons >Texture > Cut UVs.

Sew UVs

Attaches UVs along the selected borders, but does not move 
them together in the texture editor view. Shortcut for Edit 
Polygons >Texture > Sew UVs.

Move and Sew UVs

Attaches UVs along the selected borders, and moves them 
together in the texture editor view. Shortcut for Edit 
Polygons >Texture > Move and Sew UVs.

Split selected UV

Separates UVs from each other along the edges connected 
to the selected UV points, creating borders. Shortcut for the 
texture editor’s Polygons > Split UVs.
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3 | Modeling 
 > UV texture editor toolbar
Isolate Selection buttons

These buttons let you work on a subset of UV faces while hiding the rest.

� ”Show only a subset of all UVs” on page 22

Layout UVs

Tries to move the UVs into a cleaner layout, based on the 
settings in the Layout UVs option box. Shortcut for Edit 
Polygons > Texture > Layout UVs.

Cycle U and V

Rotates the U and V values of the selected polygon.

Align Min U, Align Max U, Align Min V, Align Max V

Aligns the positions of the selected UVs. Shortcuts for the 
texture editor’s Polygons > Align UVs.

Move UVs to grid

Moves every selected UV to its nearest grid intersection in 
texture space. Shortcut for Edit Polygons > Texture > Grid 
UVs.

To change the grid, right-click the Toggle Grid button on 
the toolbar.

Relax UVs

Spreads out all UVs to make them easier to work with. 
Shortcut for Edit Polygons > Texture > Relax UVs.

Toggle isolation

Switches between showing all UVs and only the isolated 
UVs. Shortcut for View > Isolate Select > View Set.

Add selected to isolation

Adds the selected UVs to the isolated subset. When you 
click the Toggle isolation button the selected UVs will be 
visible. Shortcut for View > Isolate Select > Add Selected.

Removed selected from isolation

Removes the selected UVs from the isolated subset. 
Shortcut for View > Isolate Select > Remove Selected.
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3 | Modeling

 > UV texture editor toolbar
View buttons

Remove all

Clears the isolated subset. You can then select a new set of 
UVs and click Toggle isolation to isolate them. Shortcut for 
View > Isolate Select > Remove All.

Toggle grid

Shows or hides the grid. Shortcut for View > Grid.

Toggle image

Shows or hides the texture image. Shortcut for Image > 
Display Image.

Toggle filtered pixels

Switches the background image between hardware texture 
filtering and sharply defined pixels. Shortcut for Images > 
Unfiltered Image.

Toggle image ratio

Switches between showing square texture space and texture 
space with the same ratio of width to height as the image. 
Shortcut for Image > Use Image Ratio.

Toggle snap to pixel

Chooses whether to automatically snap UVs to pixel 
boundaries. Shortcut for Image > Pixel Snap.

Toggle thick texture borders

Chooses whether Maya draws UV borders with a thick line.

Show image RGB/Show image Alpha

These two buttons switch between showing the RGB (color) 
channels of the image and the Alpha (transparency) 
channel. Shortcuts for Image > Display RGB Channels and 
Image > Display Alpha Channels.
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UV edit buttons

Exponential smoothing smoothes UVs

The Polygons > Smooth action with exponential smoothing now smoothes 
UVs as well, retaining texture placement after smoothing.

Improvements to Split Polygon tool options

• Snap to Edge now constrains point placement to edges.

• Snap to Magnets snaps point placement to regular distances along an 
edge.

• Number of Magnets controls the number of magnet points inside 
edges.

U coordinate, V coordinate

Show the coordinates of the selected UVs. Edit 
the text boxes and press Enter to move the 
points.

The UV coordinates in the text boxes on the 
toolbar do not update automatically as you 
move the selected UV point. Click the refresh 
button to update the values in the text boxes.

Copy/paste faces or UVs

Switches the Copy and Paste buttons on the 
toolbar between working on UVs and UV faces.

Copy

Copies the selected UV points or faces 
(depending on the Copy/paste faces or UVs 
button) to the clipboard.

Paste

Pastes UV points or faces (depending on the 
Copy/paste faces or UVs button) from the 
clipboard.

Paste U to selected UVs, Paste V to selected UVs

Paste only the U or V values on the clipboard 
onto the selected UV points.
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 > New option for Move tool in texture editor
• Magnet Tolerance controls how close the point must be to a magnet 
before the point snaps to it. Set this to 100 to constrain points to 
always be at magnet points.

New option for Move tool in texture editor

In previous versions, snapping UVs with the Move tool would snap all the 
selected vertices to the same point.

You can now turn on the Retain Component Spacing option in the Move 
tool’s options panel to snap the manipulator while maintaining UV layout.

Additional changes and improvements

The Maya texture editor view now always updates interactively. The 
MAYA_TEXTURE_VIEW_INTERACTIVE_REFRESH environment 
variable no longer has any effect.

1 2 3
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 > Proportional Modification Tool works in parametric space
Proportional Modification Tool works in parametric 
space

You can now use Modify > Transformation Tools > Proportional 
Modification Tool with falloff (the amount of influence the control point 
has on its surrounding points) set in parametric space (that is, measured 
across the surface, rather than in absolute world space).

This means that the influence on surrounding points is based on how 
close they are across the surface, rather than in absolute world space. In 
many cases this can lead to more intuitive results.

This feature only works on NURBS.

To use proportional modification with parametric falloff

1 Select a CV on a NURBS surface.

2 Select Modify > Transformation Tools > Proportional Modification 
Tool > ❒ .

3 Set the Modification Falloff option to one of the parametric choices.

When you transform the selected CV, other CVs move proportional to 
their distance from the selected CV across the surface.

Limitations

• Multiple CVs cannot be selected at this time.

• Performance may be slow for large falloff values on complex surfaces.
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4 Animation
For Maya 5, we have added the following functionality to animation:

• The ability to mute animation channels

• New types of ghosting and enhanced ghosting display

• Improved clip snapping

• New colors for channel status in the Channel Box and Attribute 
Editor.

Muting Animation

You can now mute animation channels. Muting temporarily disables the 
animation on the selected channel without disconnecting its curve from 
the animated object.

Example

Muting lets you isolate and focus on a specific motion. When working 
with a model whose arms and legs are animated, you can use muting to 
turn off the animation of either the arms or legs.

Mute in the Channel Box

In the Channel Box, you can right-click selected channels and select the 
following options from the menu that appears.

Mute Selected

Mute the selected animation channels.

Unmute Selected

Removes muting from the selected animation channels.

Mute All

Mutes all channels for the current object(s).

Unmute All

Removes muting from all the channels of the current object(s).

Mute node in the Channel Box

When you mute the animation channels of an object, a mute node is 
automatically created in the dependency graph for each muted channel.

Note Muted channels appear brown in the Channel Box.
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 > Graph Editor and Dope Sheet
The mute node in the Channel Box has the following format: 
mute_objectn_channel. Example mute node names include: 
mute_pCube1_translateX, mute_joint1_rotateZ and so on.

When the mute is set to on, all animation nodes that connect to the mute 
node are muted. When the mute is set to off, all animation nodes that 
connect to the mute node are not muted. Setting the mute node to off in 
the Channel Box does not remove it from the dependency graph.

Graph Editor and Dope Sheet

A red icon appears beside a channel’s name when it is muted. 

A green icon appears beside a channel’s name when it is not muted, but 
still connects to a mute node. When the mute node is set to off in the 
Channel Box, the green icon still appears beside the channel’s name in the 
Graph Editor. See ”Change the status of a mute node from the Channel 
Box” on page 30.

Change the status of a mute node from the Channel 
Box

To turn the mute node on or off

1 Select the mute node in Hypergraph.

2 In the Channel Box, click in the Mute field and enter the following:

• Type on or 1 and press Enter to turn the mute node on.

• Type off or 0 and press Enter to turn the mute node off.

Note You can mute a time range by animating the status (on/off) of 
the mute node.
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 > Ghosting Improvements
Ghosting Improvements

You can control ghosting locally on each object in your scene with the new 
Ghost Selected and Unghost Selected Options windows or with the 
Ghosting Information Attributes. In addition to ghosting individual 
objects, you can now ghost entire skeletons or object hierarchies.

The appearance of ghosts in the scene view has also been improved for 
Maya 5. The color of ghosts before and after the current frame/keyframe 
lightens according to their distance from the current frame/keyframe. 
This is visible only when scene view Shading is set to Wireframe. See the 
following examples.

Examples

In the following example, the sphere’s Type of Ghosting is Custom Frame 
Steps, and the sphere’s ghost options are set to the following: Steps before 
Current Frame is set to 3, Steps after Current Frame is 0, and the Step Size 
is 3.

In the following example, the cube’s Type of Ghosting is Custom Frames, 
and the cube’s ghost options are set to the following: frame numbers 20, 
40, 60, and 80 are present in the Frames to Display field and Hierarchy is 
on. The cylinder is the child of the cube. The cube also has a Motion Trail 
with frame numbers.

Ghosts lighten as their 
distance from the object 
increases.
What’s New in Maya 5

31



4 | Animation 
 > Set Local Ghosting
Set Local Ghosting

To set ghosting options for an object or skeleton

1 Select the object or the root of the hierarchy that you want to ghost.

2 Select Animate > Ghost Selected > �.

The Ghost Options window appears.

3 Set the ghosting options. See ”Animate > Ghost Selected” on page 32.

4 Do one of the following:

• Click Ghost to apply the Ghost Options settings to the current 
object. The Ghost Options window closes.

• Click Apply to apply the Ghost Options settings to the current 
object, overriding any other ghosting settings on the object. The 
Ghost Options window remains open.

 • Click Close to disregard any changes made to the ghosting 
options and close the Ghost Options window.

Animate > Ghost Selected

Animate > Ghost Selected > �

Type of Ghosting

Global 

Preferences Uses the ghosting settings from Windows > 
Settings/Preferences > Preferences > Animation. 

Custom Frames Generates ghosts at the frames specified in the 
Frames To Display field. See ”Frames to Display” on 
page 33.

Custom Frame 

Steps Controls the number and spacing of ghosts for 
frames.

Custom Key 

Steps Controls the number and spacing of ghosts for 
keyframes. 

Note You can also set local ghosting options with the Ghosting 
Information attributes. To access these attributes, select Attribute 
Editor > objectShape > Object Display.
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Keyframes Generates ghosts at the range of keyframes defined 
by the Frame Range options. See ”Frame Range” on 
page 34.

Frames to Display

Lets you define a list of frames at which ghosts are generated for the 
current object. When entering frame numbers, use the following 
syntax: 

#, #, #, #

For example: 1, 5, 10, 15. This field is available only when the ghosting 
type is Custom Frames.

Steps Before Current Frame

Only available when the ghosting type is Custom Frame Steps or 
Custom Key Steps.

When the ghosting type is set to Custom Frame Steps, this field sets 
the number of ghosts that appear before the current frame. Spacing of 
these ghosts is defined by the Step Size field.

When the ghosting type is set to Custom Key Steps, this field sets the 
number of ghosts that appear before the current frame. Spacing of 
these ghosts is defined by the number of keyframes on an object and 
the Step Size.

Steps After Current Frame

Only available when the ghosting type is Custom Frame Steps or 
Custom Key Steps.

For Custom Frame Steps, this field sets the number of ghosts that 
appear after the current frame. Spacing of these ghosts is defined by 
the Step Size field.

For Custom Key Steps, this field sets the number of ghosts that appear 
after the current frame. Spacing of these ghosts is defined by the 
number of keyframes on an object and the Step Size.

Step Size

Only available when the ghosting type is Custom Frame Steps or 
Custom Key Steps.

For Custom Frame Steps, Step Size determines the number of frames 
between each ghost. For example, if the Step Size is 10, every tenth 
frame is ghosted.

For Custom Key Steps, Step Size and the number of keyframes control 
the spacing of ghosts. For example, if the Step Size is 2, then every 
other key is ghosted.
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Frame Range

These options are available only when the ghosting type is Keyframes.

Timeslider  Generates a ghost of the current object at every 
keyframe on the timeline.

Start/End Generates a ghost of the current object at the 
keyframes between the specified Start Frame and 
End Frame.

Start Frame

The frame at which the ghosting of keyframes begins. This field is 
available only when Start/End under Frame Range is selected.

End Frame

The frame at which the ghosting of keyframes ends. This field is 
available only when Start/End under Frame Range is selected.

Hierarchy

The specified ghost options are applied to the entire hierarchy below 
the selected joint or object. If Hierarchy is not selected, only the 
selected object is affected by the Ghost Options.

Use Ghost Driver

When on, the specified keys from the first selected object drive the 
ghosting for the rest of the selected objects. When off, all the selected 
objects use their own keys for ghosting. Use Ghost Driver is useful for 
comparing timing.

Animate > Unghost Selected

Animate > Unghost Selected > �

The Unghost Selected menu item turns ghosting off for selected objects. 

Note • Hierarchy can seriously affect performance. We recommend 
that you use Hierarchy sparingly.

• For Custom Key Steps and Keyframes, ghosts only appear 
for objects in the hierarchy that possess keyframes, unless 
Ghost Driver is on.

Note Ghost Driver is relevant for only keyframe-based ghosting.
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 > Changes to Ghosting in the Display menu
Hierarchy

When on, the selected object and its child bones or objects are 
unghosted. When off, only the selected object is unghosted.

Animate > Unghost All

Turns off ghosting for all objects in the scene.

Changes to Ghosting in the Display menu

Ghosting and No Ghosting have been removed from Display > Object 
Display.

Clip Snapping Improvement

In previous versions of Maya, clips in the Trax Editor could only snap to 
the nearest frame. Now when you move or scale a clip on a track where 
multiple clips are present, the edges of the clip will snap to the edges of its 
neighboring clips. This is useful when working with clips that begin or 
end with a value that is not a whole number or if you are viewing many 
frames and require accuracy.

Changes to Channel colors

The colors that represent the state of channels in the Channel Box and 
Attribute Editor have changed for Maya 5. The following table illustrates 
these changes.

State Color

Locked • Gray (Windows, IRIX, and Linux)

• Pink (Mac OS X)

Muted Brown

Blended Green

Keyed Light Orange

Expression Purple

Constrained Blue

Connected Yellow
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 > Changes to Channel colors
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5 Character Setup
For Maya 5, we have added the following functionality to character setup:

• The Parent constraint and many other constraint features

• The ability to blend IK and FK animation on the same skeleton

• The ability to apply keyframe animation and constraints to the same 
object

• The ability to use a NURBS object as the sculpt deformer’s sculpting 
tool.

Parent Constraints

With a parent constraint, you can relate the position—translation and 
rotation—of one object to another, so that they behave as if part of a 
parent-child relationship that has multiple target parents. An object’s 
movement can also be constrained by the average position of multiple 
objects.

Understanding Parent Constraints

A parent constraint lets you constrain the X, Y, and Z translation and 
rotation of one object to another—mimicking a parent-child relationship. 
When a parent constraint is applied to an object, the constrained object 
does not become part of the constraining object’s hierarchy or group, but 
remains independent and behaves as if it is the child of its targets. The 
constraining object is also known as the target object. 

For more information, search the online help for Target objects.

An object with a parent constraint does not behave the same as an object 
with a point and orient constraint. When a Parent constraint is used, 
rotating the target objects affects the constrained object’s rotation along 
the world axis. When a Point and Orient constraint are used, rotating the 
target objects affects the constrained object’s rotation along its local axis. 
This is shown in the following figure.
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Workflow for Parent Constraints

Scenario

A character walks, looks around, stops, and then removes his hat from his 
head and places it on a table nearby.

1 Select the character’s head, and then the hat.

2 Parent constrain the hat to the head, making sure that Maintain Offset 
is on and the weight is set to 1 in the constraint options.

For the procedure on creating parent constraints see ”To create a 
parent constraint” on page 40.

Maintain Offset preserves the original, relative translation and 
rotation of the constrained object.

The Weight attribute sets the amount of influence that the target’s 
position and orientation has on the constrained object. For information 
on parent constraint weighting see ”Weight” on page 42.

A parent constraint is created. Now when the character moves, the hat 
respects the position and orientation of the character’s head in the 
scene.

3 Select the hat, and then select the head’s weight in the Channel Box.

Parent Constraint Point and Orient Constraint

Original 
position Local 

rotation

Note When the hat is selected, the parent constraint and all its target 
weights appear in the Channel Box.
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4 Right-click the head’s weight and select Key Selected from the menu 
that appears.

This anchors the parent constraint’s weighting, and the state of the 
hat, at the current time in the character’s animation.

5 Animate the character so that it appears to walk, look around, and 
then stop.

The parent constraint forces the hat to follow the head’s movements 
as it nods up and down and rotates from side to side.

6 Animate the character’s arm and hand so that it reaches up and takes 
hold of the hat’s brim.

7 Select the hand, and then the hat.

8 Parent constrain the hat to the hand, making sure that Maintain Offset 
is on and the weight is set to 0 in the constraint options.

9 Key the weight of the head and the hand. See steps 3 and 4.

10 Advance one frame along the timeline.

11 Set the weight of the head to 0 and the weight of the hand to 1.

The hand now fully controls the translation and rotation of the hat.

12 Key the head and hand weights. See steps 3 and 4.

This anchors the weighting of the head and hand at the current time 
in the character’s animation.

13 Transform the arm and hand to the position where it appears to be 
placing the hat on the table.

14 Set the hat’s current position as its rest position.

Setting the hat’s rest position prevents it from popping back to its 
original position when the hand’s weight is set back to 0. For more 
information on the rest position, see ”Constrain > Set Rest Position” 
on page 45.

15 Set the weight of the hand to 0 and key the weight.

16 Animate the hands so that they return to their original positions 
hanging at the characters sides.

Since the hands no longer have any influence over the hat’s position 
or rotation, the hat remains on the table as the hands move back to the 
character’s sides.

Note If you want to ensure that their is no interpolation between 
weights (weights switch between 1 and 0 with no blend), set the 
tangent types of the weights to Stepped.
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Creating Parent Constraints

Before creating your first parent constraint in a Maya session, we 
recommend that you set the Parent constraint options. See the ”Constrain 
> Parent” on page 42.

After you’ve created a parent constraint, you can add more target objects 
for additional control over the constrained object’s position and rotation. 
Adding more target objects changes the target point, which in turn 
changes the constrained object’s position.

For more information, search the online help for Target Point.

To create a parent constraint

1 Select one or more target objects, followed by the object you want to 
constrain.

2 Select Constrain > Parent > �.

The Parent Constraint Options window appears.

3 Set the constraint options or select Edit > Reset Settings.

For information on these options, see ”Constrain > Parent” on 
page 42.

4 To finish setting the constraint, do one of the following:

• Click Add to create a parent constraint. The Parent Constraint 
Options window closes. Select Edit > Save Settings to save the 
constraint options.

• Click Apply to create a parent constraint. The Parent Constraint 
Options window remains open. By clicking apply, you can also 
apply the current constraint options settings to other objects. 
Select Edit > Save Settings to save the constraint options.

• Click Close to close the Parent Constraint Options window 
without setting or creating the constraint.

A parent constraint is created with the current constraint options. 

The constrained object’s position attributes (Translate X, Y, and Z) and 
rotation attributes (Rotate X, Y, and Z) are now influenced by the 
target point.

For more information, search the online help for Target Point.

To add a target object

1 Select one or more objects to add as target objects, followed by the 
constrained object.

2 Select Constrain > Parent.
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The constrained object’s position and rotation change, indicating that 
it is now constrained by the objects you have added as target objects.

Editing a Parent Constraint

You can edit a parent constraint’s attributes in the Channel Box and 
Attribute Editor. When you select a constrained object, its constrained 
axes appear blue in the Channel Box and Attribute Editor. This means that 
any changes you make to the Parent constraint affects only those axes.

Offset Parent Constraints

There are no offset values or fields present in the settings for Parent 
constraints. Unlike other constraints, you cannot offset Parent constrained 
objects from the Channel Box or options window. However, you can use 
the Maintain Offset option to set the offset of your constrained object or 
you can set a single key on the object to change its offset position.

To offset a Parent Constrained object using Maintain Offset

1 Select the constrained object.

2 Translate and rotate the object to where you want it positioned in your 
scene.

3 Select the target objects, followed by the constrained object.

For more information, search the online help for Targets.

4 Select Constrain > Parent Constraint > �.

The Parent Constraint Options window appears. See ”Constrain > 
Parent” on page 42.

5 Set the Parent constraint options to reflect the values of the 
constrained object’s channels and settings in the Channel Box.

6 Verify that Maintain Offset is on.

7 Click Add or Apply.

The constrained object is now offset from its targets by its current 
rotation and translation.

Note If you turn on Maintain Offset in the Parent Constraint Options, 
the constrained object’s position and rotation will not change 
when you add a target to the constraint.
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Constrain > Parent

Constrain > Parent > �

Maintain Offset

Preserves the original (state prior to constraining), relative translation 
and rotation of the constrained object. Use this option to maintain 
spatial and rotational relationships between constrained objects. See 
”Offset Parent Constraints” on page 41.

Constraint Axes

Determines whether the parent constraint is restricted to a specific 
axis (X, Y, Z) or to All axes. When All is checked, the X, Y, and Z 
boxes are dimmed.

Weight

This is useful only when there are multiple target objects. 

Sets the amount of influence that a target object’s position and 
rotation has on the constrained object. If the weight is 0.0000, the 
target object has no influence over the translation and rotation of the 
constrained object. If the weight is 1.0000, the target has full control 
over the constrained object’s translation and rotation. Default weight 
is 1.0000.

Parent Constraint attributes

In the Attribute Editor, you can view or edit the characteristics of the 
parent constraint node. To edit this node, you must first select its name in 
the Outliner or its tab in the Attribute Editor. If you selected it in the 
Outliner, go to Windows > Attribute Editor or use the shortcut Ctrl+a to 
view its attributes.

For more information, search the online help for Constraint node 
attributes.

The following section describes the attributes specific to the Parent 
constraint node (parentConstraint).

Interp Type

Sets the rotation interpolation type for the constraint. Interp Type is 
relevant only when the constrained object has multiple targets.

Average Averages rotation between the constrained object 
and its targets.
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Shortest Finds the shortest path between rotations from the 
constrained object to its targets using quaternion 
interpolation.

Longest Finds the longest path between rotations from the 
constrained object to its targets using quaternion 
interpolation. This path is in the opposite direction 
from Shortest.

No Flip and 

Cache No Flip caches the current rotation onto the 
constrained object. Once you select No Flip, you 
must click the Cache button to create the cache. 
Cache appears in the Interp Type menu field when 
there is cached interpolation on the constrained 
object.

Cache button Caches the current rotation interpolation onto the 
constrained object and creates an animation curve 
for the current rotation interpolation on the 
constraint’s node. Caching reduces the chance of 
flipping. Only available when you select No Flip.

Delete button  Deletes the current rotation interpolation cache from 
the constrained object. Only available when Cache 
appears in the Interp Type menu field.

Constraint Translate

Displays the constrained object’s current position. This value can be 
useful when specifying the Offset Translate value. This field is read-
only.

Constraint Rotate

Displays the constrained object’s current rotation. This value can be 
useful when specifying the Offset Rotate value. This field is read-only.

Maintain Offset

With Maintain Offset, you can now preserve the original, relative 
translation, rotation, and scaling of a constrained object. Maintain Offset is 
present in all constraint option menus.

Constraint Axes

You can now select which individual axes (X, Y, Z, or All) of the 
constrained object are affected by the constraint. The Constraint Axes 
checkboxes are located in the constraint options windows.
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Constrain > Modify Constrained Axis

Modify Constrained Axis lets you change which axes of a constrained 
object are influenced by the target object. Use this feature when you want 
to modify the axes of a constraint. Modify Constrained Axis can only be 
used in conjunction with the following constraint types: point, orient, 
scale, aim and parent.

To modify the axes of a constraint

1 Select the constrained object and its targets.

2 Select Constrain > Modify Constrained Axis. 

The Modify Constrained Axis options window appears.

3 Check the Constrain axes (X, Y, Z). You can also turn on Maintain 
Offset to preserve the relative position, rotation, or scaling of the 
constrained object.

4 To finish setting the node’s new axes, do one of the following:

• Click Modify to change which of the constrained object’s axes are 
influenced by the target object. The Modify Constrained Axis 
options window closes.

• Click Apply to change which of the constrained object’s axes are 
influenced by the target object. The Modify Constrained Axis 
options window remains open.

• Click Close to cancel the modify constrained axis operation. The 
Modify Constrained Axis options window closes.

Constrain > Remove Target

Constrain > Remove Target > �

With Remove Target, you can sever the connection between a target object 
and a constrained object without deleting the constraint node. When you 
remove a target from a constrained object, it no longer affects the 
constrained object.

To remove a target

1 Select the target object from which you want to remove the constraint 
connection, followed by the object it is constraining.

2 Select Constrain > Remove Target > ❒ .

The Remove Target Options window appears.

3 Check the constraint types whose connections you want to sever.

• If you want to sever all constraint connections between the 
selected target and the constrained object, turn on All. 
What’s New in Maya 5 

44



5 | Character Setup

 > Constrain > Remove Target > �
• If you want to preserve the relative transformation (translation, 
rotation, scale, and so on) of the constrained object, turn on 
Maintain Offset.

4 To finish this operation, do one of the following:

• Click Remove to remove the specified connection between the 
selected target object and the constrained object. The Remove 
Target options window closes.

• Click Apply to remove the specified connection between the 
selected target object and the constrained object. The Remove 
Target options window remains open.

• Click Close to cancel the remove target operation. The Remove 
Target options window closes.

Constrain > Set Rest Position

With Set Rest Position, you can set where in world space your constrained 
object is positioned when its target weight is 0. Rest position gives you 
control of the constrained object, rather than relying on the last position of 
the target objects. Setting the rest position prevents constrained objects 
from sticking to undesired positions in the scene when their target 
weights are set to 0. 

For example, a book is point constrained to a character’s hand. When the 
character places the book on the table, the book’s position on the table is 
set as its rest position. This prevents the book from popping back to the 
model’s hands when the weight of the hand changes to 0. The books 
target (the model’s hand) weight is then set to 0. The hand now no longer 
influences the book’s position. The character then proceeds to release the 
book, turn, and walk away from the table. The book does not snap back to 
the hand because its rest position was set.

To define a constrained object’s default position

1 Select the constrained object for which you want to define the rest 
position.

2 Set the constrained object’s target weights to 0.

3 Move the constrained object to a new position or leave it at its current 
position.

4 Select Constrain > Set Rest Position.

The current position of the constrained object is now its default 
location in world space when its target weights are 0.
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Rest Position in the Attribute Editor

The rest position settings for each constraint are located in the constrained 
object’s constraint attributes.

Enable Rest Position

If on, the rest position is active for the constrained object. If off, the 
rest position is inactive for the constrained object. Turning Enable Rest 
Position off does not remove it from the constrained object.

Rest Translate

Sets the X, Y, and Z translation for the constrained object’s Translate 
rest position. These fields are present for only Point and Parent 
constraints.

Rest Rotate

Sets the X, Y, and Z rotation for the constrained object’s Rotate rest 
position. These fields are present only for Orient, Aim, and Parent 
constraints.

Rest Scale

Sets the X, Y, and Z scaling for the constrained object’s Scale rest 
position. These fields are present only for Orient and Parent 
constraints.

Constraint Improvements

You can now transform constrained objects regardless of their targets’ 
weight settings. For example, if a cube is constrained by a sphere, you can 
manipulate the cube (constrained object) whether the sphere’s (the target) 
weight is 0 or 1. This is useful when applying animation and constraints to 
the same object. See ”Animation-Constraint Blending” on page 52.

Animate > IK/FK Keys > Move IK to FK

Move IK to FK moves an IK handle to the last joint of its IK joint chain.

In a typical FK/IK rig, the IK handle does not move with the skeleton 
during FK manipulation and thus appears out of sync. This can cause 
confusion when there are many IK handles. When animating with IK and 
FK, you can use Move IK to FK to synchronize the IK handle’s position 
with the end effector’s position.

If the IK handle is grouped or constrained in a control hierarchy, use 
Animate > IK/FK Keys > Connect IK to FK in conjunction with Move IK 
to FK to move the entire hierarchy.
What’s New in Maya 5 

46



5 | Character Setup

 > Freezing Joint Orientation
Freezing Joint Orientation

You can now freeze the local joint rotation axes to match world space by 
turning on the new Orient option in Modify > Freeze Transformation > �. 
If Orient is off, the local joint rotation axes are not affected by Freeze 
Transformation.

IK/FK Blending

IK/FK blending lets you apply keyframe animation to joints and also 
control them with IK animation. Due to the addition of IK/FK blending, 
the IK Solver Enable attribute has now changed from an on/off value to a 
numeric 0.000–1.000 blend. Also, Ik Blend has replaced Enable Solver in 
the IK Handles Attributes. See ”Ik Blend” on page 52.

Now when you select a joint chain and its IK handle, the joint chain is 
drawn using three default or user defined colors. The blue joint chain 
represents the skeleton with pure FK animation, the brown joint chain 
represents the skeleton with pure IK animation, and the magenta joint 
chain represents the resulting animation blend. Also, you can customize 
the colors of the IK/FK joint chains and the size of the IK/FK joints. See 
”Modify the display of IK/FK animated joint chains” on page 50.

Blend IK and FK Animation

To create an animation blend from FK to IK

1 Select your joint chain and IK handle.

2 In the IK Solver Attributes, drag the Ik Blend slider to 0.000.

The animation mode is now set to pure FK.

3 Set a key (default hotkey: s key).

4 Deselect the IK handle, select a joint in your joint chain, and set a key 
once more. 

Note In addition to blending IK and FK animation over multiple 
frames, a blend can occur over a single frame. Blending over a 
single frame switches IK to FK or FK to IK instantly.

Note For skeletons with IK animation created in previous versions of 
Maya, turn on Ik Fk Control if you want to rotate or key the 
joints in the skeleton’s joint chains. See ”New IK Solver 
Attributes” on page 52.
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You will now be keying the joint (for FK)—not the handle (for IK).

5 Drag the current time indicator along the timeline and translate or 
rotate the joint.

6 Set a key. 

7 Repeat steps 5 and 6 until you complete the FK portion of your 
animation.

8 Once you set the last FK key, deselect the joint and select the IK 
handle of your joint chain.

9 Verify that the Ik Blend slider is at 0.000, and set a key.

10 Drag the Ik Blend slider to 1.000 and set a key on the handle.

Since there is no period of animation between the last pure FK key 
and the first pure IK key, the FK animation switches to IK instantly 
(without a blend).

The animation mode is now set to pure IK.

Example

Blending the FK animation of a swinging arm with the IK animation of a 
waving arm.

Note When there is a period of animation between a pure FK key and 
a pure IK key, it is interpolated by the IK Solver. The 
interpolated animation then appears as Ik Blend values between 
0.000 and 1.000.

1 40 80 120 160 200 2

arm swings

FK keys

FK
IK
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A simple animation of a swinging arm during a walk cycle is created by 
selecting the root of an arm’s joint chain (the shoulder joint), rotating it 
along the Z axis, and then setting keys for the joint. This produces a 
rudimentary FK animation.

This FK animation sequence is blended with the directed motion of the 
arm waving by setting keys on the IK handle and the shoulder joint at the 
end of the FK animation, moving the timeline indicator to create a blend 
region, changing the Ik Blend value to 1.000 (pure IK), and once again 
setting keys on the shoulder joint and IK handle. In the area between the 
pure FK and IK animation—the blend region, the IK Solver interpolates 
the animation from 0.000 to 1.000.

1 40 80 120 160 200 2

FK/IK blend

arm rises

IK Blend 0.000
IK key

FK key

IK Blend 1.000
IK key
FK key

FK

IK
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Pure IK animation is reached once the Ik Blend value is 1.000. The IK 
handle is then translated and rotated while setting keys, to produce the 
animation of the arm waving.

When the animation of the waving arm is complete, the animation is set 
back (using another blend region and changing the Ik Blend value to 
0.000) to pure FK. The resulting animation resembles a swinging arm (FK) 
that rises into a wave (IK) and then descends back into a swinging motion 
(return to FK).

Modify the display of IK/FK animated joint chains

To set the display parameters for bones with FK or IK 
animation

1 Select Window > Settings/Preferences > Preferences from the Maya 
main menu bar.

The Maya Preferences window appears.

2 Click Kinematics under Display to open the Kinematics Display 
Preferences.

The Inverse Kinematics preferences appear.

3 Select a display option:

• Choose None if you do not want to display any of the IK/FK 
blend skeletons.

• Choose IK if you want to display only the IK and blend skeleton.

• Choose FK if you want to display only the FK and blend skeleton.

IK

1 40 80 120 160 200 2

arm waves

IK keys
FK
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• Choose Both if you want to display all the IK/FK blend skeletons. 
Both is the default setting.

4 Do one of the following:

• Click Save to save all changes to the IK/FK Blending Display. The 
Maya Preferences window remains open.

• Click Cancel to disregard any changes to the IK/FK Blending 
Display. The Maya Preferences window closes.

To set the color of IK/FK joint chains

1 Select Window > Settings/Preferences > Colors from the Maya main 
menu bar.

The Colors settings window appears.

2 Click the arrow beside IK/FK Blending to reveal the IK/FK joint color 
settings.

3 Click-drag the sliders beside FK Joints and IK/FK Blended Joints to 
set their display colors.

4 Do one of the following:

• Click Save to save all changes to the Blend and FK Joint display 
colors. The Color settings window remains open.

• Click Reset to Saved to cancel any changes made to the Blend and 
FK Joint display colors and revert to the color settings from your 
last file save. The Color settings window remains open.

• Click Close to cancel any changes to the Blend and FK Joint 
display color. The Color settings window closes.

To set the joint size for bones with FK or IK animation

1 Select Window > Settings/Preferences > Preferences from the Maya 
main menu bar.

The Maya Preferences window appears.

2 Click Kinematics under Display to open the Kinematics Display 
Preferences.

The Inverse Kinematics preferences appear.

3 Set the joint size using the Ik/Fk Joint Size field or slider.

4 Do one of the following:

• Click Save to save all changes to the Ik/Fk Joint Size. The Maya 
Preferences window remains open.

• Click Cancel to disregard any changes to the Ik/Fk Joint Size. The 
Maya Preferences window closes.
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New IK Solver Attributes

Ik Blend

An Ik Blend value of 0.000 sets the animation mode to pure FK, and 
an Ik Blend value of 1.000 sets the animation mode to pure IK. When 
the Ik Blend value is a number between 0.000 and 1.000, then the 
animation on the current skeleton is blended IK and FK.

Ik Fk Control

Lets you manipulate and key the joints of a joint chain that has an 
animated Ik handle. In addition to being located in the local Ik Handle 
Attributes, Ik Fk Control is also present in the global skeleton settings 
(Skeleton > Enable Ik Fk Control).

Animation-Constraint Blending

You can now blend keyframe animation and constraints on the same 
object. 

Examples

• A man runs to a parked convertible car, jumps over the door and into 
the driver’s seat, and then drives away. In this example, both the 
character and car models are animated, and various parts of the man 
are point constrained to the car’s door, seat, and steering wheel.

• A basketball player dribbles the ball, picks it up, and throws it to 
another player. The player that catches the ball pauses and then 
shoots for the hoop. In this example, the ball and all the players hands 
are animated, and the ball is parent constrained to the various player’s 
hands.

Workflow for Animation-Constraint blending

Scenario
A basketball player character passes a ball to his teammate.

1 Select the first player’s hands, and then the basketball.

2 Parent constrain the ball to the hands, making sure that Maintain 
Offset is on and the weight is set to 1 in the constraint options.

Note • Ik Blend has replaced Solver Enable. 

• The new Ik Fk Control attribute turns off global and local IK 
Handle Snap.
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For the procedure on creating parent constraints, see ”To create a 
parent constraint” on page 40.

Maintain Offset preserves the original, relative translation and 
rotation of the constrained object.

The Weight attribute sets the amount of influence that the target’s 
position and orientation has on the constrained object. For information 
on parent constraint weighting see ”Weight” on page 42.

3 In the Channel Box, set keys for the weights of the first player’s hands.

This anchors the parent constraint’s weighting, and the position and 
orientation of the basketball, at the current time in the character’s 
animation.

4 Animate the arms of the first player so that they appear to be 
throwing the ball.

5 At the point in the first character’s animation where he is to let go of 
the ball, set a key on the ball and on the weights of the hands.

Since the basketball now has both a constraint and keyframe 
animation, a new blend weight attribute appears in the Channel Box.

6 Change the blend weight to 1, and key the blend weight.

7 Advance one frame along the timeline.

8 Set the weight of the first player’s hands to 0, and set the blend weight 
to 0.

When the blend weight is 0, the keyframe animation has full control 
over the position and orientation of the ball.

9 Key the hands’ weights and the blend weight.

This anchors the animation-keyframe blend weight and the first 
player’s weight at the current time in the character’s animation.

10 Keyframe the ball as it is thrown from the first player to the second 
player.

11 When the ball reaches the position where the second player catches it, 
parent constrain the ball to the hands of the second player, making 
sure that Maintain Offset is on and the weight is 0 in the constraint 
options.

12 Key the weights of the second player’s hands and that of the blend 
weight.

13 Advance one frame along the timeline.

Note When the basketball is selected, the parent constraint and all its 
target weights appear in the Channel Box.
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14 Set the blend weight to 1 and the second player’s hands’ weights to 1.

When the blend weight is 1, the parent constraint has full control over 
the position and orientation of the ball.

15 Key the blend weight and the weights of the second player’s hands 
again.

This anchors the weighting of the ball’s animation and that of the 
parent constraint at the current time in the characters’ animation.

16 Animate the second player.

Blend Weights in the Channel Box

Blend Constraintn

The keyframe animation-constraint blend value determines the 
amount of influence that the constraint and keyframe animation have 
on the constrained object. If the value is 0, the keyframe animation has 
total control over the constrained object’s transformations. If the value 
is 1, the constraint has total control over the constrained object’s 
transformations.

If there are more than one of the same type of constraint applied to the 
object, n stands for the constraint number. This value appears in the 
pairBlend node’s attributes as Weight.

pairBlend node

The pairBlend node is automatically generated when both keyframe 
animation and a constraint are applied to an object. Once the animation 
and constraint are linked to the pairBlend node, you can modify the 
weight of the animation-constraint blend to generate various effects. See 
”Blend Weights in the Channel Box” on page 54.

In the dependency graph, the pairBlend node functions as a link between 
constraints, animation, and the object to which both are applied. The 
pairBlend node connections resemble the following: all target objects 

Note If you want to ensure that the transitions between the blend 
weights are clean (no interpolation), set the tangent types of the 
weights to Stepped.

Note When the driven object is selected, all its target and blend weight 
values can be viewed in the Channel Box under SHAPES > 
objectn_typeConstraintn or INPUTS > pairBlendn.
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connect to the constraint node, the constraint node and keyframe 
animation connect to the pairBlend node, and the pairBlend node connects 
to the object.

When multiple constraints are applied to the same object, a separate 
pairBlend node is created for each constraint and the animation channels 
of the constrained object connect to the same pairBlend node as their 
related constraints.

pairBlend attributes

Caching

Unlike other cache data in Maya (for example, caches in Dynamics, Cloth, 
and Fluid Effects), the cache data for pairBlend is also an animation curve. 

For more information, search the online help for node Caching.

Node State

For more information, search the online help for the Node State 
Attributes.

InTranslaten

The InTranslate fields display the X, Y, and Z translation values for 
Input 1 and Input 2. n represents the input number.

InRotaten

The InRotate fields display the X, Y, and Z rotation values for Input 1 
and Input 2. n represents the input number.

Weight

Displays a blend value that determines the amount of influence that 
the constraint and keyframe animation have on the constrained object. 
This field is read-only. See ”Blend Constraintn” on page 54.

TranslateXMode

Blend Inputs  The blended X translation of Input 1 and Input 2 
controls the driven object’s X translation.

Input 1 only  The X translation of Input 1 controls the X 
translation of the driven object.

Input 2 only  The X translation of Input 2 controls the X 
translation of the driven object.

Note Input 1 always represents the keyframe animation on the 
constrained object and Input 2 always represents the constraint 
node.
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TranslateYMode

Blend Inputs  The blended Y translation of Input 1 and Input 2 
controls the driven object’s Y translation.

Input 1 only  The Y translation of Input 1 controls the Y 
translation of the driven object.

Input 2 only  The Y translation of Input 2 controls the Y 
translation of the driven object.

TranslateZMode

Blend Inputs  The blended Z translation of Input 1 and Input 2 
controls the driven object’s Z translation.

Input 1 only  The Z translation of Input 1 controls the Z 
translation of the driven object.

Input 2 only  The Z translation of Input 2 controls the Z 
translation of the driven object.

RotateMode

Rotation is calculated by blending the rotation of the specified inputs 
along all axes.

Blend Inputs  The blended X, Y, and Z rotation of Input 1 and 
Input 2 controls the driven object’s rotation along all 
axes.

Input 1 only  The X, Y, and Z rotation of Input 1 controls the 
driven object’s rotation along all axes.

Input 2 only  The X, Y, and Z rotation of Input 2 controls the 
driven object’s rotation along all axes.

Rotation Interpolation

Euler Angle Use Euler Angles when the pairBlend weight value 
is between 0 (driven by keyframes) and 1 (driven by 
the constraint). Euler is the default rotation 
interpolation.

For more information, search the online help for Independent Euler 
Angles.

Note Euler angles may cause flipping when used to interpolate 
between keyframes and constraints. If this occurs, we 
recommend that you switch to quaternion rotation.
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Quaternion Quaternions smoothly interpolate the keyframe-
constraint blend without producing anomalies (such 
as flipping). Use Quaternion when the pairBlend 
weight value is 1 or 0.

For more information, search the online help for Synchronized 
Quaternions.

Sculpt deformer can use any NURBS surface

The sculpt deformer can now use a NURBS object as the sculpting tool 
instead of the default implicit sphere.

To use a NURBS surface with the sculpt deformer

1 Select the object to deform, and then the NURBS surface to use as a 
sculpting tool.

2 Select Deform > Create Sculpt Deformer > ❒ .

3 Turn on Use Secondary Object as Sculpt Tool.

4 Click Create.

MEL command

Two new flags have been added to the sculpt command to support this 
functionality.

• -st/-sculptTool objectName

The -sculptTool flag takes the name of the NURBS object to use as the 
sculpt tool when creating the deformer. If you do not specify this flag, 
the command uses an implicit sphere.

• -e/-edit

Use the -edit flag with the -sculptTool flag to replace the sculpt tool 
with a different object.

Limitations

• Geometry types other than implicit spheres and NURBS objects are 
not currently supported. To use another type of surface, convert it to a 
NURBS surface.

• Performance can degrade as the number of vertices in the sculpt tool 
and/or the object being deformed increase.

Note Deleting the sculpt node or the deformed object does not delete 
the custom sculpt tool.
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• For best results use closed, convex objects as sculpting tools.

Advanced

• As with previous versions of Maya, it is possible to have multiple 
sculpt deformers deforming the same object.

• You can use the connection editor or the MEL connectAttr command 
to manually connect a different object as the sculpt tool.
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6 Rendering
Overview 

We’ve added new rendering features and made the following 
enhancements in Maya 5:

• We’ve provided new options for QuickTime output for Mac OS X and 
made improvements to the way the IPR default light and the Convert 
to File Texture and depth map shadows algorithms work. 

For more information, see ”Maya software rendering” on page 60.

• The mental ray for Maya plug-in has been integrated into the Maya 
application, and a significant number of improvements have been 
made, including: 

• the integration of bake-sets, which let you bake several objects 
with different baking options during the same baking process

• improvements that optimize the export to .mi process

• extended support for the IFF image format that permits both color 
and depth information to be written into a single file

• support for Subdivision surface rendering 

• support for Particle types

For more information, see ”mental ray for Maya rendering” on 
page 62.

• Maya’s new Hardware renderer provides an intuitive workflow to 
generate hardware rendered images for previews, specific passes, and 
hardware rendered particles. In some cases, image quality may be 
good enough for final delivery.

For more information, see ”Maya hardware rendering” on page 74.

• Maya’s new Vector renderer lets you create stylized renderings (for 
example, cartoon, tonal art, line art, hidden line, wireframe) in various 
bitmap image formats and 2D vector formats.

For more information, see ”Maya Vector rendering (Windows and 
Mac OS X)” on page 76.

• Render globals for Maya’s new hardware renderer, the newly 
integrated mental ray for Maya renderer, Maya’s software renderer, 
and the Maya’s new Vector renderer have been consolidated into one 
Render Globals Settings window. 

For more information, see ”Unified Render Globals Settings window” 
on page 60.
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Unified Render Globals Settings window

Render globals for the new Maya Hardware renderer, the integrated 
mental ray for Maya renderer, the Maya Software renderer, and the Maya 
Vector renderer have been consolidated into one Render Globals Settings 
window. 

To choose the renderer

• Do one of the following:

• Click Render > Render Using, then choose the renderer.

• Select the renderer from the dropdown list in Render View or the 
Render Global Settings window.

To open the Render Global Settings window

• Do one of the following:

• Click Window > Rendering Editors > Render Globals.

• Click the Display Render Globals Window button on the main 
toolbar or in Render View.

The new Common tab of the Render Global Settings window contains 
the common attributes, which decreases the number of parameters 
you need to modify when switching between renderers. Settings 
specific to the chosen renderer are available in another tab.

For descriptions of options in all tabs, see the online Rendering guide.

Maya software rendering

New options for QuickTime Output (Mac OS 
X)

For the Maya software renderer (and the new Maya Hardware renderer), 
QuickTime output now supports over 20 different compression codecs for 
batch rendering and Playblast.

This provides more flexible output options, and removes the necessity to 
edit uncompressed movies in another application.

Tip Hold down the Ctrl key when adjusting the quality slider for 
finer control.
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IPR default light improvements

The IPR default light that is created when doing an IPR render of a scene 
without a light operates like the Maya Software default light. 

• The IPR default light is removed from the scene as soon as the IPR 
session is terminated (for example, when you click the IPR stop 
button).

• The IPR default light is not saved with the scene, preventing you from 
accidentally adding the IPR default light to their saved scene.

Convert to File Texture improvements

The algorithm Maya uses to Convert to File Texture has been improved to 
produce more reliable visual results more quickly and efficiently. Seams in 
UV space are now handled better. The algorithm is used for subdivision 
surfaces and polygons.

The new algorithm consists of two passes by default. The first pass 
samples the color of the inside of triangles; the second pass extends the 
sampled color slightly in each direction along the polygon border to fill 
texture seams. Games developers, or other users who have no room for 
overscanning, can disable the second pass by turning off the Fill Texture 
Seams option.

MEL command changes

The following flag for the mel command convertSolidTx is now obsolete:

-ubi/-uvBBoxIntersect boolean

The following flag has been added: 

-fts/fillTextureSeams boolean

This specifies whether or not to overscan a polygon beyond its outer 
edges when creating the file texture. The default is true.

Depth map shadow improvements

The algorithm to compute mid dist depth shadows has been improved, 
making them more robust and removing some artifacts. 
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mental ray for Maya rendering

About the integration of mental ray for Maya

mental ray for Maya has been integrated into the Maya application. It 
allows interactive and batch mental ray rendering from within the Maya 
user interface. With the help of built-in shaders supporting almost any 
effect available in Maya, mental ray for Maya allows the rendering of 
scenes created within Maya or their export into the mental images file 
format (mi). 

The mental ray for Maya plug-in is based on the new mental ray 3.2 core. 
All features of this version are accessible by mental ray for Maya. 

For more information, see the online Rendering guide.

Selecting the mental ray for Maya renderer

When you select the mental ray for Maya renderer, Maya’s user interface 
is automatically configured to use mental ray for Maya. If you render the 
current frame, Maya uses mental ray for Maya. If you click the Display 
Render Globals Window button (in the main menu or in Render View), 
the unified Render Globals Settings window appears, showing the mental 
ray tab. 

To select the mental ray for Maya renderer

• Do one of the following:

• Click Render > Render Using > mental ray.

• Select mental ray from the dropdown list in Render View or the 
Render Global Settings window. 

For more information on the mental ray for Maya render settings, see 
the online Rendering guide. 

Note Because of the unified render global settings (see ”Unified 
Render Globals Settings window” on page 60), the mental ray for 
Maya ‘derive from Maya’ settings no longer exist. You may need 
to modify some older files for which ‘derive from Maya’ was set 
by setting the mental ray for Maya render global settings. 
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Baking and prelight improvements (mental 
ray for Maya)

The procedures for baking to textures and vertices with mental ray for 
Maya have been optimized to improve workflow for baking illumination, 
shadow, shading, and textures. These improvements benefit users such as 
game developers who require more flexibility to perform complex baking 
options. 

Bake-sets, which let you bake several objects with different baking options 
during the same baking process, have been implemented. For information 
on bake-sets and instructions on how to bake textures and vertices with 
mental ray for Maya, see ”Using bake-sets” on page 66.

mental ray for Maya export improvements

Improvements let you optimize the export to .mi process. If objects do not 
change, reprocessing before exporting to .mi is not required, and the 
export process is significantly shortened as a result. 

File > Export Selection  > �

Additions have been made to the Export Selection Output options for File 
Type mental ray. 

Export Selection Output

Renderable 

Scene This is the default. 

Maya exports all scene entities (lights, cameras, 
shaders, globals, etc.) that are necessary to render 
the selected geometry. The resulting scene will be 
renderable using the mental ray standalone.

Scene 

Fragment Maya exports only the nodes that are selected. This 
mode can be used to export particular lights, 
cameras, shaders, or geometry. The resulting .mi 
file will most likely not be directly renderable, so it 
is called a Scene Fragment.

Note Maya’s Convert to File Texture command and Polygon Prelight 
command remain unchanged.
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Export Materials

In addition to the selected nodes, this setting also exports any 
materials that they are connected to. This applies to selected geometry 
and shading nodes.

Export All Incoming Shaders

In addition to selected shading nodes, also exports all inputs to those 
nodes. For example, if a surface shader is selected, this mode causes 
any texture networks feeding into the shader to be exported along 
with the shader.

Export Entire Child DAG

This option specifies that in addition to selected geometry, any 
children of that geometry should also be exported.

The standard export filters (enabled by turning on Export Selected Items 
Only) are also applied to the nodes identified for export. This allows you 
to prevent the export of unwanted node types. 

Scene Export Optimization Controls

Several new controls let you manually optimize the process of exporting 
scenes to .mi format. The translator now recognizes a specific set of 
dynamic attributes that you can add to nodes to control how they are 
exported. 

You can accelerate the process of exporting scenes to .mi format by 
disabling deformation checking for objects that are known to be static over 
an animation (buildings, for example), and by disabling tangent vector 
export for objects that do not use bump mapping or other tangent-based 
shading effects.

miDeformation

Controls whether or not the translator tries to detect deformation of 
an object.

To support per-object control of deformation determination and 
motion vector calculation of shape nodes, this dynamic attribute of 
type boolean is recognized. It overrides the global Export Shape 
Deformation option and either marks the current shape for or 
excludes it from deformation motion blur. Two common scenarios are 
supported: 

• disable deformation globally but enable it for specific shapes

• enable deformation globally but disable it for specific shapes

miTangents

Controls export of tangent vectors on objects.
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To support per-object control of tangent vector calculation for polygon 
meshes and NURBS surfaces, this dynamic attribute of type boolean is 
recognized. It overrides the global Export ... Derivatives options and 
marks or ignores the current shape accordingly for tangents 
computation. Two common scenarios are supported: 

• disable tangents globally but enable them for specific shapes

• enable tangents globally but disable them for specific shapes

The tangents are first order derivatives supplied as mental ray bump 
basis vectors. They are required for mayabase shader filtering and 
bump mapping purposes.

Extended subdivision surface support 

Subdivision surface rendering is now supported. 

The support for subdivision surfaces has been added and includes 
hierarchical edits, hierarchical material assignments, edge and vertex full 
creases only, uncreases, texture reference objects, deformation motion 
blur, and derivatives (for bump mapping and texture filtering). Unlike 
Maya, however, mental ray for Maya can handle only quadrilateral base 
meshes (a number of Maya standard subdiv shapes are therefore rejected), 
and UV coordinates can only be specified on the base mesh (level 0). 

To prepare subdivision surfaces not directly supported (for example, 
where the base mesh does not contain only quads), you must bake the first 
level of subdivision surfaces to get quads everywhere. 

To get quads everywhere in a rejected subdivision surface

1 Select Subdiv Surfaces > Collapse Hierarchy >  �.

2 Set Number of levels to 1. 

3 Click Apply.

Particle system translation and rendering 

Particle types for software rendering are now supported on all platforms 
for rendering with mental ray. To render particles, a new mayabase 
shader library is required, which is also provided for all platforms. 
Particle data are also exported to .mi files. These files cannot be rendered 
yet on machines with different byte ordering (big end or little end) than 
the machine where Maya has been used (for example, mixing IRIX and 
Windows). Particle translation and rendering is limited and may not be 
able to handle large particle counts. Light linking is not supported with 
particles. However, software particles and particle instancing should work 
together seamlessly. 
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IFF color and depth format 

The IFF image support in mental ray 3.2 has been extended to permit both 
color and depth information written into a single file. This requires the 
proper parameters to be set in the Render Global Settings (Depth Channel 
(Z Depth) in the Image File Output section must be turned on).

Improved support for batch rendering with 
mental ray for Maya 

Any batch render with mental ray for Maya issued from the Maya user 
interface reports progress back to the Maya script editor. This has been 
improved to report frame numbers and file name extensions correctly. 

Using bake-sets

About Bake-sets

Bake-sets

Bake-sets, which let you bake several objects with different baking options 
during the same baking process, have been implemented in Maya. 

Bake-sets and their attributes define the properties with which sets of 
objects are baked. 

Bake-sets let you:

• Easily apply different settings to different objects. For instance, you 
can texture-bake objects with different UV ranges or output 
resolution, or vertex-bake objects with different color blending or 
clamping. 

• Save different baking parameter configurations, making it easier to re-
bake periodically when needed.

Texture bake-sets and Vertex bake-sets

If you want to bake objects with different settings, you can create bake-
sets and assign objects to them. When you bake textures (see ”Bake 
textures” on page 67) or vertices (see ”Bake vertices” on page 67), Maya 
automatically bakes the objects according to the attributes of the bake-set 
to which they are assigned. 

(Bake-sets are derived from object sets. See the online documentation for 
more information about object sets.)
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Bake textures and vertices

If you bake objects that you have not assigned to a bake-set, the objects are 
automatically assigned to the initial bake-set, and the baking proceeds. 

In other words, if your baking requirements are simple (for example, you 
want to bake all objects in your scene with the same settings), you don’t 
need to create bake-sets and assign objects to them. An initial bake-set is 
automatically created, and you can just bake textures or vertices. 

Bake vertices

To bake vertices with mental ray for Maya

1 Select the objects for which you want to bake vertices. 

2 Do either of the following: 

• In the Rendering menu set, select Lighting/Shading > Batch Bake  
> �.

• In the Modeling menu set, select Edit Polygons > Color > Polygon 
Prelight (mental ray) > �. 

3 If desired, adjust any attributes, then click Convert and Close or 
Convert.

For a description of the mental ray Baking Options window, see 
”mental ray Baking Options window” on page 68.

Bake textures

The process of baking textures using mental ray for Maya is no longer 
available from the Hypershade menu Convert File to Texture (it remains 
for Maya Software rendering). Instead, new menu items from the 
Rendering menu in the Rendering menu set let you do the following:

Note Although no additional tasks are required for simple baking, the 
steps you must follow have changed for baking textures. Baking 
vertices using the Polygon Prelight command has not changed.

Note Usually you don’t modify the attributes of an initial texture 
bake-set or an initial vertex bake-set. However, you can modify 
them if you want to change one or two of the default attributes 
with which new objects are baked. See ”Adjust bake-set 
attributes” on page 70.
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• Assign object to a new bake-set, which creates a new bake-set, letting 
you bake that object according to the attributes of that bake-set. See 
”Create a bake-set” on page 69.

• Assign object(s) to an existing bake-set, which lets you bake those 
objects according to the attributes of that bake-set. See ”Assign objects 
to existing bake-sets” on page 73.

• Batch bake selected objects, which immediately bakes the selected 
objects according to:

• the options set in the mental ray Baking Options window (see 
”mental ray Baking Options window” on page 68)

• the attributes in their respective bake-set(s) (see ”Bake-set 
attributes” on page 70)

To bake a texture

1 Select one or more objects you want to bake.

2 Select Lighting/Shading > Batch Bake (mental ray) > �.

3 Set the desired options, then click Convert or Convert and Close.

mental ray Baking Options window

Objects to Bake

Select from this list to bake all objects, or only selected objects.

Skip objects in initialBakeSets

If you select Select All from the Objects to Bake option, then all objects 
that are not assigned to the initial bake-sets are baked. 

For information on initial bake-sets, see ”Bake textures and vertices” 
on page 67.

Bake To

Bake either textures or vertices. The default is Texture when you 
access this window through the Lighting/Shading menu. If you select 
vertices, vertices are baked in the same manner as ”Bake vertices” on 
page 67.

Note Most of options in the mental ray Baking Options window 
(formerly available from the Hypershade) have now moved to 
either the Texture bake-set Attribute Editor (see ”Texture bake-
set attributes” on page 70) or the Vertex bake-set Attribute Editor 
(see ”Vertex bake-set attributes” on page 72).
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Color Mode

Allows mental ray for Maya to bake only illumination versus surface 
color with illumination. This is the converse of Maya’s Bake Shading 
Group Lighting option, which allows you to bake only surface color 
vs. surface color with illumination. Select from one of the drop-down 
list options: Fully Lit and Shaded (default) or Incoming Global 
Illumination Only.

Bake Shadows

Turn this checkbox on to bake shadows.

Orthogonal Reflection

This option is off by default, which is useful if you are baking in order 
to accelerate software rendering and the reflections will only be 
viewed from the baked position. However, the textures or vertex 
colors it generates are not for use as textures in a game engine. When 
turned on, the Orthogonal Reflection option causes all reflection rays 
to be orthogonal to the surface being baked. They are no longer true 
reflection rays, pointing instead parallel to the surface normal vectors, 
but the resulting baked texture or vertex colors will be meaningful 
when viewed later from any direction.

Use Face Normals

mental ray for Maya lets the user specify the use of face normals for 
baking instead of interpolated vertex normals, as usually used for 
rendering.

Normal Direction

Determines in which direction the normals of the object to be baked 
should be pointing. The options in the drop-down list are: Face 
Camera, Front, and Back Camera.

Create a bake-set

You can create your own bake-sets to be able to bake objects in different 
ways. To create a bake-set, you must have an object in your scene that you 
want to assign to the bake-set. 

To create a bake-set

1 Selected one or more objects for which you want to create a bake-set. 

2 Use one of the following methods to assign the bake-set:

• Click Light/Shading > Assign New Bake-Set > Texture Bake-set 
(to create a Texture bake-set) or Vertex Bake-Set (to create a Vertex 
bake-set).
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• Right click the object, then select Baking > Assign New Bake-Set > 
Texture Bake-set or Vertex Bake-Set.

• Use the MEL command:

createNode [textureBakeSet|vertexBakeSet]

The new bake-set’s attributes appear in the Attribute Editor (unless 
the Attribute Editor has been hidden).

3 Adjust the bake-set’s attributes, see ”Adjust bake-set attributes” on 
page 70.

Adjust bake-set attributes

Bake-set attributes

To adjust the attributes of a bake-set

1 Do one of the following: 

• If the bake-set’s attributes are shown in the Attribute Editor, 
proceed to the next step. (If you can’t see the Attribute Editor, 
make sure it is not hidden.)

• If the bake-set’s attributes are not shown in the Attribute Editor, 
right-click the object, then select Baking Attributes. 

• To select a bake-set without selecting an object, you can select it 
from the tab that contains bake-sets in the Hypershade. If you do 
not see a tab that contains bake-sets, you must create one. See 
”Create a Bake-Set tab in Hypershade” on page 74. 

2 Adjust the attributes.

Texture bake-set attributes

Prefix

Any bitmaps generated by this bake-set are prefixed with the value 
typed in this box. 

x resolution, y resolution 

The horizontal and vertical resolution of the image file, measured in 
pixels. The slider range is 1 to 512. The default value is 256.

File format

Lets you choose a format in which to save the file texture. The default 
is IFF.

Bits per channel 

Specifies the number of bits per channel to use in the output bitmap.
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Bake Alpha 

Turn this on to bake the alpha channel (equivalent to Maya’s Bake 
Transparency option) and then select an Alpha Mode.

Alpha mode

When Bake Alpha is turned on, the Alpha Mode specifies how it’s 
computed. Select one of the options, which include Pass Through 
(alpha as output from shading network), Surface Transparency, 
Luminance of Surface Color, and Coverage. 

 

UV range 

Specifies the amount of the surface to sample in UV space. For 
example, if you select one or more faces on a polygonal object, instead 
of sampling the whole surface, only the selected faces are sampled.

U min, U max 

Slider values specify how much to stretch the sampling range of U or 
V components. Maya stretches the sample region to fit the output 
image size within the [0,0] to [1,1] sampling range.

V min, V max 

Minimum V and maximum V for baking.

Fill texture seams

If the selected UV space contains boundaries, these boundaries may 
appear as black stripes in renderings that use the baked textures. This 
occurs when the texture is sampled so close to a boundary that the 
filter picks up values (generally black) from outside the desired space. 

This setting artificially extends the boundaries by a small amount to 
alleviate this problem. It is measured in texels (pixels of texture). 
Typically, the filter is only a few texels in diameter and can only reach 
as far as its radius into these boundary spaces, so a value of 1 or 2 is 
usually enough.

Note The Pass Through option is mainly for custom shader usage 
within Maya. The returned baked color alpha component is 
retained and is not further affected by Maya's matte channel. 
Custom shaders usually set the fourth component of a mental 
ray color to provide the alpha channel.
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Fill scale

This option carries out a boundary detection in the UV space to be 
baked. If UVs are normalized to the unit square and the mesh is finely 
tessellated, accuracy problems (such as zero-size triangles) can occur. 
Temporary up-scaling the UVs helps in this case.

Override mesh UV set assignments

Activate this option to bake meshes as if they were in the specified UV 
set instead of the UV sets to which they are currently associated.

UV set name

The UV set to use for the meshes in this textureBakeSet.

Vertex bake-set attributes

Shared Vertices

A vertex often exists in a few different faces. Use this option to bake a 
single result for each vertex in the mesh rather than a single result for 
each vertex in each face in the mesh. Choosing shared vertices usually 
softens (sometimes dramatically) the shading of a mesh.

Bake Alpha

Turn this on to bake the alpha channel (equivalent to Maya’s Bake 
Transparency option) and then select an Alpha Mode.

Alpha Mode

When Bake Alpha is turned on, the Alpha Mode specifies how it’s 
computed. Select one of the options, which include Pass Through 
(alpha as output from shading network), Surface Transparency, 
Luminance of Surface Color, and Coverage.

Scale Rgba

Scale vertex colors by the specified value.

Clamp Min, Clamp Max

Turn on these options to clamp the minimum and maximum RGBA 
values so that the values are forced to be within the range you set.

Min Color

The lower limit to which to clamp vertex color.

Max Color   

The upper limit to which to clamp vertex colors.
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Color Blending

Merges existing vertex colors with the ones just baked, if any. The 
Don’t Overwrite option means that no color data is written onto the 
mesh. If the mesh already has color data, those values remain 
untouched. If the mesh has no color, it remains colorless.

Alpha Blending

Merges existing vertex alphas with the ones just baked, if any. The 
Don’t Overwrite option means that no color data is written onto the 
mesh. If the mesh has color data already, those values remain 
untouched. If the mesh has no color, it remains colorless.

Assign objects to existing bake-sets

After you create a bake-set, you can assign any additional objects you 
create to that bake-set. 

To assign objects to existing bake-sets

• Assign each object, instance, or group to be baked to a bake-set, using 
one of the following methods:

• The Maya Relationship Editor 

• Lighting/Shading menu > Assign Existing Bake-Set > then choose 
from the list of existing bake-sets.

• Right-click the bake-set node in the Hypershade, then select 
Assign Selection to Bake Set.

• Right-click the object, then select Baking > Assign Existing Bake-
Set > then select the Bake-Set.

• Use the MEL command. For example, 

sets –add myBakeSet nurbsSphere2;

To change the attributes of the initial bake-set

1 Select any object in your scene.

The object’s attributes appear in the Attribute Editor. 

2 Select the initial bake-set tab. 

3 Set any of the attributes.

To change the attributes of the initial texture bake-set, see ”Texture 
bake-set attributes” on page 70.

To change the attributes of the initial vertex bake-set, see ”Vertex 
bake-set attributes” on page 72.
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Create a Bake-Set tab in Hypershade

You can create a bake-set tab in the Hypershade to be able to view and 
select bake-sets.

To create a Bake-set tab

1 In the Hypershade, select Tab > Create New Tab.

2 In the Create New Tab window, type Bake-sets in the New Tab 
Name field. 

3 In the Show Nodes Which Are field, select Bake Sets.

4 Click Create.

Maya hardware rendering

About Maya’s new hardware renderer

Maya’s new hardware renderer presents a seamlessly integrated 
rendering solution that leverages the ever increasing power of next-
generation graphics cards to render frames.

Benefits include an intuitive workflow to generate hardware rendered 
images for previews, specific passes, and hardware rendered particles. 
The integration takes advantage of the new unified rendering workflow; 
you can render and display images using the Render View, which lets you 
compare images during the shading and lighting tasks. 

The user experience and the visual quality of the final images significantly 
surpass that of the current hardware render buffer. You can produce 
broadcast-resolution images in less time than with software rendering. In 
some cases, the quality may be good enough for final delivery.

The hardware renderer uses Maya's existing interface and workflow for 
assigning shaders, textures, particles, light linking, and so on. 

To prevent the windows of other applications from interfering with the 
rendering of the image, you can perform off-screen batch rendering. 

Highlights of supported features

Supported features include:

• Integrated rendering workflow and interface

• Polygons and NURBS geometry

• Multiple textured channels

• Advanced transparency

• Hardware particles
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• Instancing

• Point, Directional, Spot, and Ambient Light types

• Any number of lights

• Light linking

• Per-vertex and per-pixel shading effects

• Multi-pass and multi-sampling anti-aliasing

• File textures for any supported channel

• On-the-fly procedural and shading network conversions

• Specular highlights

• Bumps

• Reflections

• Shadows

• Motion blur

• RBG color, alpha matte (mask), and Z depth output

• Command line rendering

• Render diagnostics. Warnings for unsupported primitives, shaders, 
and light types and light features are provided.

Supported hardware and platforms

Only specific hardware and platform combinations are supported by 
hardware rendering. For more information, see: 

www.aliaswavefront.com/qual_charts

Selecting the hardware renderer

When you select the hardware renderer, Maya’s user interface is 
automatically configured to use the hardware renderer. If you render the 
current frame, Maya uses the hardware renderer process the image and 
display it in the Render View. If you click the Display Render Globals 
Window button, the unified Render Globals Settings window appears, 
showing the Common tab and Maya Hardware tab. 

To select the hardware renderer

• Do one of the following:

• Select Maya Hardware from the dropdown list in Render View or 
Render Global Settings window. 

• Select Render > Render Using > Maya Hardware.
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For more information about the Maya Hardware Global render 
settings, see the online Rendering guide. 

Maya Vector rendering (Windows and 
Mac OS X)

About the Maya Vector renderer

You can use the Maya Vector renderer to create stylized renderings (for 
example, cartoon, tonal art, line art, hidden line, wireframe) in various 
bitmap image formats (for example, IFF, TIFF, and so on) or in the 
following 2D vector formats:

• Macromedia Flash (non-interactive) version 3, 4 or 5 (SWF)

• Adobe Illustrator version 8 (AI)

• Encapsulated PostScript Level 2 (EPS)

• Scalable Vector Graphics (SVG).

Example Animations

helicopter.swf flowers.swf

boat.swf car.swf
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For more information see “The Maya vector renderer” in the online 
Rendering guide.

Note The Maya Vector renderer cannot render certain Maya features 
(see “Maya features that will not vector render” in the Rendering 
online documentation.
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7 Paint Effects, 
Artisan, 3D Paint

We've added or enhanced the following painting features in Maya.

Paint Effects

• ”Paint Effects shelf and new brushes” on page 79

• ”Select strokes by name” on page 80

• ”Flip Tube Direction” on page 81

• ”Convert Paint Effects to polygons” on page 81

• ”Optimize Paint Effects Mesh quality” on page 82

• ”ThinLine Brush Type” on page 83

• ”Mesh Brush Type” on page 84

• ”Thorns on Mesh” on page 87

• ”Mesh Environment Reflections” on page 89

• ”Mesh Displacement/Bump Mapping” on page 90

• ”New brush attributes” on page 91

• ”General improvements” on page 97

Artisan

• ”Paint Vertex Color Tool and Script Paint Tool ported to the new 
Artisan architecture” on page 99

• ”Paint vertex or vertex face” on page 99

3D Paint Tool

• ”Displacement attribute paintable” on page 99

• ”Edit existing textures” on page 99

• ”Set Erase Image” on page 99

• ”Color, Flood and Opacity” on page 100

Paint Effects

Paint Effects shelf and new brushes

We’ve added a Paint Effects shelf that contains a range of Paint Effects 
tools and brushes, including some new brushes. 

If you are upgrading to Maya 5, the Paint Effects shelf will not be 
displayed. You can load the shelf manually using the instructions below 
in “To load the Paint Effects shelf.” 
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If you are new to Maya, the Paint Effects shelf, like the other Maya 
shelves, is loaded automatically on Windows and Mac OS X. The shelves 
are not loaded by default on IRIX and Linux because they can seriously 
impede the start up performance of Maya. To load these shelves on IRIX 
or Linux, follow the instructions in “Load the default shelves” in the 
Basics guide. To load only the Paint Effects shelf, follow the instructions 
below in “To load the Paint Effects shelf.”

To load the Paint Effects shelf

1 Open the Script Editor (Window > General Editors > Script Editor). 

2 Copy and paste the following in the Script Editor:

loadNewShelf "shelf_PaintEffects.mel";

saveAllShelves $gShelfTopLevel;

3 Select Script > Execute.

Select strokes by name

You can now select multiple strokes by name, for example, to have them 
share one brush. Use the Select Brush/Stroke Names Containing menu 
item in the Paint Effects menu.  

Example created using the new Mesh type brush
Image courtesy of Duncan Brinsmead
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To select strokes by name

1 Select a stroke.

2 Select Paint Effects > Select Brush/Stroke Names Containing.

3 In the Name Fragment text box, type the name of the stroke, for 
example, daisy.

4 Click Select Strokes. The strokes of that name are selected.

Flip Tube Direction

We’ve added a new menu item, Flip Tube Direction, to the Paint Effects 
menu, and a new Flip Tube Direction button on the toolbar in the Paint 
Effects panel. 

Use this to switch the direction of the current brush between Along Path 
(best for canvas painting of plants) and Along Normal (best for scene 
painting of plants). This command is available as a hotkey. 

In addition, we’ve added a Force Tube to be Along Path checkbox to the 
Canvas section of the Paint Effects Globals. Force Tube Direction to be Along 
Path causes brushes with tubes whose elevationMin is greater than 0.5 to 
be drawn along the path rather than along the normal in Canvas mode. 
This has the effect of making plant brushes draw in the expected direction 
when painting in the canvas.   

Convert Paint Effects to polygons

You can convert Paint Effects strokes to polygonal meshes, including 
construction history, using Modify > Convert > Paint Effects To Polygons. 

This allows you to:

• render in any renderer, including the Maya Software renderer, mental 
ray for Maya, the Hardware renderer, and the Vector renderer (For 
more information, see the online Rendering guide.)

• have Paint Effects show up in reflections, refractions and through 
transparent objects (For more information, see the online guides 
Lights and Cameras, and Shading.)

• use other polygon editing tools on them (For more information, see 
the online Modeling Polygons guide.)
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You can edit brush attributes and see the effect on the output mesh. 
Shaders that closely match the look of the Paint Effects render are 
automatically generated and assigned to the resulting meshes. You can 
optionally choose to output color per vertex and also to bake lighting onto 
the mesh.

These are the options in the Paint Effects To Polygons Options window 
(Modify > Convert > Paint Effects To Polygons > �):

Vertex Color Mode

The default is None. Other options include Color and Illuminated.

Quad Output

Turn this on to output to quads. The default is off, defaulting output 
to triangles.

Hide Strokes

Turn this on to hide the Paint Effects strokes once they’re  converted 
to Polygons. Even if a stroke is hidden, its attributes can still be 
updated and will affect the polygon mesh. The default is on. 

Poly Limit

This value indicates that when converting the Paint Effects stroke to 
polygons, it should stop after it has reached approximately this 
number of faces. This can be used to avoid creating excessively large 
meshes that could cause you to run out of memory. The default is 100 
000. A value of 0 indicates no limit. 

Optimize Paint Effects Mesh quality

Paint Effects Mesh Quality settings can be useful in simplifying both 
normal Paint Effects strokes as well as strokes that have been converted to 
polygons.

When converting Paint Effects to polygons, you can optimize the 
conversion by keeping some attribute values as low as possible, such as 
Segments, Leaf Segments, Petal Segments, Sub Segments, Split Max 
Depth, and Tube Sections. Also the Flatness value should be exactly 1 on 
leaves and petals as this can dramatically reduce the number of triangles if 
the Tube Sections value is large. 

Note To optimize converting Paint Effects to polygons, see ”Optimize 
Paint Effects Mesh quality” on page 82.
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All the attributes mentioned above are located in different sections of the 
Paint Effects Brush Settings editor, so it can be time consuming to find and 
modify them for each brush you want to edit. To save time,  use the Paint 
Effects Mesh Quality window (Paint Effects > Paint Effects Mesh Quality).

The Paint Effects Mesh Quality window is a collection of attributes from 
the selected brush and, where indicated, stroke. It refers to the first valid 
selection found and only represents one brush at a time. The brush may be 
selected indirectly through a stroke, a surface that was painted on, or a 
mesh that resulted from converting Paint Effects to polygons. 

Changing the segments, Leaf Segments and Petal Segments may change 
the overall shape of the tubes. You can compensate for this somewhat on 
leaves and petals by adjusting the leaf and petal Stiffness, which also 
appear in this window. For segments you may need to modify Force 
attributes in the Paint Effects Brush Settings editor.

You can increase the number of sub segments without affecting the tube 
shape, although this will not remove nickling as the sub segments are 
linearly interpolated between the main segments. Sub segments are most 
useful if the brush has displacement turned on and you want to better 
resolve the displacement texture with more triangles, but don’t want to 
affect the overall shape of the tubes. There may be other situations where 
more triangles are desired, but you don’t want to affect the overall tube 
shape.

ThinLine Brush Type

We’ve added a ThinLine type of brush that allows you to render large 
numbers of fine tubes much more quickly than the Paint Brush Type. It 
uses a direct anti-aliased line draw rather than a series of brush stamps. A 
new Multi Streak method is also available when this Brush Type is used. 
In combination with the Multi Streak method, the ThinLine Brush Type 
can be up to 100 times faster for hair than the Paint Brush Type with better 
line detail. In addition, new looks are possible using the Multi Streaks, 
such as wet clumping hair.)

These are the attributes used to control the Multi Streaks: 

Multi Streaks

The number of additional tubes or hairs to create around the original 
tube.

Note When using a large value for Tube Width with the ThinLine 
brush type, this may result in artifacts. 
What’s New in Maya 5

83



7 | Paint Effects, Artisan, 3D Paint 
 > Mesh Brush Type
Multi Streak Spread1

The maximum offset at the tube base for the streaks.

Multi Streak Spread2

The maximum offset at the tube tip for the streaks.

Diffuse Random

Amount to randomize the brightness of each offset tube.

Specular Random

Amount to randomize the specular brightness of each offset tube.

Light All Streaks

Compute lighting for each added tube.

Mesh Brush Type

We’ve added a Mesh type of brush that renders Paint Effects using 
triangulated tubes instead of brush stamps. This results in accurate conical 
geometry with textures that correctly map on the surface. Flat surfaces are 
rendered more accurately than when the Paint Brush Type is used. While 
the Paint Brush Type is generally better when representing soft, fuzzy 
volumes, the Mesh Brush Type is better at hard surfaces. 

Example of long hair created using the ThinLine Brush Type
Image courtesy of Duncan Brinsmead
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With the Mesh Brush Type you can now create Paint Effects trees and 
plants that are convincing not just from a distance, but also close-up. You 
can also create previously impossible shapes, such as hard-edged 
geometry (buildings). You can do per-pixel lighting on the mesh 
(including specular highlights). There is also a new built-in environment 
map on the brush that is useful when simulating reflective surfaces (see 
”Mesh Environment Reflections” on page 89). We’ve added displacement 
and bump mapping to enhance the detail of the mesh surface (see ”Mesh 
Displacement/Bump Mapping” on page 90). The triangles are not kept in 
memory, but rather generated at render time. As a result, you can use a lot 
of triangles without running out of memory.

Another feature made possible by representing the tubes as triangles is 
converting Paint Effects to Polygons. For details, see ”Convert Paint 
Effects to polygons” on page 81.

These are the attributes to control the Mesh Brush Type:

Tube Sections

The number of points in the circle that is swept along the tube.

Sub Segments

The number of cross sections per segment of the tube.

Single Sided

Cull away facing triangles.

Per Pixel Lighting

Light each pixel, as opposed to each vertex.

End Caps

This adds end cap geometry to tubes when using the Mesh Brush 
Type.

Hard Edges

This affects the lighting of the object and makes the edges around 
tubes hard when using the Mesh Brush Type. For example, if the tube 
sections are set to 4 and Hard Edges is turned on, it will make the tube 
shade as if the 4 sides are flat, rather than trying to simulate a 
rounded tube. For bends in the direction of the tube, for example, due 
to changes in the Width Scale, the bend angle across a given must be 
sufficiently large to make the angle hard. The number of segments 
used can affect whether a given region on the tube becomes hard 
edged or not. This attribute adjusts the normals used for shading and 
does not alter the shape of the tube. This is off by default. 
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Example using the Mesh Brush Type with Hard Edges turned on
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Thorns on Mesh

Large numbers of thorns may be generated off the surfaces of the triangles 
created when using the Mesh Brush Type. These thorns are drawn using 
the rendering method associated with the ThinLine Brush Type and 
render quickly. They are single segment tubes, and do not appear in the 
wireframe representation of the strokes. You can use these to add thorns 
and prickles to plants or to create furry or fuzzy tubes. 

Examples of trees created using the 
Mesh Brush Type
Images courtesy of Duncan Brinsmead
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These are the attributes to control the look and size of the thorns:

Branch Thorns

Enable thorns on base tubes, including when tubes are off.

Twig Thorns

Enable thorns on twigs.

Leaf Thorns

Enable thorns on leaves.

Flower Thorns

Enable thorns on flowers.

Thorn Density

The number of thorns relative to the overall tube.

Not

e Thorns on Mesh are only created at render time.

Example of thorns on mesh
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Thorn Elevation

The rotation of the thorns relative to the base tube's surface normal.

Thorn Length

Length of the thorn relative to the average tube width.

Thorn Base Width

The width of the thorn at the base (relative to average tube width).

Thorn Tip Width

The width of the thorn at the tip (relative to average tube width).

Thorn Specular

Specular highlight intensity (using an anisotropic model).

Thorn Base Color

Color at thorn base.

Thorn Tip Color

Color at thorn tip.

Mesh Environment Reflections

A simple ramp-based environment may now be used in conjunction with 
the Mesh Brush Type. This can be used to create looks such as chrome, 
water, glass, shiny paint, etc. 

Example of Mesh Environment Reflections
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These are the attributes to control the Mesh Environment Reflections:

Branch Reflectivity

The amount the environment is reflected on base tubes, including the 
stroke when tubes are turned off.

Leaf Reflectivity

The amount of environment reflection on leaves.

Flower Reflectivity

The amount of environment reflection on flowers.

Environment

The ramp represents the reflected color of a spherical placement: the 
left side of the ramp is the color at the bottom of the spherical 
reflection and the right side of the ramp is the color at the top of it.

Reflection Rolloff

Represents the reflectivity with changing view angle (facing ratio).

Mesh Displacement/Bump Mapping

In the Texturing section of the Brush Settings window, you can apply 
displacements to the triangles created when using the Mesh Brush Type. If 
Per Pixel Shading is used, then a bump map is also applied along with the 
triangle displacement. 

These are the attributes to control mesh displacement/bump maps:

Map Displacement

Turn on for displacement of triangles using texture.

Displacement Scale

Amount of displacement relative to tube width.

Displacement Offset

Amount of displacement independent of local tube width.

Bump Intensity

Strength of the added bump effect (if Per Pixel Shading is on).

Bump Blur

Controls separation of samples used in bump mapping.

Use Luminance

Use color brightness instead of the alpha for displacement.
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New brush attributes

Forward Twist attribute

We’ve added Forward Twist (Brush Profile), Leaf Forward Twist (Tubes > 
Growth > Leaves) and Petal Forward Twist (Tubes > Growth > Flowers) 
attributes to the Brush Settings Attribute Editor. 

When Forward Twist is turned on, then tube Flatness is always oriented 
towards the camera. This is particularly useful when the Flatness is 1, as 
you can use billboard textures to minimize geometry. For leaves, you 
could use a texture of a large clump of leaves with alpha on flat leaves. 
Turning on Leaf Forward Twist would ensure that the broad side of the 
textured leaf clump is rotated towards the view so it always looks full. 
Another example might be to use the image of an apple with alpha on a 
flat flower petal. Turning on Petal Forward Twist twists the petal to face 
the view so the apples do not look flat from some angles. The simplest 
way to represent a tree is an image of a tree with alpha textured to a 
billboard facing the camera. The following settings can be used to set up 
this type of billboard:

• Brush Type = Mesh

• Forward Twist = on

• Flatness1 = 1.0

• Flatness2 = 1.0

• Map Opacity = on

• Map Color = on

• Texture Type = File

• Image Name "yourTreeWithAlpha"

• Tube = on

• Segments = 1

• Tube Length1, 2 = 0.5

• Tube Width1, 2 = 0.5

These are the attributes to control Forward Twist:

Forward Twist

Forward twist applied to tubes so the broad or flat side is always 
oriented towards the camera. Textures are similarily affected so that 
they always face the camera.
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Leaf Forward Twist

Forward twist applied to leaves so the broad or flat side is always 
oriented towards the camera. Textures are similarily affected so that 
they always face the camera.

Petal Forward Twist

Forward twist applied to petals so the broad or flat side is always 
oriented towards the camera. Textures are similarily affected so that 
they always face the camera.

Bend attribute

We’ve added a Bend attribute to the Tubes Behavior section of the Brush 
Settings Attribute Editor. Bend can be used to curl up leaves and flowers, 
as well as to make the overall branches bend in the U direction (along the 
length). You can create natural looking flower petals and plants, such as 
fiddlehead ferns. It is automatically animated in growth animations if 
non-zero. You can use the Curl attribute to bend leaves and petals in the V 
direction (along the width). 

These are the attributes to control Bend:

Bend

Bend applied to base tubes.

Leaf Bend

Bend applied to leaves.

Flower Bend

Bend applied to flower petals.

Bend Bias

This controls how far down the stroke the bend starts. With a value of 
0, the bend starts at the base. With a value of 1, there is no bend. High 
values cause a faster bending near the tip.

Curl attribute

We’ve added a Curl attribute to the Tubes Growth section of the Brush 
Settings Attribute Editor. Curl can be used to curl up leaves and petals. 
You can create realistic looking flower petals and leaves, such as lotus 
petals. 

You can use the Bend attribute to bend leaves or petals in the U direction 
(along the length), and you can use the Curl attribute to bend leaves and 
petals in the V direction (along the width). Using these attributes allows 
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you to create a realistic and sophisticated looking flower with several 
petals. The Curl attribute is also useful at preventing collisions between 
petals.

The ramp controls the curl from root to tip of the leaf/petal. The left side 
of the ramp is the base of the leaf/petal and the right is the tip. 
Controlling the curl from base to tip can help define the natural shape of 
petals and leaves, as well as prevent interpenetration within a cluster. The 
mid line value on the ramp (0.5 ) represents zero curvature. Many petals 
and leaf shapes have curvature that is constantly changing. For example, 
iris petals or mistletoe leaves can be simulated by a wavy curl ramp. 

These are the attributes to control Curl:

Leaf Curl

Curl applied to leaves.

Petal Curl

Curl applied to flower petals.

Twirl attribute

Twirl controls the initial rotation of a leaf or petal relative to the branch. 
For example, by default a group of leaves at the top of a palm tree would 
twist sideways. With Twirl you can rotate them to a proper orientation 
with the flat side facing the ground. We’ve added Leaf Twirl (Tubes > 
Growth > Leaves) and Petal Twirl (Tubes > Growth > Flowers) to the 
Brush Settings Attribute Editor. 

These are the attributes to control Twirl:

Leaf Twirl 

Twirl applied to leaves.

Petal Curl was 
used to create 
natural looking 
petals for this 
rose
Image courtesy 
of Yiqun Chen
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Petal Twirl

Twirl applied to petals.

Stiffness attribute

Force attributes may affect leaves either too strongly or too weakly. The 
number of segments in a leaf or flower relative to the base segment count 
determines how much forces will affect the shape. The Stiffness attribute 
gives you an independent way of controlling how much the forces, such 
as Gravity, Random, and Turbulence, affect leaves and flowers. Stiffness 
affects the way forces act on the leaf. If the Stiffness is set to 1, forces have 
no effect. If Stiffness is set to 0.5, forces have the same effect per segment 
that they do on the main branches. If Stiffness is set to 0,  forces totally 
affect the leaf or petal like a limp spaghetti noodle. If you have no forces, 
such as Spiral and Twist, Stiffness will have no effect. 

We’ve added Twig Stiffness (Tubes > Growth > Twigs), Leaf Stiffness 
(Tubes > Growth > Leaves) and Petal Stiffness (Tubes > Growth > 
Flowers) to the Brush Settings Attribute Editor. The default for all of three 
attributes is 0.5.

These are the attributes to control Stiffness:

Twig Stiffness

Stiffness applied to twigs.

Leaf Stiffness

Stiffness applied to leaves.

Petal Stiffness

Stiffness applied to flowers.

Width Scale attribute

This allows you to use a graph to control the width from root to tip of 
tubes, rather than using a simple linear interpolation between two values. 
When combined with the Mesh Brush Type you can define shapes like 
spheres, as well as control the profile of a leaf. Width Scale is applied as a 
scale to the current width and defaults to 1.0 so that previous presets work 
with it. 

These are the attributes to control Width Scale:

Width Scale

Affects tubes.

Leaf Width Scale

Affects leaves.
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Petal Width Scale

Affects flowers.

Branch After Twigs attribute

We’ve added a Branch After Twigs checkbox to the Twigs section of the 
Brush Settings Attribute Editor (Tubes > Growth > Twigs). Turn this on to 
put branches on twigs rather than twigs on branches. If Branch After 
Twigs is turned on, then twigs are evenly distributed along the main 
trunk and branches split after the twig. The splitting defined by the 
branch attributes will occur on the twigs. This is useful in helping define 
many common tree shapes, such as pines. You can have a central trunk 
with multiple branches splitting off of it. You can also use the Twig 
Length Scale attribute to adjust the overall profile of the tree; from the 
twigs' starting point, it controls the density of the twigs and branches 
along the main trunk. Shorter twigs are adjusted to have fewer branching 
events and segments.

Click a point along the graph and drag to 
position it in the graph. The shape of the 
graph corresponds to the width along the 
tube, leaf, or petal. In this example, the 
width would be narrow initially at the base, 
quickly widening at the middle and then 
narrow again at the tip.

The graph above was used 
to scale the Leaf Width for 
the leaves on the mature 
birch in the image on the left. 
As you can see the graph 
corresponds to a cross 
section of the shape of the 
leaf.

Mature birch Image courtesy 
of Yiqun Chen
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Twig Length Scale attribute

The base length of twigs is defined by the Twig Length attribute. However 
you might want twigs at the tip of a trunk to be shorter than ones at the 
base. The Twig Length Scale attribute allows you to scale the Twig 
Length: when it is set to 1.0 then the twigs will equal the Twig Length 
value, when it is set to 0.5 the twigs will be half the Twig Length value, 
etc. The horizontal dimension of the graph corresponds to the position 
from root to tip of the tube from which the twigs sprout.

Before turning on Branch After 
Twig

After turning on Branch After 
Twig

Click a point along the graph and 
drag to position it in the graph. 
The shape of the graph 
corresponds to the length of the 
twigs. In this example, the length 
of the twigs at the base of the 
trunk would be as specified by 
the Twig Length, at the middle of 
the tree they’d be a bit shorter 
and at the top of the tree they’d 
be really short. This Twig Length 
Scale graph was applied to the 
pine tree as seen in the image to 
the left. 
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Specular control on components

You frequently may want leaves, flowers and branches to have a different 
specularity. The specular intensity is now controlled separately. We’ve 
added Leaf Specular (Tubes > Growth > Leaves) and Flower Specular 
(Tubes > Growth > Flowers) to the Brush Settings Attribute Editor.

These are the attributes to control specularity:

Leaf Specular

Specular control for leaves.

Flower Specular

Specular control for flowers.

Texture Flow attribute

We’ve added a Texture Flow check box to the Flow Animation section of 
the Brush Settings Attribute Editor. This moves the texture with flow as 
defined by Flow Speed (another attribute) in Flow Animation). In general 
this is best turned off for growth animations (growth with time clipping) 
because the textures will not move during the plant growth. But this is 
useful when you want a texture, particularily a displacement, to flow 
down the tubes. This is on by default.

General improvements

Object Shading menu

The name of the Shading menu in the Paint Effects panel was changed to 
the Object Shading menu to more accurately reflect what the menu is used 
for. 

Preset Blending

We’ve modified the procedure for turning Preset Blending on and off. 
Previously Preset Blending was turned on or off by opening or closing its 
options window. Now when you select Preset Blending in the Paint 
Effects menu, a check mark appears beside it indicating it’s on. To turn it 
off, select Preset Blending in the Paint Effects menu again and the check 
mark disappears. To open the Brush Preset Blend window and set the 
Shading and Shape values, select Paint Effects > Preset Blending >�. 
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Refresh improvements

The wireframe draw of Paint Effects strokes in the modeling view is now 
cached, dramatically speeding up refresh, in some cases by a factor of 100 
or more. You can now work with the Stroke Settings Display Quality 
always at 100%. The new default for Display Quality is 100. 

To speed up playback, there is a new Paint Effects Performance Settings 
option with three settings (Window > Settings/Preferences > Performance 
Settings). 

On

Always updates strokes when they change.

Interactive

Updates strokes when changed, except during playback.

Off

Never updates strokes, even when the brushes or strokes are edited.

Animated strokes, for example, through turbulence on the brush, will 
automatically regenerate during playback, which can make playback 
slow. The Interactive Performance option is useful when you need fast 
playback, but you don’t need to preview the turbulence animation. 

Anti-aliasing quality

There are two new options in the Paint Effects section of Render Globals. 

Oversample 

Renders the Paint Effects at double resolution for better anti-aliasing.

Oversample Post Filter 

Applies a weighted filter to the oversampled image for better 
smoothing.

These options are particularly useful when rendering Paint Effects fur or 
hair. Also the new Mesh Brush Type requires oversample be used to anti-
alias the tube edges if you don’t convert the Paint Effects to polygons.
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Artisan

Paint Vertex Color Tool and Script Paint Tool 
ported to the new Artisan architecture

The Paint Vertex Color Tool and Script Paint Tool have been converted to 
the new Artisan architecture. For details on using brushes in the revised 
architecture, see “Brush Tool settings (revised architecture)” in the online 
Painting guide.

Paint vertex or vertex face

In the Color section of the Paint Vertex Color Tool settings window we’ve 
added two Paint options, Vertex and Vertex face. For more information 
about using this tool, see the online Modeling Polygons guide.

3D Paint Tool

Displacement attribute paintable

Displacement has been added to the Attribute to Paint drop-down list in 
the File Textures section of the 3D Paint Tool settings. Displacement is 
now a paintable attribute. 

Edit existing textures

You can now edit both the size and file format of existing 3D Paint 
textures using the Assign/Edit Textures button in the File Textures section 
of the 3D Paint Tool settings. This button was  previously named Assign 
Textures and was used only for assigning new textures; the button 
formerly had no effect on existing textures. 

Set Erase Image

We’ve added a Set Erase Image button so you can set the current paint 
layer as what to erase back to. 

Example of using Set Erase Image

1 Paint a base layer, such as a layer of dirt.

2 Click the Set Erase Image button.

3 Flood the layer with a color, such as grey.

4 Erase patches and the dirt layer shows through.
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Color, Flood and Opacity

In the 3D Paint Tool settings we’ve modified the Color section and added 
a Flood section so you can set Flood Color and Opacity independent of 
Color and use it independent of the current brush Operation mode. 

The Color section now only contains two attributes used for painting: 
Color and Opacity. The new Flood section also contains two attributes, 
Color and Opacity; and it has two buttons, Flood Paint and Flood Erase, 
with Flood options: All and Selected.

To flood paint

1 Specify a Color and Opacity value in the Flood section.

2 Select Flood All or Flood Selected.

3 Click the Flood Color button.

To flood erase

1 Specify an Opacity value in the Flood section.

2 Select Flood All or Flood Selected.

3 Click the Flood Erase button.
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For Maya 5, we have added the following functionality to Fluid Effects:

• The ability to define the contents of fluid initial states

• The ability to insert fluid contents with curves

• The ability for objects to push 2D and 3D fluids

• New Pond and Wake fluids.

Fluid Effects > Set Initial State

Fluid Effects > Set Initial State > �

With the Initial State Options window, you can set the contents of a fluid’s 
initial state. The contents turned on in the Set Initial State Options 
window are set in the initial state. By default, all initial state content 
options are turned on.

The initial state of a fluid is created from the dynamic or static grid 
contents. When setting the initial state, if a content method has dynamic 
or static grid attributes but is not turned on in the Set Initial State Options 
window, a warning appears and you are prompted to either include the 
grid attributes or omit them from the cache.

Fluid Effects > Add/Edit Contents > 
Initial States

Fluid Effects > Add/Edit Contents > Initial States > �

This Initial State Options window lets you set the resolution of your fluid 
to that of an example fluid’s initial state. By default, fluid examples have a 
very high resolution. Setting the fluid resolution is useful when you want 
to match the resolution of a fluid container to that of a fluid example. By 
default, From Initial State is on.

Fluid Resolution

As Is Keeps the fluid container’s current resolution.

Note Fluid Effects is available only in Maya Unlimited.
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From Initial 

State Sets the current fluid container’s resolution to that of 
the fluid example’s initial state.

Set Contents with Curve

Set Contents with Curve lets you use a curve to define where contents are 
added to a fluid container. Like a painted fluid stroke, the curve does not 
emit the fluid but instead inserts fluid samples into the fluid container. 
When setting fluid contents from a curve, the container’s fluid Content 
Methods must be set to dynamic or static. See “Create dynamic fluid 
effects” and “Create non-dynamic fluid effects” in the Fluid Effects guide.

To add fluid contents with a curve

1 Create a 2D or 3D Fluid container with or without an emitter.

See “Create a fluid container with a fluid emitter” in the Fluid Effects 
guide. 

2 Draw a curve within the Fluid container. 

For more information, search the online help for Drawing Curves.

3 Select the curve and the container, and then select Fluid Effects > 
Add/Edit Contents > With Curve > �.

The Set Fluid Contents From Curve Options window appears.

4 Set the options for the fluid contents that are placed in the container 
by the curve. See ”Fluid Effects > Add/Edit Contents > With Curve” 
on page 103.

5 Click one of the following:

• Click Apply and Close to apply the defined fluid settings to the 
fluid contents that are inserted by the curve. The Set Fluid 
Contents From Curve Options window closes.

• Click Apply to apply the defined fluid settings to the fluid 
contents that are inserted by the curve. The Set Fluid Contents 
From Curve Options window remains open.

• Click Close to disregard any additions or changes to the fluid 
settings. The Set Fluid Contents From Curve Options window 
closes.

Note If the curve extends past the boundaries of the container, fluid 
contents are added to the container only where the curve is 
within its boundaries, and the number of fluid samples are 
calculated for the entire curve.
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6 Set the initial state of your fluid. See “Set or delete the initial state of a 
fluid” in the Fluid Effects guide. 

You must set the initial state of your fluid to retain the contents added 
to your fluid container by the curve.

Fluid Effects > Add/Edit Contents > With Curve

Fluid Effects > Add/Edit Contents > With Curve > �

The following section describes the options of the Set Fluid Contents With 
Curve Options window.

Density

Sets the density value of the fluid contents that are inserted by the 
curve. The default amount of density is 1.000.

Velocity

Sets the velocity value (magnitude and vector) for the fluid contents 
that are inserted by the curve. The default value is 1.000.

Temperature

Sets the temperature value of the fluid contents that are inserted by 
the curve. The default temperature value is 1.000.

Fuel

Sets the fuel value of the fluid contents that are inserted by the curve. 
The default fuel value is 1.000.

Color

Sets the color value of the fluid contents that are inserted by the curve. 
The default color is red.

Operation

Lets you Add to or Replace the contents of the affected voxels. 
Replace is on by default.

Note You now have the option to delete the curve. This will not affect 
the contents of the container.
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Number Of Curve Samples

Sets the number of samples that are calculated along the curve. For 
example, if you set the number of curve samples to 1, only one fluid 
sample on one voxel is generated. For best results, set the number of 
samples to a number that is greater than the number of voxels you 
want to affect. The maximum number of samples is 1000.

Radius

Defines the radius in which the fluid contents are inserted along the 
curve. The radius is measured in the same units as those set in your 
global user defined preferences. For more information, search the 
online help for Working Units.

Curve-Based Velocity

Sets the velocity of the fluid contents inserted along the curve to the 
value specified in the Velocity field of the Set Fluid From Curve 
options. When this option is on, the velocity’s magnitude decreases at 
high curvature points along the curve and increases at low curvature 
points. When this option is off, the velocity is stabilized at the 
specified velocity value and the velocity draw arrows all appear the 
same length. Curve-Based Velocity is off by default.

Set Initial State

Sets the selected fluid container’s Initial State when the contents are 
applied. Set Initial State is on by default.

Ponds

Ponds are 2D fluids that use a spring mesh solver and a height field. For 
information on Pond attributes, search the online help for 2D fluid 
container attributes. With the Pond options and attributes, you can set the 
size and color of your fluid surface.

You can generate waves, bubbles, and ripples in the fluid surface using 
Wakes. See ”Wakes” on page 105. Increasing the size of your pond 
extends the range of your waves and ripples.

The Pond menu items function in almost the same manner as the Ocean 
menu items. For information on Pond menu items and attributes, search 
the online help for Ocean menu items and attributes.

Create Ponds

To create a Pond fluid

1 Select Fluid Effects > Pond > Create Pond > �.

The Create Pond window appears.
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2 Set the Pond options. See ”Fluid Effects > Pond > Create Pond” on 
page 105.

3 Do one of the following:

• Click Create Pond to insert a pond fluid container with the 
defined size into your scene. The Create Ponds window closes.

• Click Apply to insert a pond fluid container with the defined size 
into your scene. The Create Ponds window remains open.

• Click Close to disregard any change to the pond size and close the 
Create Pond menu.

Fluid Effects > Pond > Create Pond

Fluid Effects > Pond > Create Pond > �

Size

Defines the size of your Pond fluid. The size of the Pond can be 
modified by using the container properties of the Pond fluid shape. 
The default size is 20.000.

Wakes

With the menu item Create Wake, you can create boat wakes, add 
additional turbulence to an ocean, or generate bubbling and ripples.

A Wake fluid is a fluid container with a Spring Mesh solver. Wake fluids 
do not use the Navier Stokes solver like regular fluids, but use the new 
Spring Mesh solver. A fluid emitter is used to drive the motion of the 
Wake fluid.

Ocean Wakes differ from Pond Wakes. For Oceans, a Wake is a fluid 
texture with a Spring Mesh solver that adds additional displacement and/
or foam to the Ocean shader. For Ponds, a Wake is a 2D fluid with a 
Spring Mesh solver that is rendered directly as a fluid.

Create Pond wakes

To place a Wake fluid in a Pond

1 Create a Pond fluid by selecting Fluid Effects > Pond > Create Pond. 

A pond appears in your scene view.

2 Select the Pond or an object you want to link to the Wake fluid.

Note You can only use Wakes with Ponds or Oceans.
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3 Create a wake by selecting Fluid Effects > Pond > Create Wake > �.

The Create Wake options window appears.

4 Set the wake options. See ”Fluid Effects > Pond > Create Wake” on 
page 107.

5 Do one of the following:

• Click Create Wake to place a Wake fluid emitter in the current 
pond, or to place the Wake fluid emitter in your scene and parent 
it to the selected object. The Create Wake options window closes.

• Click Apply to place a Wake fluid emitter in the current pond, or 
to place the Wake fluid emitter in your scene and parent it to a 
selected object. The Create Wake options window remains open.

• Click Close to disregard any changes made to the Create Wake 
options, and close the Create Wake options window.

6 Set the Wake attributes.

For more information, search the online help for Fluid Emitter attributes.

Create an Ocean wake

To place a Wake fluid in an Ocean

1 Create an Ocean by selecting Fluid Effects > Ocean > Create Ocean.

An Ocean appears in your scene view.

2 Select the ocean and create a wake by selecting Fluid Effects > Ocean > 
Create Wake > �.

The Create Ocean Wake options window appears.

3 Set the wake options. See ”Fluid Effects > Ocean > Create Wake” on 
page 107.

4 Do one of the following:

• Click Create Ocean Wake to place a Wake fluid container in the 
current Ocean. The Create Ocean Wake options window closes.

• Click Apply to place a Wake fluid container in the current Ocean. 
The Create Ocean Wake options window remains open.

• Click Close to disregard any changes made to the Create Ocean 
Wake options, and close the Create Ocean Wake options window.

5 Set the Wake attributes.

For more information, search the online help for Fluid Emitter attributes.
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Fluid Effects > Ocean > Create Wake

Fluid Effects > Ocean > Create Wake > �

Wake Size

For Oceans, Wake Size sets the size attribute (located in the fluid 
shape container properties) of the Wake fluid.

Wake Intensity

This value determines the magnitude of the wakes. In the fluid emitter 
attributes, this value is Density/Voxel/Second. The default intensity 
is 5.00.

Foam Creation

This value determines the amount of foam generated by the fluid 
emitter. In the fluid emitter attributes, this value is the Heat/Voxel/
Second. For Oceans, this value directly affects the foam. The default 
amount of foam is 0.00.

Fluid Effects > Pond > Create Wake

Fluid Effects > Pond > Create Wake > �

Wake Size

For Ponds, the size of the Wake fluid is determined by the size 
attribute of the Pond fluid container.

Wake Intensity

This value determines the magnitude of the wakes. In the fluid emitter 
attributes, this value is Density/Voxel/Second. The default intensity 
is 5.00.

Note A negative Wake Intensity value pushes the fluid surface down 
while a positive value pushes the surface up.

Note A negative Wake Intensity value pushes the fluid surface down 
while a positive value pushes the surface up.
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Foam Creation

This value determines the amount of foam generated by the fluid 
emitter. In the fluid emitter attributes, this value is the Heat/Voxel/
Second. For Ponds, this value corresponds with the temperature input 
on the shading ramp attributes. The default amount of foam is 0.00.

Fluid Effects > Make Motion Field

With Make Motion Field, you can accurately simulate objects moving 
through a fluid. This new field applies a force to its parent object, so that 
the object then appears to move or push the fluid.

Example

For the animation of a character walking through thick fog, you can apply 
a motion field to the character so that it appears to push through the fog 
while it is in motion.

Motion field attributes

Fluid Motion fields have the same attributes as regular Uniform Fields in 
Maya, with the exception of Push Intensity.

For more information, search the online help for Uniform Field attributes.

Push Intensity

Sets the magnitude of the Motion field. The greater the Push Intensity, 
the greater the amount of fluid that is pushed or moved by the Motion 
field’s parent object.

Create Motion field

To create a Motion field

1 Create a fluid container with an emitter.

2 Select the fluid, and then the object that you want to move the fluid.

3 Select Fluid Effects > Make Motion Field.

The Motion field appears, and is automatically parented to the object.

Note Motion fields can only be used with 2D and 3D fluids.

Note The Push Intensity of a Motion field automatically increases and 
decreases according to the speed of its parent object.
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Workflow for using Motion fields

1 Create a Motion field.

2 In the Volume Control Section of the Motion field’s attributes, select a 
Volume Shape that closely matches that of the object to which it is 
parented.

3 If necessary, transform the motion field to match the shape of its 
parent object.

4 Set the Push Intensity in the Motion field attributes.

The Push Intensity slider is located in the Extra Attributes section 
under the motionField tab.

Cache Contents 

You can view the contents of your fluid’s cache with the Cache Contents 
attributes. These read-only attributes are a useful reference when working 
with cached fluids. Once a fluid is cached, you can view its contents from 
the initialState_fluidShape node or the cache_fluidShape node in the Attribute 
Editor.

New Emitter Attribute

We have added the Jitter attribute to all emitters so that it can be turned 
on for normal emitters and off for Wakes. With normal fluid emitters, the 
emission sampling is jittered to provide smoother emissions over time. 
However, for Wakes, which use the Spring-Mesh solver, turning off jitter 
usually results in a more stable solution. For when Jitter is turned on for 
Wake emitters, boiling and sizzling effects occur. Jitter is off by default for 
Wake emitters.

New Fluids Command

You can access worldspace information about your fluid’s voxels with the 
new fluidVoxelInfo MEL command. For example, use this command to 
locate the center of a voxel in worldspace. For more information about this 
command, select Help > MEL Command Reference from the Maya main 
menu bar.

Note The initialState node displays the cache contents present at the 
start frame, and the cache node displays the cache contents 
present at the current time.
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New Fluid Examples

We have created new fluid examples to aid you in creating fluid effects 
with our new Ponds and Wakes. Select Fluid Effects > Get Fluid Example 
or Fluid Effects > Get Ocean/Pond Example to access fluid examples in 
the Visor. Select Fluid Effects > Fluid Examples on the Web to download 
fluid examples from the web.
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New Fur presets

On the Fur shelf we’ve added several new Fur presets, including Bison, 
Duckling, Calico Cat, Wet Otter, Wet Labrador, etc., and we’ve  updated 
the existing presets (Sheep, Bear, Llama, etc.) . If you are an upgrading 
customer, these new presets will not automatically appear on your Fur 
shelf; follow the instructions below in ”For upgrading customers” on 
page 111.  

For upgrading customers

1 If you have a Fur shelf, delete it.

• Select the Fur shelf tab.

• Click the Shelf pull-down menu  and select Delete Shelf.

• Select OK when prompted to delete the shelf.

2 Open the Script Editor (Window > General Editors > Script Editor).

3 In the Script Editor, type:

loadNewShelf “shelf_Fur.mel”;

saveAllShelves $gShelfTopLevel;

4 Select Script > Execute.

Fur attractors on polygons

Now you can create attractors either as a grid, or on the selected faces of a 
polygon. Use attractors to add movement to Fur.  

To create a grid of attractors on polygons

1 Select the polygon with fur on it and click the Select Tool.

2 Select Fur > Create Attractor.

3 Select the A grid of attractors on the selected surface option and then click 
Create.

To create a single attractor at a selected polygon face

1 Select the polygon with fur on it and click the Select Tool.

Note Fur is available only in Maya Unlimited.
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2 Right-click the polygon and select Face.

3 Select the face on the polygon where you want to add an attractor.

4 Select Fur > Create Attractor.

5 Select the One attractor at the selected surface point(s)/face(s) option and 
then click Create.

For more information see the Fur guide, Chapter 4, “Adding movement 
to Fur.” 

Attractors on multiple surface points/faces/
surfaces

Now you can create attractors on multiple surface points/faces/surfaces 
simultaneously for both NURBS and polygons. 

Fur clumping

You can now create clumps of fur, such as wet or matted fur. This 
provides a whole new range of fur looks. 

In the Fur Description Attribute Editor we’ve added three attributes to 
create and control clumping. As with all Fur attributes, painting and 
mapping are supported.

In order to preview clumping accurately, set the Fur Accuracy attribute to 
1, which is in the shape node of the Fur Feedback Attribute Editor.

Clumping respects other attributes, including Inclination, Roll, and Polar. 
For example, if Inclination is set to 1 so the fur is lying flat, then the 
clumps lie flat too.

This example 
has the 
Clumping 
Frequency 
mapped using 
a radial ramp 
to vary the 
size of the 
clumps over 
the surface. 
You can also 
paint this 
value, as well 
as the degree 
of Clumping 
and the Clump 
Shape.

Jill Ramsay
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Clumping

The degree to which the hairs are pulled in towards the centre of the 
clump. The higher the clumping value, the more the hairs are pulled 
in. The range is from 0 to 1. The default is 0, which means no 
clumping.

Clumping Frequency

Controls how many clumps occur across the surface. The higher the 
frequency, the greater the number, and therefore the smaller the size 
of the clumps. The range is from 0 to 100. The default is 5.

As you increase the Clumping Frequency, the rendering time 
increases.

Unlike other Fur attributes, the number of feedback hairs (samples) 
affects the Clumping Frequency. For example, at a frequency of 100 
there will be 1 clump for every feedback hair.

Clump Shape

Controls the shape of the curve of the hair as it is attracted to the 
center of the clump. Negative values create a concave shape and 
positive values create a convex shape. The range is from -10 to 10. 

Note With clumping there may be the appearance of gaps between the 
clumps on the surface of the object. To correct this use one or 
more of the following solutions:

• Apply the same color to the shader that is applied to the 
Fur’s Base Color.

• Add an additional Fur Description of overall short fur that 
matches the color of the first Fur Description.

• Add some noise to Clumping, Clump Frequency, or other 
values.

Clump Shape value of -10 is concave Clump Shape value of 10 is convex
What’s New in Maya 5

113



9 | Fur 
 > Fur clumping
Clumping Noise attributes

All existing Maya Fur attributes have both Noise Amplitude and 
Noise Frequency attributes, and the same is true for clumping. See the 
Details section of the Fur Description Attribute Editor. Use these 
Noise attributes to add randomness and make the fur look more 
realistic.

Clumping noise The degree of randomness around the strength of 
the clumping effect.

Clumping 

Frequency 

noise The degree of randomness around the frequency of 
the clumps.

Clump Shape 

noise The degree of randomness around the shape of the 
curve of attraction towards the centre of the clump.

To apply clumping to fur scenes created before Maya 5

1 Select the object with the Fur Description.

2 Select Fur > Fur Description (more) > Detach > FurDescriptionName, 
where FurDescriptionName is the name of the Fur Description.

3 Select Fur > Attach Fur Description > FurDescriptionName, where 
FurDescriptionName is the name of the Fur Description.

To create clumps of fur on part of an object, for example, on 
the chest fur of a cat

1 Select the object with the fur on it.

2 Select Fur > Paint Fur Attributes Tool. The Paint Fur Attributes Tool 
Settings window appears.

3 Select Clumping from the Fur Attribute drop-down list.

4 In the Script Paint Tool window set Value to 0 and then click Flood. 
This removes clumping from the object.

5 Set Value to 1 and paint on the object where you want clumps.

Note To apply clumping to fur scenes created before Maya 5, detach 
the Fur Description and then reattach it. This updates the Fur 
Description so it understands the clumping attributes. See the 
procedure below.
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To map or paint ranges that are greater than 0 to 1, such as 
Clumping Frequency 

Set the attribute’s Map Multiplier value to the maximum value of the 
range. In the case of Clumping Frequency, this value would be 100.

Now you can paint or map the attribute as usual. White will represent the 
Multiplier value (100), black will represent 0, and grayscale values will be 
distributed evenly between.

To map or paint ranges that can be negative, such as Clump 
Shape

1 Set the attribute’s Map Offset value. For example, set the Map Offset 
to -10 for Clump Shape.

2 Set the attribute’s Map Multiplier Value. For Clump Shape this would 
be 20 so the black to white map would represent the full range of -10 
to 10.

New Map Width and Height attributes

We’ve added two new attributes for defining the size or resolution of 
equalizer and attribute maps. 

Map Width

Defines the width of the equalizer or attribute map. The default is 256.

Map Height

Defines the height of the equalizer or attribute map. The default is 256.

Attribute maps

When mapping a texture and then baking to a file you can specify the 
attribute Map Width and Map Height in the Fur Description Attribute 
Editor so that baking operations create attribute maps according to these 
values.

When painting a fur attribute on a surface you can specify the attribute 
Map Width and Map Height in the Paint Fur Attributes Tool so the 
painting operation creates a map according to these values.

Equalizer Maps

The Equalizer Map Width and Equalizer Map Height attributes define the 
size (resolution) of the equalizer map, for example, 512 x 512. These 
attributes can be set in the Advanced Fur Rendering window if creating 
an equalizer map during Advanced Fur Rendering or in the Fur Globals 
window if doing regular rendering. 
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Mapping Fur attributes to animated file 
textures

Fur attributes can now be mapped to animated file textures. Map the 
attribute in the normal way, animate the file extensions and then click 
Bake. 
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Start/Stop Simulation

We’ve modified the Start Simulation and Stop Simulation menu items in 
the Cloth menu to be Start Local Simulation and Stop Local Simulation so 
they specify the type of simulation.  

Specify number of iterations for local 
simulation

You can specify the number of iterations to go through for a local 
simulation using the localSimulationFramesMax attribute in the  CpSolver 
node. For example, this is useful if you only want to run the local 
simulation for 10 frames. In this case you would use the setattr command 
in the Command Line to change this attribute to 10. 

Intermediate cache saving

We’ve added a Cache Save Interval attribute to the Solver Attribute 
Editor. The default value is 0, but you can set it to any value. For example, 
if you set it to 10, caches will be saved every 10 frames during simulation.  

Cloth simulation is often processing intensive and sometimes time 
consuming. By saving simulations in small increments this can often 
overcome situations where an entire simulation is lost. As such the ability 
to save partial caches has been implemented.

Save Cache

We’ve added a Save button to the Solver Attribute Editor, beside the 
Cache Name attribute. This allows you to save the cache when you want 
to, ensuring that successful simulations are retained. 

Query stiffness for seams

When you connect two pieces of cloth together using  Cloth > Create  
Seam, a seam is added that allows you to control the stiffness. Most seams 
in real clothing have some stiffness as the material gets doubled, tripled or 
quadrupled. 

Note Cloth is available only in Maya Unlimited.
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The cpSeam MEL command now allows you to query the stiffness. In the 
Command Line or Script Editor, type:

cpSeam -query -stiffness;
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New MEL commands

• artUserPaintCtx

• attrControlGrp

• catchQuiet

Similar to catch but does not print an error message.

• dgtimer

See ”Improve scene efficiency with the dgtimer command” on 
page 119.

• fluidVoxelInfo

• pairBlend

• parentConstraint

• polyReduce

• rehash

See ”Turn on script path caching to improve network performance” 
on page 123.

• renderer

Improve scene efficiency with the dgtimer 
command

Overview

The new Maya DG debugging tool (dgtimer) allows you to:

• Measure the amount of time spent in the compute methods of each 
node in the scene file.

• Determine the inclusive computation time for a DG chain (a node plus 
its descendents).

• View the number of times each node's compute method was executed.

• Detect nodes which have never been executed.

How it works

• Implemented by the new dgtimer MEL command.

• Uses built-in hardware timers where available and thus has virtually 
no overhead.
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• Each node can be thought of as having its own timer which can be 
reset, turned on or off individually.

• Only measures "compute" time (which includes data propagation 
time). Other statistics such as dirty propagation time are not currently 
being recorded but could be future enhancements.

Usage

Global options

-on

Turns on node timing. Can be specified with -name to turn on timing 
for a single node, with -type for all nodes of a given type, otherwise 
all nodes are turned on. Turning on timing causes the computation 
time for nodes which are on to sum into the node's timer value.

-off

Turns off node timing and is the converse of the -on flag.

-reset

Resets the node's timer values to zero seconds. Can be specified with 
the -name, -type or -on.

-q-query

Prints the value(s) of the specified node's timers. Can be used with the 
Query options listed below.

Options which can be used with any of the global  options

-name nodename

Specifies the name of a node to be affected by the dgtimer operation.

-type typename

Specifies the node type to be affected by the dgtimer operation.

-h-hierarchy

Can be used with -name or -type to affect all descendents of the 
selected node(s).

Query options

-ct -combineType

Causes the query to combine all nodes of the same type on a single 
line of output.

-m -maxDisplay numLines

Limit the display to the most expensive numLines entries.
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-o -outputFile fileName

Specifies a file that the query will be written to (the default is stdout). 
A special case is -outputFile MEL, which allows easy grabbing in a 
MEL script.

-th -threshold percent

Truncates reporting after the percentage of the total execution time 
drops below percent.

Query output format

Output columns when using -query:

Rank

The position of a given node (or node type when using -combineType) 
as sorted by Self time.

ON

If this node's time is currently on, a Y is displayed, otherwise an N is 
displayed.

Self time

The total amount of time in seconds spent executing the node (or node 
type's) compute method.

Percent

The Self time expressed as a percentage of the total Self time for all 
nodes.

Cumulative

A running total of Self time.

Inclusive

The total computation time for the node (or node type) and all its 
descendents in the DG.

Count

The total number of times the node (or node type) has been computed.

Type Name

The type of the node and the name of the node (the name is omitted 
when -combineType is specified).
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Examples

Turn on timing, play the scene, and then dump the timer values to
 stdout:

dgtimer -on -reset
playback -wait
dgtimer -maxDisplay 10 -query

This generates the following output:

MAYA DEPENDENCY GRAPH TIMING INFORMATION
----------------------------------------
Global DG timing is currently: ON

Total time since last global timer reset:
Total real time : 2.1784 sec
Total user time : 1.44 sec
Total sys time : 0.07 sec
Real time in DG eval: 1.37719 sec

Per-node timing information:
Rank ON  Self time Percent Cumulative  Inclusive  Count  Type Name
   1 Y     1.2366  89.79%     1.2366     1.2596     327  cpClothSolver cpSolver1
   2 Y     0.0225   1.63%     1.2591     0.0231     720  transform     locator
   3 Y     0.0103   0.75%     1.2694     0.0247      29  gravityField gravityFieldShape1
   4 Y     0.0049   0.36%     1.2743     0.0054      30  pointEmitter  emitterShape1
   5 Y     0.0048   0.35%     1.2791     1.2637      30  mesh          clothShape1
   6 Y     0.0011   0.08%     1.2802     0.0011     121  time          time1
   7 Y     0.0010   0.07%     1.2812     0.0010     174  transform     particle1
   8 Y     0.0001   0.01%     1.2813     0.0001      66  cpPanel       panelShape1
   9 Y     0.0001   0.01%     1.2815     0.0001      95  cpSeam        seamShape1
  10 Y     0.0001   0.01%     1.2816     0.0001      66  cpPanel       panelShape1
----------------------------------------------------------------------------------

288        1.2463 100.00%     1.2463     2.7160    1969
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Turn off timing for all nodes, reset all timers to zero, and then turn on 
timing for node cpSolver1 and all its descendents. Query the timer and 
output to a file on disk.

dgtimer -off -reset
dgtimer -on -name cpSolver1 -hierarchy
dgtimer -name cpSolver1 -outputFile /home/toon1/timer_info

Turn on script path caching to improve 
network performance

We’ve added the ability to cache script paths to MEL. This lets MEL find 
scripts more efficiently.

To ensure this change does not affect core MEL functionality, the caching 
feature is disabled by default. To turn caching on, set the 
MAYA_CACHE_SCRIPT_PATH environment variable in the Maya.env file in 
your prefs directory.

We encourage you to try this feature if you use many copies of Maya on a 
network. Caching can significantly reduce network traffic when any part 
of a user’s script path points to a network location.

When caching is on, Maya will not be able to tell when scripts are added 
to or removed from the cached script directories. Use the rehash 
command to update the cache.

New catchQuiet structure

The new catchQuiet structure works like catch, however it does not print 
an error message.
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New features in translators

The following new file import/export and translation features are 
available:

• IGES for Linux and Mac OS X

• Studio import changes

• DXF/DWG import/export

• OBJ .mtl (material) file support

• OpenFlight changes for version 1.1

IGES for Linux and Mac OS X

This functionality is now available on Linux and Mac OS X through a 
plug-in. The IGES option is available as a File Type in the Import and 
Export options dialog boxes when this plug-in is loaded.

Studio import

This functionality is available through a plug-in. The studioImport option 
is available as a File Type in the Import option dialog boxes when this 
plug-in is loaded.

Many bugs in the studioImport functionality have been fixed in Maya 5.

You can set the following options in the Import Options dialog box when 
studioImport is selected:

Up Axis

You can select one of Y, Z, or From File. This allows you control over 
the co-ordinate system.

Raytrace

If selected, Maya will optimize the import for raytracing. If not 
checked, it chooses ray casting (default).

Include Cameras

If selected, cameras are brought in from the Studio data. Default is off.
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DXF/DWG import and export

The ability to import and export DWG format is new in Maya 5. The 
ability to import and export DXF format is new on Linux and Macintosh 
in Maya 5. This enables Maya to read and write AutoCAD files. All 
versions from 1 to 2000 are supported.

This functionality is available through a plug-in. The DXF and DWG 
options are available as File Types in the Import and Export options 
dialog boxes when the dwgTranslator plug-in is loaded.

You can set the following options in the Import Options dialog box when 
DWG_DXF  is selected:

Override file units with

Allows you to control what units are being used in Maya. This will 
map the file units to the unit selected. If this option is not selected, the 
units in the file will be used.

Select one of millimeters, centimeters, meters, inches, feet, yards, 
miles.

Scale factor

Default is 1.0. You can select the scaling factor.

You can set the following options in the Export Options dialog box when 
DWGExport or DXFExport is selected:

Output file format

By default, this is AutoCAD 2000. Select another option, if necessary.

Units

Select one of  millimeters, centimeters, meters, inches, feet, yards, 
miles.

Scale factor

Default is 1.0. You can select the scaling factor.

Polygon mesh options

Tessellation Select one of No Tessellation, Triangulate, or 
Quadrangulate.

Export as Select one of PolyMesh face (default), Separate 
polygons, or 3DFace. These are AutoCAD entities 
that give you better control. You select them 
depending on what you want to do in AutoCAD.

NURBS Surface Tessellation Options

Type Triangulate or Quadrangulate
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Method General, standard, or count.

Chord Height Ratio, Fractional Tolerance, Minimal Edge Length, 3D 

Delta

For more information on these options, see the documentation on the 
NURBS to polygons tool. 

OBJ .mtl file support

Maya now supports the import and export of .mtl files on all platforms. 
.mtl files define material properties as used in .obj files.

OpenFlight changes (version 1.1)

OpenFlight Menu

An OpenFlight menu is added to the main window when the  OpenFlight 
plug-in is installed. The menu contains the following menu items:

• ”OpenFlight > Create Light Points” on page 127

• ”OpenFlight > Create Light Points on Curve” on page 128

• ”OpenFlight > Edit Light Points Color” on page 128

• ”OpenFlight > Edit Light Points Normal” on page 128

OpenFlight > Create Light Points

Invokes the fltLightPoints command to create a new set of light points in 
the scene.  

OpenFlight > Create Light Points > �

Number of Light Points

Sets the number of light points.

Distance Between Light Points

Sets the distance between light points.

Light type

Choose one of Omnidirectional, Unidirectional, or  Bidirectional.

Light Normal

Only active when the light type is unidirectional or bidirectional. Set 
the light normal.
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Light Color

Sets the light color.

OpenFlight > Create Light Points on Curve

Invokes the fltLightsOnCurve script to create light points along a selected 
curve.  

OpenFlight > Create Light Points on Curve > �

Number of Light Points

Sets the number of light points.

Light type

Choose one of Omnidirectional, Unidirectional, or  Bidirectional.

Light Color

Set the light color.

OpenFlight > Edit Light Points Color

Used to change the color of selected light points.

To change the color of selected light points

1 Select the light points to modify. 

2 From the OpenFlight menu, select Edit Light Points Color.

The Light Points Color Editor appears.

3 Select the color to apply to these light points in the color slider. 

4 Click the Apply (or Apply and Close) button to apply the color to the 
selected light points. 

This dialog box works with light points selected in object mode and with 
light points selected in component mode.

OpenFlight > Edit Light Points Normal

Allows you to change the normal of any selected light points. 

To change the normal of any selected light points

1 Select the light points to modify. 

2 From the OpenFlight menu, select Edit Light Points Normal.

The Light Point Normal Editor appears. 
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3 Enter the value of the new normal to apply to these light points.  

4 Click the Apply (or Apply and Close) button to apply the normal of 
the selected light points.  

This dialog box works with light points selected in object mode and with 
light points selected in component mode.

Light point functionality

Light point functionality has been extended to display the effects of 
several more attributes of light point shapes:

• Directional Type

• Intensity

• Directional Ambient  Intensity

• Back Intensity

• Horizontal Lobe Angle

• Vertical Lobe Angle

• Roll Lobe Angle

• Normals Display

• Lobe Display

Both Normals Display and Lobe Display have no Creator equivalent.  
They are used to control the visibility of the normal and lobe of light 
points as you develop your scene inside of Maya.  You cannot display 
lobes of omni-directional lights.

Currently the back color only displays as red regardless of the actual 
value set. This default color does respond to the back and ambient 
intensities to enable more sophisticated simulation.

Additional Light Point Maya Node Attributes

fltLightPoints Command

A new flag has been added to the fltLightPoints command to specify the 
directional type of the light point when it gets created:

Flag:  

Name Long (Short) Type Default Flags

DisplayNormals (dn) Boolean false RWSK

DisplayLobe (dl) Boolean False RWSK
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-dt (ce) Type must be one of "OMNIDIRECTIONAL", 
"UNIDIRECTIONAL", or  "BIDIRECTIONAL". By default, light points 
are omnidirectional.

 -dnml (ce) Enable or Disable the display of normals (true/false)

Examples:

// this creates a light point string with 5 light points and 
visible normals
fltLightPoints -c 5 -dnml true;
// this makes the normals of the selected light points 
string invisible and
// changes the light type to be Unidirectional.
fltLightPoints -e -dnml false -dt UNIDIRECTIONAL;

Shading Models—Flat Shading

OpenFlight objects have a flat shading flag, which specifies whether the 
object is to be drawn with flat shading or Gouraud (smooth) shading.  
This flag is now connected with the Smooth Shading attribute of polygons 
in Maya (as found in the Render Stats tab of the Attribute Editor for the 
shape).

While OpenFlight supports the flat shading flag at the object level as well 
as at the face level, Maya only supports the flag at the object level.  Thus, 
the flat shading flag of any object imported into Maya must be set 
identically for the object and all its faces.

Illumination

The illumination flag of OpenFlight objects specifies whether the object is 
to be illuminated by nearby lights or whether it is exclusively self-
illuminating.  

When importing a self-illuminating object, the following attributes of the 
corresponding Maya object are turned off: Casts Shadows, Receive 
Shadows, Visible in Reflections, and Visible in Refractions.  When the 
imported object is not self-illuminating, all these attributes are turned on.

When exporting a Maya object to OpenFlight, the self-illumination flag is 
set if and only if the Receive Shadows attribute of the Maya object is 
turned off.

Light Sources

Support has been added to Maya for OpenFlight light sources.  They can 
be imported and exported into OpenFlight files, with the following 
restrictions:
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Import

• Modeling lights are not supported

• OpenFlight Infinite lights are imported into Maya as directional lights

• OpenFlight Local lights are imported into Maya as ambient lights

• OpenFlight Spot lights are imported into Maya as spot lights

Export

• Directional lights are exported as infinite lights

• Ambient lights are exported as local lights

• Spot lights are exported as spot lights

• Light types not supported by OpenFlight (area lights, point lights) are 
exported as infinite lights

• Modeling lights are not supported

Other limitations

No transformations on externally referenced nodes will be saved out to 
OpenFlight format. To transform a referenced file from within the current 
scene, the DAG root objects in the referenced file should be grouped, and 
any transformations should be applied to the group node.

Notes • One light palette is created for each light source

• The orientation of the light palette is always Yaw = 0, 
Pitch = 0
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Known Issues

The following outlines the known issues in OpenFlight:

• It is not possible to change the Maya display color of a unidirectional 
or bi-directional light. This color always defaults to red. It is expected 
that future releases will have the ability to map back colors to RGB 
display.

• An attempt is made to map Eye Points to Cameras in Maya; however, 
the mapping appears incorrect in some cases. Eye points are not 
exported from Maya.

• Track Planes are not supported.

• The only way to freeze a DOFs co-ordinates from within Maya is to 
export the scene as an OpenFlight file and then read it back in.

• Articulations on group nodes are not supported.

• Maya's LODs need to be extended to better handle the flexibility of 
the OpenFlight LODs.

• UI-based tools are missing to support Switch nodes, and LODs.

• If you perform a Freeze Transformations on a translated Light Point, 
Maya versions older than 4.0.3 will crash. This can be fixed by 
updating to Maya 4.0.3.

• File textures may only be applied to the color attribute of a Maya 
shader. Textures applied to other attributes are ignored.

• The only export type supported is OpenFlight 15.7.
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This release contains many improvements to the Maya API. New classes 
have been added to the API along with improvements to existing classes. 
In addition, we have new examples and updates to existing examples.

New classes and header files

• MFnParticleSystem

Provides access to particle information.  The dynamics of a particle 
node are evaluated at a chosen time and information such as particle 
name, position, age, etc. can be accessed.

• MFnVolumeLight

For creation and manipulation of volume lights.  The light shape (box, 
sphere, volume, cone) and the light direction can be specified. 
Additional attributes such as arc, coneEndRadius, emitAmbient, color 
ramp and penumbra ramp can be accessed and set.

• MItInstancer

A particle instancer node iterator to traverse all instancer nodes in the 
dependency graph.  Filter types can be applied to the iterator.

• MIOStream.h

A header file that controls the including of the iostream system 
functionality in the API. Developers can define REQUIRE_IOSTREAM 
to include “iostream” rather than “iostream.h” on Linux. 

• MLockMessage

Allows listening for events associated with Maya node and plug 
locking.

When you attach an MLockEvent callback, you can listen for queries 
to a plug or node’s lock state.You can also control how Maya responds 
to the lock query (that is, you can override the default behavior of a 
lock). You can use this to implement finer locking granularity than 
what Maya provides.

• MPx3dModelView

Creates custom model views.  Works with 
MPxModelEditorCommand to create a user defined model editor that 
can be used in a window or scripted panel.

• MPxModelEditorCommand

Creates custom editors.  Provides flags and options of the model 
editor command and works in conjunction with MPx3dModelView.
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• MPxObjectSet

Creates new types of sets.  Attributes such as dag set members and 
nodes which use the set are available from this class.

• MPxPolyTweakCommand

A  command base class used for moving polygon UVs.

• MRampAttribute

Affects ramp attributes of MFnVolumeLight. This class is used to add, 
delete and set entries for color and curve ramps.

Examples

New examples

• blindDataMesh

Demonstrates the use of a hardware shader that receives its input 
from blind data.

• cgFxShader (Windows only)

Demonstrates the integration of hardware shading and the cgFx 
language.

• flipUVCmd

Demonstrates the use of the new MPxPolyTweakUVCommand class 
to flip mesh UVs.

• lockEvent

Demonstrates the API callbacks for node and plug locking.

• maTranslator

Demonstrates the use of the MPxFileTranslator class to write out a 
close approximation of the Maya ASCII file format.

• meshOpCmd

Demonstrates the use of the new high level polygon API methods 
added to MFnMesh.

• volumeLightCmd

Demonstrates the use of the new MFnVolumeLight class.

• particleSystemInfoCmd

Demonstrates the usage of the MFnParticleSystem class by writing 
particle information frame by frame.
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Important changes to existing examples

• marqueeTool can now be used with software overlays.  You must 
enable the USE_SOFTWARE_OVERLAYS define and recompile the 
plug-in.

• apiMeshShape has now been improved significantly to fix problems in 
the original example.  In addition, this example has been updated to 
take advantage of the new functionality added to MPxSurfaceShape.

• The simpleHwShader example is obsolete and is no longer shipped. 
Developers should instead look at the hwUnlitShader because it is 
more realistic.

Important changes to existing classes

M3dView

Support for additional view information.

New enum for use with the MPx3dModelView class.

DisplayObjects

Methods:

MString viewSelectedPrefix(MStatus *ReturnStatus) const;

Returns the prefix name used when displaying the camera name in 
the heads up display when the view selected is on.

MStatus setViewSelectedPrefix(MString &prefix);

Set the prefix name used when displaying the camera name in the 
heads up display when the view selected is on.

bool showViewSelectedChildren(MStatus *ReturnStatus) const;  

Tests if the selected view displays all of the children of the objects that 
are flagged for the view selected.

MStatus setShowViewSelectedChildren(bool);

Allows only the objects in the view selected set and their shapes to be 
drawn.

static MStatus getM3dViewFromModelPanel(const MString 
&modelPaneName, M3dView &view);

Return the view given a panel.

static Mstatus getM3dViewFromModelEditor(const MString 
&modelPaneName, M3dView &view); 

Return the view for the model editor.
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MDGModifier can lock and unlock nodes

You can now lock and unlock nodes with the MDGModifier class. This 
lets you implement undo of node locking operations.

MStatus setNodeLockState( const MObject & node, bool newState 
);

MFileIO  now can prevent users from saving 
over the current file

You can set a new mode through the MFileIO class to prevent the user 
from saving over the current scene file. When the user tries to save the 
current scene, Maya will present a Save As dialog box.

static bool mustRenameToSave(MStatus *ReturnStatus = NULL);

Return if the user is forced to rename their file in order to do a save.

static MStatus setMustRenameToSave(bool);

Set whether or not the user is forced to rename their file in order to do 
a save.

static MString mustRenameToSaveMsg(MStatus *ReturnStatus = 
NULL);

Get the message Maya displays when the user is forced to rename 
prior to a save.

static MStatus setMustRenameToSaveMsg(MString &);

Set the message Maya displays when the user is forced to rename 
prior to a save.

MFnCamera

You can now access and modify the transformations that control film back 
roll with the following new methods:

MStatus setHorizontalRollPivot( double horizontalRollPivot );

Set the horizontal roll pivot for film back roll.

double horizontalRollPivot( MStatus * ReturnStatus = NULL ) 
const

Returns the current horizontal roll pivot value.

MStatus setVerticalRollPivot( double verticalRollPivot );

Set the vertical roll pivot for film back roll.

double verticalRollPivot( MStatus * ReturnStatus = NULL ) 
const

Returns the vertical roll pivot's value.

MStatus setFilmRollValue( double filmRollValue ); 
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Set the film roll value for film back.

double filmRollValue( MStatus * ReturnStatus = NULL ) const;

Returns the current roll value in radians.

MStatus setFilmRollOrder( RollOrder filmRollOrder );

Set the order in which the film back rotation is applied with respect to 
the pivot point.

RollOrder filmRollOrder( MStatus * ReturnStatus = NULL ) 
const;

Returns the current roll order.

MStatus setPreScale( double sf ); 

Set the pre scale value.

double preScale( MStatus * ReturnStatus = NULL ) const; 

Return the post projection matrix's pre-scale value

MStatus setPostScale( double sf ); 

Set the post scale value.

double postScale( MStatus * ReturnStatus = NULL ) const; 

Return the post projection matrix's post-scale value.

MStatus setFilmTranslateH( double translate ); 

Set the horizontal film translate.

double filmTranslateH( MStatus * ReturnStatus = NULL ) const; 

Returns the horizontal film translate value.

MStatus setFilmTranslateV( double translate ); 

Set the vertical film translate.

double filmTranslateV( MStatus * ReturnStatus = NULL ) const; 

Returns the vertical film translate value.

MFloatMatrix postProjectionMatrix( MStatus * ReturnStatus = 
NULL ) const 

Returns the post projection matrix used to compute film roll on the 
film back plane.

MFnDependencyNode

We have improved this class to prevent the user from adding duplicate 
attributes on a node (duplicate attributes lead to low-level problems in 
Maya and should never be created).

Support for per-node flags have been added:

static unsigned allocateFlag( const MString pluginName, 
MStatus* ReturnStatus=NULL ); 
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Reserve the use of a bitflag on all nodes.

static MStatus deallocateFlag(const MString pluginName, 
unsigned flag); 

Relinquish the use of a bitflag on all nodes.

static MStatus deallocateAllFlags(const MString pluginName); 

Relinquish the use of all reserved bitflags on all nodes.

MStatus setFlag(unsigned flag, bool state);  

Set the value of a bitflag on a node.

New methods to query node settings:

MObject reorderedAttribute( unsigned index,MStatus* 
ReturnStatus=NULL);  

Returns the attributes according to the reordering that is required for 
file I/O.

bool isNewAttribute( const MObject& attr,MStatus* 
ReturnStatus=NULL); 

Returns if the attribute was added to this node within the current 
scene.

bool isDefaultNode(MStatus* ReturnStatus=NULL) const;  

Returns if the node is a default node.

bool canBeWritten(MStatus* ReturnStatus=NULL) const;  

Returns if the node can be written to scene files.

bool isFlagSet(unsigned flag, MStatus* ReturnStatus=NULL) 
const; 

Return the value of a bitflag on a node.

MFnMesh

Support for creating mesh objects with UVs and performing high level 
polygon operations.  High level polygon operations include splitting, 
subdividing, extruding, extracting, collapsing and duplicating.

Creation:

MObject create( int numVertices, int numPolygons,
const MFloatPointArray &vertexArray,
const MIntArray &polygonCounts,
const MIntArray &polygonConnects,
const MFloatArray & uArray,
const MFloatArray & vArray,
MObject parentOrOwner  = MObject::kNullObj,
MStatus * ReturnStatus = NULL );

MObject create( int numVertices, int numPolygons,
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const MPointArray &vertexArray,
const MIntArray &polygonCounts,
const MIntArray &polygonConnects,
const MFloatArray & uArray,
const MFloatArray & vArray,
MObject parentOrOwner  = MObject::kNullObj,
MStatus * ReturnStatus = NULL );

High Level Polygon Operations:

Mstatus split( MIntArray &placements, MIntArray &edgeList, 
MFloatArray &edgeFactors, 
MFloatArray &internalPoints );

MStatus subdivideFaces(MIntArray & faceList,
int divisionCount);

MStatus subdivideEdges(MIntArray & edgeList,
int divisionCount);

MStatus extrudeFaces(MIntArray & faceList,
int extrusionCount,
MFloatVector* translation,
bool extrudeTogether);

MStatus extrudeEdges(MIntArray & edgeList,
int extrusionCount,
MFloatVector* translation,
bool extrudeTogether);

MStatus duplicateFaces(MIntArray & faceList, MFloatVector* 
translation);
MStatus extractFaces(MIntArray & faceList, MFloatVector* 
translation);
MStatus collapseFaces(MIntArray & faceList);
MStatus collapseEdges(MIntArray & edgeList);

Support for accessing UV shell IDs.

MStatus getUvShellsIds( MIntArray& uvShellIds,
unsigned int & nbUvShells,
const MString * uvSet = NULL ) const;

You can now turn off checking for duplicate points when creating 
polygons.

static void     setCheckSamePointTwice( bool check = true );
static bool     getCheckSamePointTwice( void );

MFnPlugin

Support for registering required functions for MPxModelEditorCommand 
proxy plug-ins.

MStatus registerModelEditorCommand(const MString& 
commandName,

MCreatorFunction creatorFunction,
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MCreatorFunction paneCreatorFunction);
MStatus deregisterModelEditorCommand(const MString& 
commandName);

MItMeshEdge

Support for creating an iterator along the edges of a polygon.  This is 
useful for working with the new high level polygon tools of MFnMesh.

MItMeshEdge( MObject & polyObject, 
MObject & component = MObject::kNullObj, 
MStatus * ReturnStatus = NULL );

MStatus reset( MObject & polyObject, 
MObject & component = MObject::kNullObj );
// new default second parameter

MItMeshPolygon

Support for new tolerance parameter when getting a point at a UV 
location.

MStatus getPointAtUV( MPoint &pt, float2 & uvPoint,
MSpace::Space space = MSpace::kObject,
const MString * uvSet = NULL,
float tolerance=0.0 );

MModelMessage has new callbacks

Add callbacks that are triggered before or after a node is duplicated.

static MCallbackId addBeforeDuplicateCallback(
void (*func)(void* clientData ),
void * clientData = NULL,
MStatus * ReturnStatus = NULL );

static MCallbackId addAfterDuplicateCallback(
void (*func)(void* clientData),
void * clientData = NULL,
MStatus * ReturnStatus = NULL );

MNodeMessage has new callbacks

Support for adding a callback that is triggered whenever a node is 
destroyed. This lets you know when a node has been removed from 
memory and is no longer in use by the user.

static MCallbackId addNodeDestroyedCallback(
MObject& node,
void (*func)(void* clientData ),
void * clientData = NULL,
MStatus * ReturnStatus = NULL );
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MPlug

Additional basic utility support.

Support for querying if a plug was created internally:

bool isProcedural( MStatus* ReturnStatus = NULL ) const;

Set the value of an MPlug with the contents of a dataHandle. This method 
is intended for use during compute only:

MStatus setValue( MDataHandle & handle );

MPxDeformerNode

Support for additional customized editing behavior on plug-in deformer 
nodes.  Allows a user to specify that custom deformer nodes use the same 
index when a shape is re-added to a deformer.  This allows connections to 
be re-used.

void setUseExistingConnectionWhenSetEditing(bool state); 

MPxFieldNode

Support for creating custom icons for dynamic fields.

virtual MStatus iconSizeAndOrigin(GLuint& width,
GLuint& height,
GLuint& xbo,
GLuint& ybo   );

virtual MStatus iconBitmap(GLubyte* bitmap);

MPxFileTranslator

Support for file filtering and setting if the translator handles namespace 
correctly has been added.

virtual bool haveNamespaceSupport () const; 

This method should be implemented to return true if a translator can 
deal with having Maya placing some or all of a file's nodes into a 
separate namespace.

virtual MString filter () const; 

This virtual method may be overloaded in a derived class to set the 
filter extension that will be used by the file dialog.

MPxGeometryData

Support for getting and setting the matrix associated with this data.

void setMatrix(const MMatrix &);
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const MMatrix &matrix() const;
bool matrix(MMatrix &) const;

MPxGlBuffer

Functionality previously unavailable on Linux is now supported.  The 
following methods now work on Linux:

virtual MStatus  open( short width, short height,                                                            
GLXContext shareCtx = NULL );
virtual GLXDrawable drawable( MStatus * ReturnStatus = NULL 
);
virtual GLXContext context( MStatus * ReturnStatus = NULL );

MPxHwShaderNode

Support for accessing the vertex IDs in a hardware shader node.  By using 
the vertex IDs and the Mesh object, a developer can access vertex blind 
data.

This method is now a pure virtual to ensure that all developers using it 
will get a compile error if they are still using the old signature.

virtual MStatus geometry( const MDrawRequest& request,
M3dView& view,
int prim,
unsigned int writable,
int indexCount,
const unsigned int * indexArray,
int vertexCount,
const int * vertexIDs,
const float * vertexArray,
int normalCount,
const float ** normalArrays,
int colorCount,
const float ** colorArrays,
int texCoordCount,
const float ** texCoordArrays) = 0; 

This method now will have vertexCount and vertexIDs array passed 
in if the provideVertexIDs() method returns true.

virtual bool provideVertexIDs(); 

This method should be implemented to return true or false if vertex 
IDs are required in the geometry() method.

MPxNode

kObjectSet added to enum Type.
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MPxSurfaceShape

Support for new shape functionality that solves previous limitations. 
User-defined shapes now contain new virtual methods that can be 
implemented to properly support deformations, tweak nodes, freeze 
transformations and undo.

New enumeration:

MVertexCachingMode

Allows shape to implement proper behavior for undo of point translations 
& freezeTransforms:

virtual void transformUsing( const MMatrix& mat,
const MObjectArray& componentList,
MVertexCachingMode cachingMode,
MPointArray* pointCache);

Allows the shape to properly handle tweak nodes:

virtual void tweakUsing( const MMatrix& mat,
const MObjectArray& componentList,
MVertexCachingMode cachingMode,
MPointArray* pointCache,
MArrayDataHandle& handle );

bool convertToTweakNodePlug(MPlug& plug) const;

An implementation of these methods allows full support for adding 
deformers to the shape:

virtual MObject cachedShapeAttr() const;
MMatrix getWorldMatrix( MDataBlock &, unsigned int ) const;

MPxTransform

Support for turning on non-affine calculations that can occur by using the 
MPxTransform class.

static MStatus setNonAffineMatricesEnabled(bool);

Set if non-affine transformations can be used.

static bool isNonAffineMatricesEnabled(MStatus 
*ReturnStatus); 

Query if non-affine transformations are allowed.

MRenderUtil

Support for additional information that makes the lighting model more 
realistic.  This includes diffuse reflectance, maximum specular reflectance, 
light attenuation and hemisphere coverage.

static float diffuseReflectance(
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int lightBlindData,
const MFloatVector& lightDirection,
const MFloatVector& pointCamera,
const MFloatVector& normal,
bool lightBackFace,
MStatus *ReturnStatus = NULL ); 

Returns the diffuse or lambertian reflectance for a given light source 
and surface.

static MFloatVector maximumSpecularReflection(
int lightBlindData,
const MFloatVector& lightDirection,
const MFloatVector&  pointCamera,
const MFloatVector& normal,
const MFloatVector& rayDirection,
MStatus *ReturnStatus = NULL ); 

Returns the vector corresponding to the point on the light source that 
provides the maximum specular reflection.

static float lightAttenuation(
int lightBlindData,
const MFloatVector& pointCamera,
const MFloatVector& normal,
bool lightBackFace,
MStatus *ReturnStatus = NULL ); 

Returns light attentuation factor of a light.

static float hemisphereCoverage(
int lightBlindData,
const MFloatVector& lightDirection,
const MFloatVector& pointCamera,
const MFloatVector& rayDirection,
bool lightBackFace,
MStatus *ReturnStatus = NULL ); 

Returns the fraction of the light that is transmitted by an object.

static void sendRenderProgressInfo (MString &pixFile, int 
percentageDone); 

Sends batch rendering status to Maya.

MRenderView

The following methods have a new flag “doNotClearBackground.” Plug-
in shaders can choose to not clear the buffer before receiving an image. If 
set to true, Maya does not clear the background image before rendering.

static MStatus startRender( unsigned int width,
unsigned int height,
bool doNotClearBackground = false );

static MStatus startRegionRender( unsigned int imageWidth,
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unsigned int imageHeight,
unsigned int regionLeft,
unsigned int regionRight,
unsigned int regionBottom,
unsigned int regionTop,
bool doNotClearBackground = false );

MStatus

We’ve added two new macros for checking status.

CHECK_MSTATUS_AND_RETURN(result,returnVal)

New macro for checking MStatus objects and returning ‘returnVal’ if 
not successful.

CHECK_MSTATUS_AND_RETURN_IT(result) 

New macro for checking MStatus objects and returning ‘result’ if not 
successful.

Support for getting and setting default 
attribute values

The following classes have support for getting default attribute values.

• MFnEnumAttribute

• MFnNumericAttribute

• MFnTypedAttribute

• MFnUnitAttribute

• MFnLightDataAttribute

• MFnMatrixAttribute

The methods are:

MFnEnumAttribute:

MStatus setDefault( short index );
MStatus setDefault( const MString &fieldString );
MStatus getDefault( short &index ) const;
MStatus getDefault( MString &fieldString ) const;

MFnLightDataAttribute:

MStatus getDefault( float & defDirectionX, 
float & defDirectionY, 
float & defDirectionZ,
float & defIntensityR,
float & defIntensityG, 
float & defIntensityB,
bool  & defAmbient, 
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bool  & defDiffuse, 
bool  & defSpecular,
float & defShadowFraction,
float & defPreShadowIntensity,
unsigned int & defBlindData);

MFnMatrixAttribute:

MStatus getDefault( MMatrix & def );
MStatus getDefault( MFloatMatrix & def );

MFnNumericAttribute:

MStatus getDefault( bool & def1 );
MStatus getDefault( char & def1 );
MStatus getDefault( int & def1 );
MStatus getDefault( int & def1, int & def2 );
MStatus getDefault( int & def1, int & def2, int & def3 );
MStatus getDefault( float & def1 );
MStatus getDefault( float & def1, float & def2 );
MStatus getDefault( float & def1, float & def2, float & def3 
);
MStatus getDefault( double & def1 );
MStatus getDefault( double & def1, double & def2 );
MStatus getDefault( double & def1, double & def2, double & 
def3 );

MFnTypedAttribute:

MStatus getDefault( MObject & defaultCustomData );

MFnUnitAttribute:

MStatus getDefault( double & defaultValue );
MStatus getDefault( MTime & defaultValue );
MStatus getDefault( MAngle & defaultValue );
MStatus getDefault( MDistance & defaultValue );

Other important changes

Windows

The plug-in wizard for Developer Studio has been updated for Maya 5.

Macintosh

We now support a basic form of building plug-ins from Code Warrior 
Stationery on the Macintosh. A developer can generate a mel command 
and a dependency graph plug-in project. 

 For developers who are familiar with Unix command line tools, a 
Makefile is now available for building plug-ins on the Macintosh.
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